17:01:48 <devananda> #startmeeting ironic
17:01:48 <thiagop> we do have a devananda
17:01:52 <JayF> o/
17:01:53 <openstack> Meeting started Mon Sep 21 17:01:48 2015 UTC and is due to finish in 60 minutes.  The chair is devananda. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:54 <jlvillal> o/
17:01:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:57 <openstack> The meeting name has been set to 'ironic'
17:02:00 <lucasagomes> devananda,:-)
17:02:07 <rloo> o/
17:02:07 <betherly> NobodyCam is on holiday I believe
17:02:12 <stendulker> o/
17:02:14 <cinerama> o/
17:02:18 <trown> looks like we have a devananda xor a NobodyCam
17:02:21 <jlvillal> o/
17:02:30 <devananda> g'morning / afternoon / evening all - welcome to the ironic meeting :)
17:02:46 <jroll> ohai
17:02:47 <devananda> our agenda can be found on the wiki -- https://wiki.openstack.org/wiki/Meetings/Ironic -- but today it appears to be empty of any specific items
17:03:02 <jroll> there's a big one in open discussion
17:03:04 <rameshg87> devananda: I have a few
17:03:15 <devananda> #topic announcements
17:03:27 <jroll> announcement: RIP JoshNang :(
17:03:33 <lucasagomes> :-(
17:03:36 <devananda> PTL voting is open -- please go vote
17:03:59 <thiagop> jroll: ??
17:04:01 <jroll> re: josh, for anyone that hasn't read it, http://lists.openstack.org/pipermail/openstack-dev/2015-September/075055.html
17:04:01 <trown> what happened to JoshNang
17:04:15 <gabriel-bezerra> o/
17:04:19 <dtantsur> jroll, not the best kind of joke tbh
17:04:44 <rloo> Thank you and Good Luck JoshNang! We'll miss you!!!
17:04:45 <JoshNang> trown: still here, totally fine, just leaving rackspace/openstack on thurs
17:04:52 <jroll> dtantsur: sorry, I use rip for lots of things, I didn't mean to induce panic :(
17:04:52 <lucasagomes> he's changing projects! g'luck on ur next work JoshNang
17:04:55 <trown> ah got it. good luck!
17:04:56 <devananda> jroll: not RIP .. just bon voyage JoshNang
17:05:07 <dtantsur> devananda++
17:05:08 <jroll> ya.
17:05:24 <thiagop> JoshNang: Good luck on the new enterprise
17:05:31 <vdrok_> o/
17:06:00 <thiagop> "Don't panic"
17:06:08 <devananda> any other announcements before we move on?
17:06:08 <JoshNang> thanks y'all. i'll miss everyone :)
17:06:23 <lucasagomes> devananda, not sure if it's important
17:06:26 <jroll> devananda: releasing 4.2.0 this week, hopefully thursday
17:06:37 <jroll> not the newest of news, but it's a thing
17:06:45 <lucasagomes> but I will be on vacations from 27 Sept. until 5 Oct. so I will miss the next two meetings
17:07:15 <devananda> jroll: right. release status. thus we're also in soft freeze right now
17:07:23 <jroll> indeed
17:07:28 <devananda> again not an announcement, but a reminder, that goes along with what you said
17:07:46 <devananda> lucasagomes: ah, thanks for the reminder on that. enjoy your time off!
17:08:06 <lucasagomes> ty
17:08:10 <devananda> #topic subteam status reports
17:08:25 <thiagop> I can go on OneView
17:08:47 <devananda> going down the list quickly, I hope :)
17:08:58 <jroll> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:08:59 <devananda> dtantsur: any release critical bugs that should be called out?
17:09:17 <dtantsur> nothing spotted for now, but I'll recheck
17:09:33 <thiagop> The oneview driver is code complete, waiting for reviews. Our CI is almost done, running tests for deploy and management interface.
17:09:35 <devananda> jroll: AIUI, neutron work has been postponed to M, so there's nothing to report there right now
17:09:38 <dtantsur> I just started cleaning up "in progress" list
17:09:43 <jroll> devananda: correct, not much new this week
17:09:47 <devananda> dtantsur: cool, thanks! that's good to hear :)
17:10:02 <devananda> dtantsur: was ironic-lib released in time for 4.2?
17:10:25 <dtantsur> devananda, it was, but we didn't switch to it :(
17:10:35 <dtantsur> also, dsvm gate patch is still under review
17:10:41 <dtantsur> https://review.openstack.org/#/c/212495/
17:10:46 <devananda> jlvillal: any release critical items on the nova<-.ironic front?
17:10:50 <devananda> dtantsur: gah! :(
17:10:53 <jroll> devananda: we didn't land code using it because g-r freeze etc, we didn't want to do things that late in the cycle
17:10:59 <jroll> it == ironic-lib
17:11:11 <jlvillal> devananda: I don't believe so. We looked last week and nothing release critical.
17:11:14 <dtantsur> devananda, it's been up since Aug 24 :(
17:11:22 <devananda> jroll: yea, I understand the reasons, just unfortunate that it's taking so long
17:11:27 <jlvillal> devananda: Not sure if lucasagomes thinks his patch for version support is release critical for Nova
17:11:32 <jroll> yar, indeed
17:11:39 <lucasagomes> jlvillal, I don't think it's critical no
17:11:48 <devananda> let's plan to make some noise about ironic-lib as soon as Mitaka opens
17:11:58 <lucasagomes> it would be good to get it in, but if we don't it's ok
17:12:17 <devananda> #info ironic-lib had a release, but we didn't switch to it beause of dep freeze. we should endeavor to switch as soon as Mitaka opens
17:12:24 <jlvillal> +1
17:12:25 <jroll> devananda: +1, I hope people are working on it already so we can jfdi
17:12:46 <devananda> I don't see lintan ... anyone else want to update on Oslo things?
17:12:59 <devananda> also, anyone tracking our i18n status, eg. for StringFreeze?
17:12:59 <jlvillal> devananda: I think all of the versionedobjects work has landed
17:13:03 <dtantsur> devananda, a lot of clean up related to objects landed recently
17:13:04 <jroll> I've seen o.vo patches flying around
17:13:04 <lucasagomes> ++ for ironic-lib, anyone is already working on the IPA bits to partition the image with it?
17:13:28 <jroll> devananda: I'd like to get in https://review.openstack.org/#/c/224079/ speaking of o.vo
17:13:30 <devananda> #info a lot of oslo.versioned_objects code is in flight // has landed
17:13:41 <lucasagomes> there's one implementing the indirection_api so we can do rolling release
17:13:47 <jroll> I learned a lot from that patch
17:13:47 <lucasagomes> rolling upgrade*
17:13:49 <jroll> heh
17:13:53 <devananda> oh nice
17:13:58 <lucasagomes> yeah that would be good to get in
17:14:02 <lucasagomes> (if possible)
17:14:18 <devananda> jroll: heh. yea, well, nova and o.vo changed things, and what we had was 'good enough' for us ... so ... will be good to pull in all that
17:14:27 <jroll> yep, indeed
17:14:44 <devananda> #info reviews needed on https://review.openstack.org/#/c/224079/ related to oslo.versionedobject support
17:15:01 <dtantsur> devananda, a suspicious bug: https://bugs.launchpad.net/ironic/+bug/1403887 . lucasagomes, are you still facing it?
17:15:02 <openstack> Launchpad bug 1403887 in Ironic "No such file or directory error during deployment" [High,Triaged]
17:15:09 <devananda> pshige_: anything in particular about docs to call out?
17:15:26 <devananda> jlvillal: any updates on testing?
17:15:33 <lucasagomes> dtantsur, oddly enough, no
17:15:42 <dtantsur> hmm
17:15:43 <devananda> jlvillal: also, do you think we'll be able to get the tempest patch for microversion API testing in?
17:15:59 <jlvillal> devananda: lekha has proposed a patch for adding functional testing to python-ironicclient using mimic.
17:16:03 <lucasagomes> I don't remember the last time I hit this problem, I'm not sure if it's gone tho
17:16:11 <jlvillal> But have to wait for code freeze to be over to get mimic added to global-requirements.
17:16:15 <devananda> jlvillal: https://review.openstack.org/#/c/166386/ for reference
17:16:40 <devananda> jlvillal: ok, so that's M, at this point
17:17:01 <jlvillal> devananda: I will see if I can get some love for the patch.
17:17:10 <devananda> jlvillal: thanks much
17:17:23 <devananda> dtantsur: if we can't reproduce a ~9mo old bug, I'd probably close it
17:17:28 <dtantsur> yep
17:17:34 * dtantsur closes
17:17:42 <devananda> dtantsur: updates on inspector (besides what's in the whiteboard?)
17:17:53 <devananda> TheJulia: updates on bifrost (^^ ) ?
17:18:03 <dtantsur> devananda, nothing to add to what is written
17:18:21 <TheJulia> nothing at this time
17:18:21 <devananda> betherly: any updates on webclient? AFAIK it's still not in anything like a releasable state, right?
17:18:44 <devananda> dtantsur: awesome. thanks for keeping the wb up to date! << ditto, TheJulia
17:18:53 * jroll wonders what happened to "update the whiteboard, we'll use meeting time for questions" :P
17:19:00 <devananda> TheJulia: also, why is shade making changes that break its users?
17:19:10 <devananda> jroll: yea, well, feel free to ask questions :)
17:19:21 <rloo> do we release IPA?
17:19:32 <jroll> rloo: not yet, red hat wants to
17:19:38 <rloo> or is inspector* stuff the only non-ironic stuff that is being packaged?
17:19:40 <jroll> for packaging purposes
17:19:55 <rameshg87> versioned release ?
17:19:58 <jroll> yes
17:19:59 <betherly> Web client wise have conversation re UX with horizon guys tomorrow
17:20:07 <TheJulia> devananda: the change affects master branch and has to do with authentication support
17:20:20 <betherly> Been back and forward a lot re whether we are using standalone client or new horizon panel
17:20:27 <trown> jroll: ya releasing IPA would make things easier for me :)
17:20:39 <jroll> trown: as I've said before, set it up and I'm happy to do it
17:21:00 <trown> I think it just requires a tagged release in the repo now
17:21:08 <dtantsur> trown, I think we'll do it with the remaining ironic
17:21:21 <betherly> Ultimately last week decided we would basically do both but the horizon panel is still under heavy debate with regard wanting to push for responsive and new code technologies vs staying with status quo
17:21:26 <jroll> trown: it's set up for pypi and everything?
17:21:31 <dtantsur> trown, I'd personally like one more patch to get in
17:21:48 <jroll> dtantsur: we can release twice :)
17:21:50 <trown> dtantsur: sounds good. no hurry from my end
17:22:03 <dtantsur> :)
17:22:18 <lucasagomes> https://pypi.python.org/pypi/ironic-python-agent seems to have something there
17:22:19 <trown> jroll: it is setup on pypi though
17:22:36 <jroll> oh neat
17:22:44 <rloo> maybe an Action Item for someone wrt packaging IPA?
17:23:13 <dtantsur> s/someone/trown/ :)
17:23:20 <lucasagomes> releasing only, distros will package it themselves
17:23:22 <devananda> betherly: that sounds like fun. LMK if I can help with that discussion this week
17:23:23 <trown> fwiw, it is packaged in Fedora rawhide already :)
17:23:40 <trown> it is just a PITA to package stuff without an upstream release
17:23:44 <betherly> Devananda: Hopefully will have something for invision that everyone is happy with this week (and by hopefully I mean we had better have...)
17:23:56 <betherly> devananda: will let you know for sure thanks
17:23:58 <lucasagomes> trown, ++
17:24:24 <rloo> thx trown & jroll, for doing a release of IPA :)
17:24:43 <thiagop> Guys, since the OneView driver and the python-oneviewclient lib are complete and the CI is "almost there", can we land this on the 4.2 release?
17:24:45 <jroll> yep np
17:25:02 <thiagop> (and ladies)
17:25:04 <devananda> #info jroll and trown working on packaging IPA releases
17:25:18 <rloo> thiagop: I think your question relates to a discussion item
17:25:42 <rloo> thiagop: maybe we can revisit it after that discussion
17:25:58 <devananda> any other updates / questions on subteam status?
17:26:18 <thiagop> rloo: right
17:26:24 <devananda> also, I know we took longer than 10 minutes, but there were several points from that which I just added to the whiteboard which were, at least, useful info for me
17:27:01 <rloo> devananda: so you'd like it explicit, for folks to put 'no updates'?
17:27:25 <thiagop> +1
17:27:35 <devananda> rloo: it differentiates from "didn't update it"
17:27:37 <wanyen> two of standalone agetn-ilo andiscsi-ilo drivers patches have landed byt conductor failer patch is still under review.  Like to be able to land standlaomen ilo driver into 4.2
17:27:42 <devananda> which results in me wondering :)
17:27:53 <dtantsur> ack
17:28:01 <rloo> devananda: ok
17:28:09 <devananda> wanyen: please make sure that status is reflected on the whiteboard, and add a link to the patch in question
17:28:25 <wanyen> deva, ok.
17:28:42 <devananda> rloo: and with the end-of-cycle coming up, nagging folks may be helpful
17:28:42 * jroll gets curious what "standalone ilo driver" means but wants to move on
17:28:56 <devananda> I think we just got about 10 updates that weren't on the whiteboard :)
17:29:04 <devananda> jroll: making ilo driver work without swift
17:29:20 <devananda> ie, work in a bifrost-style environment
17:29:21 <jroll> ah
17:29:26 <lucasagomes> ah nice
17:29:36 <devananda> thanks, all. moving on now
17:29:48 <devananda> #topic soft freeze // do we allow features in?
17:30:02 <devananda> rloo, rameshg87 - this one has your name on it
17:30:15 <rameshg87> devananda: yes, but question is open to everyone :)
17:30:17 <rloo> cuz I don't want to allow features in now. I want to focus on bugs :)
17:30:27 <devananda> rloo: ++
17:30:47 <dtantsur> I'd say: we might allow a feature if: 1. it's very close to landing, 2. it does not look breaking, 3. core team has cycles to land it
17:30:50 <thiagop> critical features or all features?
17:31:21 <devananda> we past the openstack feature freeze a few weeks ago -- https://wiki.openstack.org/wiki/Liberty_Release_Schedule
17:31:25 <rloo> people might say 'it depends on the feature' but I don't have the bandwidth to decide whether/which feature can go in. seems like folks should have brought up their feature to discuss before last Thurs.
17:31:28 <jroll> dtantsur: that's my thuoght as well; OTOH we have ~72 hours and a few bugs left to fix
17:31:38 <devananda> that said, we're not strictly following it, and I agree with dtantsur 's criteria
17:31:46 <jroll> dtantsur: so I'm hesitant to say we'll land any features that don't already have +2s on them
17:32:25 <rloo> at this point, we should be prioritizing bugs/features? If they aren't high, do we have bandwidth to land?
17:32:54 <devananda> at this point, we should be focusing on known bugs and any really important features that are done being written
17:32:57 <devananda> like o.vo
17:33:17 <rloo> devananda: ++
17:33:18 <devananda> it's not a shiny feature for vendors to talk about, but it' simportant to th eproject
17:33:36 <lucasagomes> right, we also merged the cisco driver today i would like to see if it's possible to merge the oneview one as well
17:33:40 <lucasagomes> because it's been there for a long time
17:33:44 <dtantsur> so, should we finish RAID+cleaning?
17:33:52 <lucasagomes> and the last time I reviewed it was almost there
17:33:54 <thiagop> I would really like for you to considerate the OneView driver
17:34:10 <devananda> jroll: the whiteboard has a list you put together around L73 -- that looks like it could use updating
17:34:19 <rloo> maybe we shouldn't have merged the cisco driver today but i guess that's too late to discuss
17:34:29 <lucasagomes> yeah, it's already there
17:34:31 <devananda> thiagop: it's really unlikely we'll have any time at this point -- AND landing a new driver this late in the cycle? honestly, not likely
17:34:52 <devananda> unless cores have already been reviewing it
17:35:10 <jroll> devananda: so I actually made a second source of truth... https://launchpad.net/ironic/+milestone/4.2.0
17:35:18 <devananda> jroll: \o/
17:35:25 <thiagop> devananda: I'd argument that we're working on that for a long time and had some +2 before some people asking to move vendor code out of the driver
17:35:39 <thiagop> devananda: just to ease reviews
17:35:43 <jroll> right, I approved the cisco driver this morning because it had 2x+2 on it, with +A waiting for "release liasion approval"
17:35:53 <jroll> not because I think we should be spending review time on drivers
17:36:15 <jroll> thiagop: the problem is we have many things to review that are higher priority, and the release is thursday
17:36:35 <jroll> thiagop: we all want this driver in, however we're really limited on time
17:37:15 <jroll> so, I'd like to be concrete about this situation and list the features folks are talking about here:
17:37:17 <JayF> one thing worht noting: Missing L should be less of a big deal, as Ironic can have its own release shortly after L including any drivers or features that missed 4.2
17:37:22 <jroll> * inband RAID config
17:37:30 <jroll> * pxe_* inband cleaning via IPA
17:37:40 <jroll> * oneview driver
17:37:52 <jroll> should we land any/all/none of those, is the question here
17:38:03 <jroll> (we probably shouldn't be landing other feature work)
17:38:08 <jroll> JayF: ++
17:38:23 <devananda> JayF: counterpoint -- many users consume ironic from distro packages, and, at least right now, most distros are packaging the openstack integrated release.
17:38:40 <dtantsur> I'd see inband cleaning working now, as it compliments already present support for cleaning in agent drivers
17:38:44 <devananda> JayF: I'd like distros to start packaging our releases directly -- but we can't ignore the current status
17:39:09 <jroll> devananda: fwiw, debian packages our intermediate releases, maybe someone can convince red hat :)
17:39:12 <lucasagomes> yeah that's not very likely, but I would like to see distros doing that too
17:39:14 <dtantsur> devananda, we even package git master, but we don't ship it to customers :) that would be harder to change
17:39:25 <devananda> jroll: "pxe inband cleaning" -- you mean over iscsi connection?
17:39:33 <trown> RDO is packaging from git master
17:39:34 <jroll> devananda: "via IPA"
17:39:40 <jroll> devananda: pxe_* works with IPA
17:39:44 <devananda> ah
17:39:52 <devananda> yea, we should land that
17:40:04 <jroll> right, so that's the next topic :)
17:40:07 <lucasagomes> I think there's a topic about it next
17:40:08 <lucasagomes> yeah
17:40:14 <rameshg871> the bigger one
17:40:16 <jroll> or the 'how'
17:40:25 <rloo> what about the other two features (before we move on)
17:40:34 <jroll> ^
17:40:37 <devananda> er, sorry, I misread. pls disregard my last sentence
17:40:52 <lucasagomes> I will review the oneview driver tomorrow early
17:41:13 <jroll> well
17:41:15 <rloo> i wanted to get the inband raid config, only cuz most of it is in.
17:41:17 <lucasagomes> last time I did it was almost there
17:41:31 <jroll> I'm worried nobody is going to review our bugfixes if we allow all three of these :(
17:41:34 <jroll> hopefully I'm wrong
17:41:42 <rloo> jroll: i think you might be right.
17:41:44 <thiagop> lucasagomes: thank you!
17:41:54 <rloo> i don't htink we should do the OneView driver.
17:42:12 <dtantsur> jroll, rloo, my gertty shows most of the patches available having at least one -1
17:42:12 <rloo> do you have a link handy for that?
17:42:30 <dtantsur> so we probably need more people coding, not more people reviewing...
17:42:35 <jroll> dtantsur: ok, good, maybe we're doing fine
17:42:38 <wanyen> update- all 3 patches of standalone ilo drivers (withotu Swift) landed earlier this morning.
17:42:39 <jroll> yeah there's that :)
17:43:27 <devananda> wanyen: good to hear :)
17:43:36 <rloo> there's some sort of weird miscommunication if we're discussing getting features in after the deadline passed, and not having this discussion before the deadline :-(
17:43:37 <wanyen> :)
17:43:40 <gabriel-bezerra> rloo: https://review.openstack.org/#/c/191822
17:43:47 <devananda> rloo: I agree
17:43:49 <jroll> rloo: yeah
17:43:53 <dtantsur> rloo++
17:44:03 <devananda> what's the impact if these don't get completed?
17:44:09 <devananda> as in -- is there partially completed code we need to disable?
17:44:28 <rameshg871> devananda: raid has all/most of the code merged.
17:44:37 <rameshg871> devananda: but it's not in effect before zapping didn't make it
17:44:41 <jroll> RAID won't actually do anything without the in-band support (unless out-of-tree drivers have OOB support)
17:44:55 <jroll> oh, right, and because zapping is missing :|
17:45:02 <lucasagomes> oh
17:45:05 <devananda> pxe_* inband cleaning should and the oneview driver should be zero-impact if not completed, right?
17:45:16 <devananda> yea, it's RAID I was concerned about being incomplete
17:45:18 <rloo> honestly, just looking at the OneView driver patch (number of files) and lack of reviews/+2s, I don't think we should even consider it for Thurs.
17:45:24 <rameshg871> so tonnes of code submitted becomes a no-op :(
17:45:32 <devananda> rameshg871: urgh :(
17:45:37 <jroll> devananda: yes, those should be no-impact
17:45:47 <devananda> it sounds like that settles it. none of thse features get in now
17:45:49 <JayF> rameshg871: can the code that's been added be used as a clean_step directly, even if zapping is disabled?
17:46:08 <jroll> JayF: that's what "inband RAID support" means, there's still code to land
17:46:10 <rameshg871> JayF: https://review.openstack.org/#/c/224938/
17:46:20 <JayF> okay; gotcah
17:46:48 <jroll> devananda: I'm good with an exception for 224938
17:46:54 * devananda looks
17:47:04 <gabriel-bezerra> rloo: it is in the same situation as the cisco driver. many files, but easy to review.
17:47:24 <rloo> gabriel-bezerra: no, it isn't in the same situation. cisco driver had two +2s this morning. OneDriver has none.
17:47:30 <devananda> rameshg871: this looks like it shouldn't be in the patch --https://review.openstack.org/#/c/224938/4/etc/ironic/ironic.conf.sample,cm
17:47:36 <lucasagomes> jroll, that's the only patch missing?
17:47:39 <rloo> gabriel-bezerra: and honestly, i would have said no to cisco driver if i was asked.
17:47:41 <gabriel-bezerra> 3 days ago it didn't have that.
17:47:42 <devananda> other than that, yea, it's small enough and important enough I'd agree with an exception
17:47:45 <jroll> lucasagomes: apparently :)
17:47:59 <lucasagomes> right yeah that looks fine, it's not big
17:48:12 <rameshg871> devananda: are you talking about changes to some other CONF options being shown ?
17:48:12 <rloo> gabriel-bezerra: i can't speak for what happened in the past 3 days or what people choose to review.
17:48:30 <rameshg871> devananda: it's just got reordered while I generated it with the tool
17:49:05 <rloo> devananda: the reordering of the configs in the conf, seems to be an issue, but nothing specific to this particular patch.
17:49:11 <devananda> ooh
17:49:26 <gabriel-bezerra> rloo: the situation is still the same as in cisco, then.
17:49:27 <rameshg871> somewhere we should be sorting I guess :D
17:49:36 <rameshg871> before that tool generates the sample
17:49:38 <rloo> devananda: i haven't had time to look into it, but i have noticed that the file changes depending on who generates it
17:50:04 <lucasagomes> yeah depending on how old is the envrioment used to create it as well
17:50:17 <rameshg871> ---- 10 minutes remaining ----
17:50:20 <jlvillal> 10 minutes remaining
17:50:23 <lucasagomes> usually we should always have a fresh .tox when generating it
17:50:38 <devananda> rloo: that's awesome :(
17:50:46 <rameshg871> can we decide on (if something)/what is getting in
17:50:47 <rloo> so config aside. did we agree to make 224938 an exception?
17:50:48 * lucasagomes thinks we should move on and look at rameshg871 problem
17:50:56 <jroll> gabriel-bezerra: ok, here's my answer on oneview: "I'm not prioritizing reviewing it, in favor of other higher priority patches, and I would encourage other cores to do the same because we have lots to do"
17:50:56 <rloo> devananda: yeah, one of the many awesome things...
17:50:57 <lucasagomes> rloo, I'm good with that
17:51:01 <jroll> rloo: +1 on 224938
17:51:07 <devananda> +1 on 224938
17:51:13 <dtantsur> ++
17:51:20 <jroll> lucasagomes: ramesh's problem isn't so urgent since we're saying it won't land this cycle, fwiw
17:51:21 <lucasagomes> I will review it today after the meeting since we are on time pressure now
17:51:40 <lucasagomes> jroll, fair enuff
17:51:44 <devananda> majority of cores present just agreed on that exception
17:51:49 <gabriel-bezerra> jroll: anything we can do to help you cores on that?
17:52:04 <jroll> gabriel-bezerra: help fix bugs and review the things on https://launchpad.net/ironic/+milestone/4.2.0
17:52:10 <wanyen> ++ on 224938
17:52:11 <rloo> I agree too, but I helped with it so didn't want to vote
17:52:13 <devananda> #agreed feature freeze exception for 224938. other features will be held until Mitaka
17:52:15 <jroll> gabriel-bezerra: also help update docs because why not
17:52:22 <jroll> devananda: /me updates launchpad
17:52:26 <devananda> jroll: thanks
17:52:43 <rloo> jroll, devananda: the hi priority bugs are as noted in https://launchpad.net/ironic/+milestone/4.2.0, right?
17:52:57 <devananda> #topic cleaning in iscsi_deploy
17:53:07 <jroll> rloo: yes, those are what I've prioritized for 4.2, at least
17:53:07 <gabriel-bezerra> jroll: OK. Is there a place where we can find more precise guidance on what needs to be done regarding the docs?
17:53:08 <rameshg871> devananda: we don't need to discuss that
17:53:09 <devananda> rameshg871: sorry for being short on time on this -- but it sounds like we'e all agreed to bump it anyway
17:53:13 <rameshg871> devananda: yeah
17:53:17 <devananda> :)
17:53:18 <devananda> #topic open discussion
17:53:48 <lucasagomes> re docs for drivers, rameshg871 put a patch removing the ilo documentation from the tree
17:53:54 <jroll> gabriel-bezerra: idk, maybe docs bugs? just pointing them out as always a thing that could need love, but the other items are more pressing
17:53:57 <lucasagomes> and pointing to the wiki
17:54:14 <devananda> gabriel-bezerra: pshige_ has stepped up to coordinate doc efforts, and there was a ML thread about reorganizing our documentation recently
17:54:20 <lucasagomes> I personally think the wiki is more flexible and easy to maintain, but does that impact on the release of the docs or something?
17:54:23 <vdrok_> I have some questions about tempest full job in nova experimental
17:54:27 <lucasagomes> should we start asking other drivers to do the same?
17:54:30 * lucasagomes finds that review
17:54:30 <vdrok_> api and scenario tests are now passing (locally at least)
17:54:33 <devananda> lucasagomes: oh? that seems odd -- I'm fine with driver docs being in tree in a driver folder ...
17:54:43 <vdrok_> there is a problem with thirdparty tests - because of a bug in nova's ec2 api, ami image is considered whole-disk because ec2 api ignores kernel_id and ramdisk_id passed when creating an image
17:54:47 <jroll> lucasagomes: -1 for docs on wiki :(
17:54:54 <lucasagomes> #link https://review.openstack.org/#/c/225602/
17:54:56 <vdrok_> and there is ephemeral_gb set, so deployment fails because it can't deploy whole-disk image with ephemeral partition
17:54:57 <devananda> -2 for docs in wiki as well
17:55:00 <rloo> lucasagomes: I'm fine with vendor docs out of tree so I don't have to review
17:55:00 <jroll> lucasagomes: if they're on the wiki nobody reviews them
17:55:00 <lucasagomes> yeah I want to gather onions on that
17:55:07 <rameshg871> devananda: jroll: problem is keeping it updated with hardware related information
17:55:07 <vdrok_> but this api is deprecated since kilo, so should we enable stackforge/ec2-api in gate, or skip thirdparty tests?
17:55:09 <lucasagomes> opinions*
17:55:15 <devananda> docs are in gerrit. either in our tree or in the doc project somewhere
17:55:19 <lucasagomes> jroll, yeah there are pos and cons
17:55:27 <jroll> rameshg871: because people won't review it, or what?
17:55:35 <rameshg871> jroll: yeah they do
17:55:41 <devananda> rameshg871: if the problem is how fast it is to land, or that a vendor needs to be able to self-approve changes for their driver
17:55:46 <rameshg871> jroll: but going everytime for something we can avoid seems odd
17:55:50 <jroll> vdrok_: this sounds like a good question for mtreinish after the meeting, I tend to think skip ec2-api
17:55:56 <devananda> rameshg871: we can set up a doc job in the ilo driver itself
17:56:06 <rameshg871> devananda: that sounds good.
17:56:08 <devananda> rameshg871: and syndicate that from the ironic driver pages.
17:56:32 <jroll> devananda: meh, I'd like docs to be reviewed :/
17:56:39 <vdrok_> jroll: yup, also because even if it was passed correctly, irt would contain ec2 like ids, like ami-00000111
17:56:45 <rameshg871> devananda: jroll: point of view is 1) we don't want to over-burden others to even review driver docs 2) wanted everything at one place
17:56:50 <vdrok_> so ironic couldn't use it
17:56:55 <jroll> vdrok_: yeah, ec2-api support seems silly
17:57:09 <vdrok_> another question - what is a reasonable amount of time for that job? I think api+scenario tests will require ~4 hours on gate, it's a lot
17:57:16 <devananda> jroll: I want our docs to be reviewed. but if a vendor needs to, say, document some wonky hardware thing for their specific out-of-tree driver library, I'm amenable to giving them self-approval control over that
17:57:20 <rameshg871> devananda: jroll: today we have some firmware related information in the wiki and actual features in ironic source tree
17:57:23 <thiagop> I just wonder about doc changes on releases, if it's in a wiki
17:57:37 <jroll> devananda: I guess yeah
17:57:49 <rloo> thiagop: the ilo wiki has links for changes per release
17:57:54 <lucasagomes> devananda, jroll apart from reviewing it, having the docs in the release is important?
17:57:56 <rameshg871> devananda: jroll: if that's possible, I would learn about that from you
17:58:02 <devananda> rameshg871: as long as "how touse ironic with the ilo drivers" is in ironic's tree...
17:58:17 <jroll> lucasagomes: I know nothing about docs w/ releases, I know we publish from master
17:58:24 <devananda> lucasagomes: IMO, yes. releases are versioned. docs relevant to that release == important
17:58:43 <rameshg871> devananda: jroll: our team can then manage that ilo doc alone and can do approvals
17:58:43 <lucasagomes> right
17:58:44 <devananda> the doc team publishes and stores previous releases of docs. we don't -- but should
17:58:59 <jroll> vdrok_: 4 hours seems untenable, but I'd love to get it passing as an experimental job and then iterate from there... we talked about maybe using multi-node devstack to increase capacity and do more in parallel
17:59:24 <devananda> vdrok_: yea, it is going to take a long time because of what that job is testing + how long it takes to start a vm-mocking-bare-metal
17:59:32 <jlvillal> Regarding genconfig and ironic.conf.sample ordering. I created a bug: https://bugs.launchpad.net/ironic/+bug/1498113  I didn't find another one with a quick search.
17:59:33 <openstack> Launchpad bug 1498113 in Ironic "Ironic genconfig does not appear to be idempotent across users." [Undecided,New]
17:59:36 <devananda> vdrok_: there was no way to speed it up that I could find, aside from running less testes
17:59:46 <devananda> jlvillal: thanks
17:59:55 <jroll> devananda: multi-node devstack with 8 "bear metals"
17:59:58 <jroll> :D
18:00:03 <devananda> rameshg871: take a look at how other projects are configured to build docs
18:00:07 <jroll> (or probably more like 6 but ya know
18:00:09 <jroll> )
18:00:20 <devananda> jroll: sure. that means using a lot of resources from infra, too
18:00:22 <rloo> thx jlvillal
18:00:26 <devananda> anyhow, w're out of time! thanks everyone!
18:00:29 <thiagop> and its it
18:00:31 <jroll> thanks all
18:00:32 <jlvillal> Thanks!
18:00:37 <devananda> #endmeeting