17:00:27 <jroll> #startmeeting ironic
17:00:28 <openstack> Meeting started Mon Sep 28 17:00:27 2015 UTC and is due to finish in 60 minutes.  The chair is jroll. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:32 <openstack> The meeting name has been set to 'ironic'
17:00:36 <dtantsur> o/
17:00:40 <NobodyCam> o/
17:00:43 <betherly> o/
17:00:45 <jroll> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:00:47 <vdrok_> o/
17:00:49 <jvmario> o/
17:00:49 <mjturek1> \o
17:00:51 <jroll> welcome everyone :)
17:00:54 <cdearborn> o/
17:00:55 <trown> o/
17:00:58 <rloo> o/
17:00:59 <stendulker> o/
17:01:01 <sinval> \o/
17:01:05 <jlvillal> o/
17:01:07 <devananda> \o
17:01:10 <yuriyz> o/
17:01:16 <Nisha> o/
17:01:55 <jroll> for those that just joined, the agenda is here: https://wiki.openstack.org/wiki/Meetings/Ironic
17:01:58 <krotscheck> ¯\_(ツ)_/¯
17:02:04 <krtaylor> o/
17:02:13 <jroll> #topic announcements
17:02:31 <jroll> so first off, apparently y'all decided I should be PTL. thanks for that, it's an honor :)
17:02:33 <NobodyCam> congratz to jroll
17:02:35 <devananda> congrats to jroll on the election :)
17:02:40 <trown> congrats
17:02:44 <mjturek1> congrats!
17:02:53 <JayF> o/
17:03:01 <dtantsur> \o/
17:03:16 <betherly> congratulations jroll
17:03:18 <cinerama> o/
17:03:20 <jlvillal> o/
17:03:25 <sinval> o/
17:03:26 <yuriyz> o/
17:03:28 <jroll> second, we released ironic 4.2.0 last friday. 21 bug fixes and 4 blueprints completed over 16(?) days. nice work everyone \o/
17:03:31 <vdrok> jroll, congrats!
17:03:32 <jroll> #link https://launchpad.net/ironic/+milestone/4.2.0
17:03:40 <NobodyCam> awesome
17:04:28 <cdearborn> congrats!
17:04:38 <jroll> #info ironic 4.2.0 released
17:04:39 <natorious> o/
17:04:41 <jroll> #info the stable/liberty branch has been cut from that same commit; backports will be released as 4.2.x for liberty final. if no backports happen, 4.2.0 will be liberty final.
17:04:43 <TheJulia> o/
17:05:02 <jroll> last but not least...
17:05:21 <jroll> #info reminder to submit mitaka design summit sessions. need to have our schedule complete by oct 15
17:05:24 <jroll> #link https://etherpad.openstack.org/p/mitaka-ironic-design-summit-ideas
17:05:43 <jroll> does anyone else have any announcements?
17:06:07 <NobodyCam> not here
17:06:10 <rloo> jroll: moving backwards from that date, when are you/we planning on looking/deciding?
17:06:43 <jroll> rloo: not sure yet, I just heard that date this morning. probably a few days or a week before?
17:07:04 <jroll> I do want that to be a collaborative thing, I will let y'all know :)
17:07:07 <rloo> jroll: ok, cuz it seems like whatever that date will be, is more important.
17:07:14 <jroll> yep.
17:07:36 <jroll> I'll post something on the ML this week
17:08:06 <jroll> moving on...
17:08:14 <jroll> #topic Review subteam status reports
17:08:21 <trown> fwiw there is a meeting the day before
17:08:25 <trown> 14th
17:08:31 <jroll> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:08:41 <jroll> trown: I see oct 15th on a thursday :P
17:09:00 <trown> lol, yep looking at september ...
17:09:48 <jroll> I see a bifrost release \o/
17:09:59 <TheJulia> Yes, had to get a few things worked out first :)
17:10:00 <NobodyCam> w00t
17:10:06 <jroll> nice work
17:10:11 <TheJulia> ty
17:10:38 <jroll> jlvillal: krtaylor lekha: I see the note about waiting for mimic in g-r; that's just client testing, right? any news on server testing?
17:11:23 <jroll> thanks everyone else for clear updates here
17:11:30 <jroll> if anyone has questions on these please do raise them
17:11:40 <rloo> who/what is 'horizon downstream'?
17:11:55 <jlvillal> jroll: No news on server functional testing from me. I will work on some prep work for functional testing in the server. Which would require moving test directories around.
17:11:57 <rloo> is that a particular company's
17:12:01 <rloo> downstream?
17:12:01 <jroll> great question
17:12:05 <jroll> krotscheck: betherly ^
17:12:14 <jroll> jlvillal: cool :)
17:12:14 <krotscheck> eh?
17:12:26 <jroll> krotscheck: what's 'horizon downstream' in this subteam update?
17:12:28 <krotscheck> rloo: There's an effort inside of HP to build an ironic panel for a specific customer.
17:12:39 <rloo> krotscheck: ah, thx for explaining.
17:12:41 <krotscheck> rloo: It's focused on Ironic kilo.
17:13:00 <krotscheck> rloo: And... well, they tried to impose their own deadline on us.
17:13:01 <betherly> sorry for not being clear in my update, thank you for clarifying krotscheck
17:13:15 <jroll> krotscheck: one more question - when can we get you and betherly as cores on ironic-webclient? is that something you just need me to push the button on?
17:13:55 <krotscheck> jroll: I can't speak for betherly. I don't want to be core, because I'd rather write code.
17:14:09 <krotscheck> Also, even with two of us, we need another +2 to approve things.
17:14:09 <dtantsur> that's the spirit :-P
17:14:13 <jroll> krotscheck: you don't want to be core on a project you started?
17:14:15 <jroll> sure.
17:14:26 <dtantsur> I'd say sometime you have to become a core
17:14:29 <krotscheck> jroll: devananda started it. I just wrote the code. Make him a core ;)
17:14:37 <krotscheck> Oh wait.
17:14:39 <jroll> krotscheck: a +2 from someone that understands the code is immensely helpful to those of us that don't understand it as well
17:14:41 <krotscheck> Hey, now that devananda
17:14:51 <krotscheck> Hey, now that devananda's not PTL naymore, he can review my code!
17:14:56 <jlvillal> Not sure how dtantsur did it in the beginning of inspector/discoverd?
17:14:57 <devananda> krotscheck: I do not know how to review node.js code
17:15:01 <rloo> are we sure we want this project then?
17:15:02 <betherly> jroll: I am happy to be so that one of us is but i will want to keep a good balance between code and reviews. ultimately because i have a webclient to build and i love building it
17:15:07 <krotscheck> devananda: That's good, because it's not node.js code :D
17:15:13 <dtantsur> jlvillal, we have a separate team, I just add people there after discussing with existing folks
17:15:15 <devananda> wait. what is it?
17:15:21 <krotscheck> devananda: browser code.
17:15:26 <devananda> oh. js.
17:15:28 <jlvillal> dtantsur: Well in the beginning when it was just you.
17:15:29 <devananda> i don't know that either :p
17:15:35 <trown> who is expected to review the code if not the people writing it?
17:15:40 <jlvillal> dtantsur: How many +2s were required...
17:15:52 <dtantsur> jlvillal, me, Imre and Lucas. I've asked the folks to join, so that I'm not along. but we needed only 1x +2 back then
17:16:00 <krotscheck> trown: I really dislike +2'ing my own code. And current policy is 2x+2, no?
17:16:06 <dtantsur> jlvillal, now are team is bigger and more diverse, so we're sticking with 2x +2
17:16:19 <dtantsur> like a big serious project :D
17:16:28 <krotscheck> Serious. Yes. That's us.
17:16:32 <jroll> devananda: krotscheck: betherly: I think right now we have a problem, because nobody familiar with in-browser javascript has the permissions to +2 any of this code. and so it's punted to ironic-core, who are already extremely busy.
17:16:33 <trown> krotscheck: it could be 1x +2 for something that is just starting
17:16:41 <jroll> krotscheck: the project sets its own policy
17:16:45 <jlvillal> krotscheck: I think you could set the policy to less strict in the beginning and make it more strict in the future as it grows?
17:17:01 <dtantsur> I was not even aware that I have a +2 on webclient...
17:17:03 <devananda> single +2 approval is fine for small / younger projects IMO
17:17:06 <jroll> I don't see the value in a second +2 if that +2 doesn't mean anything.
17:17:29 <NobodyCam> I tend to agree
17:17:44 <krotscheck> jroll: Project policy for subprojects is your call, no?
17:18:09 <betherly> jroll: I am therefore happy to be a core to enable there to be one who is more familiar with in browser js
17:18:23 <jroll> krotscheck: no, it's that project team's call. which right now, is ironic-core. which is weird because nobody on that team works on that project.
17:18:57 <jroll> krotscheck: I'd rather you and betherly run that project. both of you should be core on it.
17:19:08 <NobodyCam> ++
17:19:15 <dtantsur> ++
17:19:22 <jlvillal> +1 if anyone cares :)
17:19:48 <betherly> i would also agree with the above...it seems not to make sense for things to be +2'd just because they need to be
17:19:48 <betherly> not because they are good code necessarily ^
17:19:49 <betherly> sorry my messages are taking weirdly long to send even with an excellent internet connection....weirdddddd
17:20:00 <krotscheck> betherly: That's IRC for ya
17:20:12 <krotscheck> Ok, this should not be a big deal.
17:20:18 <betherly> krotscheck: ++
17:20:21 <krotscheck> Let's just make the two of us cores.
17:20:22 <jroll> krotscheck: so, I can't make you accept core, but I encourage you to do so
17:20:26 <jroll> cool, thank you.
17:20:26 <krotscheck> I dislike the idea.
17:20:36 <krotscheck> But that's fine
17:20:41 <NobodyCam> if there are things that need a second set of eyes I am happy to help... do note that really need glasses
17:20:46 <krotscheck> Because seriously we have better things to do , like write code :)
17:21:01 <dtantsur> krotscheck, I would not call it "better"
17:21:22 <jroll> krotscheck: ironic cores would like to write code too :)
17:21:22 <dtantsur> like, serious, code review is equally important part of making a high-quality product
17:21:27 <betherly> I guess at that point that is our boundary we set up...although i have not been core before so i guess ill find out ;)
17:21:28 <Madasi> sounds like your first job as core is to "borrow" some js web client developers from somewhere
17:21:30 <rloo> krotscheck: i feel like i was just insulted. makes me wonder why I review.
17:21:57 <dtantsur> we do that not because we adore to put -1 on people's work, but because it's a required and in avoidable part :)
17:22:04 <jlvillal> Reminds me that sometimes I don't think the other people in my company value code-reviewing as much as I do...
17:22:04 <jroll> #action jroll to make krotscheck and betherly core on ironic-webclient
17:22:05 <betherly> I would 100% agree that reviewing is massively important
17:22:14 <krotscheck> rloo: urr... sorry, what? I didn't mean to insult you.
17:22:20 <jroll> I think we should probably continue this discussion elsewhere, for the sake of time, please
17:22:31 <krotscheck> rloo: It was more of a me-capitulating thing in favor of moving the project forward.
17:22:35 <rloo> krotscheck: you want to write code and complain that no one reviews your stuff. who is oging to review if everyone wants to write code?
17:22:40 <jroll> any other questions/comments on subteam updates?
17:22:54 * dtantsur points at ironic-inspector liberty release as well
17:22:57 <NobodyCam> jroll: +1 for moveing on
17:23:00 <krotscheck> rloo: Let's move this to the ironic channel.
17:23:04 <NobodyCam> dtantsur: ++ w00t
17:23:14 <jroll> thanks
17:23:18 <rloo> krotscheck: no need to move it, i don't feel a need to discuss further.
17:23:21 <jroll> moving on
17:23:36 <jroll> #topic Deprecation policy
17:23:59 <jroll> this was a late add, sorry if I didn't give enough reading time
17:24:03 <jroll> in short:
17:24:18 <jlvillal> This?  https://review.openstack.org/#/c/228489/
17:24:22 <jroll> openstack has a new deprecation policy for configs/APIs/features/etc
17:24:25 <jroll> #link https://github.com/openstack/governance/blob/master/reference/tags/assert_follows-standard-deprecation.rst
17:24:42 <jroll> today we tend to follow a one-cycle deprecation period, which is good
17:24:53 <jroll> this adds a minimum of 3 months time, for continuous deployment folks
17:25:03 <jroll> which I think is good, and we should do
17:25:14 <jroll> I want to make sure there's no objections to us doing that
17:25:44 <dtantsur> so the question essentially is whether we like the current deprecation policy?
17:25:45 <jlvillal> How does it differ from before?
17:25:46 <dtantsur> I do
17:25:47 <jroll> I've added a commit to governance repo, to add the tag that signifies that we follow this policy:
17:25:49 <jroll> #link https://review.openstack.org/#/c/228489/
17:26:00 <jroll> objections welcome here or in that review
17:26:04 <jroll> jlvillal: the 3-month thing
17:26:05 <rloo> jroll: I'm fine with the 3-month stuff. Did you read the fine print about documenting migration path, email thread on openstack-operators. (might be more, that's all i read so far)
17:26:27 <jroll> rloo: yeah, and we should do a better job of that regardless
17:26:39 <jlvillal> jroll: Because now we release more frequently than every three months?
17:26:58 <jlvillal> Sounds reasonable to me.
17:27:02 <NobodyCam> I'm ok with the 3 month thing as described in the links above
17:27:06 <jroll> jlvillal: well, it's more important to us due to that, yes, but it's also there for people deploying from master
17:27:20 <rloo> jroll: it is at least 3 months + next stable release branch.
17:27:22 <jroll> so it's 3 months + a cycle boundary
17:27:24 <jroll> yep
17:27:45 <NobodyCam> any issues if we just bumped to two cycles?
17:28:00 <dtantsur> too much old stuff to support?
17:28:01 <jroll> NobodyCam: makes for more stale code
17:28:05 <rloo> NobodyCam: 2 cycles is too long for some stuff
17:28:12 <jroll> things like configs are easy to do in one cycle
17:28:30 <dtantsur> arguably, if people didn't fix their code after the first notice, they won't do that the second time as well
17:28:36 <NobodyCam> ack but at 1 cycle and 3 months we're like 3 months away from 2 full cycyles
17:28:37 <rloo> NobodyCam: 2 cycles makes sense for bigger features maybe, but we can assess that on individual basis.
17:28:40 <NobodyCam> just saying
17:28:53 <jroll> there's an email thread, a gerrit review, and a cross project meeting log with more info on this topic as to how people decided on this
17:29:00 <dtantsur> NobodyCam, I understood it like "1 cycle, but at least 3 months", no?
17:29:06 <rloo> NobodyCam: we've been doing 1 cycle+ now anyway.
17:29:12 <NobodyCam> yea
17:29:25 <jroll> NobodyCam: it depends when it was deprecated :) if something is deprecated at the start of a cycle, two cycles is a year, this is only 6 months
17:29:28 <NobodyCam> so not a hugh change for us to add the extra 3 months
17:29:35 <jroll> yep
17:29:57 <jroll> just means, for example, we couldn't remove the bash ramdisk today because it was deprecated with the 4.2.0 release
17:29:59 <rloo> NobodyCam: but it seems to me that since we've been doing it for 1 cycle and no one has asked/complained for 2 cycles, why 'impose' it?
17:30:10 <NobodyCam> :) I am good with the change.. just asking about the other.. no real skin  in the game for me
17:30:26 <jroll> devananda: so there's one more thing here - do you know what the current status of our grenade jobs is?
17:30:37 <jroll> there's a requirement to have upgrade testing
17:30:46 <devananda> jroll: not off hand. last time I touched it was the start of Liberty
17:30:54 * devananda misses adam_g
17:30:55 <jroll> so we may not be able to tag the project in the governance repo until we get that done
17:31:06 <jroll> maybe a good item for jlvillal and friends' todo list
17:31:19 <jroll> :)
17:31:28 * jlvillal makes a note to get more details after meeting
17:31:38 <jroll> cool
17:32:26 <jroll> #info ironic will follow the new openstack deprecation guidelines
17:32:36 <jroll> any other questions/comments on this topic?
17:32:57 <jroll> #topic Open Discussion
17:33:02 <jroll> have at it :)
17:33:05 <NobodyCam> lol
17:33:11 * jroll grabs a drink real quick
17:33:30 <rloo> I'd like to thank Devanada for being PTL
17:33:37 <NobodyCam> yes!
17:33:37 <jlvillal> +++++
17:33:39 <devananda> \o/
17:33:41 <dtantsur> yeah, big +++
17:33:43 <jvmario> ++
17:33:50 <jroll> +3 \o/
17:33:51 <Madasi> ++
17:33:52 <vdrok> and from me too :)
17:33:54 <sambetts> ++ :)
17:33:55 <rloo> I don't think ironic would exist w/o him
17:33:58 <TheJulia> ++
17:33:58 <jroll> and for, ya know, starting this project :)
17:34:12 * jroll has big virtual shoes to fill
17:34:22 <NobodyCam> lol
17:34:31 <devananda> thanks, all -- it wouldn't be what it is w/o all of your contributions too!
17:35:24 <devananda> and don't worry -- y'all wont get rid of me by just voting in a new PTL ;)
17:35:34 <jlvillal> hehe
17:36:48 <jroll> really, nothing to discuss?
17:36:57 <NobodyCam> I had a question on a L patch. I wanted to poll folks about what they thought the chances of the one view driver landing as a backport are for the L release
17:37:14 <jroll> NobodyCam: ...backporting a feature?
17:37:25 <rloo> 0.0000001 % chance I think
17:37:35 <jroll> rloo: seems high :)
17:37:56 <dtantsur> backporting the whole driver... is against all current policies, I guess
17:38:03 <jlvillal> Maybe a dumb question on Ironic/Neutron work. Will it enable multi-tenant deployments?  Being able to isolate bare-metal users from each other?
17:38:03 <jroll> NobodyCam: even if we did it, the release team would probably hurt me
17:38:04 <NobodyCam> #link https://review.openstack.org/#/c/191822
17:38:07 <devananda> backporting a driver? -2
17:38:16 <jroll> jlvillal: from a network perspective, yes
17:38:28 <jlvillal> Sweet :)
17:38:31 <NobodyCam> thats what I was checking on
17:38:40 <devananda> NobodyCam: they could publish a kilo or liberty driver to github
17:38:45 <rloo> the whole idea of the new versioning is so that people can get a release with a feature in sooner than the 6-month releases. NobodyCam, that doesn't work for you?
17:38:47 <jroll> jlvillal: I'm sure you know all the caveats of sharing hardware, you need to do more than clean disks :)
17:38:48 <devananda> and then we could link to it in docs and/or wiki -- i think that's fine
17:39:02 <jroll> rloo++ I fully expect this to be in 4.3
17:39:09 <jlvillal> jroll: Oh yeah! For sure.
17:39:22 <NobodyCam> yea
17:39:22 <lekha> jroll: Did not get to do any ironic functional tests last week. Am hoping to get it started this week.
17:39:34 <NobodyCam> I was just checking with folks
17:39:44 <TheJulia> rloo: I suspect they hope for it on the stable/liberty branch, which just isen't going to happen
17:39:53 <jroll> lekha: yeah no worries, just was checking up on it :)
17:39:53 <NobodyCam> so I could provide feed back
17:40:08 <dtantsur> yeah, there are some chances that we'll publish an updated dell driver separately on github, but you better ask ifarkas
17:40:08 <NobodyCam> thank you :)
17:40:26 <liliars> devananda, NobodyCam yeah we thought about publishing a liberty driver to github and would be nice to have it on docs, thanks (:
17:40:43 <JoshNang> (a bit late but..) devananda thanks all your work as PTL! especially navigating the integration challenges
17:40:54 <jroll> :o a wild JoshNang
17:40:58 <JoshNang> :D
17:41:14 <lekha> jroll: congrats on being the new PTL :)
17:41:20 <rloo> hey JoshNang. And that you too, for your contributions!
17:41:22 <JoshNang> and congrats to jroll :D
17:41:25 <JoshNang> :)
17:41:27 <jroll> thanks :)
17:41:32 <rloo> JoshNang: s/that/thank/
17:41:42 <jlvillal> Whoa, JoshNang in the house? :)
17:41:48 * rloo thinks we should be partying now
17:41:50 <dtantsur> the meeting is devoted to saying thank you :)
17:41:56 <JoshNang> ha
17:41:56 <NobodyCam> lol
17:42:09 <jroll> ikr
17:42:13 <jroll> ok, anything else?
17:42:32 * jroll gives folks some free time back
17:42:33 * NobodyCam really does think everyone in the Ironic family is awesome
17:42:40 <jroll> thanks everyone!
17:42:47 <jroll> #endmeeting