17:00:23 <dtantsur> #startmeeting ironic
17:00:23 <sambetts> Hey
17:00:23 <openstack> Meeting started Mon Feb 27 17:00:23 2017 UTC and is due to finish in 60 minutes. The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:26 <jlvillal> o/
17:00:26 <TheJulia> o/
17:00:27 <openstack> The meeting name has been set to 'ironic'
17:00:28 <joanna> hello :)
17:00:29 <mjturek> o/
17:00:30 <Michael-ZTE-1> o/
17:00:32 <hshiina> o/
17:00:33 <vdrok> \o/
17:00:34 <aarefiev> o/
17:00:38 <bradjones> o/
17:00:38 <mariojv> o/
17:00:38 <dtantsur> #chair jroll TheJulia
17:00:39 <openstack> Current chairs: TheJulia dtantsur jroll
17:00:42 <crushil> \o
17:00:49 <mgoddard> \o
17:00:50 <dtantsur> I may disappear due to horrible internet, please back me up :)
17:00:53 <jroll> oh my, I'm special
17:00:59 <rloo> o/
17:01:03 <rpioso> o/
17:01:05 <soliosg> o/
17:01:07 <bfournie> o/
17:01:18 <dtantsur> #topic Announcements / Reminders
17:01:19 <baha> o/
17:01:26 <dtantsur> We've had an awesome PTG, thanks all for attending!
17:01:44 <aslezil> o/
17:01:44 <rpioso> \o/
17:01:48 <dtantsur> I plan on writing a summary to the ML, but personal summaries from other folks are also welcome.
17:01:52 <lucasagomes> o/
17:01:53 <rloo> big thanks to mturek? for taking great notes!
17:01:57 <dtantsur> #action dtantsur to write a PTG summary
17:02:04 <mjturek> :-D np rloo
17:02:09 <dtantsur> oh yeah, mjturek++
17:02:18 <mjturek> sorry I couldn't make the last day
17:02:35 <dtantsur> mjturek, there was no much to write down, don't worry :)
17:02:41 <mjturek> :)
17:03:06 <dtantsur> any other announcements / reminders / saying thanks you? :)
17:03:18 <jroll> it was an awesome ptg, thank you all
17:03:22 <jroll> and +100000 for mjturek
17:04:03 <dtantsur> ok, moving on
17:04:11 <dtantsur> #topic Review subteam status reports
17:04:26 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard line 76
17:05:05 <dtantsur> I don't expect a lot of updates, except for things discussed on the PTG, but please check what we have
17:05:10 * jroll would be surprised to see updates
17:05:28 * jlvillal is full of surprises ;)
17:05:43 <jlvillal> Or at least three lines of updates
17:06:01 <rloo> jlvillal & vasyl, great work getting multinode grenade working (or close to it)
17:06:04 <dtantsur> more than nothing, you see :)
17:06:08 <dtantsur> ++
17:06:31 <jlvillal> rloo: Thanks :) I am seeing the light at the end of the tunnel. Have to figure out the non-OSIC cluster failures still
17:06:48 <jlvillal> +1 for vsaienk0 help!
17:06:52 <rloo> someone needs to update the driver comp section...
17:06:54 <jroll> ++ nice work
17:07:18 <dtantsur> rloo, it's more or less up-to-date apparently
17:07:24 <jroll> yeah, it's pretty close
17:07:39 <jroll> once I go over notes from PTG I'm happy to update with pike plans and such
17:07:48 <dtantsur> ditto
17:08:04 <rloo> jroll: ok, i'll update with what you just said
17:08:10 <jroll> heh
17:08:19 * dtantsur gives folks a few more minutes to read/update
17:08:30 <NobodyCam> :)
17:09:35 <rloo> dtantsur: what was decided about the soft power off stuff. I forgot.
17:09:50 <rloo> dtantsur: was it going to be a separate spec?
17:10:07 <dtantsur> just tracked separately on the whiteboard, I think
17:10:19 <dtantsur> the spec is still valid
17:10:37 <rloo> dtantsur: ok, i'll wait til you do the priorities patch...
17:11:01 <dtantsur> yes, please give me a day or two :) it's a hard recovery
17:11:18 <rloo> dtantsur: wrt the bugs... didn't folks decide on a process for doing bug triage?
17:11:38 <rloo> dtantsur: something to do with volunteers?
17:11:58 <dtantsur> a process is to ask for volunteers every week to drive the bug triaging
17:12:11 <dtantsur> which is part of the next topic in the agenda
17:12:22 * dtantsur thinks of moving to it
17:12:58 <dtantsur> done with the updates?
17:13:05 * rloo done
17:13:17 <dtantsur> #topic Deciding on priorities for the coming week
17:13:27 <dtantsur> this was not an explicit topic before, but we anyway did it every time
17:13:35 <jroll> priority one: put head back on straight
17:13:44 <dtantsur> one and only, I would say :)
17:13:48 <mat128> o/
17:14:06 <dtantsur> let's try to finish with the priorities by the next meeting, if possible
17:14:21 <dtantsur> there are two subitems proposed for this meeting topic
17:14:30 <jroll> +1, and get the subteam list updated
17:15:06 <dtantsur> "Stuck specs for current and potential priorities" which is about useful stuff that does not get reviewed. we didn't finally agree on this item, but I added it anyway, mostly to continue thinking about it
17:15:31 <dtantsur> "Appointing a bug liaison for the next week" this is what rloo was asking for (I know people don't like liaison in this context, just change to a better word)
17:15:51 <dtantsur> now let's if it works :) is there anyway who wants to keep an eye on the bug list this week?
17:15:56 <rloo> dtantsur: was this for volunteer to do bug triaging?
17:16:32 <dtantsur> yep
17:17:31 <vdrok> I can do it this week
17:17:36 <vdrok> apart from today
17:17:39 <dtantsur> \o/ thanks vdrok
17:17:45 <TheJulia> Thank you vdrok
17:17:56 <dtantsur> #action vdrok to drive bug triaging this week
17:18:13 <dtantsur> side note: this does not mean that I stop doing it, but now it gets moar eyes
17:18:16 <jroll> nice, thanks vdrok
17:18:27 <rloo> another side note? the volunteer does NOT have to be core?
17:18:33 <dtantsur> no, not necessary
17:18:35 <vdrok> should I add my name on the whiteboard?
17:18:41 <dtantsur> vdrok, yes please
17:18:56 <dtantsur> rloo, just a good understanding of the project is enough IMO
17:19:18 <rloo> dtantsur: ++
17:19:33 <rloo> dtantsur: to be clear, are you going to continue to update the bug stats in the whiteboard?
17:19:47 <dtantsur> yes, I will still do it
17:19:59 <rloo> dtantsur: thx
17:20:36 <dtantsur> okay, I guess we're good to move on
17:20:49 <dtantsur> #topic OSIC Ops adopt-a-project
17:20:51 <jroll> well
17:20:55 <dtantsur> I don't see a name, who was it?
17:21:01 <jroll> so we're good with the weeks' priorities?
17:21:11 <jroll> (this is me asking mrhillsman to bring this topic, btw)
17:21:15 <dtantsur> jroll, the priorities: get some priorities :)
17:21:21 <jroll> heh
17:21:29 * jroll doesn't see that in the list
17:21:32 <jroll> mrhillsman: around?
17:21:49 <rloo> dtantsur: i'm a bit confused. is the 'deciding on prioriites..' stuff in the agenda a one-time (today) thing, or is that a new thing that we will look at weekly?
17:22:08 <mariojv> "review specs" priority item was removed; was that intentional?
17:22:13 <dtantsur> rloo, weekly. that's what we've done for more than a cycle, just without an explicit item
17:22:31 <jlvillal> Makes sense to me.
17:22:34 <dtantsur> mariojv, it was. while it's always important, it's not a priority item right this second.
17:22:34 <rloo> dtantsur: it doesn't make sense to have the 'appointing a bug liaison' under that?
17:22:43 <mariojv> ack, thx
17:22:55 <dtantsur> rloo, this is planning for next week, but dunno
17:23:09 <rloo> dtantsur: planning isn't priorities
17:23:32 <dtantsur> rloo, how badly is this inconsistency going to affect everyone's work?
17:24:00 <rloo> dtantsur: dunno, i can't answer for everyone. just seems ... odd, so i'm mentioning it.
17:24:29 <jroll> I thought the end goal was a weekly bug triage change (with less than weekly while we ramp up)
17:25:10 <jroll> it's weird but we can deal with it later
17:25:11 <dtantsur> not necessary weekly, but yes. asking for volunteers every week
17:25:22 <mrhillsman> o/
17:25:22 <dtantsur> let's move it to the channel or Just Do It (tm) please :)
17:25:24 <jroll> last call for mrhillsman for the topic we're currently on
17:25:24 <mrhillsman> sorry jroll
17:25:25 <rloo> could we put down some more priorities for this week? eg, review tags?
17:25:25 <dtantsur> mrhillsman, o/
17:25:27 <jroll> ah there we go
17:25:37 <mrhillsman> #link https://etherpad.openstack.org/p/ops-adopt-a-project-pike
17:25:51 <mrhillsman> we have rounded out what we think from an ops view but it is open
17:26:13 <jroll> rloo: let's go back to it in open discussion in a few
17:26:16 <mrhillsman> it boils down to us basically wanting to establish loop between ironic and ops team in osic to help as we can
17:27:17 <jroll> mrhillsman: mind explaining a bit more on what y'all are doing (and/or how we can help?)
17:27:19 <rloo> mrhillsman: what does '2. supported by 7 or more SDKs' mean?
17:27:25 <mrhillsman> we have time for pike to determine the work so again, nothing is set in stone
17:27:33 <dtantsur> ++ to rloo's question, it caught my attention too
17:27:42 <mrhillsman> rloo: i grabbed that from the project navigator
17:27:54 <vdrok> yeah it has this item
17:28:01 <mrhillsman> https://wiki.openstack.org/wiki/SDKs
17:28:05 <mrhillsman> i assume ^
17:28:05 <vdrok> the "maturity" tag
17:28:11 <rloo> mrhillsman: i don't know if ironic is supported by 7 or more sdks
17:28:12 <jroll> #link https://www.openstack.org/software/releases/ocata/components/ironic
17:28:17 <jroll> for what the project navigator is
17:28:39 <vdrok> it seems like only by 2 - PythonOpenStackSDK and OSC
17:28:46 <jroll> oh wow great face on there
17:29:09 <rloo> jroll: you mean cool dtantsur, right?
17:29:21 <jroll> >.>
17:29:31 <mrhillsman> so we will ideally install ironic
17:29:36 <mrhillsman> according to the documentation
17:29:37 <dtantsur> lol
17:29:48 <mrhillsman> if we find gaps/issues/whatever, file bugs/patches
17:30:10 <jroll> woot
17:30:18 <mrhillsman> we will try to scale it as much as we can, again, bugs/issues/whatever
17:30:18 <rloo> sweet
17:30:28 <rloo> we could use help on testing rolling upgrades at some point :)
17:30:36 <mrhillsman> if there are things ironic team would like us to test, we are welcome to it
17:30:38 <dtantsur> mrhillsman, this is fantastic! what kind of help you need from us if any?
17:30:57 * jlvillal likes :)
17:31:06 <mrhillsman> so on that etherpad, we just right now want to know if you had ops team that could focus on just your project
17:31:09 <dtantsur> yeah, any help with upgrades and docs is particularly welcome
17:31:10 <mrhillsman> what would you expect from them
17:31:31 <mrhillsman> if just upgrades and docs, that is ok, we will try to do as much or as little as asked
17:31:32 <jroll> I agree, docs will be a big one
17:31:39 <jroll> probably multitenant networking
17:31:50 <mrhillsman> feel free to just dump stuff on there
17:31:57 <jroll> mrhillsman: I'm also going to start writing a sort of reference architecture, that includes kvm+ironic in the same region, I might drag you into that
17:32:04 <jroll> as it... isn't trivial
17:32:06 <mrhillsman> we have like 2-3 weeks plus the ops midcycle to gather intel and work out a plan
17:32:12 <rloo> mrhillsman: do you also help with openstack gate/CI? I mean improving ironic tests in the gate?
17:32:18 <mrhillsman> sounds good jroll
17:32:36 <dtantsur> jroll, just wanted to mention the reference architecture :)
17:32:38 <joanna> jroll: I love the idea
17:32:39 * dtantsur types too slowly
17:32:59 <mrhillsman> rloo nothing has been decided, we are gathering info right now and will define our actual work in a couple weeks after the ops midcycle
17:33:08 <mrhillsman> and we hope to get others to participate as well
17:33:14 <mrhillsman> to increase adoption
17:33:16 <mrhillsman> and feedback
17:33:19 <mrhillsman> to your team
17:33:20 <jroll> cool
17:33:39 <jroll> #action ironic team to put some operations requests in https://etherpad.openstack.org/p/ops-adopt-a-project-pike
17:33:41 <jroll> sound good?
17:33:41 <rloo> mrhillsman: that'd be great
17:33:45 * dtantsur needs to add ironic to his pet SDK side-project :D
17:33:48 <mrhillsman> perfect jroll
17:34:20 <rloo> mrhillsman: to be clear, where in that etherpad do you want us to add stuff? under the 'Ironic' part?
17:34:22 <mrhillsman> i would say keeps the ops midcycle in mind as well in case you can think of anything relevant to that audience
17:34:24 <mrhillsman> adding etherpad
17:34:37 <mrhillsman> sure, that works
17:34:45 <mrhillsman> we can make it all pretty and organized later
17:35:19 <dtantsur> this is awesome, thanks mrhillsman
17:35:39 <jroll> yes, thank you!
17:35:39 <mrhillsman> thank you all for entertaining us :)
17:35:52 <mrhillsman> looking forward to working together
17:36:00 <mrhillsman> that was all i had
17:36:03 <mrhillsman> thanks again jroll
17:36:18 <dtantsur> any questions for mrhillsman before we move on?
17:36:33 <jroll> no problem :)
17:37:25 <dtantsur> ok, we don't have RFE prepared for review, I guess, so
17:37:37 <dtantsur> #topic Open discussion
17:37:47 <dtantsur> bring whatever you have :)
17:38:22 * jroll has nothing
17:38:32 <jroll> unless we want to come back to weekly priorities
17:38:40 <jlvillal> For those of us who weren't at PTG.
17:38:51 <jlvillal> Curious on the movement of tempest plugin to its own repo.
17:38:51 <dtantsur> I'll repeat my comment from the channel about priorities: we don't have Pike priorities, and I'm not convinced people have enough time to really jump on anything this week
17:38:55 <jlvillal> Is that something we want to do?
17:39:02 <dtantsur> jlvillal, the same state, but yes, we want
17:39:05 * TheJulia has nothing, nor brain cells to say much else
17:39:12 <jlvillal> dtantsur: Thanks.
17:39:17 <jroll> dtantsur: ah right, I did see that
17:39:22 <dtantsur> jlvillal, they still target Queens, and the same people still disagree with that
17:39:23 <soliosg> There was an email from QA requesting to keep manage.py from tempest.scenario
17:39:24 <soliosg> http://lists.openstack.org/pipermail/openstack-dev/2017-February/112938.html
17:39:35 <soliosg> s/manage.py/manager.py
17:39:53 <dtantsur> oh
17:39:56 <jroll> oh ffs
17:40:06 <soliosg> it seems manager.py is going under refactoring/changes, and qa wants to minimize job gate breaks
17:40:09 <jroll> that's the worst way to deal with their problems there
17:40:19 <rloo> dtantsur: by the way, it is only monday, is something going on that folks won't have time, or do you mean that the folks that went to the ptg need to get back into work mode, etc?
17:40:43 <dtantsur> rloo, just the latter
17:41:04 <rloo> dtantsur: gotcha!
17:41:09 <dtantsur> :)
17:41:25 <soliosg> so, I will take create an ironic bug to summarize the QA request
17:42:00 <dtantsur> I guess we don't have many options here, do we?
17:42:08 <jroll> the tempest thing?
17:42:11 <jlvillal> Not really
17:42:26 <dtantsur> yep
17:42:35 <dtantsur> we've been using an unstable interface, apparently
17:42:43 <jroll> I don't see how this helps openstack as a whole
17:42:52 <jroll> we're just going to end with a bunch of copy pasted code around
17:42:59 <jroll> but this isn't the right venue for that argument
17:43:12 * dtantsur thinks of reviving oslo-incubator</kidding>
17:43:29 * jroll hopes that we can maneuver to just use the stable API and stop importing manager.py
17:43:34 <rloo> isn't it just copy/paste until they 'formalize' the new interfaces or whatever?
17:43:49 <rloo> anyway, thx solio for bringing it up etc
17:43:50 <soliosg> jroll: yeah, the suggestion is that every project keeps a copy of manager.py around
17:43:58 <dtantsur> rloo, it is
17:44:11 <jroll> 'until' never happens
17:44:13 <jroll> ever
17:44:20 <dtantsur> looking at the source code, we may use quite a lot of it..
17:44:27 * jroll stops talking, goes to be angry elsewhere
17:44:32 <rloo> jroll: you're so pessimistic! ha ha.
17:44:42 <aNuposic> I have a quick question, wrt to my patch https://review.openstack.org/#/c/403910/ do we want to allow logical names in PATCH call for port as well?
17:45:04 <jroll> rloo: I have 3 year old TODOs if you want me to prove my point :)
17:45:17 <rloo> jroll: i hear you ;)
17:45:43 <dtantsur> aNuposic, if you mean node names, likely yes
17:46:00 <aNuposic> dtantsur, yes node names
17:46:04 <aNuposic> cool
17:46:26 <dtantsur> as to the tempest issue, I don't see a lot of choice. I welcome someone to research the possibility of using only stable interfaces, but it does not look easy at first glance
17:46:45 <jroll> yeah, I'm just yelling to yell, it's monday
17:46:54 <dtantsur> I guess we'll have to do this "temporary" moving manager.py to our code (with potentially getting rid of everything we don't use)
17:47:32 <jroll> I suspect if tempest team finds it hard to refactor, we will too, but we can try
17:48:12 <dtantsur> well, we don't have to make every project happy in this case :)
17:48:31 <dtantsur> so e.g. we may strip bits obviously belonging to other projects (e.g. base classes we don't inherit)
17:48:38 <jlvillal> soliosg: Do you want to work on the tempest issue?
17:48:39 <jroll> right
17:49:11 <soliosg> jlvillal: I can take a look to see what it'll require
17:49:20 <jlvillal> soliosg: Thanks!
17:49:34 <dtantsur> #action soliosg to look into problem stated at http://lists.openstack.org/pipermail/openstack-dev/2017-February/112938.html
17:49:56 <dtantsur> thanks for mentioning it, much appreciated!
17:50:05 * dtantsur is still not even close to finishing his email backlog
17:50:24 <TheJulia> 10 minutes
17:50:34 * rloo wonders what is wrong with dtantsur's delete key
17:50:46 <jroll> heh
17:50:48 <dtantsur> hehe
17:51:08 <TheJulia> Or a pythons script using an imap client.... >.>
17:51:24 <TheJulia> s/pythons/python/
17:51:40 <dtantsur> moar pythons :)
17:51:57 <mgould> dtantsur: the day I found the "mark folder as read" key in Thunderbird was a great day indeed
17:52:08 <dtantsur> mgould, if it was so easy for me :D
17:52:16 <dtantsur> anyway, does anyone has anything else (too many "any" in one sentence)?
17:52:54 <rloo> crickets
17:52:59 <jroll> ^
17:53:07 <mgould> TheJulia: machine-learning system assigning a probability that each email is worth reading
17:53:17 <jroll> mgould: "return 0"
17:53:22 <dtantsur> yeah
17:53:26 <TheJulia> mgould: what troll said
17:53:28 <TheJulia> err
17:53:29 <jroll> WOW
17:53:31 <dtantsur> troll LOL
17:53:32 <TheJulia> jroll
17:53:33 * jroll ragequits
17:53:37 * TheJulia kicks autocorrect
17:53:38 <mgould> :-)
17:53:44 <dtantsur> I think we can wrap up on this note
17:53:46 <rloo> more crickets
17:53:52 <dtantsur> thanks everyone
17:53:53 <TheJulia> jroll: sorry about that, autocorrect seems to hate me today
17:54:02 <jroll> TheJulia: you know I don't care :)
17:54:02 <rloo> thx dtantsur
17:54:06 <mgould> either that or it hates jroll
17:54:13 * jroll points out he has the nick 'tjroll' registered
17:54:17 <vdrok> thanks all
17:54:18 <Michael-ZTE-1> :)
17:54:21 <mgould> o/
17:54:21 <Michael-ZTE-1> 88
17:54:26 <dtantsur> #endmeeting