17:00:02 <dtantsur> #startmeeting ironic
17:00:02 <mjturek> o/
17:00:02 <openstack> Meeting started Mon Apr 10 17:00:02 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:03 <lee4> o/
17:00:04 <fellypefca> o/
17:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:06 <openstack> The meeting name has been set to 'ironic'
17:00:07 <sauloaislan> o/
17:00:09 <rama_y> o/
17:00:14 <rpioso> o/
17:00:18 <crushil> \o
17:00:20 <dtantsur> Hi everyone!
17:00:25 <rloo> howdy
17:00:35 <milan> o/
17:01:00 <dtantsur> our agenda (quite light) is as usual at:
17:01:07 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:01:11 <stendulker> o/
17:01:33 <dtantsur> #topic Announcements / Reminders
17:01:56 <alezil> I/
17:02:00 <dtantsur> #info Boston Forum schedule was published
17:02:08 <jroll> \o
17:02:08 <dtantsur> (with some mistakes to be corrected, apparently)
17:02:13 <sambetts> o/ o/
17:02:16 * dtantsur does not have a link at hand
17:02:29 <nicodemos> o/
17:02:30 <soliosg> o/
17:02:53 <dtantsur> I don't have other announcements. Anyone?
17:03:05 <dtantsur> ah, hmm
17:03:38 <dtantsur> #info dtantsur is on PTO starting from Fri, Apr 14. Back on Mon, Apr 24
17:03:42 <dtantsur> yes, again :)
17:03:48 <jroll> woohoo
17:03:51 <milan> :)
17:03:58 <rloo> dtantsur: wow, lucky you!
17:03:59 <dtantsur> I think a few more folks are going to be out the same week, right? TheJulia at least
17:04:01 <jroll> I'll be out tues-thurs this week, btw
17:04:05 <jroll> julia as well
17:04:12 <jroll> (leadership training)
17:04:23 <JayF> o/
17:04:29 <dtantsur> thanks! let's keep it in mind when defining priorities for the coming weeks
17:04:53 <dtantsur> #info a suggestion for a virtual meetup: https://etherpad.openstack.org/p/ironic-virtual-meetup
17:04:54 <rloo> jroll: would you chair next Mon's meeting?
17:05:02 <rloo> jroll: please :)
17:05:22 <jroll> rloo: sure, why not
17:05:27 <dtantsur> thanks jroll!
17:05:31 * rloo going to see if there is any diff with jroll's leadership...
17:05:54 <jroll> 3 cycles of history not enough? :P
17:06:03 <dtantsur> hah, rloo is already preparing for the next elections :)
17:06:07 <rloo> jroll: but the leadership course...!!
17:06:12 <jroll> oh, that
17:06:18 <dtantsur> ah, yeah. fair :)
17:06:23 <jroll> I've been once already, I'm helping connect dots
17:06:39 <rloo> :)
17:06:42 <dtantsur> please have one in EU, and I'll attend. otherwise you'll have to live with my terrible leadership for some more time :-P
17:07:03 <dtantsur> anyway, another request to take a look at the virtual meetup proposal: https://etherpad.openstack.org/p/ironic-virtual-meetup
17:07:16 <rloo> wrt virtual meetup. with dtantsur and TheJulia gone next week. Am wondering whether we should punt it another week.
17:07:26 <dtantsur> rloo, it's proposed for week of Apr 24
17:07:31 <joanna> o/
17:07:41 <dtantsur> as it was suggested on the previous meeting
17:07:44 <rloo> dtantsur: right, you and TheJulia will have just come back. will you be prepared to participate?
17:07:53 <TheJulia> I will be
17:07:59 * TheJulia re-engages the cloaking device
17:08:00 <dtantsur> always prepared :) I'm not going anywhere, just hanging out here in Brno
17:08:17 <dtantsur> trying to reduce stress by examining the nearby bars
17:08:36 <TheJulia> dtantsur: That sounds like an awesome plan
17:08:37 <milan> dtantsur, +2000
17:08:53 <dtantsur> we can get back to the meetup topic in the open discussion. any other announcements?
17:09:26 * milan announces lack of sleep :P
17:09:33 <dtantsur> :)
17:09:44 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:09:54 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:10:02 <dtantsur> starting with line 75
17:10:15 <rloo> (oh, was it last week that we did an ironic release?)
17:10:50 <dtantsur> yeah, probably
17:10:58 <jroll> yes, april 5
17:11:04 <jroll> 8.0.0 specifically
17:11:26 <JayF> Only three more major releases and we'll be better than windows! /s
17:11:41 <rloo> JayF: huh, aren't we better already?
17:11:52 <JayF> rloo: Windows is 10, we're only 8!
17:12:02 <dtantsur> Firefox is 52..
17:12:07 <xavierr> lol
17:12:08 <rloo> JayF: but we're better, regardless ;)
17:12:24 <mrtenio> rloo, agreed
17:12:31 <JayF> I was joking, obviously :)
17:12:40 <dtantsur> "jroll promises to look at this week of march 27" I wonder if he did ;)
17:12:45 <dtantsur> (line 154)
17:12:56 <jroll> damn, no I did not
17:13:18 * jroll bumps on todo list, sorry
17:14:27 <dtantsur> rolling upgrades: "make a change to the grenade job to only upgrade conductor" (from the priority list)
17:14:29 <dtantsur> was it done?
17:14:33 <rloo> jroll: related to last week and these priorities. you were going to review the nova stuff to see if there is anything we need to do b4 nova's feature proposal freeze
17:15:09 <jroll> rloo: yes, I instead did paperwork all week. I've got it docketed for today
17:15:28 * jroll hasn't had much time for upstream, sorry
17:15:29 <rloo> vdrok: ^^ do you know what the status is with multi-node grenade testing changes?
17:15:42 <rloo> jroll: ok, i'll try to remember to ask next week :)
17:17:22 <dtantsur> 2 more minutes to review the statuses
17:19:17 <dtantsur> done reviewing?
17:19:28 <rloo> yuppers
17:19:44 <dtantsur> #topic Deciding on priorities for the coming week
17:20:02 <dtantsur> I'm inclined to leave it as it is now (with moving BFV to next patches)
17:20:05 <dtantsur> what are your thoughts?
17:20:16 <jroll> fine with me
17:20:35 <rloo> +1
17:20:40 <joanna> +
17:20:43 <JayF> ++
17:20:54 <mariojv> ++
17:21:04 <dtantsur> good
17:21:27 <dtantsur> before we move on. who was leading the bug triage previously and who wants to?
17:21:50 * dtantsur thinks we should also start fixing bugs, not only triaging..
17:22:22 * jroll looks back
17:22:24 <JayF> I don't know who was doing it before, but I can take it this week if there are no volutneers
17:22:34 <dtantsur> awesome! thanks JayF
17:22:43 <dtantsur> #info JayF to help with bug triaging this week
17:22:52 <jroll> I think we missed it last week
17:23:08 <jroll> was TheJulia and vdrok previously
17:23:12 <dtantsur> yeah, my bad. was just out of PTO :)
17:23:31 <dtantsur> #topic #Trello fate
17:23:36 <dtantsur> wut?
17:23:38 <dtantsur> #undo
17:23:39 <openstack> Removing item from minutes: #topic #Trello fate
17:23:45 <dtantsur> #topic Trello fate
17:23:56 <dtantsur> looks good now :) rloo, your turn
17:24:15 <rloo> well, dtantsur brought it up at a previous meeting. we had been using trello. do we want to continue?
17:24:16 * jroll pulls out a knife
17:24:26 * jroll waits for the kill word
17:24:30 <rloo> trello hasn't been updated so if no one will volunteer to use it, i think we should NOT
17:24:35 <dtantsur> I'm very pleased with how we track things on the etherpad
17:24:38 <rloo> i mean, volunteer to update it
17:24:57 <rloo> so might be easiest to ask: does anyone want to continue using trello?
17:25:11 <jroll> we've been asking about it for weeks, nobody has stood up and said they want it, afaik
17:25:38 <dtantsur> I think somebody wanted it on the previous meeting.. but I'm not sure
17:25:44 <rloo> ok, let's get rid of it. fwiw, the etherpad doesn't cover stuff that used to be i trello. trello had links to nova patches and ironic patches.
17:26:02 <rloo> dtantsur: i wanted it cuz i found it useful, but only if it is keep up to date.
17:26:03 <dtantsur> rloo, 1-2 gerrit topics should cover it
17:26:06 <jroll> any reason the etherpad doesn't? I feel like it should
17:26:33 <rloo> no reason tht the etherpad cannot. i'm just not sure it does have that info.
17:26:38 <dtantsur> let's just add all related topics to subteam items on the etherpad
17:26:57 <dtantsur> anyone wants to? otherwise I can do it
17:27:51 <dtantsur> #agreed abandon our Trello board in favor of the WhiteBoard
17:28:24 <rloo> dtantsur: while you're at it, i'm not sure cuz it has been a while, but trello had some projects that weren't completed that I don't think are in our priorities. if taht's the case, would you please make sure there are bugs open for those?
17:28:32 <dtantsur> rloo, sure
17:28:41 <rloo> thx dtantsur
17:28:51 <dtantsur> #action dtantsur to move all useful information from Trello to the WhiteBoard or Launchpad (for non-priorities)
17:28:57 <dtantsur> anything else here?
17:29:27 <dtantsur> ok, before we jump into open discussions
17:29:32 <dtantsur> #topic Virtual meetup
17:29:43 <dtantsur> #link https://etherpad.openstack.org/p/ironic-virtual-meetup
17:30:03 <dtantsur> if it does happen on the week of Apr 24, I need to organize it *this* week. or I need somebody to organize it the next week.
17:30:29 <jroll> what all needs to be organized? time/place/?
17:30:35 <dtantsur> I suggest to start with a doodle for specific dates
17:30:54 <dtantsur> then getting a conference number (or how was it called?)
17:31:09 <dtantsur> actually, we can try using my bluejeans, they work with latest FF and Chrome without plugins
17:31:19 <dtantsur> but I can't promise :) so we'd better have SIP as a backup
17:31:41 <dtantsur> and finally, to announce the details on the ML
17:31:45 <rloo> i thought we used something that openstack provided. that stopped working during the meetup
17:31:53 <NobodyCam> ++ to SIP backup!
17:32:02 * jroll wonders if there's anyone that will refuse to / cannot use bluejeans
17:32:08 <dtantsur> rloo, this is what I just call SIP
17:32:16 <rloo> dtantsur: ah.
17:32:19 <dtantsur> jroll, it probably involves non-free javascript, so there may be
17:32:34 <jroll> dtantsur: right, also curious if it's reachable from china etc
17:32:39 <dtantsur> oh yeah
17:32:54 <dtantsur> I think I had meetings with folks from China, but the point is still valid
17:32:55 <jroll> anyway, openstack SIP is always open, so that's an easy backup
17:32:57 <JayF> I'll say that personally, I find it extremely difficult to understand what folks are saying without an accompanying video to lip read from
17:33:06 <JayF> but I understand if folks freedom-concerns prevent that
17:33:13 <dtantsur> JayF++
17:33:22 <dtantsur> fwiw I think you can call into bluejeans from a phone
17:33:27 <rloo> well, i guess that's why we have PTG
17:33:35 <dtantsur> which is of course completely free and open source ;)
17:33:43 <dtantsur> (the phone, I mean)
17:33:45 <jroll> hah
17:34:03 <rloo> do we have an idea of how many days/hours?
17:34:09 <dtantsur> jroll, should we reserve something in OpenStack SIP for specific days?
17:34:22 <jroll> dtantsur: there's no reservation system, afaik
17:34:26 <dtantsur> rloo, so, my idea was: two slots in one day to accommodate different timezones
17:34:31 <dtantsur> similar to the midcycle
17:34:49 <jroll> dtantsur: this would be the closest thing to reservations https://wiki.openstack.org/wiki/VirtualSprints
17:35:10 <rloo> oh my, this was the previous midcycle: https://etherpad.openstack.org/p/ironic-newton-midcycle
17:35:14 <dtantsur> so, back to planning, ideally if I can create the doodle this week, the next week somebody makes it official
17:35:34 <dtantsur> but I can rush everything in this week, if there are no volunteers
17:36:22 * jroll doesn't want to promise anything right now, hopes someone steps up to coordinate
17:36:23 <dtantsur> #link https://wiki.openstack.org/wiki/VirtualSprints
17:36:50 <rloo> do we really want a midcycle? i'm half joking. just looking at the previous one and what we have gotten accomplished since then...
17:37:02 <mariojv> git clone https://git.openstack.org/openstack-dev/devstack.git devstack
17:37:07 <mariojv> whoops, sorry
17:37:19 <thomasem> lol
17:37:20 <dtantsur> mariojv, access denied ;)
17:37:25 <rloo> am wondering whether we should 'just' have days/times, regardless of what week, to *do* something
17:37:46 * jroll wonders if rloo is implying we haven't done much since, or have and so we don't need them
17:37:49 <dtantsur> rloo, I was thinking into breaking the midcycle into such smaller sprints. and I want to have the first happening before I can suggest do it regularly
17:38:03 <rloo> i mean, just pick feature X, prepare, and meet at <whenever> and do it.
17:38:35 <dtantsur> planning is hard though: timezones, other meeting, etc
17:39:06 <rloo> if sprints work for folks then that is fine. i was just wondering if it might work better if we just say, eg. rescue is there, we want to just sit down and go over it. or spec Foo is there, lets just meet and go over it...
17:39:29 <rloo> so eg, etags spec looks like it is almost there. let's just meet this week at .. and get it done.
17:39:51 <dtantsur> this is a bit different think, I suspect
17:40:06 <dtantsur> in your etags example, we only need cores and the author
17:40:16 <joanna> rloo: something like regular spec review meeting with specific timeslot and list of specs?
17:40:16 <dtantsur> this can indeed just happen one day this week
17:40:18 <JayF> I like rloo's example, honestly
17:40:35 <rloo> dtantsur: well, i was looking at your #2 in the meetup. what are we going to accomplish there?
17:40:40 <JayF> and it mirrors some stuff we've done before with some features, i.e. a couple of weeks ago mario, annie, anup and I met and worked on rescue for a couple of hours
17:40:55 <dtantsur> rloo, something close to what you suggest, I guess
17:41:44 <jroll> I believe we had a similar conversation when dtantsur originally proposed this. and agreed we should do targeted meetups like rloo mentioned, *and* occassional syncups like dtantsur proposed. am I remembering this wrong/
17:41:49 <rloo> dtantsur: of those things listed in the meetup, i would be only interested in #3.
17:41:49 <jroll> s/\//?/
17:42:08 <dtantsur> jroll, I thought the same
17:42:17 <rloo> dtantsur: i think it'd be great if we could do 1, 2 in a diff way.
17:42:28 <rloo> dtantsur: i was hoping that our weekly meetings could address 1
17:42:49 <dtantsur> rloo, my point is, such meetup can collect bigger audience (e.g. our QE got interested when I talked about my proposal last week)
17:43:05 <dtantsur> for the benefit of people who don't attend every meeting we have
17:43:23 <dtantsur> 3rdparty CI conversation will attract specific audience who is not necessary here
17:43:32 <dtantsur> but dunno. I agree with jroll, we should have both
17:43:47 <dtantsur> and I think targeted meetups do not have to be driven by the PTL ;)
17:43:54 <jroll> ++
17:44:08 <jroll> if people aren't interested in the 'midcycle' topics, they don't need to join
17:44:09 <rloo> dtantsur: i'm fine if others want to have this meetup and will get something from it. and i agree the 3rd party ci will be a useful meeting to have.
17:44:12 <jroll> let's give it a shot
17:44:41 <dtantsur> ok, so I'll start with a doodle
17:44:56 <jroll> (or those people can add more topics, of course) :)
17:45:00 <dtantsur> as I don't see volunteers for organizing it, the deadline for the doodle will be Friday
17:45:24 <jroll> dtantsur: thanks for doing that
17:45:50 <dtantsur> we'll use SIP, but we can also experiment with Bluejeans, if folks will feel like. co-ordination through our regular channel. any other thoughts?
17:46:54 <dtantsur> I'm ready to move on. And you? :)
17:47:39 * jroll is
17:47:47 <dtantsur> #topic Open discussion
17:47:53 <ricardoas> hey, I've got an issue to share regarding oneview drivers :)
17:48:04 <dtantsur> sure
17:48:06 <xavierr> hey ironic, we from oneview have a patch where we are discussing about non-persistent boot in our drivers we want your opinion if our idea for implement that is fair. suggestions are welcome! link: https://review.openstack.org/#/c/436469/
17:48:07 <ricardoas> we'd love to replace python-oneviewclient (and deprecated it) by hpOneView, it's been more actively maintained and supporting newer oneview api versions and we are already using it at oneview ml2 driver
17:48:29 <rloo> want opinion on whether to show driver 'type' column in https://review.openstack.org/#/c/419274/
17:48:53 <dtantsur> rloo, in driver-list or driver-show?
17:49:00 <ricardoas> but we need some advice on what to do with specific validations like the ones at https://github.com/openstack/ironic/blob/master/ironic/drivers/modules/oneview/common.py#L150
17:49:09 <mariojv> rloo: oh, this is that microversion inconsistency topic?
17:49:19 <dtantsur> ricardoas, what's the problem with that?
17:49:19 <ricardoas> our best guess is to move it upstream, wdyt?
17:49:28 <rloo> mariojv: yeah.
17:49:41 <dtantsur> ricardoas, "move it upstream" gets my support any day :)
17:50:06 <soliosg> One item here. Wonder if we could bring forward 'move ironic tempest plugin to the new repository' task
17:50:09 <ricardoas> dtantsur, i've talked with some of you during the week and it was suggested to raise it here... so just checking if it is ok to move this validations upstream
17:50:11 <rloo> dtantsur: in driver_list
17:50:29 <ricardoas> dtantsur: \o/
17:50:35 <mariojv> rloo: i think it should be consistent with what driver show does
17:50:36 <soliosg> I did some initial work, porting patches from ironic/ironic_tempest_plugin to the new repo
17:50:49 <rloo> dtantsur: in driver_show, it will show 'type' with no value, but it is in a row. in driver_list, 'type' will be a column with nothing in it.
17:50:54 <dtantsur> rloo, hmm, in list. I suspect the answer is "no, because of microversions", right?
17:50:56 <dtantsur> right
17:51:12 <dtantsur> rloo, I suggest we don't show it. I hope the day will come when all drivers are new-style.
17:51:15 <mariojv> rloo: but if it's a huge refactor to get it hidden or something, i might be ok with the small inconsistency
17:51:43 <soliosg> They're still waiting for review. I think cores could review & approve. The real review would be when making changes to project config and devstack-gate
17:51:47 <rloo> so the right way, is not to show info that isn't avail in a microversion but we didn't do that for information. to date, that info is usually some field, so it shows up as a row in eg <resource>-show.
17:51:48 <dtantsur> soliosg, thanks! this is one thing I constantly forget about. We have to freeze our tempest plugin and start merging the patches.
17:52:01 <rloo> this list one is the first time (I think) the info is a column.
17:52:27 <mariojv> also here are some links illustrating the issue in case anyone has trouble visualizing this: http://paste.openstack.org/show/603982/ vs http://paste.openstack.org/show/603983/
17:52:32 <dtantsur> soliosg, with project-config and devstack-gate, I think you can rely on help of #openstack-qa and mtreinish personally :) they are very keen on projects moving to branchless plugins.
17:52:58 <ricardoas> regarding this patch that xavierr pasted... i think we should just store something at the node internal info to warn the boot change function that the next operation will be non persistent. Any better idea, folks? :D
17:53:12 <soliosg> dtantsur: yes, also jlvillal_pto has provided great support!
17:53:13 <dtantsur> rloo, why do we need to show this column at all?
17:53:34 <mtreinish> dstanek: heh, actually both project-config and devstack-gate are the domain of -infra. I'll gladly look and review patches, but I don't have the big rubber stamp on either :)
17:53:43 <rloo> dtantsur: well, that is a good question. it isn't a need. do we want to or not?
17:53:56 <mariojv> dtantsur: i suppose we don't, but then we'd be not exposing something potentially useful returned by the api
17:53:57 <dtantsur> mtreinish, yeah, I specifically mean "look and review" part
17:54:17 <rloo> dtantsur: with the driver stuff, i think it is in the spec that driver-list shows the type.
17:54:23 <dtantsur> rloo, mariojv, I hope one day all drivers are new-style, and this "Type" column will be always-true
17:54:31 <mariojv> oh, i see your point
17:54:43 <dtantsur> even worse, if we remove it in one microversion, then this column will have to go away too..
17:55:01 <dtantsur> rloo, how many times have we amended this spec already? one more won't hurt :)
17:55:29 <rloo> dtantsur: I'm fine with amending the spec. we just need to decide. (and i wanted a decision before i reviewed more).
17:55:38 <rloo> dtantsur: keep in mind, the API is returning 'type' .
17:55:55 <dtantsur> yeah, but we don't have to expose everything in a list CLI call
17:56:10 <dtantsur> especially when we have reasons to believe that it will become redundant one day
17:56:26 <rloo> dtantsur: that is true. i'm fine with that. so no type in CLI except in show or if we add 'filter'ing on driver-list...
17:56:55 <ricardoas> dtantsur: if there is some time left, i'd like to talk about this patch too: https://review.openstack.org/#/c/408298/
17:57:10 <mariojv> i think that's reasonable for now
17:57:17 <rloo> dtantsur: or if driver-list --detail is specified. i think we have --detail...
17:57:18 <ricardoas> (and everyone else...)
17:57:42 <dtantsur> rloo, ++
17:57:49 <NobodyCam> *Two (2) minutes to go*
17:58:37 <rloo> dtantsur: ok, no one is in disagreement, so i'll convey the news to the author of the patch :)
17:58:58 <dtantsur> rloo, thanks! good point to raise indeed, the author of the driver composition spec clearly did not think about it ;)
17:59:17 <dtantsur> I suggest we move the discussion of the specific patches to the channel, if you don't mind
17:59:21 <dtantsur> ricardoas, ^^^
17:59:24 <rloo> dtantsur: can't expect the author of the spec to think about everything. but we're close to the finish line now :)
17:59:25 <ricardoas> ok :)
17:59:33 <ricardoas> no problem
17:59:51 <dtantsur> #agreed Do not expose "Type" column in the output of driver-list without --detail
17:59:58 <dtantsur> thanks everyone!
18:00:02 <mariojv> ty
18:00:04 <joanna> thanks :)
18:00:04 <soliosg> thanks all
18:00:07 <milan> o/
18:00:08 <ricardoas> thanks!
18:00:10 <dtantsur> #endmeeting