17:23:56 <dtantsur> #startmeeting ironic
17:23:56 <openstack> Meeting started Mon May  1 17:23:56 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:23:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:24:00 <openstack> The meeting name has been set to 'ironic'
17:24:12 <jlvillal> o/ Like I've been waiting a really long time....
17:24:12 <dtantsur> finally! hello everyone and welcome to ironic meeting :)
17:24:17 <NobodyCam> w00t
17:24:21 <dtantsur> our agenda is as usual at
17:24:23 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:24:27 <Nisha_Agarwal> :)
17:24:29 * jlvillal arm is tired ...
17:24:36 <dtantsur> #topic Announcements / Reminders
17:24:46 <dtantsur> #info Pike priorities update: https://review.openstack.org/#/c/460086/, all cores please vote
17:24:59 <dtantsur> we're reducing the number of priorities :( and removing some people :( :(
17:25:20 <rloo> :-(
17:25:24 <Nisha_Agarwal> :(
17:25:31 <dtantsur> next,
17:25:35 * jlvillal emotes sadness
17:25:37 <dtantsur> #link http://lists.openstack.org/pipermail/openstack-dev/2017-April/116095.html summary of the virtual meetup
17:25:47 <dtantsur> it was quite good, let's try moar of these
17:25:59 <dtantsur> #info OpenStack R will be called Rocky :)
17:26:21 <jlvillal> dtantsur: There was a suggestion that maybe we could do one of our meetings each month as a conference call
17:26:22 <dtantsur> next, I suggest canceling the next meeting, on May 8th
17:26:31 <dtantsur> jlvillal, we can try it, sure
17:26:33 <jlvillal> dtantsur: I am +1 on that. Maybe first meeting of the month?
17:26:47 <dtantsur> jlvillal, starting with June, I guess?
17:26:47 <jlvillal> Not sure what others think.
17:26:53 <Nisha_Agarwal> +1
17:27:10 <jlvillal> Okay for cancelling if a lot of people will be absent. I'll be around.
17:27:10 <dtantsur> jlvillal, let's bring it to the ML, we don't have a quorum here unfortunately
17:27:19 <jlvillal> Works for me.
17:27:33 <dtantsur> May 8th is a holiday in many places, and it's also the 1st day of the Forum
17:28:03 <rloo> in honor of ^^, lets skip the meeting next Monday
17:28:04 <jlvillal> makes sense then.
17:28:10 <dtantsur> ok
17:28:15 <NobodyCam> sounds good
17:28:18 <dtantsur> #agreed Let's skip the meeting next Monday
17:28:29 <dtantsur> any other announcements, reminders?
17:28:56 <dtantsur> #topic Review subteam status reports
17:29:13 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard starting with line 92
17:29:26 <dtantsur> I hope that most of you already had a chance to review/update it due to the late start
17:29:31 <dtantsur> any questions or comments?
17:30:10 <rloo> i have a question about bfv. there's a lot of stuff there. what i want to know is: is it working?
17:30:27 <dtantsur> TheJulia, mjturek ^^^
17:30:39 <TheJulia> hshinna has been doing testing, although he found a blocking connection information constraint
17:30:53 <TheJulia> hopefully we'll have that taken care of this week
17:30:54 <rloo> TheJulia: so all the patches are there, just need more testing, reviewing?
17:31:22 <TheJulia> some refactoring of the cinder driver is going to be needed to send along exactly what cinder is expecting, not just what it is using, since it expects more.
17:31:39 <rloo> TheJulia: and the nova side -- is that a 'simple' patch? (just trying to get an idea of when we need to get the ironic side done etc in order to get it all into pike)
17:31:41 <wanyen> IMO, uefi iscsi boot fromcinder volume should be part of the bfv
17:31:43 <TheJulia> and another patch needs to be wrapped up that is skip logic for the conductor
17:32:04 <TheJulia> wanyen: This has been discussed.  We have a specific BFV meeting if you wish to discuss it.
17:32:31 <rloo> TheJulia: ok. if we don't ask, someone should ping us when we are getting close to eg nova deadlines...
17:32:34 <dtantsur> TheJulia, do we already have a chain of patches that can be tried out? or is it still too WIP?
17:32:39 <TheJulia> rloo: fairly simple, I believe it is just one patch.  I'm starting to doubt pike because the fallout has pretty much nuked our velocity right now
17:32:39 <wanyen> The Julia, when and what room of bfv meeting?
17:32:49 <rloo> TheJulia: :-(
17:32:53 <dtantsur> wanyen, https://wiki.openstack.org/wiki/Meetings/Ironic-BFV
17:32:53 <TheJulia> wanyen: please see https://eavesdrop.openstack.org
17:32:55 <jlvillal> wanyen: http://eavesdrop.openstack.org/
17:33:08 <wanyen> The Julia, tx
17:33:19 <TheJulia> dtantsur: chain, but one that is needed is WIP which is deployment skip logic
17:33:21 <dtantsur> TheJulia, did you have a chance to chat with derekh? you can try throwing things on him
17:33:27 <TheJulia> I created it and tossed it up to see
17:33:49 <TheJulia> I briefly chatted with derekh, he was going to look into things and get back with me
17:34:09 <dtantsur> ok, good. I hope he can more or less compensate the loss of people..
17:35:00 <TheJulia> me too
17:35:12 <dtantsur> it still looks doable, let's try to keep the pace
17:35:25 <rloo> the other 'big' thing i'm not sure about, are all the network-related stuff.
17:35:53 <rloo> there are links to various things, not sure which are more urgent, which to review first, etc.
17:36:01 <dtantsur> TheJulia, I wonder if it's possible to more aggressively split the patches to avoid 1000-lines like https://review.openstack.org/#/c/366197/
17:36:12 <dtantsur> rloo, the week priorities? :)
17:36:44 <dtantsur> I mean, networking is great, but BFV and rolling upgrades are around for so long that they count as technical debt :)
17:36:46 <TheJulia> dtantsur: it is kind of one of those half full or half empty things.  More patchesets will also just slow us down just as well
17:36:53 <rloo> dtantsur: yes, but who knows what the priorities are :-(
17:37:02 <dtantsur> TheJulia, maybe. it's much easier for me to review small patches
17:37:20 <dtantsur> rloo, we decide it every week, no? or do I misunderstand your question?
17:37:26 <jlvillal> +1 on easier to review smaller patches, but I'm stating the obvious :)
17:37:43 <rloo> dtantsur: we do, but we haven't had network folks in our meetings for a few weeks.
17:37:55 <rloo> dtantsur: do you know what the priorities are for the network related work?
17:38:26 <TheJulia> seems like we need to circle back tomorrow about networking stuff
17:38:43 <dtantsur> rloo, not quite, that's why we have meetings..
17:38:48 <mjturek> TheJulia: I'm hoping to get an update on the cinder driver either today or tomorrow FYI. I might have some questions later today though
17:39:04 <TheJulia> mjturek: awesome
17:39:10 <rloo> dtantsur: right, which is why i'm bringing it up, I don't have a good feel for the network related stuff :)
17:39:43 <dtantsur> me neither. my gut feeling is that it's not THAT pressing as stuff we have now (and our priorities seem to confirm that)
17:39:55 <TheJulia> rloo: status I'm aware of is sambetts|afk was writing the spec as of last week
17:39:58 <TheJulia> for routed networks
17:40:18 <TheJulia> They are intertwined, perhaps we should re-prioritize the network stuff for landing next cycle......
17:40:25 <TheJulia> the remaining stuff that is
17:40:28 * dtantsur notes that we're past 10 minutes cap for the statuses
17:40:39 <rloo> seems like a chicken/egg (just saying). since i don't know if any network things are priorities, i wouldn't suggest they get on the weekly priority list...
17:41:01 <TheJulia> rloo: without specs/things to review.... *shrug*
17:41:28 <dtantsur> well, let's chat about priorities then :)
17:41:30 <rloo> ok, lets take offline. if anyone sees any of the network guys grab them and interrogate.
17:41:43 <dtantsur> #topic Deciding on priorities for the coming week (2 weeks in this case)
17:41:48 * TheJulia orders large bright lights off of amazon
17:41:58 <dtantsur> TheJulia++
17:42:10 <dtantsur> ok, we've landed one of the items - the client side for the driver comp (\o/)
17:42:38 <rloo> the etags spec has one +2.
17:42:50 <dtantsur> do we even want to take more? or let's try to make some progress during these 2 a bit shorter (for some of us) weeks?
17:43:31 <TheJulia> I can go take a look at the etags spec later today once I test out some images in my lab
17:43:40 <dtantsur> cool!
17:43:52 <rloo> thx TheJulia!
17:44:32 <rloo> dtantsur: i'm fine with the weekly priorities as is. maybe after forum, we can pick up momentum.
17:45:00 <dtantsur> yeah, we can't expect a lot of activity till next meeting, due to all these things
17:45:12 <dtantsur> any objections to keep pushing on the same topics?
17:45:45 <dtantsur> oh, I'm putting https://review.openstack.org/#/c/460086/ there as it's a must do
17:45:50 <TheJulia> I wouldn't mind a longer list of priority things that need reviews, personally. But I'm stupidly busy right now
17:46:22 <dtantsur> if we magically finish with what we have, we can take more from the same topics
17:46:31 <TheJulia> wfm
17:46:45 <dtantsur> ok, then
17:46:48 <dtantsur> #topic Open discussion
17:47:04 <dtantsur> anything?
17:47:49 * dtantsur wraps up in 1 minute of nobody brings anything :)
17:47:55 <rloo> just a quick one i hope. wrt cimc
17:48:07 <rloo> sam wants to rename the Cisco UCSM driver (https://review.openstack.org/#/c/400673/). Given the dynamic drivers, is it worth doing?
17:48:16 <rloo> or sorry, ucsm.
17:48:41 <TheJulia> we agreed a long time ago not to change the legacy drivers once composition landed
17:48:55 <dtantsur> oh, that driver..
17:49:00 <dtantsur> yes, TheJulia++
17:49:10 <dtantsur> what's even worse, IIRC UcsSdk is deprecated
17:49:10 <rloo> that's what i thought.
17:49:19 <rloo> OH
17:49:30 <rloo> so -2 on that patch i guess.
17:51:07 <rloo> (that's it for me)
17:51:08 <dtantsur> I suspect so
17:51:09 <TheJulia> I feel like -2 is kind of right
17:52:00 <dtantsur> ok, let's comment on the patch then
17:52:03 <dtantsur> anything else?
17:52:31 <TheJulia> is it worth mentioning that people should ping me if they need an ironic core next week?
17:52:38 <TheJulia> at the summit/forum?
17:52:47 <rloo> TheJulia: yup
17:52:57 <rloo> TheJulia: i think you'll be the only core there?
17:53:05 <TheJulia> I believe so yes
17:53:17 <rloo> unless jroll is going? anyone know?
17:53:18 <jlvillal> REPRESENT! ;)
17:53:23 <TheJulia> It may also mean that I might have to take on an additional session
17:53:29 <dtantsur> rloo, I think he is not
17:53:31 <TheJulia> I don't think jroll is going ag this point
17:53:36 <TheJulia> err, at
17:53:47 <TheJulia> I just messaged him earlier so I'll know soon enough
17:53:48 <rloo> thank you so much TheJulia! :)
17:53:57 <jlvillal> +1 Thanks TheJulia
17:54:00 <dtantsur> ++
17:54:05 <TheJulia> <3
17:54:21 <TheJulia> No thanks are required, I'm just doing what is needed :)
17:55:38 <dtantsur> finishing 5 minutes earlier as a compensation of the late start? :)
17:55:44 <rloo> ++
17:55:45 <NobodyCam> :)
17:56:01 <dtantsur> thanks all, see you in 2 weeks in this room and tomorrow otherwise!
17:56:01 <TheJulia> dtantsur: sounds awesome :)
17:56:15 <dtantsur> #endmeeting