17:00:28 <dtantsur> #startmeeting ironic
17:00:29 <openstack> Meeting started Mon Jun 19 17:00:28 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:32 <openstack> The meeting name has been set to 'ironic'
17:00:33 <TheJulia> o/
17:00:41 <mjturek> o/
17:00:41 <stendulker> o/
17:00:45 <rpioso> o/
17:00:47 <dtantsur> hi everyone!
17:00:47 <anupn> o/
17:00:49 <rloo> o/
17:00:52 <crushil> \o
17:00:57 <rama_y> o/
17:01:13 <jlvillal> o/
17:01:26 <dtantsur> our agenda is as usual at:
17:01:29 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:01:35 <milan> o/
17:02:22 <sambetts> o/
17:02:22 <NobodyCam> o/
17:02:34 <baha> o/
17:02:46 <dtantsur> #topic Announcements / Reminder
17:02:57 <dtantsur> #info PTG information and registration available
17:03:03 <dtantsur> #link https://www.openstack.org/ptg/
17:03:35 <dtantsur> this is hopefully self-explanatory :)
17:03:39 <TheJulia> :)
17:03:54 <dtantsur> #info ironic-lib 2.8.0 (Pike) released
17:03:59 <vdrok> o/
17:04:10 <dtantsur> anything else?
17:05:03 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:05:15 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard starting with line 99
17:05:39 <ricardoas> o/
17:05:53 <fellypefca> o/
17:06:21 * jlvillal wonders if we should make gate-grenade-dsvm-ironic-multinode-multitenant-ubuntu-xenial-nv a voting job
17:06:26 <rloo> dtantsur: wrt your tool at http://ironic-divius.rhcloud.com, i use it when you aren't around and i want to update the bugs stats :-)
17:06:33 <jlvillal> http://ci-watch.tintri.com/project?project=ironic&time=7+days
17:06:48 <dtantsur> rloo: cool :)
17:07:13 <dtantsur> jlvillal: this sounds like something to make voting. what additional coverage does it provide?
17:07:32 <jlvillal> dtantsur: It is testing the rolling upgrade scenario
17:07:52 <dtantsur> jlvillal: which we don't have yet, right? I mean, the upgrade
17:07:58 <jlvillal> dtantsur: Having an old and new conductor at same time.
17:08:04 <jlvillal> dtantsur: Right, it is the only job that tests that.
17:08:57 <dtantsur> I guess we can make it voting and hope that we do land rolling upgrades :)
17:09:14 <rloo> jlvillal: has that test been passing (as expected), etc?
17:09:30 <jlvillal> rloo: Based on http://ci-watch.tintri.com/project?project=ironic&time=7+days, I would say yes
17:10:22 <rloo> jlvillal: is there any way to see beyond 7 days?
17:10:39 <jlvillal> rloo: Change the "time=" setting?
17:10:52 <rloo> jlvillal: i think it has been behaving properly, just wonder what the status show
17:11:02 <jlvillal> But when I tried 14 days it gave server error
17:11:03 <rloo> jlvillal: no, that only seems to work for max 7 days. 'that' == CI Watch
17:11:19 <jlvillal> I think that is all the history we have
17:11:41 <rloo> well, i'm good with having it vote, we can always unvote if there are issues, and better to notice now than at end of cycle?
17:12:32 <jlvillal> +1
17:12:37 <dtantsur> ++
17:12:44 <TheJulia> +1
17:13:22 <jlvillal> Okay. I will propose a patch
17:13:54 <rloo> thx jlvillal
17:14:04 <rloo> dtantsur: should we put a #agree or whatever it is?
17:14:06 <jlvillal> #action jlvillal to submit patch to make gate-grenade-dsvm-ironic-multinode-multitenant-ubuntu-xenial-nv a voting job
17:14:34 * TheJulia wonders if that gets recorded if it is done by someone who is not the chair
17:14:40 * dtantsur wonders too
17:14:44 <jlvillal> I think it is "#agreed" https://wiki.debian.org/MeetBot
17:14:52 <dtantsur> action should also work
17:15:00 <dtantsur> #action jlvillal to submit patch to make gate-grenade-dsvm-ironic-multinode-multitenant-ubuntu-xenial-nv a voting job
17:15:05 * dtantsur duplicated just to be sure
17:15:09 <jlvillal> action is for everyone. #agreed is only for the chair
17:15:09 <TheJulia> \o/
17:15:23 <jlvillal> According to https://wiki.debian.org/MeetBot
17:15:34 <dtantsur> nice
17:15:38 <dtantsur> #undo
17:15:39 <openstack> Removing item from minutes: #action jlvillal to submit patch to make gate-grenade-dsvm-ironic-multinode-multitenant-ubuntu-xenial-nv a voting job
17:16:09 <dtantsur> anything else about the statuses?
17:16:11 * jlvillal is still proud that #undo now displays the text instead of Removing <id 0x381283>
17:16:40 <jlvillal> Tiny tiny little victories :)
17:16:41 <rloo> there's a question at L240, about whether that RFE needs approval.
17:17:14 <rloo> didn't we already discuss that, maybe last week, and decided it wasn't needed?
17:17:36 <rloo> sambetts: ^^ wrt https://bugs.launchpad.net/ironic/+bug/1658964
17:17:37 <openstack> Launchpad bug 1658964 in Ironic "[RFE] Implement neutron routed networks support in Ironic" [Wishlist,Confirmed] - Assigned to Sam Betts (sambetts)
17:18:25 <rloo> jlvillal: wrt tempest plugin, L257. anything new to report?
17:18:37 <jlvillal> rloo: Sadly no :(
17:18:48 <rloo> jlvillal: but you're back from vaca? :-)
17:19:07 <jlvillal> I got distracted with BFV, rolling upgrade, and getting caught with emails and stuff :(
17:19:10 <sambetts> rloo: yeah, I think we decided that we didn't need the RFE anymore, but I'll keep it arounds in case I ( although I don't think we will) need to make changes to Ironic
17:19:24 <dtantsur> I need to say that the plugin split is much less a priority than e.g. BFV
17:19:35 <rloo> sambetts: ok, thx for clarifying
17:19:59 <rloo> dtantsur: right, that's why it is 'Optional'
17:20:18 * dtantsur wants to get rid of "optional priorities" in Queens
17:21:19 <TheJulia> dtantsur: +1
17:21:26 <rloo> dtantsur: well, we knew we were taking on too much, although we didn't anticipate what changed this cycle...
17:21:46 <dtantsur> indeed
17:22:05 <dtantsur> ready to move on? we've spent 15 mins on priorities already
17:22:19 * rloo ready
17:22:37 <dtantsur> #topic Deciding on priorities for the coming week
17:22:45 <dtantsur> so, we've done some great job again :)
17:22:56 <jlvillal> Congrats on OSC!!!! :)
17:23:06 <dtantsur> the only thing left is the rolling upgrades patch (the next BFV patch was added during the week)
17:23:29 <rloo> jlvillal: ha ha. now we just have to remember to keep feature parity!
17:23:46 <jlvillal> rloo: And start deprecating the 'ironic' client
17:23:49 <dtantsur> rloo: I suggest we don't accept changing the "ironic" command first
17:23:57 <dtantsur> like some people do, first "ironic", then "osc"
17:24:06 <dtantsur> "osc", then "ironic" fine, until we declare it deprecated
17:24:08 <dtantsur> wdyt?
17:24:13 <rloo> jlvillal, dtantsur: I added a note to the subteam report, we aren't deprecating until queens.
17:24:21 <jlvillal> dtantsur: Sounds reasonable to me
17:24:22 <dtantsur> right, I remember
17:24:24 <rloo> dtantsur: that is a good idea
17:24:39 <TheJulia> dtantsur: I like it, as long as we don't apply that requirement to things already in the queue for the client
17:24:47 <TheJulia> dtantsur: and those items already have parity across patchsets
17:25:01 <rloo> i think we want an #agreed here :-)
17:25:03 <dtantsur> #agreed Do not allow new features in the "ironic" command that do not have corresponding features in the "openstack baremetal" command first
17:25:07 <dtantsur> rloo: I was writing it :)
17:25:15 <rloo> great minds and all...
17:25:34 <rloo> and yes to TheJulia, grandfathering and all...
17:26:12 <TheJulia> I think the volume info stuff is all ironic then osc in the order, but they have parity if I'm remembering correctly
17:26:35 <dtantsur> are we ready to take https://review.openstack.org/#/c/470406 to the list? this is the essence of physical network awareness, I guess
17:26:54 <dtantsur> and I wonder if we should take 2 patches from BFV, as things have been moving faster recently
17:26:58 <dtantsur> wdyt on both ^^^
17:27:03 <rloo> dtantsur: ++ I added physnet
17:27:40 <rloo> dtantsur: is the ipxe template a simple patch?
17:27:56 <rloo> dtantsur: if so and the next patch is ready to be reviewed, sure.
17:28:03 <TheJulia> dtantsur: I would <3 the next three patches for BFV to be on the list, mainly so we have api patch visibility and get towards that soonish since it blocks other changes like in the client library
17:28:27 <TheJulia> or maybe the third as a stretch
17:29:01 <dtantsur> yeah, I suspect
17:29:02 <rloo> TheJulia: it seems to me (I coudl be wrong) that someone that is reviewing a feature tends to review the next patch in the series anyway. (At least I do)
17:29:09 <dtantsur> ++
17:29:31 <jlvillal> Maybe 3 could be the topic URL?
17:29:50 <dtantsur> maybe I propose the classic driver deprecation spec? https://review.openstack.org/#/c/464046/
17:30:05 <TheJulia> rloo: for some of us yes, but not everyone
17:30:05 <jlvillal> I mean 1.3
17:30:26 <TheJulia> dtantsur: I say sure
17:30:29 <dtantsur> jlvillal: I'd like to be specific on what we consider in scope
17:30:31 <rloo> TheJulia: true. I am hoping 'most' is still true and hint hint folks :-)
17:30:59 <TheJulia> rloo: heh :)
17:31:00 <jlvillal> dtantsur: okay
17:31:06 <dtantsur> ok, wdyt about the list. 4 code patches and one spec.
17:31:23 <jlvillal> +1
17:31:40 <rloo> +1
17:31:50 <TheJulia> +1
17:31:52 <rloo> wait, shouldn't we add a stretch goal (just kidding)
17:32:14 <dtantsur> hah
17:32:19 <dtantsur> any more suggestions here?
17:33:01 <TheJulia> nothing from me
17:33:11 <dtantsur> #topic PTG in Denver
17:33:21 <dtantsur> a few formal questions I have to ask:
17:33:27 <dtantsur> Do we want to attend? (just say yes)
17:33:45 <rloo> maybe? :-)
17:33:49 <dtantsur> :)
17:34:04 <TheJulia> I say yes
17:34:07 <rloo> who is planning or would like to attend?
17:34:13 <dtantsur> o/
17:34:28 <rloo> o/
17:34:34 <TheJulia> o/
17:34:47 <rloo> ok, we have three so far. it is a go!
17:35:24 <jlvillal> o/ would like to attend
17:35:31 <rloo> dtantsur: i think it'll only be useful if we have enough people. maybe we ought to plan for it, and find out closer to the date, who will be most likely attending
17:35:35 <Nisha_> o/ would like to attend
17:35:57 <rpioso> o/ I plan to attend
17:36:00 * Nisha_ can attend virtually only
17:36:17 <TheJulia> rloo: I think we have to do it that way as people will need to obtain employer travel approval
17:36:18 <dtantsur> rloo: we have to plan in advance, unfortunately
17:36:19 * milan would go if approved
17:36:34 <dtantsur> ok, I got some information at least
17:36:44 <wanyen> Does it allow remote particpation?
17:36:47 <rloo> exactly. no one does NOT want to have an ironic thing there, which is good :-)
17:37:03 <milan> lol
17:37:25 <dtantsur> wanyen: I'm not sure yet. we can try our best, but we cannot guarantee that available tech serves us well (e.g. internet connection)
17:37:28 <rloo> i thought there was a discussion/talk about a way for people to attend virtually but i don't recall the details or anything
17:37:31 <ricardoas> o/ i´d like too
17:37:57 <TheJulia> I remember there was discussion on bringing greater visibility on "what is going on"
17:38:31 <TheJulia> Anyway, we should move on to the next question
17:38:36 <wanyen> dtantsur, tx.  remote participation will reallyhelp.
17:38:40 <dtantsur> next question: do we need Friday?
17:38:56 <dtantsur> we tend to be only active in the morning, but it's still a productive time
17:39:04 <dtantsur> so I don't have a particularly strong opinion here
17:39:21 <TheJulia> I say plan on the morning again.  For some technically productive, others socially productive to gain mutual context and build better communication
17:39:21 <rloo> i think we don't need it
17:39:26 <vdrok> oh, I do plan to attend
17:39:31 <vdrok> denver ptg
17:40:02 <milan> Friday +1: inspector day ;)
17:40:06 <dtantsur> just to clarify: there is no pressure on us to NOT use Friday
17:40:11 <TheJulia> If we don't do Friday morning, we should at least set aside half a day or a couple hours to break into groups to allow sub team discussion
17:40:12 <dtantsur> we just need to decide
17:40:23 <dtantsur> if unsure, say yes
17:40:27 <jlvillal> yes!
17:40:38 * TheJulia copies the yes
17:40:41 * jlvillal is unsure
17:40:47 <rloo> no
17:41:02 * dtantsur feels like some voting
17:41:04 * jlvillal hopes to be going. But travel budget has been very tight at work :(
17:41:26 <rloo> dtantsur: do you/we need to decide now?
17:41:27 * TheJulia is sure, but largely because she also knows and understands why the foundation offers friday as an option to teams.
17:41:51 <dtantsur> rloo: not necessary. if everyone said "no", I would communicate it to the foundation
17:41:57 <dtantsur> otherwise we get Friday by default
17:42:16 <dtantsur> which is fine
17:42:17 <rloo> dtantsur: ok, some say yes, so as long as 2? people are there and they are productive, then yes is good.
17:42:29 <dtantsur> ok, thanks
17:42:46 <dtantsur> I guess I'm ready to open the floor
17:42:49 <dtantsur> #topic Open discussion
17:43:14 <rpioso> dtantsur: Do we need a #agree
17:44:09 * TheJulia has nothing for open discussion
17:44:28 <rloo> +1
17:44:31 <dtantsur> rpioso: not necessary here. it's mostly for me to understand
17:44:33 <TheJulia> Well, actually
17:44:44 <TheJulia> A giant sign saying "please review" :)
17:45:04 <rloo> TheJulia: anything in particular (outside of this week's priorities?)
17:45:19 <rloo> TheJulia:  or a general 'we would love more reviews'?
17:45:25 <TheJulia> rloo: in general
17:45:35 <rloo> +++++
17:46:18 <dtantsur> #info Please be active on reviews, we really need them!
17:46:27 <TheJulia> <3
17:46:53 <rloo> PTG hotel is on Quebec Street. I guess I *have* to go then :-)
17:46:58 <dtantsur> hah
17:47:08 <dtantsur> anything else before we move to our nice warm channel?
17:47:18 <rloo> (Quebec is a province in Canada)
17:47:57 <dtantsur> I'm saving you 12 minutes of time now:
17:48:02 <NobodyCam> :)
17:48:04 <rloo> crickets
17:48:04 <dtantsur> #endmeeting