17:00:03 <dtantsur> #startmeeting ironic
17:00:04 <openstack> Meeting started Mon Jul 10 17:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:06 <TheJulia> o/
17:00:08 <openstack> The meeting name has been set to 'ironic'
17:00:15 <NobodyCam> o/
17:00:16 <dtantsur> who is here for the most ironic of the ironic meetings?
17:00:28 <sambetts> o/
17:00:30 <kaifeng> o/
17:00:35 <mgoddard_> o/
17:00:35 <rloo> o/
17:00:43 <stendulker> o/
17:00:43 <etingof> o/
17:01:06 <dtantsur> hi everyone! and welcome :)
17:01:13 <dtantsur> our agenda as usual can be found at:
17:01:15 <rpioso> o/
17:01:19 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:01:30 <jlvillal> o/
17:01:31 <rama_y> o/
17:02:09 <dtantsur> #topic Announcements / Reminder
17:02:21 <dtantsur> #info Release request for ironicclient 1.14 with BFV API submitted (thanks TheJulia)
17:02:37 <rloo> ++
17:02:46 <dtantsur> this is amazing progress. you folks seem to review things faster, when I'm on PTO. I need to go on PTO more often ;)
17:02:54 <jlvillal> No!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
17:02:57 <jlvillal> :)
17:02:59 <TheJulia> Please no!
17:03:00 <dtantsur> haha
17:03:09 <NobodyCam> :)
17:03:21 <rloo> dtantsur: it is really the other way around, we review faster when you are here
17:03:25 <dtantsur> #info Non-client libraries deadline next week. This affects ironic-lib and sushy.
17:03:46 <dtantsur> I know there are certain patches for sushy in flight
17:04:00 <rloo> wrt ^^, does anyone have a list of patches that we 'need' to get landed?
17:04:33 <dtantsur> nothing really "needed" to my best knowledge
17:04:50 <dtantsur> one patch supporting redfish session is quite important, but I guess it also needs an ironic RFE
17:05:04 <dtantsur> #link https://review.openstack.org/#/c/471942/
17:05:13 <rloo> dtantsur: ok. also, how (or maybe it doesn't) does the neutron plugin fit, is it considered a non-client library?
17:05:27 <dtantsur> good question, I'm not sure
17:05:59 <dtantsur> we haven't had a single release for it yet
17:06:24 <TheJulia> :\
17:06:25 <rloo> dtantsur: we need to find out, decide quickly whether we want that in pike or not then.
17:06:57 <rloo> sambetts, vdrok ^^
17:07:10 <dtantsur> networking-ovn has type "other"
17:07:20 <dtantsur> I guess we're similar, so this should not affect us
17:07:44 <rloo> dtantsur: ok, that makes sense
17:08:11 <rloo> dtantsur: sorry, wrt the sushy session, it is marked high importance. is sushy driver usable w/o this change?
17:08:41 <rloo> dtantsur: well, we can take it offline.
17:08:58 <dtantsur> rloo: it is, but only on hw not using these session
17:09:05 <dtantsur> using plain HTTP auth
17:09:21 <dtantsur> any other announcements or reminders?
17:09:40 <TheJulia> PTG Hotel block closes on 8/20
17:09:49 <dtantsur> oh, yeah. PTG IS COMING!!
17:10:14 <dtantsur> the good time to ask for travel approval is yesterday
17:10:19 <rloo> and just another reminder, nova feature freeze is week of jul 24
17:10:32 <dtantsur> rloo: this is pike-3, right?
17:10:41 <rloo> dtantsur: yup, pike-3
17:11:04 <dtantsur> ok, if the ironicclient release is done soon (it should), we'll be able to push on the g-r and nova changes
17:11:12 <dtantsur> TheJulia: link for the g-r change handy?
17:11:17 <milan> o/
17:11:26 <TheJulia> https://review.openstack.org/#/c/482146/
17:11:40 <dtantsur> #link https://review.openstack.org/#/c/482146/
17:11:54 <rloo> dtantsur: wrt travel support, round one was july 2; round 2 is aug 6: https://www.openstack.org/ptg#tab_travel
17:12:24 <dtantsur> rloo: right, I was referring to asking for approval from employers though
17:12:32 <rloo> dtantsur: ha ha
17:12:55 <dtantsur> anyway :) good points. anything else to add?
17:13:20 * jlvillal still waiting to find out if he will get approved. Has submitted request awhile ago.
17:13:57 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:14:12 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard starting with line 107
17:14:15 <wanyen> Is it possible to attend PTG remotely via call?
17:14:42 <dtantsur> wanyen: it may be, but it's not a question to us here, but rather to the foundation. I doubt, however, that it would be a pleasant experience :(
17:15:06 <wanyen> better than not be able to attend at all
17:15:09 <dtantsur> e.g. it will require to use microphones for everyone. I'm not sure how practical it is. we did not use them the last time..
17:16:22 <dtantsur> TheJulia: any reason not to approve https://review.openstack.org/#/c/463908/ and https://review.openstack.org/#/c/463972/ ?
17:16:40 <TheJulia> dtantsur: None
17:16:54 <dtantsur> then I encourage you to do so ;)
17:16:57 <TheJulia> dtantsur: I didn't do it myself since I rebased them last and had to do it locally
17:17:22 <dtantsur> I can do it, but with 3x +2 it's not critical IMO
17:17:37 <TheJulia> okay, the diff shows I didn't change content
17:17:40 * TheJulia pushes the buttons
17:18:02 <TheJulia> And pushed.
17:18:06 * TheJulia updates etherpads
17:18:09 <dtantsur> \o/
17:18:25 <dtantsur> at least the ironic part is moving quite well
17:18:38 <rloo> folks, in case you missed it, i am planning on removing the 'feature parity between two CLIs' subteam report after this week's meeting, unless people want it to stay
17:18:57 <dtantsur> rloo: I guess it's right. we've achieved the parity.
17:19:08 <dtantsur> I'd like to also remove the Redfish topic
17:19:46 <dtantsur> folks, I'd like to highlight https://review.openstack.org/#/c/442153/. the pike-3 is also a client deadline, and this has to go in in Pike for us to change the version in Queens
17:19:56 <dtantsur> #link https://review.openstack.org/#/c/442153/
17:20:05 <rloo> dtantsur: ++ wrt redfish
17:20:36 <rloo> dtantsur: i think 442153 can be one of this week's priorities
17:20:43 <dtantsur> I hope so
17:20:50 <rloo> dtantsur: "should be" easy (w/o looking at it)
17:21:07 <dtantsur> it's not really hard indeed
17:21:22 <TheJulia> Yeah, looks simple
17:21:34 <rloo> dtantsur: also, wrt your spec on classic driver deprecation -- do we need to discuss anything? julia had some comments
17:21:52 <dtantsur> I'm just out of PTO, I need to refresh on it first...
17:22:00 <dtantsur> what was the concern, the timing?
17:22:09 <rloo> dtantsur: https://review.openstack.org/#/c/464046/.
17:22:12 <dtantsur> I don't think we require any serious actions for Pike, do we?
17:22:36 <TheJulia> I think it was just communication/expectation setting at this point
17:22:41 <TheJulia> I'm good otherwise, I think
17:22:58 <rloo> dtantsur: oh, i also had a question forgot about it. what if vendors don't provide hardware types that are analagous to classic.
17:23:08 * TheJulia thinks it has been a week since she looked
17:23:11 <rloo> dtantsur: i think we know but it isn't documented in the spec. that's all.
17:23:24 <dtantsur> rloo: well, the spec implicitly gives the answer. one day the classic drivers are removed, no matter if they have analogs or not.
17:23:59 <rloo> dtantsur: yeah, i know it implicitly. i just want to make sure it is 'clear enough' for the hardware vendor folks out there, that's all.
17:24:10 <dtantsur> I suspect we can solve it on the spec review itself. or we can discuss during the open discussion, wdyt?
17:24:25 <rloo> dtantsur: if people think it is obvious or whatever, then i think we can +A it.
17:24:44 <rloo> dtantsur: yup, was just trying to fasttrack it since the spec has been around for awhile.
17:25:05 <dtantsur> if it's not critical for merging the spec, I can follow up with this
17:25:18 <dtantsur> as long as TheJulia's concerns are also / can also be resolved
17:25:33 <TheJulia> We can always follow-up imho
17:25:51 <rloo> dtantsur: ok, i've brought it up, hardware vendors should be reading the minutes of this, so it is documented and i am fine to move on
17:25:54 <dtantsur> sambetts or someone: we probably need a volunteer to nag nova folks about https://review.openstack.org/#/c/419975/
17:26:03 * TheJulia pulls it up
17:26:08 <dtantsur> thanks rloo!
17:26:25 <dtantsur> meanwhile, anything else on the statuses? we're past 10 minutes (well, as always)
17:27:38 <TheJulia> w/r/t the future of classic drivers, I just changed my vote to +2
17:27:45 <dtantsur> thanks!
17:28:07 <dtantsur> #topic Deciding on priorities for the coming week
17:28:08 * rloo ready to move on
17:28:31 <rloo> we should get the rest of bfv client patches merged
17:28:33 <sambetts> dtantsur: I can do some pestering
17:28:33 <dtantsur> so, the docs re-org is in progress, and is of very high priority. I guess we keep it
17:28:40 <dtantsur> thanks sambetts!
17:29:05 <dtantsur> rloo: right. TheJulia, what's the next for BFV?
17:29:10 <TheJulia> speaking of the docs, I've got the IPA repo open on my other screen right now.
17:29:56 <TheJulia> Client largely, aside from that the nova change. I suspect they are going to want us to make sure our tempest test is ready to rock and roll as well
17:30:14 <dtantsur> TheJulia: then let's take the devstack and tempest
17:30:29 <dtantsur> or do they need the OSC commands to be finished?
17:30:55 <TheJulia> We need to get the OSC commands out the door and released if memory serves before we can take on devstack
17:31:49 <dtantsur> oh, so another release
17:32:06 <dtantsur> well, we'll need a pike-3 release anyway
17:32:08 <dtantsur> so
17:32:22 <dtantsur> please take a look at the list. we have quite a few items there, but many are simple
17:33:03 <dtantsur> dunno how many of the rolling upgrades patches we want. rloo?
17:33:23 <rloo> dtantsur: what i see there is enough
17:33:28 <rloo> dtantsur: i mean, in this week's priorities
17:33:30 <sambetts> not sure how much more effort we need to put into refactoring the docs, the bulk of the work moving the content around is done, but the landing page needs revamping
17:33:36 <rloo> dtantsur: i'll be happy if one gets reviewed :)
17:34:30 <dtantsur> sambetts: I'd start with merely moving them. I just got an email about ironic-lib, virtualbmc, sushy, sushy-tools and molteniron work not started yet
17:34:33 <rloo> sambetts: i think what we need to do is make sure the high level things are good. like contributor/*, separating developer docs from other contributor docs.
17:34:47 <dtantsur> .. and bifrost and ironic-inspector-client
17:35:11 <sambetts> dtantsur: I can start looking at the sub-projects
17:35:24 <rloo> dtantsur: oh, since ironic-lib & sushy freeze is next week, we should get those done this week
17:35:33 <dtantsur> thanks sambetts! I think milan is looking at ironic-inspector-client now
17:35:36 <TheJulia> sambetts: You might want to double check with the list since someone signed up to take care of some of the other projects
17:35:38 <dtantsur> rloo: right
17:35:40 <milan> dtantsur, ack
17:35:53 <milan> dtantsur, sushy?
17:36:04 <sambetts> TheJulia: oh great, I'll get on review patrol for those, I think they're all linked of the whiteboard now
17:36:05 <dtantsur> milan: wanna do it? ;)
17:36:12 <milan> heh :D
17:36:33 <milan> yeah I can add it to the doto list
17:36:54 <TheJulia> sambetts: Only some of them had been submitted from what I've seen, fwiw.  I'll be in the air for a good chunk of time tomorrow, so I'll likely have time to re-shuffle all of bifrost's docs around then.
17:37:32 <rloo> milan: put your name down at https://etherpad.openstack.org/p/doc-migration-tracking
17:37:38 <rloo> milan: L203
17:37:54 <milan> rloo, thx
17:37:58 * milan adding himself
17:38:34 <rloo> that leaves sushy-tools, molteniron & virtualbmc
17:38:52 * dtantsur wonders why we even have docs for sushy-tools...
17:39:11 <dtantsur> sushy-tools and virtualbmc only have dev docs, should be easy
17:39:18 <dtantsur> anyone want to pick them? etingof? ;)
17:39:22 <rloo> any volunteers for those? ^^
17:39:30 * milan unsure about tuanlua in the projects but I guess it's OK if I patch
17:39:32 <sambetts> I can do it
17:39:58 * etingof is too slow
17:40:04 <rloo> thx sambetts!
17:40:05 * dtantsur leaves an opportunity for non-cores to jump in
17:40:13 <rloo> etingof: not too slow, you can do it if you'd like
17:40:13 <sambetts> etingof: feel free to take it
17:40:18 <rloo> :D
17:40:29 <dtantsur> sambetts: if you could guide etingof with reviews and advice instead, that would be awesome
17:40:31 <dtantsur> :)
17:40:37 <sambetts> absolutly :)
17:40:45 <etingof> ok, I can try to do that thing
17:41:17 <dtantsur> molteniron.. who is driving it nowadays?
17:41:29 <rloo> thx etingof!
17:41:37 <sambetts> unsure, jlvillal?
17:41:44 <TheJulia> I'm drawing a blank on the name
17:41:54 <rloo> isn't molteniron from ibm folks?
17:41:55 <TheJulia> krtaylor_: ?
17:42:02 <TheJulia> It is from IBM folk
17:42:08 <rloo> yeah, one of kurt's people i think
17:42:37 <rloo> anyway, can take that question off line? :)
17:42:38 <jlvillal> sambetts: Not me. krtaylor_ was molteniron
17:42:43 <dtantsur> well, I guess we can just migrate it and see. assuming we have core rights on it :)
17:42:52 * krtaylor_ pops up
17:42:57 <dtantsur> mmm, are we done with the priorities?
17:43:05 <dtantsur> I guess we can discuss the docs a bit later
17:43:06 * krtaylor_ reads scrollback
17:43:49 <dtantsur> #topic REST API to list volume connectors & volume targets returns node_uuid, but port & portgroup doesn't
17:43:54 <dtantsur> rloo: the mic is yours
17:44:22 <rloo> so in ironic's REST API, if you do a port-list or portgroup-list, you do not get node_uuid. only if you ask for that field explicitly, or detail=True
17:44:38 <rloo> i just noticed that for the new volume connector * volume target resources, you will get the node_uuid.
17:44:54 <rloo> i love consistency, so wondered if we are ok with this inconsistency
17:44:56 * TheJulia thinks this is a good thing, fwiw
17:45:19 <dtantsur> I always disliked that we don't return node_uuid for port listing FWIW
17:45:24 <TheJulia> I would <3 to see it on ports, personally
17:45:30 <dtantsur> I'd rather fix the ports
17:45:35 <rloo> i think TheJulia thinks it is a bug that it isn't avail for ports & port groups?
17:45:47 <rloo> dtantsur: only ports, or portgroups too?
17:45:50 <dtantsur> well, I'd not call it a bug. rather an easy RFE
17:45:52 <dtantsur> rloo: both
17:45:54 <rloo> i'm fine either way :-)
17:46:07 <rloo> ok, done. thx! (I mean, done, we've decided.)
17:46:28 <rloo> i'll take care of the paperwork later :)
17:46:35 <dtantsur> any objections to returning node_uuid on port(|group)s listing with detail=False?
17:46:53 <dtantsur> 3..
17:46:55 <dtantsur> 2..
17:46:57 <dtantsur> 1..
17:47:00 <dtantsur> done, thanks rloo! :D
17:47:07 <NobodyCam> :p
17:47:09 <rloo> dtantsur: maybe some #decided thing?
17:47:36 <dtantsur> #agreed We need to update port and portgroup listing API to include node_uuid by default (not only with detail=True)
17:47:49 <dtantsur> #topic Open discussion
17:48:06 <dtantsur> 13 minutes for any bikesheding you like!
17:48:08 <rloo> dtantsur: we should, soon, next 1-2 weeks? review our pike priorities
17:48:19 <rloo> dtantsur: and focus ...
17:48:28 <dtantsur> rloo: I would do it today, but I'm kinda busy this week
17:48:40 <rloo> dtantsur: next monday meeting?
17:48:42 <dtantsur> so yeah, totally. certain things are obviously moving too slowly
17:48:58 <dtantsur> a voice meeting next week? or just as part of the next IRC meeting?
17:49:18 <rloo> i think part of next irc meeting. what do others think?
17:49:20 <xavierr> dtantsur: I've implemented the flag based solution for agent_pxe_oneview driver we were discussing https://review.openstack.org/#/c/482209
17:49:26 <jlvillal> For people who want a break. https://review.openstack.org/447310 ( hacking check to require autospec=something)  and a WIP patch of mine: https://review.openstack.org/481316  for keyword argument enforcing.
17:49:32 <jlvillal> Very low priority though!!!!
17:49:32 <xavierr> dtantsur: waiting for our UFCG OneView CI :)
17:49:46 <wanyen> please review https://review.openstack.org/#/c/422572/
17:49:56 <jlvillal> wanyen: Why? What is it?
17:49:59 <rloo> dtantsur: no nays so i'll put on agenda for next week :-)
17:50:09 <dtantsur> xavierr: ack, thanks
17:50:24 <dtantsur> rloo: sure! thanks for the idea
17:51:23 <rama_y> Hi, would like to bring up the dmidecode patch for some reviews: https://review.openstack.org/#/c/435573/
17:51:24 <jlvillal> rloo: On the port/portgroup thing. Is there an owner for that? Or is it up for grabs? Will you create a bug/RFE?
17:51:44 <rloo> jlvillal: i will create an RFE
17:51:49 <jlvillal> rloo: Thanks.
17:51:59 <wanyen> sorry it is nothing to do with your topics.  It's a patch hanging there for a long time and needs review
17:52:09 <jlvillal> rama_y's patch has one +2 (mine). As a note.
17:52:11 <dtantsur> rloo: this is going to be a low-hanging-fruit, so I guess we'll find someone
17:52:38 <rloo> dtantsur: yup, i'm not worried about finding someone for that.
17:53:11 <rloo> so many patches, so little time and few reviewers...
17:53:13 <dtantsur> wanyen, rama_y, I'll try to, but I'm half-busy this week
17:53:30 <kaifeng> dtantsur: I wonder the spec about fault, how is that going
17:53:43 <rama_y> Thanks dtantsur!
17:53:49 <wanyen> dtantsur, thanks!  iLo team really like to get this one in Pike.
17:53:50 <dtantsur> kaifeng: specific faults? it's stuck IIRC
17:54:10 <rloo> wanyen: don't know how much it would help, but if your patches of interest showed that your folks reviewed them, it would help.
17:54:18 <dtantsur> folks, I have an unusual request
17:54:20 <rloo> wanyen: oh, i guess it would help :)
17:54:21 <TheJulia> Same, I'm also traveling part of this week.  I kind of wonder if it would help if we got a list of patches from driver teams that they need reviewed to make it into pike.
17:54:41 <kaifeng> dtantsur: the spec about ironic detect & recover from some fault
17:54:42 <TheJulia> Since, we can't read minds and all
17:54:46 <dtantsur> I'm holding an internan deep dive on ironic tomorrow. could someone please take a look at my slides (a lot of them) in case I'm doing something stupid? http://dtantsur.github.io/talks/pike-ironic-deploy-deep-dive/#/
17:54:47 <jlvillal> dtantsur: Hawaiian shirt Friday?
17:54:57 <jlvillal> Ah different unusual request
17:54:58 <dtantsur> jlvillal++ LOL
17:55:01 <wanyen> rloo: yes. we all reviewed them alreay.  We got a +2 last week but due to mege conflict, we rebased it and need more rvew to get 2 +2.
17:55:10 <TheJulia> jlvillal: Shouldn't that be daily ;)
17:55:16 <dtantsur> I spent the last 2.5 days writing it, and in the end I was tired
17:55:17 <jlvillal> :)
17:55:37 <rloo> wanyen: i just looked at that link you provided, unfortunately, w/o at first glance seeing that there are reviews on it...
17:55:38 <dtantsur> if anyone has any comments, please send me them by tomorrow morning
17:55:49 <rloo> wanyen: all i see is that jenkins is happy
17:55:56 <jlvillal> dtantsur: I'll take a look today.
17:56:03 <rloo> wanyen: i don't have time to spend 5-10 minutes just trying to figure out hwat the state of a patch is.
17:56:07 <dtantsur> thanks jlvillal!
17:56:28 <jlvillal> dtantsur: I have to learn to press right arrow and then when I see down arrow press it...
17:56:32 <rloo> ^^ that goes to everyone's patches. we need to try to communicate/help as much as possible since again, so many patches, so little time... etc. maybe i will make up a song...
17:56:38 <dtantsur> jlvillal: just press space all the time
17:56:40 <dtantsur> :)
17:56:43 <jlvillal> dtantsur: At first I did right arrow... and finished very quickly :)
17:56:50 <dtantsur> LOL
17:56:57 <TheJulia> rloo: ++
17:57:18 <wanyen> rloo, we just re-based the patch. It's been patch 21.
17:57:35 <jlvillal> rloo: I recommend to the tune of Too Much Time On My Hands by Styx ;)
17:57:37 <shobhar> jlvillal: I agree.. I did the same and see the presentation got over in no time
17:57:40 <dtantsur> any rebase requires re-review, unfortunately
17:57:54 <rloo> wanyen, i *only* looked at the top "fold"/part of that url. i am not going to scroll down and spend any more seconds on it.
17:58:27 <jlvillal> shobhar: :)
17:58:50 <dtantsur> jlvillal, shobhar, I've been using reveal.js for a while, and only learned about using space yesterday :D
17:58:58 <rloo> also, i realize that folks may be new/not feel comfortable reviewing 'core' features cuz of whatever, but wrt driver patches, we're all in the same boat there, it would be great if driver teams could help review *other* driver team's patches.
17:59:23 * dtantsur points that reviewing core features is a great way to learn the project
17:59:37 <TheJulia> One minute warning
17:59:51 <dtantsur> yeah, I guess we can continue in the channel (and I have to run)
17:59:56 <dtantsur> thanks everyone!
18:00:03 <dtantsur> #endmeeting