17:00:01 <dtantsur> #startmeeting ironic
17:00:02 <openstack> Meeting started Mon Jul 31 17:00:01 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:03 <vdrok> o/
17:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:06 <openstack> The meeting name has been set to 'ironic'
17:00:20 <crushil> \o
17:00:21 <nicodemos> o/
17:00:21 <dtantsur> who's up for having some ironic meeting on the last day of July? :)
17:00:23 <rama_y> o/
17:00:28 <etingof> o/\/
17:00:31 <kaifeng> o/
17:00:32 <jlvillal> o/
17:00:33 <anupn> o/
17:00:36 <aarefiev> o/
17:00:36 <yuriyz> o/
17:00:40 <rpioso> o/
17:00:47 <tiendc> o/
17:00:48 <rloo> o/
17:00:50 <fellypefca> o/
17:00:52 <pas-ha> o/
17:00:53 <stendulker> o/
17:00:58 <mrtenio|afk> o/
17:01:07 <rloo> although not having a meeting today would be nice too :)
17:01:23 <dtantsur> nope ;)
17:01:32 <mjturek> o/
17:01:35 <baha> o/
17:01:35 <dtantsur> hi and welcome everyone, who wants and who does not want a meeting :)
17:01:40 <dtantsur> our agenda as usual can be found at
17:01:42 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:01:43 <sauloaislan> o/
17:02:04 <NobodyCam> o/
17:02:08 <dtantsur> #topic Announcements / Reminder
17:02:13 <dtantsur> we have some today!
17:02:23 <dtantsur> #info Soft feature freeze starting tomorrow, Aug 1st
17:02:56 <dtantsur> this is probably the most important one. starting tomorrow, we should concentrate on priorities and small vendor features, as well as, obviously, bug fixes and documentation improvements
17:03:14 <dtantsur> (see my email to openstack-dev a couple of weeks ago for details)
17:03:39 <dtantsur> #info Pike branches created for all library projects
17:03:45 <xavierr> o/
17:04:04 <dtantsur> sushy, ironic-lib, python-{ironic,ironic-inspector-}client now have stable/pike. no new features will go to Pike for these projects
17:04:26 <dtantsur> #info We're about to remove the SSH drivers: https://review.openstack.org/#/c/481688/
17:04:33 <dtantsur> you saw this one coming, right? ;)
17:04:43 <NobodyCam> :(
17:05:15 <dtantsur> and the last but not the least:
17:05:20 <dtantsur> #info PTL nominations start tomorrow - don't forget to nominate yourself
17:05:29 <rloo> is it already there, or is someone planning on adding ssh driver to that other project that i always forget the name of?
17:05:44 <NobodyCam> tagging drivers
17:05:44 <dtantsur> ironic-staging-drivers?
17:05:47 <NobodyCam> nope
17:05:51 <rloo> yeah, that one
17:05:53 <dtantsur> we have a libvirt-based driver there, dunno if we want another one
17:05:56 <NobodyCam> *Staging
17:06:07 <dtantsur> I'm definitely not planning on it
17:06:20 <rloo> just asking/mentioning, in case someone wants it still
17:06:27 <dtantsur> that's all from me. other announcements/reminders? questions?
17:06:54 <rloo> dtantsur: next week is rc1 target week - doesn't apply to us, right
17:07:07 <vdrok> what's the ironic dates on the ptg planning etherpad?
17:07:10 <dtantsur> I *think* it does not
17:07:10 <rloo> dtantsur: and Hard StringFreeze -- that affects exception strings?
17:07:13 <vdrok> is it wed-fri?
17:07:21 <dtantsur> rloo: all translated strings
17:07:23 <dtantsur> vdrok: yes
17:07:39 <dtantsur> rloo: we can be a bit relaxed about it, given that we've never had any serious translations
17:07:49 <dtantsur> but yes, it affects everything within _()
17:07:54 <rloo> dtantsur: ok
17:08:33 <rloo> dtantsur: we should decide? on a date before week of Aug21, for feature freeze or whatever?
17:08:49 <dtantsur> sorry?
17:08:57 <rloo> dtantsur: that's the 'final rcs and intermediary releases week'
17:09:12 <dtantsur> yep, so that week is our target
17:09:34 <dtantsur> we should probably slow down active feature development a week before, which leaves not so much time for features, really
17:09:57 <rloo> dtantsur: yes, that's what i wanted to know ^^. at least 1 week before :)
17:10:25 <dtantsur> this is now a hard promise, just let's try not to rush everything in on the last day :)
17:10:48 <dtantsur> keep in mind that the gate load will keep increasing
17:10:55 <dtantsur> anything else?
17:10:58 <jlvillal> And the gate isn't reliable right now :(
17:11:01 <dtantsur> well, vdrok reminded me:
17:11:06 <dtantsur> #link https://etherpad.openstack.org/p/ironic-queens-ptg
17:11:58 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:12:10 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard starting with line 124
17:13:32 <rloo> congrats to BFV folks for getting the nova patch landed! hip hip hurray!
17:13:35 <dtantsur> \o/
17:13:39 <dtantsur> good job, really!
17:13:55 <dtantsur> rloo: is https://review.openstack.org/#/c/408556/ the last big code patch for rolling upgrades?
17:14:13 <jlvillal> FYI: I'm working on a little script that I can watch specific patches and keep doing recheck if Jenkins fails.
17:14:14 <rloo> dtantsur: yes, that's the plan. unless someone proves otherwise!
17:14:28 <dtantsur> jlvillal: Recheck-as-a-Service!
17:14:35 <xavierr> lol
17:14:36 * rloo sad that jlvillal has to write a script for that
17:14:46 <dtantsur> this is actually quite sad :( at least make sure to use elastic recheck messages wisely
17:14:47 <jlvillal> dtantsur: heh. Well I kept watching patches during the weekend and thought there had to be a better way
17:14:57 <dtantsur> yeah, me too
17:15:01 <rloo> thx jlvillal!
17:16:22 <rloo> dtantsur: if i understand correctly, the only stuff we *have* to get done wrt driver comp, are docs?
17:16:29 <rloo> dtantsur: for Pike I mean
17:16:39 <dtantsur> rloo: this is correct
17:16:50 <rpioso> rloo, dtantsur: drac h/w type, too.
17:17:04 <dtantsur> I put it a bit later on agenda, but I guess I'll mention it now: what about adding as-ha's client refactoring to the priorities list? https://review.openstack.org/#/q/topic:bug/1699547
17:17:22 <rloo> dtantsur: and for OSC default API version change. we're done for PIke, can remove that item. How are we tracking the actual switch in Queens? Is it in ptg etherpad as a priority or something?
17:17:29 <vdrok> dtantsur: yup, I'm all for it
17:17:29 <dtantsur> rpioso: this is really nice to have (as well as other hardware types), but that's not a critical priority (release blocker, so to say :)
17:17:36 <vdrok> the sooner we do this the better
17:17:55 <rpioso> dtantsur: Got it
17:17:57 <dtantsur> rloo: this is exactly what I was thinking a minute ago: how to track it. I guess I'll add it to the etherpad
17:18:05 <rloo> dtantsur: i view pas-ha's stuff as bug-related, since our gate broke cuz of that before.
17:18:20 <rloo> dtantsur: and/or add a bug too
17:18:28 <vdrok> rloo: it is, just a lot of code
17:18:34 <pas-ha> I'm in a middle of rebase + adding some goodies from fresh KSA Monty was telling us. Hopefully by the tomorrow's evening will get the series working
17:18:48 <rloo> vdrok: yeah, you can review it, i know you can :)
17:19:07 <pas-ha> but we'd need to pull this requirements sync too https://review.openstack.org/#/c/488117/
17:19:09 <dtantsur> rloo: it's a big chain, so I'd track it anyway on our list
17:19:26 <vdrok> :) I'll update the client change too, according to pas-ha suggestions
17:19:35 <dtantsur> pas-ha: recheck all the things \o/
17:19:51 <dtantsur> ok: objections to putting that patch chain to the priorities list?
17:19:52 <rloo> oh, we can't update client for pike any more
17:19:54 <pas-ha> done 5min ago :)
17:20:00 <vdrok> rloo: yeah, I know.
17:20:12 <rloo> maybe we should discuss offline then
17:20:15 <vdrok> just want to get it done as soon as possible in the cycle
17:20:28 <vdrok> *next cycle
17:20:31 * dtantsur recorded no objections so far
17:20:39 <pas-ha> yep, but I'd suggest to make the next client release a major version bump (deprecating ironic CLI ans such)
17:20:54 <rloo> so what's left to do for physical network awareness? there are related things but those are only 'related'
17:20:57 <dtantsur> deprecating anything does not require a major version bump, removing does
17:21:43 <pas-ha> dtantsur: removing hard-dependency on OSC might warrant the bump (as it changes what's installed by default)
17:21:44 <dtantsur> pas-ha: added an item on line 248
17:21:48 <pas-ha> thanks
17:22:00 <dtantsur> pas-ha: yes, I bumped the major version of the inspector client due to that
17:22:13 <dtantsur> also, changing the OSC default version requires a major version bump IMO
17:23:01 <vdrok> seems like a lot of major version bumps for the next release :)
17:23:06 <rloo> dtantsur: it does? major version bump to what?
17:23:31 <vdrok> rloo: to indicate possibly breaking behaviour?
17:23:42 <rloo> vdrok: sorry, i mean version bump to what version?
17:23:46 <dtantsur> rloo: ironicclient; if we remove the dependency on OSC, people doing 'pip install python-ironicclient' will stop receiving 'openstack baremetal' commands
17:24:20 <rloo> dtantsur: oh, we're talking about the version of python-ironicclient package?
17:24:24 <dtantsur> yep
17:24:24 <vdrok> yup
17:24:29 <rloo> that's fine with me :)
17:24:32 <dtantsur> :)
17:24:42 <dtantsur> everyone done with statuses? we're past 10 minutes IIRC
17:24:56 <rloo> well, i wanted to know what was left to do for physical network awareness
17:25:00 * dtantsur sees 3 patches merging, nice!
17:25:13 <rloo> i mean, 'priority' patches, not related patches.
17:25:55 <dtantsur> mjturek or anyone: the BFV tempest test has merged, feel free to propose moving the job to the check queue
17:26:08 <vdrok> rloo: none I think
17:26:15 <mjturek> dtantsur: sounds good
17:26:21 <dtantsur> rloo: one of the rolling upgrade bits still goes through the gate
17:26:24 <dtantsur> everything else seems optional
17:26:31 <rloo> vdrok: ok thx. let me know if there are any other network-related patches that ought to be reviewed
17:26:53 <rloo> dtantsur: you lost me there wrt rolling upgrade bits
17:27:07 <dtantsur> rloo: rolling upgrade for create_port
17:27:20 <dtantsur> #link https://review.openstack.org/#/c/485773
17:27:21 <rloo> dtantsur: oh, you mean the physical network aware thing. yeah. no need for reviews, just 'recheck' :-(
17:27:31 <dtantsur> yeah, another dozen of rechecks
17:27:55 <vdrok> it has almost gotten through :) just grenade remaining
17:27:59 <dtantsur> moving on?
17:28:12 <rloo> +1
17:28:23 <dtantsur> #topic Deciding on priorities for the coming week
17:28:42 <dtantsur> still some docs left
17:28:50 <dtantsur> but everything has had quite a progress!
17:29:11 <rloo> dtantsur: oh, wrt docs, we need the config page: https://review.openstack.org/#/c/486934/
17:29:16 <dtantsur> right
17:29:25 <rloo> that's an easy review ^
17:29:31 <rloo> also easy to bikeshed :-(
17:29:36 <dtantsur> of course! :)
17:29:50 <dtantsur> mjturek: do we have anything urgent for BFV to put on the prio list
17:29:52 <dtantsur> ?
17:30:27 <mjturek> dtantsur: checking - there were some patches in the meeting that need reviews
17:30:50 <dtantsur> as to physnet awareness, we have a refactoring chain: https://review.openstack.org/#/q/topic:refactor-vif-attach-mixin
17:31:21 <mjturek> nvm - those were the tempest tests :)
17:31:26 <dtantsur> yep :)
17:31:48 <rloo> dtantsur: is the refactoring chain important?
17:32:01 <dtantsur> rloo: I think it enables some additional testing in the CI
17:32:11 <dtantsur> like, having real VIF plugging/unplugging in tempest API tests
17:32:16 <dtantsur> but nothing deadly critical
17:32:16 <mjturek> dtantsur: actually this one is this weeks priority list and hasn't merged. Reviews would be appreciated https://review.openstack.org/#/c/473717/
17:32:26 <rloo> dtantsur: i think we want that testing, don't wek?
17:32:33 <dtantsur> we do
17:32:35 <vdrok> dtantsur: oh if it does it would be good to have
17:32:48 <dtantsur> oh nice, mjturek! and now I remember that we also have api-ref for volume API
17:32:56 <rloo> yeah, then we should get the refactoring done
17:34:18 <dtantsur> does the list look good?
17:34:30 <dtantsur> I can also offer you some awesome upgrade docs for hw types, if you're up for some long read ;)
17:34:57 <rloo> should we add pas-ha's stuff? or is that premature
17:35:08 <dtantsur> rloo: he needs to rework it, let's add it next week, I guess..
17:35:14 <rloo> also there's sambett's ipa thing...
17:35:16 <dtantsur> but IPA API is a good candiadate
17:35:17 <dtantsur> right
17:35:26 <rloo> https://review.openstack.org/#/c/364834/
17:35:58 <dtantsur> ok, the docs can wait :) does the list look good now?
17:36:04 <rloo> +1
17:36:26 <vdrok> +1
17:36:50 <dtantsur> okay, let's have some flame war finally :)
17:36:54 <dtantsur> #topic Adding API interop assert tag to ironic: https://review.openstack.org/#/c/482759/
17:37:18 <dtantsur> this raised some contentions. and I don't want to approve this thing on behalf of the team without even asking the team
17:37:48 <dtantsur> the technical side of the tag is that we agree to follow microversioning and to have branchless tempest. we do both already.
17:38:14 <dtantsur> some people, myself included, don't quite understand, what the end users/operators should derive from these tags
17:38:29 <dtantsur> so I'd like to hear more opinions, from whatever standpoint
17:39:32 <rloo> dtantsur: what is the 'ironic deliverable'?
17:39:45 <dtantsur> rloo: whatever is in openstack/ironic repo
17:39:56 <dtantsur> in this context, ironic-api
17:39:59 <rloo> dtantsur: just ironic repo then, not the other ironic-related projects
17:40:09 <dtantsur> yeah, that caused me some confusion as well
17:40:20 <dtantsur> only ironic itself, not e.g. inspector
17:40:50 <rloo> dtantsur: i'm fine with it, except it isn't clear whether ironic follows the api interop guidelines.
17:40:57 <vdrok> maybe it does show some level of 'maturity'? should be a good thing
17:41:02 <dtantsur> techinically, it does
17:41:29 <rloo> if ironic technically satisfies the requirements for having this tag, then i am ok with it.
17:41:38 <dtantsur> vdrok: well, this is actually a difficult point. we're inventing the definitions of maturity, based on the practices we already do, not based on what people want (??) or what standard practices are (??)
17:42:01 <dtantsur> (things marked (??) are not necessary true, I just haven't seen enough proof to get convinced)
17:42:04 <rloo> ^^ yeah, i think we have to decide based on a list of requirements, not 'maturity' (too vague)
17:42:05 <pas-ha> AFAIU that's for consumers to be sure an upgrade will not break users (if they use the same old still supported API microversion)
17:42:26 <dtantsur> pas-ha: well, except that nobody can claim that, there may be a bug in the versioning itself
17:42:33 <vdrok> dtantsur: I'm more thinking about https://www.openstack.org/software/releases/ocata/components/nova, if people look at those
17:42:43 <dtantsur> and put this way, it requires integration tests for every microversion, which nobody does
17:42:50 <rloo> dtantsur: one cannot claim anything then, cuz there can be bugs in anything
17:43:05 <dtantsur> vdrok: I don't think it's the same, but I may be wrong
17:43:22 <dtantsur> rloo: well, screwing up microversions is not too hard, testing all of them is hard
17:43:38 <rloo> dtantsur: we write perfect code. no need to test ;)
17:43:39 <vdrok> dtantsur: at least 'follows standard deprecation' is there which is also a tag iirc
17:43:44 * dtantsur playing devil's advocate mostly
17:43:54 <dtantsur> vdrok: right
17:44:15 <rloo> dtantsur: we test some combination of versions, don't we? grenade, grenade multi, nova+ironic.
17:44:18 <dtantsur> so, it seems that the folks are in favour of this idea, right? can I hear more voices please? ;)
17:44:30 <dtantsur> rloo: these are mostly testing at release cycle boundaries
17:44:47 <dtantsur> barely anybody is going to test e.g. 1.30, outside of functional tests
17:44:51 <rloo> dtantsur: right, which is most likely when it will be of most importance
17:44:59 <dtantsur> this is not quite true
17:45:09 <rloo> dtantsur: ?
17:45:13 <dtantsur> the idea of microversioning is to pick the version you need
17:45:24 <pas-ha> I'd like to get understanding of how dtantsur comment re free-form schema-less fields is playing here
17:45:26 <dtantsur> which, in our reality, indeed turns into "pick the Pike version" or something
17:45:45 <dtantsur> pas-ha: this is even more important for us specifically
17:45:59 <dtantsur> we change behavior based on driver_info and properties (hello, boot_mode)
17:46:15 <dtantsur> these are mostly driver-provided and are not versioned
17:46:25 <pas-ha> exactly. If the driver changes in-between, the same request with the same API version *will* fail after upgrade
17:46:34 <rloo> personally, i don't care about this tag. i get the feeling dtantsur is being devil's advocate very strongly, so let's not do it. i think it woudl be good for dtantsur to comment in the patch, the reasons why ironic may not conform to it.
17:46:37 <dtantsur> we don't even (IIRC) provide a way to get a list of capabilities (for example) that change ironic's behavior
17:46:57 <rloo> we (or some of us) know how much dtantsur loves the microversioning in ironic
17:47:04 <dtantsur> rloo: I'm mostly expaining why I did not +1 it with an easy heart, don't take it as a principal position :)
17:47:39 <rloo> dtantsur: those are valid reasons, if they are requirements for this tag.
17:47:56 <rloo> dtantsur: i still don't know the requirements for the tag... (i mean, details by which to decide)
17:48:03 <dtantsur> rloo: http://docs-draft.openstack.org/59/482759/1/check/gate-governance-docs-ubuntu-xenial/29826eb//doc/build/html/reference/tags/assert_supports-api-interoperability.html#requirements
17:48:45 <dtantsur> and this is the api-wg spec behind it: http://specs.openstack.org/openstack/api-wg/guidelines/api_interoperability.html
17:48:49 <rloo> dtantsur: thx. is everything discoverable now? it wasn't before.
17:49:05 <vdrok> pas-ha: I think other projects do have the same problem. eg nova will migrate flavors from usual ones to the custom resource classes, by setting an extra spec. so if extra spec with such name was used for something else, the api interoperability is broken
17:49:21 <dtantsur> tags: https://governance.openstack.org/tc/reference/tags/index.html
17:49:21 <rloo> dtantsur: i think we shoudl take this offline. maybe someone can spend some time reading those requirements and report back?
17:49:43 <dtantsur> rloo: I suggest everyone reads all the links, and +/- the patch in question
17:49:57 <dtantsur> then I'll make my final decision based on what I hear from you
17:50:01 <rloo> dang, i was hoping that we only needed one person to investigate :)
17:50:13 <dtantsur> it's a buy-in from the whole team..
17:50:24 <dtantsur> we're committing to following some rules, when changing the API
17:50:35 <dtantsur> how do we write/review changes without knowing these rules for sure?
17:50:51 <rloo> dtantsur: if we are already following those rules, then i am fine :)
17:51:13 <dtantsur> not precisely, as it seems to me.. anyway, please come to the patch with your review
17:51:35 <dtantsur> #action everyone please put your thoughts on https://review.openstack.org/#/c/482759/
17:51:42 <rloo> ok. i see this as a lower/lowest priority amongst everything we have on our plates now. wrt pike release.
17:51:58 <dtantsur> it's not urgent at all, but it's not going to take too much time as well
17:52:32 <dtantsur> any other comments or thoughts?
17:53:07 * dtantsur thinks that it's too hot outside
17:53:11 <dtantsur> #topic RFE review
17:53:30 <dtantsur> #link https://bugs.launchpad.net/ironic/+bug/1700071 Make DIB-build IPA fully supported
17:53:30 <openstack> Launchpad bug 1700071 in Ironic "[RFE] Make DIB-build IPA fully supported" [Wishlist,Confirmed] - Assigned to Dmitry Tantsur (divius)
17:53:43 <dtantsur> we more or less agreed on it on the PTG, just bringing to your attention
17:54:31 <rloo> dtantsur: it just needs to be approved? maybe add link to PTG etherpad?
17:54:45 <dtantsur> I'm fine with just approving it, and yeah, I need to find a link
17:54:51 <vdrok> +1
17:55:09 <vdrok> if noone will complain about the number of jobs on ipa :)
17:55:19 <yuriyz> +1
17:55:21 <dtantsur> #link https://etherpad.openstack.org/p/ironic-pike-ptg-ci-testing
17:55:22 <rloo> vdrok: shhhh, we won't tell anyone...
17:55:35 <dtantsur> vdrok: welll...
17:55:37 <pas-ha> +1
17:55:49 <dtantsur> we should really work on standalone tests for IPA
17:56:01 <dtantsur> okay, I'm marking this one as approved
17:56:40 <dtantsur> #topic  Open discussion
17:56:47 <dtantsur> 4 minutes :)
17:57:20 <rloo> crickets
17:57:33 <dtantsur> mmm, we can save a couple of minutes of our life I guess :)
17:57:38 <dtantsur> thanks everyone!
17:57:41 <vdrok> thanks :)
17:57:54 <dtantsur> #endmeeting