17:00:12 <dtantsur> #startmeeting ironic
17:00:13 <openstack> Meeting started Mon Sep 25 17:00:12 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:18 <openstack> The meeting name has been set to 'ironic'
17:00:26 <dtantsur> hi all
17:00:28 <TheJulia> o/
17:00:33 <kaifeng> o/
17:00:35 <crushil_> \o
17:00:40 <jlvillal> o/
17:00:40 <rloo> o/
17:00:45 <sambetts> o/
17:01:00 <stendulker> o/
17:01:01 <rpioso> o/
17:01:04 <rama_y> o/
17:01:12 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:01:17 <etingof> o/
17:01:18 <dtantsur> is our agenda for today
17:01:22 <anupn> 0/
17:01:28 <anupn> *o/
17:01:32 <fellypefca> o/
17:02:35 <pas-ha> o/
17:03:21 <dtantsur> #topic Announcements / Reminder
17:03:27 <dtantsur> (sorry, got a call)
17:03:54 <TheJulia> IRC Meeting Life :)
17:03:58 <dtantsur> #info A bunch of stable releases was done
17:04:16 <dtantsur> this includes the Pike rolling upgrades fix and the inspection regression
17:04:25 <dtantsur> also whatever outstanding was in ocata and pike
17:04:39 <rloo> thx!
17:05:00 <dtantsur> now I'd like to get some queens releases, but I haven't checked what we have
17:05:09 <dtantsur> probably not enough on the ironic side, but maybe enough on ironicclient
17:05:44 <dtantsur> #info Queens priorities proposal: https://review.openstack.org/505173
17:05:55 <dtantsur> this is important, please review (and thanks to all who reviewed)
17:06:00 <rloo> dtantsur: wrt ironicclient, i think we want a major version bump?
17:06:07 <rloo> dtantsur: i can discuss with you later
17:06:12 <dtantsur> rloo: yes, we have two reasons for that already :)
17:06:19 <dtantsur> I need to check vdrok
17:06:26 <dtantsur> vdrok's patch though
17:06:33 <Nisha_Agarwal> o/
17:06:50 <rloo> dtantsur: +1 for getting vdrok's patch in
17:06:50 <dtantsur> #info dtantsur out Sep 28 - Sep 29; spotty availability the week after (TheJulia to back up)
17:07:22 <dtantsur> I'm relocating to Berlin :) I'm staying with Red Hat, but of course there'll be some official stuff involved, so I'm not sure I'll be available all the time
17:07:32 <dtantsur> what is worse, sometimes I'll be suddenly unavailable
17:07:53 <dtantsur> I'll definitely catch up on emails and will try to answer pings when I have time
17:08:26 <rloo> and dtantsur will host everyone that goes to the Berlin Forum ;)
17:08:30 <jlvillal> Good luck on the move! Berlin sounds like fun :)
17:08:33 <dtantsur> :D
17:08:35 <rpioso> dtantsur: Prost
17:08:59 <TheJulia> Good luck dtantsur, and remember not to rush on our account!
17:09:44 <dtantsur> #info dtantsur is still organizing his notes from the PTG into a long human-readable text. please stay tuned.
17:09:52 <dtantsur> thanks all :) anyone has anything else?
17:10:07 <rloo> bfv is voting test now
17:10:22 <dtantsur> oh yeah, that's great
17:10:35 <TheJulia> \o/
17:10:39 <dtantsur> TheJulia: do you feel like talking to nova about making it run non-voting on them?
17:10:51 <dtantsur> or we have no chances? :)
17:11:15 <TheJulia> dtantsur: I doubt we have a chance, but I'll poke a few people and see how they feel about it.
17:11:23 <dtantsur> thanks!
17:11:30 <TheJulia> no problem!
17:11:36 <dtantsur> or did we actually agree to roll this job into existing ones?
17:11:44 <dtantsur> I start recalling something like that from the PTG..
17:12:24 <TheJulia> I'm not sure we truly reached consensus on bfv, but we did discuss deduping some of our tests down as standalone jobs
17:13:28 <TheJulia> bfv has cinder in the stack which adds more of a memory load to the machine, so a devstack based job running many things might not work so well
17:14:00 <dtantsur> okay, let's start with talking to nova folks
17:14:11 <dtantsur> if they firmly disagree, we can look into other options
17:14:11 <TheJulia> I guess I'm just advocating careful progression forward ;)
17:14:15 <dtantsur> right
17:15:36 <dtantsur> okay, anything else here?
17:15:52 * dtantsur falls asleep in front of the computer, ping him from time to time
17:16:05 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:16:20 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard line 134
17:16:36 <TheJulia> dtantsur: no sleeping until the meeting is over ;)
17:16:38 <dtantsur> no really much to review - the priorities are not finalized
17:16:42 <dtantsur> so please review them :)
17:16:43 <jlvillal> Review request for tempest test migration: https://review.openstack.org/489762
17:16:51 <dtantsur> oh, yes, this one
17:16:59 <jlvillal> Not sure if this is a good week to do that or not.
17:17:02 <dtantsur> #link https://review.openstack.org/#/c/489762/
17:17:13 <dtantsur> jlvillal: I'm half-unavailable, so dunno
17:17:15 <rloo> jlvillal: we should wait til dtantsur is available i think
17:17:25 <jlvillal> Okay. Works for me.
17:17:26 <dtantsur> I'd target mid-October
17:17:43 * jlvillal goes to update whiteboard
17:17:52 <dtantsur> oh, and btw: I'd like to have a call/quartercycle/name it about inspection and ironic-inspector mid-October as well
17:18:09 <dtantsur> I'll send out something about it soon(ish)
17:18:33 <rloo> dtantsur: oh. will that be too late? i thought there were some decisions that needed to be made soon wrt what direction to take, but i could be wrong.
17:19:16 <dtantsur> rloo: I'd like to meaningfully participate, which requires finishing the relocation, getting drunk a few times, and finally achieving some level of internal balance :)
17:19:27 <TheJulia> :)
17:19:36 <rloo> dtantsur: ah. in that case... :)
17:19:49 <dtantsur> overall, I think it's still the right time to review specs and see what else (in addition to priorities) we could get in
17:19:52 <TheJulia> I also think we are going to need some info from johnthetubaguy. I know he started writing one of the specs that he indicated he would write, not sure the status
17:20:03 <dtantsur> yep, I've seen a WIP patch
17:20:20 <rloo> are we talking about inspection only? i thought the big thing there was whether to move it into ironic
17:20:41 <dtantsur> rloo: rough agenda is:
17:20:42 <rloo> dtantsur: or are you talking about a midcycle for ironic too?
17:21:01 <dtantsur> rloo: 1. moving introspection rules into ironic, 2. moving most of ironic-inspector into ironic, 3. how this affects the HA and WSGI work
17:21:14 <dtantsur> no, this is not about the midcycle. this is a compensation for not having milan at the PTG
17:21:16 <dtantsur> :(
17:21:28 <dtantsur> I'll plan a virtual midcycle too (maybe even two of them?)
17:21:31 <rloo> dtantsur: got it. what does that have to do with thetubaguy's specs?
17:21:53 <dtantsur> rloo: it may end up getting to traits
17:21:57 <rloo> dtantsur: or is one of the specs about ^^? (I'm only thinkin about tht etraits specs)
17:22:05 <dtantsur> because they'll be an important part of the scheduling picture soon
17:22:19 <rloo> dtantsur: gotcha, thx for clarifying
17:22:34 <dtantsur> like, introspection rules are not only about setting resource_class, they can also set traits
17:22:44 <dtantsur> we do use them nowadays to set capabilities in tripleo
17:23:17 <rloo> dtantsur: i guess i see the traits stuff as separate from the above 3 points you mentioned.
17:23:29 <rloo> dtantsur: but let's move on :)
17:23:41 <dtantsur> yep :) anything else on statuses?
17:24:03 <dtantsur> #topic Deciding on priorities for the coming week
17:24:16 <dtantsur> so. this is the first time when we have more slots for priorities
17:24:20 <rloo> i/we still need the rolling-upgrades patches merged
17:24:55 <dtantsur> I like the main priorities list as it is, to be honest
17:24:56 <rajinir> /me o/
17:25:04 <rloo> if they aren't merged before some patch-that-mucks-with-rolling-upgrades-is-merged, we might have a mess. also, i plan on forgetting how it all works soon ;)
17:25:20 <dtantsur> and two vendors and two subteams (in my face, lol) decided to propose their priorities - please pay attention to them to
17:25:48 <dtantsur> * too
17:26:09 <dtantsur> how is the whole list (incl. new additions) looking?
17:26:29 <dtantsur> mm, jlvillal's patch too, lemme add
17:26:41 * jlvillal likes :)
17:27:06 <dtantsur> finished now. comments?
17:27:08 <rloo> jlvillal: if we defer the tempest stuff til oct, does it make sense to review your tempest patch now?
17:27:26 <jlvillal> rloo: I don't envision it changing. It is a script to do the work.
17:27:32 <rloo> jlvillal: if it extracts to a separate git repo, won't you have to keep it i n sync after that?
17:27:33 <dtantsur> yep, it's just a script
17:27:33 <jlvillal> rloo: The script can be called/run at anytime
17:27:49 <rloo> jlvillal: so it is just a script, it isn't actually going to be run soon?
17:27:54 <rloo> jlvillal: guess i could just look at it...
17:28:11 <jlvillal> rloo: The idea is we run it when ready. Once ready, I push to a github repo. And ask infra to push it to the openstack/ironic-tempest-plugin repo
17:28:16 <TheJulia> dtantsur: lgtm
17:28:40 <rloo> jlvillal: ok. i guess for me, i don't want to look at it until we are ready to press the button ;) but that's just me.
17:28:46 <dtantsur> we need to decide whether we want ironic-inspector plugin there too or separate.. I guess it's for the open discussion
17:29:05 <rloo> i'd like to see a networking-baremetal patch in the priorities. Oh well.
17:29:11 <rloo> other than that, i'm good with the priorities :)
17:29:23 <dtantsur> this is a call for networking-baremetal subteam members
17:29:34 <dtantsur> my gertty does not list ready-to-review patches for n-b
17:29:53 <rloo> well, hopefully there will be something there next week
17:29:57 <dtantsur> #topic Appointing a bug triaging lead for the coming week
17:29:57 <jlvillal> +1
17:29:59 <dtantsur> yep
17:30:10 <dtantsur> okay, any volunteers? :)
17:30:49 <TheJulia> I guess I can
17:31:21 <dtantsur> thanks!
17:31:30 <dtantsur> #action TheJulia to lead bug triaging this week
17:31:46 <dtantsur> okay, let's move to serious business ;)
17:31:51 <dtantsur> #topic Any forum session worthy topics?
17:32:20 <dtantsur> TheJulia: your turn (though the topic is obvious)
17:32:29 <dtantsur> I'd bring the scheduling question
17:32:39 <dtantsur> as a heads-up as well as feedback
17:32:50 * jlvillal wonders how many people are planning on attending the Summit / Forum?
17:32:58 <dtantsur> jlvillal: I cannot for reasons that are now obvious
17:32:59 <TheJulia> So yes, I'm wondering if we have anything to schedule a session on
17:33:11 <dtantsur> TheJulia: do you have an etherpad for ideas?
17:33:17 <TheJulia> I think the scheduling question might be a good topic to go ahead and get a room
17:33:19 <TheJulia> dtantsur: I do not
17:33:20 <TheJulia> :(
17:33:50 <dtantsur> yep. it can include both discussion the scheduling approach, and the introspection rules, and whatever
17:34:00 <TheJulia> Feedback would be new for us at the forum, maybe we would get feedback, but I suspect questions would be the actual feedback from the project update
17:34:30 <dtantsur> well, I don't think a lot of operators and users have experience with new-style scheduling at this point
17:34:51 <TheJulia> yeah
17:34:55 <dtantsur> so it's kind of "We did this. What do you think? Could we do better? Can we improve on it?"
17:35:21 <TheJulia> for feedback, I was speaking in general
17:35:26 <dtantsur> aha
17:35:33 <dtantsur> If you mean a feedback session, I'm all for it
17:35:49 <dtantsur> I'd specifically ask for feedback on newer stuff, like networking integration, BFV, driver comp, etc
17:36:10 <dtantsur> from previous surveys I know that lack of neutron integration was the biggest pain point
17:36:14 <dtantsur> I wonder if the people are happy now
17:36:18 <TheJulia> wfm, I think all of the scheduling stuff needs to shake out a little more first
17:36:47 <dtantsur> well.. when people get hit by it, it's going to be a tiny bit late :)
17:37:02 <dtantsur> but I'll leave the final choice up to you as our representative ;)
17:37:06 <TheJulia> okay
17:37:14 <rpioso> Should we create a Summit/Forum wiki?
17:37:41 <dtantsur> etherpad, rather..
17:37:47 <rpioso> Right
17:37:52 <dtantsur> again, leaving it up to Julia, I don't care about the exact format
17:37:59 <TheJulia> Etherpad, but the sessions need to be submitted today
17:38:05 <dtantsur> ouch :)
17:38:12 <TheJulia> yeah :(
17:38:25 <TheJulia> so Etherpad for actual output is likely what we will have
17:38:26 <dtantsur> well, we have two ideas (feedback, scheduling). anything else?
17:38:58 <TheJulia> I think those are good, but I don't have any other ideas right now. Anyone else have anything they would like discussed at the forum?
17:38:58 <rpioso> TheJulia: The ML email subject said 9/29.
17:39:35 <dtantsur> TheJulia: maybe something around deploy steps, ansible driver and deploy templates? this one may be premature indeed...
17:39:37 <TheJulia> rpioso: I think the email I got directly indicated today, but maybe I'm mixing things up in my head.
17:40:12 <sambetts> I don't we should have a general "this is whats up and coming" in ironic session
17:40:15 <rloo> are these session(s) separate from one that describes the upcoming Queens priorities?
17:40:29 <sambetts> I think we should have *
17:40:39 * sambetts is tired
17:40:49 <dtantsur> sambetts: like "Bare metal roadmap"? yeah
17:40:57 * dtantsur hears sambetts re "tired"
17:41:09 * rloo wonders why everyone is tired ;)
17:41:21 <dtantsur> rloo: I was packing stuff the whole weekend, and barely got any good sleep
17:41:35 <TheJulia> sambetts: we have a project update session where we can cover what we did, where we are going, etc
17:41:44 <dtantsur> right
17:41:59 <rloo> TheJulia: great. that's where we can get feedback, i hope.
17:42:00 <sambetts> yeah, remembering the Forum is for users, I don't think we want to have too many deep dives into things we're currently working on, but should mention them to make sure we're heading in the right direction
17:42:01 <jlvillal> sambetts: Did you see the call for a 'networking-bare-metal" review priority item?
17:42:13 <dtantsur> TheJulia: is this session going to happen before the feedback one?
17:42:28 <jlvillal> sambetts: Whiteboard, around line 126
17:42:51 <TheJulia> dtantsur: that is a great question!
17:43:18 <dtantsur> :) if the status update comes before the feedback, people will be able to comments on our plans
17:43:59 <TheJulia> dtantsur: looks our status update is end of the day on monday
17:44:17 <TheJulia> they tried to stack sessions on other days in boston, so I think we'll be fine.
17:44:34 <dtantsur> great
17:45:12 <dtantsur> so, we still have two ideas? anybody? :)
17:45:56 <kaifeng> i goess bonding is covered by networking bare metal?
17:46:16 <kaifeng> guess
17:46:21 * TheJulia suspects we're good with two
17:46:33 <sambetts> are we having a project onboarding??
17:46:40 <dtantsur> kaifeng: bonding is implemented in ocata, if I get you right
17:46:54 <TheJulia> sambetts: afaik no
17:47:08 * dtantsur has not heard about it either
17:47:12 <kaifeng> dtantsur: the switch part has to set manually
17:47:24 <TheJulia> same, I've not seen anything regarding project onboarding sessions
17:47:26 <dtantsur> kaifeng: I think it was fixed in ironic, now it has to be fixed in the ML2 drivers
17:47:46 * sambetts is just looking at the boston forum schedule trying to see if I can think of anything
17:47:49 <dtantsur> networking-baremetal is not related here, it does not actually talk to any switches
17:48:00 <kaifeng> yes, that is what dynamic port group doing
17:48:53 <TheJulia> sambetts: thanks!
17:49:23 <TheJulia> dtantsur: I think we can move on
17:49:26 <dtantsur> yep
17:49:32 <dtantsur> #topic Open discussion
17:49:48 <dtantsur> maybe we discuss whether we need two or one tempest plugin?
17:50:17 * jlvillal is undecided
17:50:28 <dtantsur> the reason I suggested merging them is that people I work with rarely understand the difference
17:50:47 <dtantsur> so they get super confused, when they figure out that tests for ironic inspection are not in the ironic tempest plugin :D
17:51:01 <sambetts> as long as we correctly flag everything behind service_enabled flags I think we should be good to merge them
17:51:08 <jlvillal> dtantsur: If they are merged will they understand the difference of where to make changes in the repo?
17:51:11 <TheJulia> I'm all for merging and just using flags
17:51:43 <dtantsur> jlvillal: not necessary. but people I'm talking about are consumers of the tempest plugin (QE, for example), not upstream contributors
17:51:56 <rajinir> Can we have a job that is voting and uses hardware in the gate?
17:52:02 <pas-ha> especially since we plan to move most of the inspector stuff back to ironic :)
17:52:11 <dtantsur> one of the reasons I like the tempest plugin split (the main one) is that we start making it a separate product
17:52:17 <jlvillal> Okay. I'm fine with merged. And what pas-ha says makes sense too.
17:52:30 <dtantsur> rajinir: it may be tricky from Gerrit point of view, and it will set much high expecations on uptime
17:52:39 <dtantsur> * higher
17:53:00 <jlvillal> rajinir: Not likely. Need at least two providers to provide hardware for infra to approve it, I believe.
17:53:13 <rajinir> dtantsur: At least have some policies for merging. If all 3rd party CI's (majority) reports failure, do not merge
17:53:24 <TheJulia> The main blocker has been the resources such a CI takes and the security implications that can exist with direct testing with real hardware
17:53:27 <dtantsur> rajinir: this is a social issue, and I agree that we need to solve it
17:53:52 <jlvillal> rajinir: The problem is that most 3rd Party CIs seems to be fail. Or at least the impression I get.
17:53:54 <dtantsur> this is one of the reasons I insisted on reverting that patch that broke people (that I so recklessly approved - sorry!)
17:53:57 <rajinir> dtantsur: It took us some time to figure out. Oftehn we are pressed on time
17:54:16 <jlvillal> rajinir: So when I see failed 3rd party CI jobs it doesn't mean much to me. Unfortunately.
17:54:27 <rloo> rajinir: well, what jlvillal said ^^. I don't have time to check to see if 3rd party cis are normally passing or not
17:54:33 <TheJulia> six minutes
17:54:34 <dtantsur> rajinir: I don't have a good excuse here - we should not have ignored the CI. if it makes you feel better, we're in the same boat wrt neutron and nova.
17:54:46 <rpioso> When all fail, it likely means it's a thing.
17:54:56 <dtantsur> this ^^^
17:55:09 <dtantsur> though this case was more compex, as not all jobs use PXE
17:55:12 <rpioso> Could we implement that?
17:55:16 <rloo> rajinir: we instituted L69: https://etherpad.openstack.org/p/IronicWhiteBoard, and i have yet to see it being updated :-(
17:55:28 <pas-ha> rloo: ++
17:55:35 <rpioso> dtantsur: Agree.  PXE is the baseline, right?
17:55:45 <jlvillal> rajinir: Here is a random job: https://review.openstack.org/#/c/506173/  How do I know which of these failures mean anything from 3rd Party CI?
17:55:50 <dtantsur> rpioso: some drivers don't use PXE, some not even by default.
17:56:08 <rpioso> dtantsur: All those that do, then.
17:56:09 <dtantsur> jlvillal: what you ask is "is 3rdparty CI useful" :)
17:56:18 <dtantsur> it's a valid question, I don't disagree, but let's make it clear
17:56:20 <rajinir> Agree, something to consider when the 3rd party CIs stabilizes
17:56:34 <dtantsur> if we ignore the CI, 1. it will never become stable, 2. why even enforce it?
17:56:39 <rpioso> dtantsur: If none of the PXE jobs succeed, fire it!
17:56:44 <pas-ha> well, actually more like iPXE (only single job in gate does not use iPXE, and is non-voting)
17:56:46 <rpioso> ;-)
17:57:19 <TheJulia> Three minutes
17:57:20 <rloo> dtantsur: what should we do if we don't want to ignore the 3rd party CI results?
17:57:20 <jlvillal> Did we come to consensus on tempest plugin?
17:57:32 <rloo> jlvillal: one plug in
17:57:37 <dtantsur> rloo: if unsure, ask around
17:57:43 <jlvillal> Sounds good. One plug-in
17:57:48 <pas-ha> jlvillal: merge it
17:57:49 <dtantsur> of course it concerns non-trivial patches to common code (incl. devstack!)
17:57:52 <rloo> dtantsur: who has time to ask around, when they seem to fail a lot. even with docs :-(
17:58:13 <dtantsur> rloo: it's we who asked for 3rdparty CI, no?
17:58:25 <dtantsur> it's not that someone forced it on us
17:58:45 <rloo> dtantsur: i won't speak personally ;) It has to be a two way street/communication.
17:58:46 <dtantsur> ensuring that things don't only Work On DevStack (tm) may be annoying indeed..
17:59:04 <dtantsur> jlvillal: I'm for merging them..
17:59:18 <rloo> dtantsur: do you really want me to ping all third party CI folks for every patch where one of their tests fail?
17:59:20 <jlvillal> dtantsur: Thanks.
17:59:30 <dtantsur> rloo: there are easier ways, I'd say
17:59:31 <rloo> rajinir: ^^ what do you suggest?
17:59:34 <dtantsur> but we have to continue in the channel
17:59:37 <dtantsur> thanks all!
17:59:41 <rajinir> rloo: Have to think about it
17:59:42 <jlvillal> Thanks
17:59:44 <dtantsur> #endmeeting