17:00:02 <dtantsur> #startmeeting ironic
17:00:03 <openstack> Meeting started Mon Oct  2 17:00:02 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:06 <openstack> The meeting name has been set to 'ironic'
17:00:10 <etingof> o/
17:00:19 <jlvillal> o/
17:00:29 <rloo> o/
17:00:35 <jlvillal> So, Zuul v3 ...
17:00:58 <fellypefca> o/
17:01:03 <dtantsur> hi all!
17:01:14 <crushil> o/
17:01:14 <sambetts> o/
17:01:16 <dtantsur> our agenda as usual can be found at
17:01:18 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:01:37 <dtantsur> it's empty today, which promises a potentially short meeting ;)
17:01:41 <rpioso> o/
17:02:05 <dtantsur> #topic Announcements / Reminder
17:02:19 <dtantsur> #info We have migrated to Zuul v3, and the CI seems broken
17:02:21 <dtantsur> right?
17:02:27 <jlvillal> Gate is broken for grenade. vsaienk0 has proposed a patch: https://review.openstack.org/#/c/508882/
17:02:45 <jlvillal> I'm not sure if other jobs are broken or not.
17:02:49 <dtantsur> #link https://review.openstack.org/#/c/508882/ fix for grenade
17:03:11 <dtantsur> #info Priorities for Queens approved: http://specs.openstack.org/openstack/ironic-specs/priorities/queens-priorities.html
17:03:18 <rloo> yeah, broken for other stuff too. something about LIB_ missing, but i think there is a patch to fix that. i saw in python-ironicclient patch.
17:03:31 <rloo> and inspector has some issues too :-(
17:03:53 <rpioso> python-dracclient changes are having difficulties, too.
17:03:58 <rloo> yay for approved priorities!
17:04:05 <jlvillal> +1!
17:04:23 <dtantsur> sigh..
17:04:32 <dtantsur> anything else?
17:04:47 <sambetts> I'm seeing issue with patches not getting picked up into the queues too
17:04:53 <mjturek> o/
17:05:18 <rloo> i believe there are performance issues with zuul3, they're working on it, so things are slow or missing...
17:05:34 <sambetts> ah makes sense
17:05:36 <dtantsur> I guess it's going to stabilize with time, more or less..
17:05:42 <rama_y> o/
17:05:55 <rloo> i'm pretty sure it'll stabilize. how much time is the question ;)
17:06:06 <dtantsur> heh
17:06:10 <dtantsur> moving on?
17:06:21 <sambetts> at the PTG they said they have a big red revert button if they need too
17:06:24 <jlvillal> I'm guessing we don't get back to normal until Thursday or so.
17:06:28 <sambetts> but lets hope not
17:06:32 <dtantsur> yeah
17:06:39 <rloo> sambetts: as of an hour ago, they weren't going to revert
17:06:48 <sambetts> \o/
17:06:52 <dtantsur> :)
17:07:03 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:07:15 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard line 169
17:07:29 <dtantsur> this is populated with our new priorities now
17:07:35 <dtantsur> so please don't forget to provide updates
17:08:17 <rloo> dtantsur: how up-to-date is the CI refactoring section (L176)?
17:08:45 <dtantsur> seems quite up-to-date
17:08:54 <dtantsur> local boot with partition images is slowly moving, I think
17:09:28 <rloo> dtantsur: ok, thx. would it help to have someone be responsible for that section?
17:10:00 <dtantsur> I think vsaienk0 is implicitly responsible :)
17:10:18 <rloo> dtantsur: let's make it explicit!
17:10:24 <dtantsur> I'll ask him
17:10:48 <rloo> sambetts, jlvillal, wrt zuul v3 jobs in-tree. does that include converting all the legacy* jobs?
17:10:59 <jlvillal> rloo: I believe so
17:11:09 <jlvillal> rloo: Over time
17:11:18 <dtantsur> yep
17:11:25 <rloo> jlvillal: do you know what the diff is? what if we don't convert for awhile, does it matter?
17:11:47 <rloo> jlvillal: just wondering what our priority ought to be, for that work
17:11:48 <sambetts> rloo: main thing is that we shouldn't be using devstack gate any more
17:11:51 <jlvillal> rloo: I don't think it is a problem. It will just make it easier for us in the long term if we switch. That way we have control.
17:12:13 <dtantsur> rloo: we want it, because we want to evolve our jobs quite actively
17:12:15 <rloo> ok, so, seems like if/when we need to change one of those tests, would be a very good time to migrate :)
17:12:20 <dtantsur> e.g. switch a lot of things to standalone jobs
17:13:57 <dtantsur> we need more folks reviewing the ansible deploy interface, while it's still in staging
17:14:06 <dtantsur> even +-1 are of great importance
17:14:18 <rloo> wrt apache & wsgi. the status thing there, seems conflicting, ironic is done and ironic is not done...
17:14:34 <rloo> dtantsur: why review it while it is still in staging?
17:14:43 <rloo> dtantsur: vs reviewing it as a patch to ironic?
17:15:06 <dtantsur> rloo: that's up to pas-ha, but looks like he's trying to clean it up first
17:15:36 <dtantsur> rloo: I don't see any contradiction in the wsgi part..
17:16:32 <rloo> dtantsur: not any more, someone cleaned it up :) (the wsgi contradiction)
17:16:58 <dtantsur> I only removed redundant things, it was like "ironic done, inspector bumped to Queens"
17:17:04 <dtantsur> now is Queens, so it makes no sense :)
17:17:21 <dtantsur> anyway, we're at the 10 minutes border. is everyone done with statuses?
17:17:22 <rloo> dtantsur: 'ironic done' was the part i was talking about, cuz it isn't done
17:17:51 <dtantsur> yeah, true
17:18:10 <dtantsur> moving on?
17:18:14 <rloo> sambetts: wrt the cisco UCS CI, would you please add that info to the whiteboard where the CI section is?
17:18:27 <rloo> sambetts: after L101
17:18:59 <rloo> sambetts: after L106 even
17:18:59 <sambetts> rloo: oh :/ I added it in the section at the bottom for third party cis
17:19:32 <rloo> sambetts: hmm, we should decide where then, does it make sense to put it a the moving L105?
17:19:57 <rloo> (we can discuss in 'other')
17:20:16 <rloo> or err 'open discussion' if we want
17:20:21 <sambetts> yeah, its worth deciding which is the best place for it
17:20:35 <dtantsur> sambetts: please move up, that's where people are looking for it
17:21:48 <dtantsur> #topic Review action items from previous meeting
17:22:05 <dtantsur> #link http://eavesdrop.openstack.org/meetings/ironic/2017/ironic.2017-01-09-17.00.html
17:22:18 <dtantsur> wait, wut
17:22:20 <dtantsur> #undo
17:22:21 <openstack> Removing item from minutes: #link http://eavesdrop.openstack.org/meetings/ironic/2017/ironic.2017-01-09-17.00.html
17:22:34 <dtantsur> #link http://eavesdrop.openstack.org/meetings/ironic/2017/ironic.2017-09-25-17.00.html
17:22:48 <dtantsur> TheJulia: how was the bug triage? :)
17:23:09 <rloo> I think TheJulia is taking a sick day
17:23:11 * jlvillal is always proud when he sees the "Removing item...with a description" :)
17:23:22 <dtantsur> ouch
17:23:22 <rloo> maybe bug triaging made her sick?
17:23:28 <dtantsur> I can easily imagine it
17:23:35 <rloo> i am joking of course :)
17:23:38 <mjturek> oh - speaking of bug triage. Was out last week but did a little bit this morning. Notes here https://etherpad.openstack.org/p/ironic-bug-triage Sorry I probably shouldn't have raised my hand last time :(
17:23:58 <dtantsur> okay, so my action items (not stated there) were to add this new topic to the agenda, so here it is :)
17:24:03 <dtantsur> mjturek: thanks!
17:24:10 * dtantsur usually forgets to leave any notes
17:24:26 <mjturek> np :)
17:24:29 <dtantsur> do you folks feel like we should move this topic up, right after announcements?
17:24:44 <dtantsur> it feels out of order between statuses and priorities to me..
17:24:45 <rloo> so that bug triage etherpad is nice, but honestly, i won't remember to look at it. mjturek, do you put notes down for every bug that you triage?
17:25:07 <rloo> dtantsur: yes, action items is odd in this order
17:25:13 <mjturek> rloo: I try to, mostly so that I remember what I changed
17:25:15 <dtantsur> k, will move
17:25:37 <rloo> dtantsur: or move AIs down after bug triaging lead
17:25:47 <rloo> in case AIs cause a discussion...
17:26:02 <dtantsur> well, it feels natural to wrap up with the last meeting before diving into a new one.. but dunno
17:26:29 <rloo> dtantsur: i suspect there is some recommended ways, folks have been having meetings for decades, etc. but i dunno :)
17:26:41 <dtantsur> tripleo starts with past action items
17:27:01 <dtantsur> moved up for now, suggestions are welcome :)
17:27:05 <dtantsur> #topic Deciding on priorities for the coming week
17:27:22 <dtantsur> so, given zuul v3, I don't think we can take much :(
17:28:01 <dtantsur> we can leave what we have, or even shrink it a bit
17:28:24 <dtantsur> jlvillal: should we postpone migrating to a new tempest plugin to after we fully migrate to zuul v3?
17:28:29 <rloo> i think we can do specs
17:28:42 <jlvillal> dtantsur: I think so. Plus we had planned for mid-October I thought
17:28:53 * dtantsur removes the related item for now
17:29:18 <jlvillal> dtantsur: Reviewing the patch would be nice
17:29:19 <dtantsur> rloo: specs, yes. I can suggest the BIOS one, it feels close
17:29:27 <jlvillal> dtantsur: Once that is merged then we can go at any time.
17:29:31 <dtantsur> jlvillal: I think I gave it +2 already ;)
17:29:33 <rloo> ++ for BIOS one
17:29:48 <rpioso> BIOS \o/
17:30:02 <dtantsur> "Refactoring of the way we access clients" seems not too ready to me..
17:31:03 * dtantsur does not see pas-ha around..
17:31:27 <rloo> i have two doc-related patches for client, want them in before we release. i think zuul likes them: https://review.openstack.org/#/c/507927/ & https://review.openstack.org/#/c/507898/
17:31:40 <rloo> dtantsur: i think pas-ha needs to update the first patch in that series
17:31:56 <rloo> dtantsur: at least, that's what i'm waiting for, before reviewing ;)
17:32:30 <rloo> this spec too, can be reviewed: https://review.openstack.org/#/c/343684/
17:32:56 <rloo> ^^ Add synchronize-events-with-neutron spec
17:33:25 * dtantsur HATES internet in his apartments
17:33:45 <dtantsur> rloo: feels too much to me
17:33:57 <dtantsur> I'm biased towards the BIOS one, because I've reviewed it already
17:34:00 <dtantsur> :)
17:34:18 <rloo> i'm fine, was just making suggestions
17:34:24 <jlvillal> dtantsur: That is the #1 thing to look at when apartment shopping ;) We don't care about kitchen, neighborhood, public transit, etc...  All we care about is Internet access :D
17:34:38 <dtantsur> jlvillal: I did not have any practical choice :)
17:34:59 <dtantsur> so, I have a list of 6 items. wdyt?
17:35:41 <rloo> +1
17:36:29 <rloo> i know we had planned on doing a client release, but I am guessing we won't until things stabilize with zuul 3, etc.
17:36:34 <dtantsur> right
17:36:42 <dtantsur> I still want vdrok's change in
17:37:04 <rloo> dtantsur: yeah, me too. and i have the deprecate-ironic-cli patch too, that'd be nice to get in
17:37:12 <dtantsur> yep
17:37:34 <dtantsur> so, rloo is okay with the priorities, we can move on? :D
17:37:41 * dtantsur wants moar voices
17:37:55 <rloo> +++
17:38:05 <dtantsur> #topic Appointing a bug triaging lead for the coming week
17:38:06 <rloo> boar voices are acceptable too
17:38:10 <dtantsur> any victim?
17:38:31 <mjturek> \o I'll go again
17:39:00 <dtantsur> thanks mjturek!
17:39:08 <dtantsur> #action mjturek to lead the bug triage this week
17:39:17 <dtantsur> #topic Open discussion
17:39:26 <dtantsur> the floor is open
17:39:55 <rloo> this wasn't an AI per se, but rajinir, did you get any response wrt a 3rd party CI meeting?
17:40:07 <rloo> Ai = action item
17:40:27 * dtantsur will respond, when he gets to this email in his inbox
17:40:35 <rpioso> rloo: rajinir may be afk
17:40:44 <rloo> ok, was just wondering
17:41:00 <rpioso> I've pinged her :)
17:41:40 <rloo> crickets?
17:42:36 <dtantsur> yep :)
17:42:48 <dtantsur> let me return you 18 minutes of life
17:42:51 <dtantsur> thanks all :)
17:43:02 <rpioso> Thank you!
17:43:04 <dtantsur> #endmeeting