17:00:04 <dtantsur> #startmeeting ironic
17:00:05 <openstack> Meeting started Mon Oct 16 17:00:04 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:08 <openstack> The meeting name has been set to 'ironic'
17:00:11 <mjturek> o/
17:00:14 <dtantsur> o/
17:00:16 <rpioso> o/
17:00:20 <anupn> o/
17:00:22 <NobodyCam> o/
17:00:31 <crushil> o/
17:00:34 <baha> o/
17:00:42 <rloo> o/
17:00:45 <stendulker> o/
17:01:04 <dtantsur> hi all!
17:01:12 <dtantsur> our agenda is where it has to be:
17:01:21 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:01:26 <TheJulia> o/
17:02:32 <rama_y> o/
17:02:37 <dtantsur> #topic Announcements / Reminder
17:02:55 <dtantsur> #info Zuul v3 switch is done (again)
17:03:22 <dtantsur> things seem more or less fine, but we do see some strange errors
17:03:23 <rloo> I looked about an hour? ago and there weren't any ironic patches in the zuul gate. so you might want to 'recheck'...
17:03:29 <jlvillal> o/
17:03:30 <dtantsur> yes, and this
17:03:37 <jlvillal> But is it working?
17:03:47 <dtantsur> jlvillal: we have patches merged since the switch
17:03:49 <jlvillal> I thought I saw a punch of POST_FAILURE errors.
17:03:53 <rloo> jlvillal: will let you know when the rechecks are working...
17:03:53 <jlvillal> Are those resolved?
17:03:55 <jlvillal> Cool!
17:03:57 <rajinir> o/
17:04:02 <rloo> jlvillal: yeah, and MERGE_FAILURES :-(
17:04:05 <dtantsur> so it's still unstable
17:04:18 <dtantsur> if you see anything strange, please report to the infra
17:04:56 <dtantsur> next,
17:04:58 <dtantsur> #info The TC election is going on
17:05:14 * dtantsur has not voted yet
17:05:25 <dtantsur> anything else?
17:05:27 <rloo> voting ends on Friday
17:05:34 <rloo> yes, nova feature freeze is Thursday
17:05:40 <rloo> feature spec freeze i mean
17:05:41 <dtantsur> OH YEAH
17:05:45 * TheJulia blinks
17:05:48 <dtantsur> #info Nova specs freeze is this Thursday
17:05:59 <dtantsur> we did land the traits spec. do we expect more specs?
17:06:04 <rloo> does anyone remember which nova specs are ironic-related? that we ought to look at?
17:06:07 <dtantsur> I think the 'nova migrate' one is affected
17:06:19 <dtantsur> anyone from Fujitsu around? re ^^^
17:06:35 <rloo> dtantsur: maybe put as priorities this week, whatever they are
17:06:41 <TheJulia> +1
17:06:44 <Nisha_Agarwal> +1
17:06:59 <dtantsur> yep
17:07:16 <rloo> dtantsur: nova resize/cold migration spec: https://review.openstack.org/#/c/449155/
17:07:21 <dtantsur> thanks
17:07:34 <dtantsur> #link https://review.openstack.org/#/c/449155/ has to land this week or it will miss Queens
17:08:31 <rloo> dtantsur: we haven't quite landed the traits spec; it has a dependency on ironic. did johnthetubaguy figure out what to do to land it? remove dependency?
17:08:36 * dtantsur pings ppl on the nova channel
17:08:44 <dtantsur> rloo: it landed with the dependency removed
17:08:51 <johnthetubaguy> spec has landed now
17:08:56 <rloo> dtantsur: sweet! thx johnthetubaguy!
17:09:00 <johnthetubaguy> nova one, that is
17:09:12 <rloo> johnthetubaguy: the easy spec ;)
17:09:21 <johnthetubaguy> yup :)
17:09:27 <dtantsur> heh
17:09:39 * johnthetubaguy feels strange calling a nova spec easy
17:09:43 <dtantsur> okay, this was a good catch. any other announcements or reminders?
17:10:13 <rloo> mention the ironic-inspector meetup?
17:10:41 <dtantsur> yep
17:10:51 <dtantsur> #link http://lists.openstack.org/pipermail/openstack-dev/2017-October/123676.html Summary of the inspector virtual meetup
17:11:00 <dtantsur> tl;dr MOAR API SERVICES \o/
17:11:38 <rloo> dtantsur: thx! we love API services :D
17:11:53 <dtantsur> more API services - more microversioning discussions... PROFIT!
17:12:00 <dtantsur> okay, anything else? :)
17:13:03 <dtantsur> #topic Review action items from previous meeting
17:13:11 <dtantsur> #link http://eavesdrop.openstack.org/meetings/ironic/2017/ironic.2017-10-09-17.00.html
17:13:28 <dtantsur> the bugs list is shrinking! thanks mjturek :)
17:13:42 <dtantsur> no more actions items recorded
17:14:14 <mjturek> fyi - I'm moving bugs to Incomplete so they expire. Is there a better way?
17:14:29 <dtantsur> mjturek: better way for what?
17:14:38 <mjturek> to have launchpad expire them
17:14:59 <dtantsur> well, you cannot put bugs to "Expired" state directly, I think
17:15:11 <dtantsur> so you can put them to Incomplete and ask the reports to re-test
17:15:20 <rloo> mjturek: why do you want them to expire?
17:15:23 <dtantsur> or you can close them right away with whatever state we have
17:15:36 <dtantsur> I'd prefer to give people a chance to say "oh, it's still hurting me"
17:16:14 <mjturek> rloo: so invalid bugs don't stay on the bug list
17:16:20 <jlvillal> rloo: I thought if the bugs are old, we were going to start closing them out.
17:16:38 <mjturek> ie there was one about objects using __getitem__ and __setitem__ which wasn't true anymore
17:16:39 <rloo> sorry, is the intent to indicate that they are invalid, or that they are incomplete?
17:16:55 <rloo> mjturek: so that one is invalid
17:17:09 <rloo> mjturek: you didn't set that to 'incomplete' did you?
17:17:30 <dtantsur> if it is not true any more, that's "Invalid"
17:17:31 <mjturek> rloo: got it, I did set it to incomplete as that's the state that launchpad expires with
17:17:39 <dtantsur> if you don't know if it's true or not, you can use Incomplete
17:17:44 <mjturek> ah, okay I'll set back to invalid
17:17:58 <mjturek> set to invalid*
17:17:59 <rloo> mjturek: oh, yeah, set it to invalid then. incomplete is if we need more info to figure out what the bug is, etc.
17:18:13 <mjturek> understood, thanks1
17:18:16 <mjturek> !*
17:18:17 <openstack> mjturek: Error: "*" is not a valid command.
17:18:24 <rloo> mjturek: thx!
17:18:24 <dtantsur> lol
17:18:29 <mjturek> lol
17:18:37 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:18:48 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard line 145
17:19:05 <rloo> there's that patch to move legacy* jobs from zuul3 to ironic, should we put the link at L233?
17:19:35 <dtantsur> totally
17:19:35 <jlvillal> This one?  https://review.openstack.org/511267
17:19:41 <dtantsur> the work is no longer "not started"
17:20:08 <rloo> jlvillal: yeah, that one
17:20:13 <jlvillal> Question. Is Line 40 still accurate?
17:20:20 * jlvillal thinks not
17:20:31 <rloo> jlvillal: i think not.
17:21:25 <rloo> for python 3.5, there is a lot of stuff there but it doesn't look like any reviews are needed?
17:21:57 <jlvillal> I changed gate status to:  16-Oct-2017: Zuul v3 transition has happened. Some things have merged, but have also seen issues
17:21:58 <dtantsur> there is an inspector patch, has -1 from jlvillal now
17:22:04 <rloo> jlvillal: for L277 (tempest plugin), we decided to defer that til after we migrate the legacy* jobs?
17:22:26 <jlvillal> rloo: That makes sense to me. Will make it easier to switch things since we will control it all.
17:22:41 <rloo> jlvillal: ok, i'll update the status then if you don't beat me to it
17:22:49 <Nisha_Agarwal> rloo, for python3.5 its put on hold as per last week meeting discussion(due to jenkins to zuulv3 transition)
17:22:54 <rloo> question about policy-in-code. there is a question about ironic-inspector, does it need a spec/RFE?
17:23:05 <jlvillal> dtantsur: Yeah, I did the -1, as I think using the tempest variables is a better idea. But people can correct me if I am wrong.
17:23:06 <dtantsur> I think there is an RFE
17:23:12 <dtantsur> jlvillal: makes sense to me
17:23:20 <rloo> Nisha_Agarwal: ok thx
17:23:39 <rloo> dtantsur: ok, i'll see if i can find it/link it. do you think it needs a spec? i don't know what is involved for inspector
17:24:08 <dtantsur> rloo: I'm fine without a spec. aarefiev?
17:25:32 <rloo> dtantsur: if aarefiev is ok w/o a spec, we can approve the rfe.
17:25:50 <rloo> dtantsur: rfe: https://bugs.launchpad.net/ironic-inspector/+bug/1719812
17:25:51 <openstack> Launchpad bug 1719812 in Ironic Inspector "[RFE] support API access policy definition and enforcement " [Wishlist,In progress] - Assigned to Pavlo Shchelokovskyy (pshchelo)
17:25:53 <dtantsur> rloo: I'll ask milan tomorrow, I think
17:26:01 <rloo> dtantsur: thx. action item? :)
17:26:19 <dtantsur> #action dtantsur to ask milan and sam about approving https://bugs.launchpad.net/ironic-inspector/+bug/1719812
17:26:47 <dtantsur> rpioso: how is the BIOS spec looking? you wrote you're going to review it by today
17:28:26 <rpioso> dtantsur: That's my status as of this minute :-)
17:28:38 <dtantsur> ok :)
17:28:48 <dtantsur> are folks done with statuses?
17:28:52 * rpioso actually updated it before the meeting
17:29:05 <rloo> dtantsur: have you reviewed the BIOS spec recently? I stopped reviewing cuz you had suggested something and the author interpreted in a way that I don't think you meant. they updated so wanted to make sure you were ok with it :)
17:29:30 <dtantsur> rloo: I'll put it on my review queue again
17:29:37 <rloo> dtantsur: thx!
17:30:16 <dtantsur> moving on?
17:30:25 <rloo> +moving
17:30:37 <dtantsur> #topic Deciding on priorities for the coming week
17:30:54 <dtantsur> aha, so the BIOS spec is already there, good :)
17:31:56 <rloo> we might have still needed the zuul3 one :-(
17:32:09 <rloo> well, we are hopeful we don't!
17:32:10 <dtantsur> rloo: at least it's not THAT horrible now
17:32:19 <rloo> dtantsur: not yet ;)
17:32:21 <dtantsur> hehe
17:32:32 <dtantsur> anyway, I've put together a list, wdyt?
17:32:43 <rloo> +1 for priorities
17:33:06 <TheJulia> lgtm
17:34:18 <dtantsur> #topic Appointing a bug triaging lead for the coming week
17:34:26 <dtantsur> so. who's up? :)
17:34:48 <TheJulia> I likely should take care of it this week
17:35:02 <dtantsur> cool, thanks TheJulia
17:35:19 <dtantsur> #action TheJulia to take lead the bug triaging this week
17:35:33 <dtantsur> #topic Open discussion
17:35:51 <dtantsur> 25 minutes for anything you want
17:36:04 <TheJulia> a nap sounds perfect
17:36:10 <rloo> 3/3 zuul tests, all failed :-(
17:36:17 <TheJulia> :(
17:36:26 <rloo> (sorry, trying not to cry)
17:36:26 * jlvillal wonders if he should ask opinion about class level variables...
17:36:56 <rloo> dtantsur: can we change the priorities? we should get that zuul one done too. soon.
17:37:10 <dtantsur> we don't have to put it on list to fix it, but ok :)
17:37:20 <rloo> dtantsur: a good reminder.
17:37:33 <dtantsur> done
17:37:43 <dtantsur> jlvillal: what's with class level variables?
17:37:53 <rloo> dtantsur: then let's push up a patch to change our jobs to non-voting!
17:37:58 <dtantsur> you're entering a funny part of python, I need to say ;)
17:38:00 <jlvillal> dtantsur: Oh this: https://review.openstack.org/#/c/485799/4/sushy/resources/base.py
17:38:02 * rloo is joking. sort of.
17:38:02 <dtantsur> rloo: \o/
17:38:29 <dtantsur> jlvillal: so, the code is correct, though I admit it's somewhat confusing
17:38:33 <jlvillal> I just don't understand why not just put it in the __init__() method.
17:39:01 <jlvillal> dtantsur: Oh yeah, it works. But why make it harder for people to understand.
17:39:02 <rloo> jlvillal: so a local variable then?
17:39:02 <dtantsur> jlvillal: variable lookup works (roughly!) by first looking at instance.__dict__, then at instance.__class__.__dict__
17:39:11 <jlvillal> dtantsur: There is this idea of lowering cognitive load.
17:39:19 <dtantsur> but setting attributes always goes to instance.__dict__
17:39:24 <dtantsur> jlvillal: I don't disagree with that fwiw
17:39:38 <jlvillal> Basically, make it so people don't have to think as hard to understand what is going on.
17:39:51 <dtantsur> I personally prefer to keep only constants and class variables at class level
17:39:52 <rloo> jlvillal: is that _is_stale to indicate that a particular resource object/instance is stale?
17:40:16 <jlvillal> rloo: I believe so. Like is the cache correct or something.
17:40:17 <dtantsur> but I know that people coming from statis object-oriented languages like to declare variables :)
17:40:59 <rloo> jlvillal: how can it be correct at the class level if one resource can have stale, and another cannot?
17:41:00 <jlvillal> Anyway, not that important to keep us here :)
17:41:10 <rloo> jlvillal: there's probably something i am missing :)
17:41:12 <jlvillal> rloo: So when they assign it, it magically becomes an object variable
17:41:28 <jlvillal> rloo: This is why I say reduce cognitive load!
17:41:38 <rloo> jlvillal: so they override it?
17:41:41 <dtantsur> rloo: self._is_stale = something will overwrite an instance variable, not a class one
17:41:51 <dtantsur> which, I agree with jlvillal, is confusing
17:41:54 <jlvillal> rloo: Well it doesn't doesn't become an object variable. An object variable is created. The class variable is still there.
17:42:29 <rloo> jlvillal: so, unless there is a need to do ResourceBase._is_stale, i think it doesn't belong there.
17:42:31 <jlvillal> So if the object variable doesn't yet exist when you check self._foo, then it goes to FooClass._foo
17:43:01 <jlvillal> But if you assign self._foo, then from now on, self._foo, is the object variable. But you can still access FooClass._foo.
17:43:05 <jlvillal> Thus why I think it is confusing.
17:43:06 <rloo> jlvillal: i mean, why not also have a _json = None then.
17:43:21 <jlvillal> rloo: Exactly! and please don't ;)
17:43:26 <rloo> jlvillal: that's my point, is there a need to access FooClass._foo in this case
17:43:41 <rloo> jlvillal: if not, then there is no need for it (and it is wrong)
17:43:49 <rloo> jlvillal: in my opinion of course
17:43:52 <jlvillal> No, I think it just needs to be in the __init__(). We all understand that. No special thinking required.
17:44:01 <rloo> jlvillal: i'm afraid to comment cuz i don't want to review it :)
17:44:02 <jlvillal> No need to write test scripts to figure out what is going on.  etc...
17:44:15 <rloo> jlvillal: i'll comment after the meeting...
17:44:18 <dtantsur> yeah, I agree
17:44:35 <jlvillal> I'll put a link to our confusing discussion in the patch ;)
17:44:51 <dtantsur> :)
17:45:03 * dtantsur just saw an IPA patchp passing the CI, w00t
17:45:51 <dtantsur> anything else?
17:46:20 <jlvillal> woot woot! :)
17:47:13 <dtantsur> if nothing more to discuss, let me return you 13 minutes of life
17:47:17 <dtantsur> thanks all :)
17:47:18 <jlvillal> Yay
17:47:20 <jlvillal> thanks
17:47:29 <Nisha_Agarwal> :)
17:47:34 <TheJulia> thanks!
17:47:36 <dtantsur> #endmeeting