17:00:49 <dtantsur> #startmeeting ironic
17:00:51 <openstack> Meeting started Mon Oct 30 17:00:49 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:54 <openstack> The meeting name has been set to 'ironic'
17:00:54 <TheJulia> o/
17:00:57 <vdrok> o/
17:01:02 <rpioso> o/
17:01:03 <crushil> o/
17:01:05 <rloo> o/
17:01:07 <dtantsur> oh that timezones :)
17:01:09 <rajinir> o/
17:01:10 <anupn> o/
17:01:22 <fellypefca> o/
17:01:24 <mrtenio> o/
17:01:26 <dtantsur> hi all, you'll have to bear (!) with me for some time - we've just switched back to winter time
17:01:29 <nicodemos> \o
17:01:37 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:02:20 <mjturek> o/
17:02:30 <jlvillal> o/
17:02:50 <dtantsur> #topic Announcements / Reminder
17:02:53 <dtantsur> first,
17:03:11 <dtantsur> #info A few releases were done this week, with more releases still pending
17:03:24 <dtantsur> #info The final Newton release 6.3.0 was done
17:03:33 <dtantsur> aaaaand if I remember it right:
17:03:36 <jlvillal> Long live Newton!
17:03:42 <dtantsur> #info Summit next week
17:03:50 <rloo> jlvillal: err, or not ;)
17:04:01 <pas-ha> o/
17:04:14 * jlvillal wonders who is going to the summit from Ironic
17:04:28 <rloo> so no meeting next week?
17:04:50 <dtantsur> I'm fine with skipping it, though I'll be here
17:04:55 <rpioso> jlvillal:  I am.
17:05:05 <rama_y> o/
17:05:19 <dtantsur> so, TheJulia is going, right? rpioso as well. who else?
17:05:20 <rloo> maybe 'who wants to skip next week's meeting', cuz i'm avail too
17:05:25 <TheJulia> jlvillal: I am
17:05:37 <dtantsur> TheJulia: there will be an onboarding session, right?
17:05:37 * vdrok should be here as well
17:05:40 * dtantsur remembers asking for it
17:05:44 <jlvillal> rpioso: TheJulia: Cool. I'm not and sad since I've never been to Australia :(
17:05:58 <TheJulia> :(
17:06:23 <dtantsur> so it looks like we can have a meeting, if TheJulia and rpioso don't mind
17:06:29 <rpioso> 😞
17:06:36 <rpioso> dtantsur: Works for me.
17:06:41 * jlvillal doesn't understand that icon
17:06:44 <TheJulia> I don't at all, I'll miss you guys
17:06:51 <rpioso> jlvillal:  :-(
17:07:00 <jlvillal> Ah, sad face. So tiny on my monitor :)
17:07:18 <dtantsur> okay
17:07:31 <dtantsur> TheJulia: we'll miss you too :( I hope to see everyone in DUB
17:07:40 * dtantsur has not started figuring out a visa yet
17:08:07 <dtantsur> anything else?
17:08:26 <dtantsur> actually, we never mentioned this here:
17:08:43 <dtantsur> #info The next PTG is in Dublin, on the week of Feb 26th: http://openstack.org/ptg
17:09:16 <vdrok> is there any info when they'll start selling tickets?
17:09:31 <dtantsur> I don't know yet
17:09:31 * vdrok needs those to apply for visa
17:09:51 * dtantsur needs an approval first....
17:10:10 <dtantsur> okay, moving on?
17:10:24 <rloo> +movin'
17:10:43 <dtantsur> #topic Review action items from previous meeting
17:10:50 <dtantsur> #link http://eavesdrop.openstack.org/meetings/ironic/2017/ironic.2017-10-23-17.00.html
17:10:59 <dtantsur> #info rloo submitted patch to "Add the supports-rolling-upgrade tag to Ironic": https://review.openstack.org/#/c/514448/
17:11:03 <dtantsur> thanks rloo!
17:11:13 <rloo> you're welcome :)
17:11:13 <dtantsur> we also need to apply for accessible-upgrades tag
17:11:25 <rloo> dtantsur: yup, was going to wait for that to merge first.
17:11:28 <dtantsur> ack
17:11:38 <dtantsur> I don't see any other action items. anything from bug triaging?
17:12:49 * dtantsur assumes nothing
17:12:53 <TheJulia> dtantsur: Very quiet on that front
17:13:00 <dtantsur> okie
17:13:09 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:13:09 <TheJulia> I did send you a list of bugs that we really should just take care of, since I don't know how you wanted to handle that or raise visibility
17:13:18 <TheJulia> fwiw, I posted a fix for one already
17:13:32 <dtantsur> TheJulia: thanks! I'll take a look when internet gods are a bit more friendly to me
17:13:48 <TheJulia> the internet gods seem grumpy for me as well today :(
17:13:56 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard our statuses are starting on line 148
17:14:05 <dtantsur> and I see the bug number decreasing indeed
17:16:06 <rloo> would be nice to get all the external project authentication rework (L187) done for next ironic release, but I guess that won't happen
17:16:15 <dtantsur> that would be hard
17:16:26 <TheJulia> I did go through and also found a few invalid/complete bugs that were really old
17:16:39 <TheJulia> so that would explain the decreasing number.
17:16:40 <dtantsur> TheJulia: I expected something like that
17:16:43 <rloo> thx TheJulia!
17:17:17 <pas-ha> when is next release planned?
17:17:28 <rloo> wrt traits, i think we should keep tags, are folks ok with that?
17:17:51 <dtantsur> rloo: what is left for https://bugs.launchpad.net/ironic/+bug/1708243 ?
17:17:52 <openstack> Launchpad bug 1708243 in Ironic "Queens: what's left for rolling upgrades" [High,In progress] - Assigned to Ruby Loo (rloo)
17:17:55 * dtantsur is fine with and without tags
17:17:58 <pas-ha> rloo: yes, their purpose is different
17:18:22 <rloo> dtantsur: done i think; i was going to review that bug to see what i noted after the reno patch gets approved
17:18:26 <dtantsur> pas-ha: I'd like the next release ASAP. I'm blocked by some release tooling weirdness. also tomorrow is a holiday, so probably Wed or Thu?
17:19:05 <dtantsur> #link https://review.openstack.org/#/c/516374/ reno update for rolling upgrades
17:19:25 <pas-ha> dtantsur: yeah, then those patches won't make it for sure
17:19:40 <pas-ha> there are 5 of them, and some quite large
17:19:55 <pas-ha> the client auth rework I mean
17:20:06 <pas-ha> sorry for the delay :(
17:20:13 <dtantsur> agreed
17:20:29 <rloo> pas-ha: next release then
17:20:56 <dtantsur> yeah
17:21:04 <rloo> dtantsur also wants to do a client release after we land https://review.openstack.org/#/c/515064/
17:21:25 <dtantsur> yep. I'll update it after the meeting
17:22:12 * rloo done with statuses
17:22:19 * dtantsur done too
17:22:50 <vdrok> oh, by the way, I proposed all the patches needed for none auth in OSC CLI, we'll need a new release of keystoneauth and osc-lib unfortunately
17:22:59 <dtantsur> thanks a lot vdrok!
17:23:02 <vdrok> which will take time
17:23:04 <dtantsur> releases are cheap ;)
17:23:16 <rloo> thx vdrok. those will help other projects too!
17:23:22 <vdrok> hopefully :)
17:23:26 <dtantsur> we still can make it in this release then
17:23:32 <dtantsur> anything else?
17:23:55 <dtantsur> #topic Deciding on priorities for the coming week
17:24:09 <dtantsur> Zuul v3 stays, obviously..
17:24:31 <dtantsur> I'm removing the RESIZE spec, unfortunately, as it missed the spec freeze
17:24:49 <dtantsur> mriedem told me he does think a spec is required here
17:25:13 <dtantsur> should wait the ironicclient patch moving "ironic" CLI to latest?
17:25:20 <dtantsur> s/wait/we add/ (???)
17:25:27 <rloo> yup, add
17:26:06 <dtantsur> 3 items, we can try taking at least one more, I think
17:26:09 <rloo> dtantsur: i did not look to see if there is anything we want landed, for the ironic release. i'll take a quick look after this meeting.
17:26:09 <vdrok> oh, /me is going to submit the blueprint for reserved field when reporting inventory. dtantsur it's not too late for that, is it?
17:26:32 <dtantsur> vdrok: do you think we even need a blueprint? anyway, only specs are frozen
17:26:59 <vdrok> yeah, I think nova folks will request it :) anyway, now I remember about it
17:27:17 <dtantsur> vdrok: cool :) I'd ask them first, maybe they'll be fine with a bug
17:27:22 <rloo> if it is a new field, i suspect they will want a BP. but no spec (we hope)
17:27:24 <vdrok> okie
17:27:35 <jlvillal> dtantsur: TheJulia rloo: Attention stable reviewers. With the recent change to Zuul regarding stable branches. Zuul will now only run the unit test/pep8/docs type jobs and then vote -1/+1 accordingly.
17:27:48 <jlvillal> No devstack jobs are run, unless we have done the Zuul v3 port to stable.
17:27:56 <dtantsur> O.U.C.H
17:28:00 <jlvillal> So be careful approving...
17:28:17 <rloo> jlvillal: i think that means we should NOT approve anything until they are fixed.
17:28:19 <jlvillal> So ironic stable/pike is good to go. stable/ocata is not until we land vdrok's change.
17:28:50 <dtantsur> #info Do not approve anything on stable branches until Zuul jobs are ported there
17:28:51 <jlvillal> I am unsure of the status of stable for IPA and ironic-lib and all the other projects.
17:28:53 <dtantsur> jlvillal: #link?
17:29:00 <rloo> jlvillal: could you/someone do me a favour, and update our whiteboard (or the zuul etherpad) with status?
17:29:05 <dtantsur> IPA, ironic-lib, sushy, clients...
17:29:14 <jlvillal> dtantsur: My chat with jeblair in infra
17:29:19 <vdrok> dtantsur: ironic ocata is https://review.openstack.org/513697
17:29:34 <jlvillal> It is OKAY to approve stable/pike for ironic.
17:29:37 <vdrok> ironic-lib pike is https://review.openstack.org/515716
17:29:48 <jlvillal> And please look at vdrok's patch to fix stable/ocata
17:29:54 <dtantsur> #link https://review.openstack.org/515064 merge this before approving anything to ironic stable/ocata
17:30:18 <jlvillal> rloo: I will update whiteboard
17:30:19 <dtantsur> #link https://review.openstack.org/#/c/515716/ fix for ironic-lib stable/pike
17:30:31 <rloo> dtantsur: that link for stable/ocata is wrong
17:30:49 <dtantsur> damn.. thanks rloo
17:30:51 <dtantsur> #undo
17:30:52 <openstack> Removing item from minutes: #link https://review.openstack.org/#/c/515716/
17:30:55 <dtantsur> #undo
17:30:56 <openstack> Removing item from minutes: #link https://review.openstack.org/515064
17:30:57 <vdrok> rloo: dtantsur ouch, I've just approved that client patch :D
17:31:08 <rloo> vdrok: ha ha, undo it please!
17:31:22 * dtantsur notes that we're supposed to read patches we're approving :D
17:31:22 <rloo> and I approved https://review.openstack.org/#/c/513697/
17:31:25 <dtantsur> #link https://review.openstack.org/#/c/515716/ fix for ironic-lib stable/pike
17:31:29 <TheJulia> fun :(
17:31:32 <jlvillal> dtantsur: I'm guessing #link doesn't take any text after the link. Not sure though. Just looking at the #undo message.
17:31:44 <vdrok> now worries, /me was joking
17:31:46 <dtantsur> jlvillal: IIRC it does
17:31:52 <jlvillal> dtantsur: Ah good
17:31:52 <dtantsur> maybe just #undo works this way..
17:31:59 <dtantsur> back to priorities
17:32:05 <jlvillal> dtantsur: Blame me for that. I added the message to #undo :)
17:32:15 <NobodyCam> :p
17:32:20 <dtantsur> hehe
17:32:32 <dtantsur> are we ok with the list of 3 priorities? given zuul, it may be ok
17:33:03 <rloo> i'd like to suggest, for the priorities, #1, make it clear which patches should be reviewed
17:33:19 <dtantsur> let's put them to the separate etherpad?
17:33:25 <rloo> and if someone could update that one, as stuff gets merged, to reflect the next patches to review...
17:33:56 <rloo> dtantsur: there is a separate etherpad but it doesn't seem to be populated very much
17:34:06 <rloo> https://etherpad.openstack.org/p/ironic-zuulv3-intree-tracking
17:34:08 <dtantsur> well, let's populate it :)
17:34:13 <rloo> or maybe it is cuz not much is being done, not sure
17:34:53 <dtantsur> #action everyone please keep https://etherpad.openstack.org/p/ironic-zuulv3-intree-tracking up-to-date
17:34:55 <vdrok> did not know about it, will do
17:35:17 <rloo> could we have a volunteer to coordinate/chase people/get people to submit patches, etc, for the zuul v3 work?
17:35:37 <rloo> project manager is probably what i'm thinking of ;)
17:35:48 <dtantsur> every project needs a manager
17:35:55 <dtantsur> thanks for volunteering, rloo :D
17:36:10 * rloo worries that dtantsur is having problems reading
17:36:28 <rloo> i could do it if no one else wants to. c'mon, it's lots of fun
17:36:46 * jlvillal thinks rloo is Tom Sawyering us...
17:37:06 <rloo> bzzzz, too late. talk to me later if you're interested. otherwise, it is all mine...
17:37:09 <dtantsur> I'd do it, but I'm out tomorrow. And still on bad internet afterwards
17:37:14 <dtantsur> rloo: thanks :)
17:37:21 <rloo> :)
17:37:32 <dtantsur> so, the priorities list is finished in 3...
17:37:34 <dtantsur> 2...
17:37:37 <dtantsur> 1...
17:37:46 <dtantsur> #topic Appointing a bug triaging lead for the coming week
17:38:00 <dtantsur> let's volunteer another volunteer! \o/
17:38:18 <vdrok> I was not doing it for a while, can be the volunteer this week
17:38:25 <dtantsur> vdrok: thanks!
17:38:33 <dtantsur> #action vdrok to lead the bug triage this week
17:39:02 <dtantsur> #topic Open discussion
17:40:07 <rloo> cri...
17:40:09 <rloo> kets...
17:40:14 <dtantsur> rloo: I was waiting for that :)
17:40:16 <rloo> err crickets...
17:40:24 <dtantsur> calling it a meeting now?
17:40:32 <rloo> +1
17:40:32 <dtantsur> in 3...
17:40:34 <dtantsur> 2...
17:40:37 <dtantsur> 1...
17:40:40 <dtantsur> thanks all!
17:40:43 <jlvillal> thanks
17:40:44 <dtantsur> #endmeeting