17:00:12 <dtantsur> #startmeeting ironic
17:00:13 <openstack> Meeting started Mon Nov  6 17:00:12 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:17 <openstack> The meeting name has been set to 'ironic'
17:00:21 <pas-ha> o/
17:00:23 <jlvillal> o/
17:00:59 <dtantsur> hi all! I wonder if we're going to have more than 2 people
17:01:11 <jlvillal> dtantsur: I don't know. We have three now
17:01:14 <jlvillal> Maybe rloo will join :)
17:01:35 <jlvillal> We did have the end of daylight savings time in the US. So instead of a 10am meeting for me, it is now a 9am meeting.
17:01:58 <dtantsur> yeah, happened to us a week ago
17:02:03 <rloo> o/
17:02:05 <dtantsur> let us give folks a bit moar time
17:02:30 * pas-ha pours coffee
17:02:49 <milan_> o/
17:03:19 <vdrok> o/
17:04:06 <dtantsur> #topic Announcements / Reminder
17:04:09 * jlvillal votes to start :)
17:04:13 <Nisha_Agarwal> o/
17:04:20 <dtantsur> the forum is happening :) I hope people are enjoying Sydney
17:04:30 <dtantsur> has anyone seen any recording? I could not find them this morning
17:04:53 <dtantsur> #info Ironic Pike 9.1.2 was FINALLY released
17:05:08 <dtantsur> #info ironic and ironicclient Queens releases to follow this week, hopefully
17:05:44 <dtantsur> anything else?
17:06:38 <dtantsur> #topic Review action items from previous meeting
17:06:46 <dtantsur> #link http://eavesdrop.openstack.org/meetings/ironic/2017/ironic.2017-10-30-17.00.html
17:06:57 <dtantsur> vdrok: how was the bug triage?
17:07:11 <vdrok> dtantsur: was good hopefully :)
17:07:24 <rloo> wrt zuulv3 - the etherpad is up to date. need folks to review.
17:07:27 <dtantsur> I see the bug number decreasing, this is good
17:07:51 <dtantsur> I've noticed that legacy jobs need A LOT OF clean up
17:08:08 <rloo> dtantsur: yup :-(
17:08:31 <dtantsur> anyway, let's finish with copy-paste first
17:08:33 <rloo> dtantsur: but it'll be beautiful after the clean up. Something to look forward to :)
17:08:38 <dtantsur> right :)
17:08:38 <vdrok> yeah. in theory, most of the things there should be rewritten, to use the new "builders"
17:08:52 <jlvillal> I was starting to work on a check script to parse the zuul v3 files and try to find any errors.
17:08:56 <jlvillal> Well obvious errors.
17:09:27 <dtantsur> #topic Review subteam status reports
17:09:41 <rloo> btw, ironic has been tagged: supports-rolling-upgrade
17:09:41 <dtantsur> this is what we're doing already, right? :)
17:09:48 <dtantsur> rloo++ yes
17:10:02 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard line 141
17:10:36 <rloo> vdrok: thx for reducing the bug count!
17:10:37 <dtantsur> we're nearly done with the first essential priority, please keep reviewing ;)
17:10:43 * vdrok checks stable branch status
17:10:50 <dtantsur> well, I guess it involves Nova part too
17:12:36 <vdrok> rloo: thanks for keeping track of the zuulv3 :)
17:13:02 <rloo> vdrok: yw, the faster we get that done, the less time I need to spend time keeping track of it ;)
17:13:12 <dtantsur> very true
17:13:17 <rloo> vdrok: then there's the 'clean up' part!
17:13:47 <vdrok> should be easy as well. rewrite to new style jobs can take more effort
17:14:41 <rloo> i'm done with subteam stuff. guessing it'll be quiet this week too?
17:15:04 <dtantsur> yeah, just updated the links to our call summary re traits
17:15:08 <dtantsur> everyone done?
17:15:30 <jlvillal> Does ironic-inspector use the tempest stuff in ironic?
17:15:47 <jlvillal> I'm around line 292, trying to update the list of projects want to have done.
17:15:48 <dtantsur> jlvillal: yes
17:16:03 <dtantsur> I mean, it's using ironic tempest plugin as a basis for its own
17:16:09 <dtantsur> and it uses bits of the jobs, I guess
17:16:28 <jlvillal> dtantsur: Okay. To be on the safe side, we should get inspector done before ripping it out of ironic.
17:16:41 <rloo> and we had decided that the new tempest repo would be for ironic and inspector and ..?
17:16:56 <dtantsur> jlvillal: I believe so, yes
17:17:03 <jlvillal> Speaking of which, would like to get the script patch merged: https://review.openstack.org/#/c/489762/ :)
17:17:07 <dtantsur> rloo: one repo, yes, but that's the next step
17:17:27 * jlvillal looks hopefully at vdrok regarding https://review.openstack.org/#/c/489762/
17:18:00 <vdrok> jlvillal: will take a look :)
17:18:09 * dtantsur looks at jlvillal looking at vdrok
17:18:21 * vdrok looking
17:18:21 <dtantsur> moving on? :)
17:18:27 <jlvillal> heh
17:18:41 <dtantsur> #topic Deciding on priorities for the coming week
17:19:11 <rloo> dtantsur: for the ironic release, there's nothing we're waiting on?
17:19:24 <dtantsur> rloo: reno clean up is still needed
17:19:25 * milan_ <3 https://review.openstack.org/#/c/489762/6/tools/make-tempest-plugin-repo.sh@105
17:19:31 <dtantsur> feature-wise, I think, we're good
17:19:47 <rloo> dtantsur: oh yeah. and actually, are they doing releases this week, given the summit going on?
17:19:55 <vdrok> this one https://review.openstack.org/419439 is looking good, and is the only thing left to close the huge upgrade rfe
17:20:14 <dtantsur> rloo: I doubt it. but I want to request it and move on :)
17:20:26 <rloo> dtantsur: ok, let's get that done then.
17:21:11 <rloo> vdrok: ++. I'd +2 it myself :)
17:21:38 <jlvillal> milan_: :)
17:21:44 <vdrok> heh
17:22:03 <dtantsur> okay, the priorities
17:22:17 <dtantsur> I think the list is good as it is, as nothing was done (sigh) to completion
17:22:43 <dtantsur> opinions?
17:22:59 <rloo> and vdrok's suggestion above? :)
17:23:11 <dtantsur> aha
17:23:37 <milan_> seems dtantsur has to put a +2 :D
17:23:47 <dtantsur> I'm good with adding it, I hope the ironic CLI thing merges soon
17:23:59 <dtantsur> how's the list looking?
17:24:14 <rloo> dtantsur: on my list; if i hadn't had to do the zuul v3 tracking, would have been reviewed sooner. :D
17:24:27 <dtantsur> zuul happens when it happens
17:24:29 <dtantsur> :)
17:24:46 <rloo> list is good with me, thx.
17:25:15 <dtantsur> moving on in 3...
17:25:19 <dtantsur> 2...
17:25:23 <dtantsur> 1...
17:25:31 <dtantsur> #topic Appointing a bug triaging lead for the coming week
17:25:44 <dtantsur> any vict^Wvolunteer?
17:26:22 <dtantsur> forest of hands :)
17:26:25 <dtantsur> I can do it this week
17:26:45 <dtantsur> I'm not sure a lot of triaging is left, maybe I'll try fixing/reviewing something bug-related
17:26:57 <dtantsur> #action dtantsur to lead bug triaging/fixing/closing this week
17:27:07 <dtantsur> #topic Open discussion
17:27:19 <vdrok> yeah, I've found most of the old bugs set to incomplete, so they'll expire soon if noone replies there
17:27:27 <dtantsur> nice
17:27:44 <milan_> let's merge dnsmasq filter on inspector? ;)
17:27:57 <vdrok> oh, that looks great!
17:28:16 <vdrok> where do I +2? :D
17:28:25 <rloo> vdrok: shoudl we ask about those functional test patches?
17:28:38 <milan_> vdrok, lol anywhere on the pull request would be great! :D
17:28:42 <rloo> vdrok: or did we decide? I can't remember
17:28:49 <vdrok> rloo: which ones?
17:28:51 <vdrok> ah
17:28:56 <rloo> vdrok: i think the client ones.
17:29:01 <rloo> vdrok: for ironic CLI
17:29:05 <vdrok> sorry, I forgot. lemme find some links
17:29:09 <jlvillal> milan_: I think you have been using github ;)  Pull request :)
17:29:27 <milan_> jlvillal, guilty as charged :D
17:29:28 <rloo> so, there are a bunch of patches to do functional tests for ironic CLI. given that we've deprecated it, how much effort do we want to put into those patches/tests?
17:29:51 <rloo> the folks that submitted those patches are no longer around.
17:30:08 <dtantsur> best effort?
17:30:17 <rloo> and i wasn't that happy with one of the patches. don't know if we should just land since it is a test, or spend time cleaning up.
17:30:22 <dtantsur> like, I don't see point in reviewing them, but I also don't see any harm in somebody landing
17:30:35 <dtantsur> rloo: -1 and move on?
17:30:45 <vdrok> yeah, one of examples https://bugs.launchpad.net/python-ironicclient/+bug/1555680
17:30:46 <openstack> Launchpad bug 1555680 in python-ironicclient "Add CLI tests to check JSON response body" [Low,Triaged]
17:31:02 <jlvillal> I vote for minimal effort to 'ironic' client. Due to deprecation.
17:31:08 <vdrok> some of them were not started, or patches are abandoned. I was thinking if we need to close those
17:31:45 <rloo> ok, let's just close them, make sure there are equivs though for OSC CLI?
17:31:47 <dtantsur> to be honest, these are not the valid bugs
17:32:05 <vdrok> that's my feeling as well
17:32:13 <dtantsur> but this is subjective. I don't like a new bug for every test people feel we could add..
17:32:29 <dtantsur> I'm happy with closing them, but leaving valid patches up
17:32:42 <rloo> bugs are a good way to track 'things-to-do', but yeah, not each separate test.
17:32:44 <vdrok> okie. I'll go through them tomorrow
17:32:58 <jlvillal> dtantsur: I am growing to like more and more the idea that bugs should be for user visible changes/issues. Though use that as a guideline, there would be exceptions of course.
17:33:23 <jlvillal> But a bug for each test is way overboard.
17:33:28 <dtantsur> thanks vdrok
17:33:49 <rloo> if there were a prize, vdrok would win it, for reducing the # bugs :)
17:34:02 <dtantsur> a beer in DUB? :)
17:34:08 <vdrok> jlvillal: well, some projects don't merge any patch without a bug reference
17:34:12 <rloo> ++
17:34:16 <vdrok> :)
17:34:20 <rloo> that was for the beer :)
17:34:24 <vdrok> hopefully I'll make it !
17:34:30 <dtantsur> vdrok: I'd like a reference for user-visible and otherwise important changes
17:34:38 <dtantsur> but not for things like a new test or a typo in a docstring..
17:34:48 <vdrok> yeah, I agree
17:35:02 <vdrok> that's why I was thinking about closing them:)
17:35:31 <pas-ha> vdrok: dtantsur ++ on bugs
17:36:19 <vdrok> also would be good to go through all the old rfes we have, but it's going to take more time
17:36:34 <dtantsur> yep
17:36:38 <dtantsur> and old approves specs
17:36:43 <dtantsur> * approved
17:37:13 <rloo> good to review rfes too :D
17:37:45 <rloo> and all patches. TOOMUCHTODO
17:38:50 <dtantsur> hehehe
17:39:07 <dtantsur> okay, anything else to discuss?
17:39:42 <milan_> rloo, crickets ;)
17:39:54 <rloo> grasshoppers...
17:40:03 <milan_> lol
17:40:24 <dtantsur> thanks all
17:40:31 <jlvillal> Bye all!
17:40:32 <dtantsur> 20 minutes are yours :)
17:40:34 <pas-ha> \o
17:40:34 <dtantsur> #endmeeting