17:10:39 <dtantsur> #startmeeting ironic
17:10:40 <openstack> Meeting started Mon Nov 13 17:10:39 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:10:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:10:43 <openstack> The meeting name has been set to 'ironic'
17:10:47 <NobodyCam> +++ woo hoo
17:10:47 <TheJulia> \o/
17:11:01 <dtantsur> see, the logging started http://eavesdrop.openstack.org/meetings/ironic/2017/ironic.2017-11-13-17.10.log.txt
17:11:04 <dtantsur> hi all!
17:11:09 <TheJulia> Greetings!
17:11:12 <jlvillal> Oh, interesting. I didn't know it worked in ironic :)
17:11:20 <rloo> o/
17:11:23 <dtantsur> tripleo team has its meeting in their channel for some time
17:11:30 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:11:41 <dtantsur> #topic Announcements / Reminder
17:11:47 <fellypefca> o/
17:11:52 <dtantsur> #info Virtual midcycle planning: http://lists.openstack.org/pipermail/openstack-dev/2017-November/124466.html
17:12:06 <TheJulia> IIRC there was a resolution to allow teams to have meetings in their channel.
17:12:10 <dtantsur> yep
17:12:28 <dtantsur> so, please vote on a date for the virtual midcycle and propose topics
17:12:38 <dtantsur> TheJulia: I proposed a Forum summary topic for you, I hope you don't mind
17:12:56 <rloo> before the midcycle, i think we should have some sort of thing/meet up to go through rfe specs
17:13:02 <dtantsur> #info python-ironicclient 2.0.0 released with the latest API version by defaultr
17:13:07 <dtantsur> rloo: why not do it right there?
17:13:11 <TheJulia> dtantsur: I do not, I may want to break that up some more. Once done with my expense report in a little bit, I'm going to go back to my summary of the forum
17:13:28 <dtantsur> #info ironic release delayed while we're reverting certain changes
17:13:34 <TheJulia> :(
17:13:53 <rloo> dtantsur: cuz i dunno, i feel like doing things in smaller bits/hours is better than 2days of stuff
17:14:14 <rloo> dtantsur: just a suggestion
17:14:39 <dtantsur> getting people to participare is an issue though
17:14:58 <TheJulia> We should get a list together to discuss and participants should be prepared to run through them quickly
17:15:15 <TheJulia> If we need longer, then we know that we need more clarity and that a spec is definitely required
17:15:19 <rloo> dtantsur: right, i think we need to address/do something about the backlog of not-reviewed/moving specs. it shouldn't be done only at a midcycle meet up
17:15:35 <dtantsur> right
17:15:39 <dtantsur> suggestions are welcome
17:15:52 <rloo> dtantsur: the midcycle meetup can be used to discuss/go into detail if there are disagreements. we don't know which have disagreements :-(
17:16:11 <dtantsur> let's move it to open discussion, ok?
17:16:13 <rloo> i just made my suggestion :D
17:16:22 <TheJulia> dtantsur: agreed
17:16:30 <dtantsur> TheJulia: anything to announce from the Forum?
17:16:35 <jlvillal> dtantsur, Should not have put periods at the end of those URLs in the email...
17:16:47 <jlvillal> They all are not-found :(
17:17:00 <dtantsur> jlvillal: or people should fix their email clients ;)
17:17:00 <TheJulia> dtantsur: Biggest thing, per the foundation's keynote, the latest user survey indicated that ironic in production went from 9% to 20%.
17:17:13 <jlvillal> dtantsur, I went to the web page you pointed me too :P
17:17:21 <dtantsur> #info the latest user survey indicated that ironic in production went from 9% to 20%
17:17:33 <NobodyCam> ++ oh ya :)
17:17:34 <dtantsur> w00t
17:17:37 <jlvillal> http://lists.openstack.org/pipermail/openstack-dev/2017-November/124466.html
17:17:51 <dtantsur> ah, mailman bug. nice
17:17:54 <NobodyCam> #link http://lists.openstack.org/pipermail/openstack-dev/2017-November/124466.html
17:18:08 <jlvillal> Doodle link: https://doodle.com/poll/wcqeu66fa6axusvw
17:18:25 <dtantsur> thanks jlvillal, NobodyCam
17:18:32 <dtantsur> anything else before we move on?
17:18:34 <jlvillal> Mid-cycle link: https://etherpad.openstack.org/p/ironic-queens-midcycle
17:18:47 <dtantsur> #link https://etherpad.openstack.org/p/ironic-queens-midcycle midcycle planning
17:18:50 <rloo> jlvillal: can you add #link?
17:18:57 <jlvillal> rloo, done!
17:18:59 <NobodyCam> jlvillal: #link so they show up on the summary
17:19:05 <dtantsur> hehe
17:19:08 <NobodyCam> :p
17:19:09 <jlvillal> done by dtantsur ;)
17:19:26 <dtantsur> #topic Review action items from previous meeting
17:19:32 * TheJulia goes off into the corner and begins brewing coffee
17:19:42 <dtantsur> #link eavesdrop.openstack.org/meetings/ironic/2017/ironic.2017-11-06-17.00.html
17:19:53 <dtantsur> to be honest, I did not do a lot wrt bug triaging
17:19:57 <dtantsur> sorry
17:20:07 <dtantsur> but I see the bug number still decreasing, so somebody has done something :)
17:20:20 <TheJulia> dtantsur: the expiration is kicking in for incomplete bugs
17:20:26 <dtantsur> right
17:20:46 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:20:50 <dtantsur> your favourite part :)
17:20:52 <TheJulia> We need to go through and clean-up our backlog, I'm willing to spend a little time this week trying to clean up things older than a year
17:21:08 <dtantsur> cool, we'll get back to it soon
17:21:12 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard line 148
17:22:50 <dtantsur> TheJulia: should we discuss version negotiation in nova (again) at the midcycle?
17:23:03 <rloo> wrt migration of legacy* jobs. TheJulia, someone needs to look at bifrost stable/ocata. jobs are failing there
17:23:32 <TheJulia> yeah, I think we may have gotten slightly off-topic and misconstrued the scope, that and where did all the time go
17:24:07 <rloo> TheJulia: info is in the etherpad: https://etherpad.openstack.org/p/ironic-zuulv3-intree-tracking
17:24:23 <TheJulia> rloo: acknowledged
17:24:47 <dtantsur> johnthetubaguy: do we need to discuss traits (again, omg) on the midcycle?
17:25:12 <rloo> dtantsur: what does the TODO: easier access to versions in ironicclient mean? L190?
17:25:24 <rloo> dtantsur: is that described in the rfe or somewhere?
17:25:33 <TheJulia> rloo: so we can add logic in nova client... or any client that is version dependent
17:25:41 <dtantsur> rloo: it's my brain dump. tl;dr let callers learn the current version and modify it on fly
17:25:44 <rloo> TheJulia: so that needs a spec?
17:25:52 <dtantsur> maybe also make sure that supported version range is accessible from our exceptions
17:26:15 * dtantsur feels like we should discuss it indeed
17:26:18 <TheJulia> I think a spec is likely overkill, maybe if we change negotiation a spec is needed
17:26:20 <TheJulia> yes ++
17:26:50 <rloo> i don't care what you call it, i'd like it documented before i'm forced to review the code :D
17:27:21 <dtantsur> fair enough; I'd use the midcycle to come up with a detailed RFE
17:27:33 <dtantsur> and show it to nova, so that they don't call us crazy when we get them a patch :)
17:27:51 <TheJulia> well, even then, we don't NEED to get them a patch unless we go to change the minimum microversion
17:28:04 <TheJulia> at that point, it is appropriate for us to change the logic around.
17:28:13 <rloo> for L248, is it tracking stuff other than migrating legacy* jobs intree?
17:29:32 <dtantsur> I'd like people to start converting the jobs on master to proper ansible
17:29:32 <rloo> jlvillal: are we good to continue with splitting away the tempest plugin? L295
17:29:55 <rloo> dtantsur: ok, i'll put that down then.
17:29:55 <dtantsur> not as an urgent priority any more, but something we gradually do
17:29:55 <jlvillal> rloo, Maybe. If everything is done for the stable branches. Then I think so.
17:30:05 <TheJulia> dtantsur: perhaps feel free, but I don't think it is something we should add as a todo right now unless people are interested and knowledgeable in that regard
17:30:08 <rloo> jlvillal: you're going on vaca soon?
17:30:24 <jlvillal> Yes, starting this Saturday.
17:30:35 <jlvillal> Gone for almost two weeks
17:30:40 <TheJulia> jlvillal: have fun!
17:30:44 <dtantsur> huh, should we do the tempest business this week then?
17:30:52 <jlvillal> Thanks! Portugal here we come :)
17:30:52 <TheJulia> possibly a good idea
17:31:03 <rloo> nope, let's hold off tempest business til jlvillal is back.
17:31:20 <jlvillal> Either way works for me.
17:31:33 <jlvillal> But the speed of our gate can sometimes be a problem.
17:31:40 <jlvillal> As witnessed by the revert series...
17:31:53 <rloo> jlvillal: but if we start this and something is wrong while you're away?
17:32:00 <dtantsur> I'm fine with delaying till December FWIW
17:32:10 <jlvillal> Yeah. Sounds good to me to wait.
17:32:20 <dtantsur> I guess we should allow people some time to merge someting, until we screw up the gate again :D
17:32:24 <jlvillal> I would hate for the gate to have an issue mid-way through and then I leave.
17:32:26 <TheJulia> I guess I'm okay as well with deplaying until december
17:32:53 <dtantsur> we're past 10 minutes. ready to move on?
17:32:53 <jlvillal> Neutron is what messed up our gate this time! Not us ;)
17:33:17 <rloo> +1 to movin' on
17:34:01 <jlvillal> +1
17:34:07 <dtantsur> #topic Deciding on priorities for the coming week
17:34:48 <dtantsur> we did finish a few things
17:35:39 <dtantsur> I'm a bit worried that rescue gets no substantial progress
17:35:48 <dtantsur> what about putting something from there on the list?
17:35:54 <dtantsur> or any other ideas?
17:35:56 <TheJulia> dtantsur: I like that idea
17:36:19 <rloo> i stopped reviewing rescue. was going to resume *after* the ironic release, which hasn't happened yet :-(
17:36:24 <dtantsur> wow, that's a lot of patches
17:36:28 <TheJulia> I think we ought to add the etherpad and doodle for midcycle topics to the priority list so people explicitly look at it.
17:36:31 <dtantsur> rloo: let's assume we can release really soon
17:36:39 <rloo> traits spec is ready, not sure it needs to be a priority: https://review.openstack.org/#/c/504531/
17:36:40 <patchbot> patch 504531 - ironic-specs - Traits on Ironic Nodes
17:36:44 <TheJulia> dtantsur: yeah, it was a few large patches, then it was asked to be split if memory serves. :(
17:36:46 <rloo> dtantsur: i've been assuming that for awhile :)
17:37:31 <dtantsur> who rememebers, should we start with ironic or IPA side?
17:37:53 <TheJulia> dtantsur: ironci and ipa mid way
17:38:06 <TheJulia> ipa needs to be in place like half way through ironic
17:38:30 <TheJulia> That could also just be ipa then ironic
17:38:40 <rloo> i'd like this as a priority too: https://review.openstack.org/#/c/467728/
17:38:41 <patchbot> patch 467728 - ironic - Rework keystone auth for glance
17:38:47 <TheJulia> +1
17:39:30 <rloo> btw the first rescue patch is really easy, it is the db change
17:39:38 <dtantsur> yeah, this is why I put several of them
17:39:53 <dtantsur> added keystoneauth
17:40:00 <dtantsur> anything else? how's the list looking?
17:40:05 <TheJulia> dtantsur: the rescue set looks good
17:40:21 <TheJulia> looks good to me except the reverts are not listed
17:40:54 <dtantsur> TheJulia: they're a bit below, in the oneview section
17:41:05 <rloo> reverts are at L131.
17:41:11 <rloo> aren't they all approved, just need to merge?
17:41:16 <dtantsur> yep
17:41:33 <rloo> so that #2 is really for dtantsur
17:41:42 <dtantsur> right, yeah
17:41:49 <dtantsur> I think we even cleaned up reno already
17:41:50 <rloo> cuz i refuse to review any more reno changes. ha ha
17:41:54 <dtantsur> LOL
17:42:01 <TheJulia> dtantsur: ahh, okay
17:42:09 <dtantsur> any other comments?
17:42:12 <dtantsur> moving on?
17:42:26 <TheJulia> sure
17:42:30 <dtantsur> #topic Appointing a bug triaging lead for the coming week
17:42:35 <dtantsur> any victims?
17:43:03 <dtantsur> I can compensate for the last week if I do find time now
17:43:14 <rloo> thx for volunteering dtantsur!
17:43:19 <dtantsur> :)
17:43:36 <dtantsur> #action dtantsur to lead bug triaging this week, this time for real
17:43:59 <dtantsur> #topic Should openstack/networking-generic-switch be under the Ironic umbrella?
17:44:04 <dtantsur> jlvillal: your turn
17:44:15 <jlvillal> I was wondering what others think about this
17:44:21 <dtantsur> who are cores on n-g-s now? pas-ha, vsaienk0, vdrok?
17:44:25 <jlvillal> We are dependent on this package for our multi-tenant jobs
17:44:30 <pas-ha> yep
17:44:33 <pas-ha> we are
17:44:37 <jlvillal> Currently all cores for n-g-s are Mirantis only.
17:44:46 <pas-ha> also true
17:44:53 <rloo> hmm, not much diversity there. or diff time zones :-(
17:45:11 <jlvillal> So if we have any pressing situations we are kind of stuck.
17:45:29 <jlvillal> Not saying we really want to be reviewing that, but in emergencies it would be useful if we had the power.
17:45:33 <rloo> pas-ha: are there other folks that have been contributing, that you feel can be core?
17:46:11 <pas-ha> mgoddard for what I remember (and I even presume they run this thingy in prod o_O :) )
17:46:26 <jlvillal> Personally I think it would be good if the Ironic cores "could" approve things, if needed.
17:46:30 <jlvillal> Other opinions?
17:46:34 <rloo> jlvillal: we also rely on nova, neutron, other projects and we don't have the power.
17:46:36 <TheJulia> I feel like I have a good understanding since I've dug through the code and contributed a patch once, so happy to serve as a sanity check core
17:46:50 <dtantsur> a work around that does not include too many unrelated people is to include ironic-stable-maint
17:46:53 <jlvillal> rloo, But those projects have multiple time-zones and companies as cores.
17:46:58 <dtantsur> this is Julia, Ruby and me
17:47:11 <dtantsur> and only use it in emergencies
17:47:14 <rloo> jlvillal: maybe we should first ask. should it be under ironic governance?
17:47:23 <dtantsur> rloo: this is a different question btw
17:47:25 <jlvillal> dtantsur, That would work too.
17:47:30 <TheJulia> pas-ha: Several people mentioned using it at the forum.... and yes, I did bring up "not intended for production use"
17:47:33 <rloo> dtantsur: i know. i am separating the two issues
17:47:43 <dtantsur> I think it should, but I'm not the one to decide :)
17:47:54 <rloo> dtantsur: but the govenance thing would/might address the 2nd one :)
17:48:00 <pas-ha> TheJulia: apparently there's no real alt for cheap HW ATM..
17:48:22 <TheJulia> pas-ha: there is not, and is is easy to modify/change to meet specific needs, which it turns out... everyone has.
17:48:47 <TheJulia> anyway, that is another discussion for not right now.
17:48:54 <jlvillal> I don't think we have to come to a decision at this time. Would be good to get vsaienk0's opinion. Since he is the main person behind the project.
17:49:01 <TheJulia> +1
17:49:04 <dtantsur> ML?
17:49:06 <rloo> so I don't know enough about networking-generic-switch. is the only reason for asking about governance, the who-can-+2 issue?
17:49:15 <pas-ha> we'd be happy to be accepted under ironic gov, just that contrary to vbmc etc our scope is a big bigger... but still BM - only swutches :)
17:49:15 <jlvillal> rloo, It is for me.
17:49:18 <mgoddard> pas-ha: Yes, in leiu of knowing of something better (or something at all), we use NGS
17:49:20 <dtantsur> rloo: I suspect it's only used with ironic and for ironic
17:49:49 <TheJulia> dtantsur: That is my take as well
17:50:08 <rloo> in that case, it makes sense to be under ironic governance.
17:50:11 <dtantsur> so, while we don't have generic alternatives, n-g-s is a reasonable addition to our portfolio
17:50:31 <rloo> just like eg sushy-library, ...
17:51:06 <dtantsur> yeah, with a core subteam (similar to inspector's) to keep pas-ha's core rights
17:51:20 <pas-ha> fits me
17:51:46 <dtantsur> pas-ha: wanna bring it to the ML for discussion?
17:51:58 <dtantsur> if we don't see critical objections, we can bring it to the TC then
17:52:06 <pas-ha> yep, will do first thing tomorrow.
17:52:17 <dtantsur> thanks!
17:52:22 <jlvillal> Thanks!
17:52:36 <dtantsur> #action pas-ha to start public ML discussion on bringing networking-generic-switch under ironic umbrella
17:53:06 <dtantsur> does it address the topic, jlvillal?
17:53:07 <TheJulia> So, roughly 7 minute warning
17:53:14 <jlvillal> dtantsur, yep. Thanks
17:53:19 <dtantsur> #topic Open discussion
17:53:38 <dtantsur> 7 minutes for cricke^Wother important things :)
17:53:45 <NobodyCam> Just wanted to say I was really impressed with how much ironic we talked about at summit!
17:54:05 <dtantsur> great! oh, NobodyCam, we'll be waiting for your summary as well ;)
17:54:06 <rloo> i was going to pull a list of rfes to discuss. i have them, but not in any order. did you want to discuss?
17:54:14 <NobodyCam> In almost every keynote
17:54:19 <jlvillal> NobodyCam, Yeah, I hear PayPal even uses it too ;)
17:54:25 <dtantsur> rloo: now or separately?
17:54:25 <NobodyCam> hehehehe
17:54:30 <dtantsur> lol
17:54:39 <rloo> these are rfe's that we haven't approved or said needs-spec
17:54:41 <dtantsur> rloo: we can see how the doodle shapes, and pick a date from there
17:54:45 <dtantsur> right
17:54:54 <dtantsur> I think the initial plan was to take 2-3 each meeting
17:54:56 <rloo> wanted to resurrect that process cuz clearly we aren't dealing with them.
17:55:08 <dtantsur> ++
17:55:10 <rloo> right.
17:55:16 <rloo> ok, here's one for today to whet our appetite
17:55:20 <rloo> https://bugs.launchpad.net/ironic/+bug/1673298
17:55:20 <openstack> Launchpad bug 1673298 in Ironic "[RFE]Virtual Machines as BMs in Devstack support multiple network interfaces" [Undecided,Incomplete] - Assigned to Tao Li (eric-litao)
17:55:43 <dtantsur> word "Devstack" makes me suspect it's not an RFE
17:55:48 <rloo> unfortunately, i haven't vetted them yet, didn't have time
17:56:22 <dtantsur> yes, it's about our CI. I don't think it should be an RFE, but rather a testing improvement
17:56:27 <rloo> dtantsur: yes, i think when we make changes to devstack, they aren't rfe's. but we don't really have a process for that. folks 'just' make changes.
17:56:39 <dtantsur> I'd use bugs to track them
17:56:45 <dtantsur> we even have a "gate" tag
17:57:00 <pas-ha> +1
17:57:02 <rloo> dtantsur: so treat them as bugs. but we should try to keep on top of them, we don't want folks working on the code changes just to find out we don't like the idea.
17:57:27 <dtantsur> the same situation as with bugs: some are WONTFIX or NOTABUG
17:57:37 <dtantsur> this is why triaging is important
17:57:48 <rloo> right, so glad dtantsur is triaging this week!
17:57:57 <dtantsur> heh
17:58:15 <dtantsur> rloo: wanna update this bug?
17:58:22 <rloo> i'll update that bug then. that's all for today, stay tuned for more fun next week!
17:58:53 <TheJulia> :)
17:58:53 <dtantsur> thanks rloo
17:59:00 <dtantsur> wrapping up?
17:59:10 <rloo> +1
17:59:13 <NobodyCam> :)
17:59:20 <dtantsur> thanks all!
17:59:27 <dtantsur> #endmeeting