17:00:09 <dtantsur> #startmeeting ironic
17:00:10 <openstack> Meeting started Mon Dec  4 17:00:09 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:14 <openstack> The meeting name has been set to 'ironic'
17:00:20 <dtantsur> hi all!
17:00:22 <sambetts> o/
17:00:24 <rpioso> o/
17:00:26 <etingof> o/
17:00:27 <rloo> o/
17:00:29 <milan_> o/
17:00:32 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:00:41 <jlvillal> o/
17:00:55 <stendulker> o/
17:01:24 <mjturek> o/
17:01:40 <dtantsur> #topic Announcements / Reminder
17:02:12 <milan_> folks, I'm moving on 1.1.2018 for new challenges, was a pleasure!
17:02:33 <dtantsur> #info Milan moving on starting with Jan, 1st
17:02:41 <sambetts> milan_: goodluck!
17:02:48 <rloo> milan_: boo, hiss. Sorry to see you moving on, but thanks for all the inspectin' and good luck!
17:02:56 <vdrok> o/
17:02:57 <dtantsur> milan_: it was just a huge pleasure to work with you as well. I'll miss our coffee spec reviews ;)
17:03:14 <milan_> <3 same here folks!
17:03:22 <milan_> thanks!
17:03:26 <rpioso> milan_: Congratulations!
17:03:34 <stendulker> milan_: Wish you all the best !!
17:03:42 <milan_> rpioso, stendulker thanks guys! :)
17:03:45 * etingof hopes that at least coffee stays...
17:03:50 <milan_> :D
17:03:51 <dtantsur> heh
17:04:01 <dtantsur> #info Due to lack of interest at present, the ironic-ui meeting will be cancelled for the time being. Please contact TheJulia if interested in contributing.
17:04:15 <jlvillal> We'll miss you milan_ !
17:04:18 <dtantsur> I think the same fate may hit the BFV meeting, but I need to double-check with Julia
17:04:37 <Nisha_Agarwal> milan_, leaving ironic?
17:04:49 <milan_> Nisha_Agarwal, yup, I am
17:05:28 <dtantsur> #info TheJulia is unavailable on Monday/Tuesday of this week
17:05:52 <pas-ha> o/
17:06:03 <dtantsur> now, folks I haven't got a lot of votes on moving this meeting to our main channel
17:06:06 <vdrok> milan_: wish you all the best on a new place!
17:06:15 <dtantsur> I am for it, and rloo as well; +2, -0
17:06:20 <rloo> dtantsur: did we vote?
17:06:25 <rloo> dtantsur: oh, yeah, there's my vote :)
17:06:32 <rloo> dtantsur: let's vote!
17:06:39 <milan_> jlvillal, vdrok, thanks guys! :)
17:06:56 <sambetts> dtantsur: +2 from me
17:07:04 <sambetts> one less channel for me to track
17:07:05 <Nisha_Agarwal> milan_, wish you all the best in next role :)
17:07:14 <stendulker> +2 from me
17:07:14 <Nisha_Agarwal> +1 from me
17:07:22 <pas-ha> dtantsur: +1 for the same reason
17:07:26 <milan_> Nisha_Agarwal, thank you :)
17:07:27 <dtantsur> #startvote Should we move this meeting to #openstack-ironic? Yes, No
17:07:28 <openstack> Begin voting on: Should we move this meeting to #openstack-ironic? Valid vote options are Yes, No.
17:07:29 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:07:35 <dtantsur> #vote Yes
17:07:35 <sambetts> #vote Yes
17:07:40 <pas-ha> #vote Yes
17:07:41 <rloo> #vote Yes
17:07:41 <etingof> Yes
17:07:42 <stendulker> #vote Yes
17:07:46 <Nisha_Agarwal> #vote Yes
17:07:47 <etingof> #vote Yes
17:07:58 <jlvillal> #vote Yes
17:07:59 <vdrok> there is no "don't care option" :)
17:08:00 <rpioso> #vote Yes
17:08:16 <mjturek> #vote yes
17:08:18 <dtantsur> vdrok: you're right, there's no such option ;)
17:08:19 <milan_> vdrok, try #vote meh :P
17:08:49 <dtantsur> any more votes?
17:08:52 <vdrok> #vote meh
17:08:52 <openstack> vdrok: meh is not a valid option. Valid options are Yes, No.
17:08:59 <milan_> lol
17:09:02 <dtantsur> see? no such option! ;)
17:09:07 <milan_> :D
17:09:34 <dtantsur> okay, let's count
17:09:36 <dtantsur> #endvote
17:09:37 <openstack> Voted on "Should we move this meeting to #openstack-ironic?" Results are
17:09:38 <openstack> Yes (10): jlvillal, rloo, pas-ha, stendulker, Nisha_Agarwal, etingof, rpioso, dtantsur, mjturek, sambetts
17:09:46 <dtantsur> wow, decided :)
17:09:50 * jlvillal should have voted no just to be ornery
17:10:09 <dtantsur> #agreed The ironic weekly meeting will move to #openstack-ironic, effective Dec 11th
17:10:26 <dtantsur> okay, this was the fun part :)
17:10:34 <dtantsur> any announcements, reminders?
17:10:50 <dtantsur> #info python-ironic-inspector-client 3.0.0 released with a bunch of deprecated features removals
17:11:19 <milan_> \0/
17:11:22 <dtantsur> oh
17:11:34 <dtantsur> #info networking-generic-switch is a part of the Bare Metal program
17:11:41 <dtantsur> I think it was merged, wasn't it? :)
17:12:29 <dtantsur> #link https://governance.openstack.org/tc/reference/projects/ironic.html#networking-generic-switch
17:12:34 <dtantsur> okay, moving on?
17:12:50 <rloo> dtantsur: ironic also got tagged with that other upgrades thing
17:12:56 <rloo> dtantsur: i forgot what it was called
17:12:59 <dtantsur> yeah, me too
17:13:16 <dtantsur> not a huge achievement, given that it was applies to use automatically :)
17:13:19 <dtantsur> but still, yes
17:13:46 <rloo> dtantsur: supports-accessible-upgrade
17:13:49 <dtantsur> yep
17:13:51 <rloo> ironic & inspector
17:14:06 <dtantsur> #info ironic and ironic-inspector now have supports-accessible-upgrade tag
17:14:23 <dtantsur> #topic Review action items from previous meeting
17:14:33 <dtantsur> #link http://eavesdrop.openstack.org/meetings/ironic/2017/ironic.2017-11-20-17.00.html
17:14:48 <dtantsur> so, n-g-s was accepted
17:15:02 <dtantsur> vdrok: how's graphical console doing? I think there was an update
17:15:16 <vdrok> yeah pas-ha has updated the spec
17:15:40 <dtantsur> nice, thanks pas-ha
17:15:59 <dtantsur> milan_, etingof, how was the bug triaging?
17:16:15 <milan_> dtantsur, awesome! For one hour, we had 0 new bugs!
17:16:21 <dtantsur> \o/
17:16:21 <milan_> then a bug came in :-/
17:16:23 <dtantsur> good job :)
17:16:23 <milan_> :D
17:16:30 <dtantsur> anything else to add?
17:16:38 <milan_> can do it again
17:16:43 <dtantsur> sure ;)
17:16:46 <etingof> +1
17:16:49 <dtantsur> #topic Review subteam status reports
17:17:05 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard line 136
17:18:37 <rloo> dtantsur: wrt migrating classic to hardware types. what did we decide in midcycle?
17:18:58 <rloo> dtantsur: we should update/reply to that email thread. L195.
17:19:19 <dtantsur> I will, yes
17:19:28 <dtantsur> #action dtantsur to follow up on the midcycle
17:19:32 <rloo> sambetts: wrt routed network support, there's a WIP: 217. where are we at with that?
17:19:44 <rloo> sambetts: L217
17:20:26 <jlvillal> dtantsur: FYI:  https://review.openstack.org/525259 Move ironic-bare-metal meeting to the #openstack-ironic channel
17:20:27 <sambetts> just checking
17:20:52 <dtantsur> thanks jlvillal
17:20:59 <rloo> vdrok: didn't you start cleaning up the deploy interface? L233
17:21:50 <sambetts> rloo: after vacation I was planning to pick this back up, but while I was gone my patch has been taken over and split (so I need to work out whats going on there) and also networking-baremetals CI was broken so not much progress has been made
17:22:00 <rloo> pas-ha: wrt ansible deploy interface, L258. If that is questionable, i say, yes, we need doc updates :)
17:22:23 <rloo> sambetts: you're planning on working on it though, right? and does it need an RFE?
17:22:23 <dtantsur> rloo: the question mark is "is it TODO?" not "do we need docs" :)
17:22:32 <rloo> dtantsur: heh.
17:22:35 <vdrok> rloo: I did start. there is a wip patch. should be able to finish this week. lemme update the board
17:22:41 <rloo> vdrok: thx
17:22:56 <rloo> pas-ha: ^^ are there docs or a doc patch for the ansible deploy interface?
17:23:11 <pas-ha> rloo: no, copying docs is on my TODO list for this week
17:23:19 <rloo> pas-ha: thx!
17:23:45 <pas-ha> docs are there in staging drivers, just need to copy and adapt structure to ironic ones
17:24:18 <sambetts> rloo: I'm planning on working on it, but as someone else has starting hacking on it I might see where they are at first before I stomp all over them
17:24:19 <dtantsur> we have a page for deploy interfaces now
17:24:22 <rloo> pas-ha: gotcha
17:24:23 <sambetts> \o/
17:24:33 <dtantsur> #link https://docs.openstack.org/ironic/latest/admin/interfaces/deploy.html
17:24:35 <rloo> sambetts: yeah, that's a good idea.
17:25:30 <rloo> for python 3.5, i thought the issue was that swift isn't avail on 3.5.
17:25:59 <Nisha_Agarwal> rloo, yes its still a issue but we have enabled for ironci and ironic-inspector bypassing swift
17:26:25 <rloo> Nisha_Agarwal: would be good to note that down in the etherpad then.
17:26:32 <jlvillal> rloo: I think that you can use Ironic without Swift for certain driver types. I forget which ones exactly.
17:26:48 <rloo> jlvillal: would be good to note that down in the etherpad then :D
17:26:54 <Nisha_Agarwal> rloo ok sure
17:26:55 <anupn> rloo, yes i also chatted briefly with swift guys and py3.5 support does not seem to be on their priority
17:26:56 <jlvillal> rloo: I know anup has been working on it for the TinyIPA work.
17:27:10 <Nisha_Agarwal> rloo, for pxe_ipmitool drivers we can do without swift
17:27:10 <rloo> anupn: would be good to note that down in the etherpad then :D :D
17:27:14 <dtantsur> jlvillal: ipmi+iscsi (former pxe_ipmitool)
17:27:35 <anupn> rloo, will do
17:28:02 <rloo> jlvillal is back, and I think we're good with doing the tempest plugin split next week?
17:28:14 <dtantsur> yeah
17:28:29 <dtantsur> let's maybe pick a day even?
17:28:38 <jlvillal> rloo: I am. This week I am busy getting caught plus have to write up my yearly performance review. Which is super awesome time of course ;)
17:28:44 <dtantsur> like, jlvillal starts in his morning, then I take over in mine
17:28:50 <jlvillal> s/caught/caught up/
17:29:08 <jlvillal> dtantsur: Tuesday my day?
17:29:18 <jlvillal> dtantsur: Then Wednesday your day?
17:29:33 <dtantsur> jlvillal: sounds good
17:29:40 <jlvillal> Great
17:29:40 <rloo> jlvillal & dtantsur: what does this mean for the rest of us? That CI won't be avail?
17:29:58 <dtantsur> can please someone -2 anything that touches the in-tree tempest plugins around right now?
17:30:09 <dtantsur> or okay, maybe on Friday
17:30:15 <jlvillal> rloo: I hope not. I'm thinking minimal impact.
17:30:40 <rloo> jlvillal: we hope so too :) this doesn't affect stable branches?
17:30:47 <dtantsur> all branches
17:30:55 <dtantsur> the plugin will be branchless
17:31:06 <rloo> OH. we should make sure all the branches pass CI before this then.
17:31:12 <jlvillal> +1 on all branches being affected.
17:31:16 <rloo> cuz i think there is at least one project that is failing...
17:31:21 <dtantsur> good call. I think stable/pike of ironic has problems
17:31:26 <jlvillal> Once we remove the tempest plugin from openstack/ironic
17:32:28 <dtantsur> so, 1. this week - fix the CI, 2. Mon (my) morning - freeze the tempest plugin, 3. Mon - John's morning - do import in github
17:32:56 <dtantsur> 4. Tue - my morning - double-check/fix inspector import, 5. Tue - John's morning - pull the trigger, 6. Wed - my morning - fix THE WORLD
17:33:04 <dtantsur> anything I missed?
17:33:16 <rloo> dtantsur: just #action item ^^ :D
17:33:19 <jlvillal> Sounds about right
17:33:23 <sambetts> 7. fix the WORLD again?
17:33:25 <Nisha_Agarwal> tempest split is for ironic only?
17:33:42 <dtantsur> Nisha_Agarwal: the whole openstack is doing it. we're talking about ironic and ironic-inspector here
17:33:55 <Nisha_Agarwal> dtantsur, ok
17:34:38 <dtantsur> #agreed We will be moving to a separate tempest plugin on Dec 11 - Dec 13. The in-tree tempest plugin will be frozen for the duration of the switch, and will be removed afterwards.
17:34:45 <dtantsur> something like this ^^^ as a tl;dr?
17:34:52 <rloo> +1
17:34:55 <sambetts> sounds good to me
17:35:16 <dtantsur> nice!
17:35:20 <dtantsur> done with the statuses?
17:35:34 <rloo> oh, i asked. about zuul v3 stuff.
17:36:00 <dtantsur> what about it?
17:36:03 <rloo> i am only going to make sure master branches have their zuul v3 stuff done. if folks want to backport the centralized stuff, they will have to do on their onw.
17:36:14 <rloo> dtantsur: L240
17:36:32 <jlvillal> dtantsur: rloo: Updated whiteboard with plan
17:36:37 <dtantsur> rloo: not as a priority, I guess?
17:36:39 <dtantsur> thanks jlvillal
17:36:43 <rloo> dtantsur: unless folks think that it is important to backport to all.
17:37:04 <rloo> dtantsur: i don't see backporting that stuff as a priority, and some projects are already out of sync so it isn't a simple cherry-pick.
17:37:09 <dtantsur> well, if we have to backport some CI change later, it will be easier if the content is in sync
17:37:17 <rloo> dtantsur: so i don't want to be responsible for making sure it is done.
17:37:19 <dtantsur> right. it's not a priority.
17:37:52 <rloo> dtantsur: ok, i'll
17:38:05 <rloo> close that off next week then... wrt what i was/am doing anyway.
17:38:17 <rloo> dtantsur: am good with status now :)
17:38:23 <rloo> thx jlvillal
17:38:28 <dtantsur> #topic Deciding on priorities for the coming week
17:38:57 <dtantsur> the authentication refactoring is moving well. wanna take more patches from it?
17:39:05 <rloo> dtantsur: yup
17:39:35 <pas-ha> i've fixed nits in swift patch (and filed two bugs while doing it :)
17:40:09 <pas-ha> the next one (neutron) is quite bigger though
17:40:54 <dtantsur> yeah, I'm thinking of taking one a week
17:41:04 <pas-ha> ok, np
17:41:07 <dtantsur> actually, I'm fine with the list, given that we have to also check the CI state
17:41:17 <dtantsur> and some of the items on the list are not moving fast enough
17:41:20 <dtantsur> wdyt?
17:41:36 <pas-ha> it seems we have some multinode troubles tho
17:42:06 <rloo> dtantsur: the list looks good, the only thing is that i think this is the 3rd rescue patch: https://review.openstack.org/#/c/509342
17:42:13 <rloo> dtantsur: but i don't know if we'll get that far so not a big deal
17:42:16 <rloo> pas-ha: :(
17:43:06 <rloo> pas-ha: is it random or always? (guess we can discuss later)
17:43:23 <dtantsur> yeah, let's discuss it out of the meeting
17:43:36 <dtantsur> #topic Appointing a bug triaging lead for the coming week
17:43:42 <dtantsur> etingof and milan_? :)
17:43:47 <milan_> dtantsur, ack
17:43:50 <etingof> ack
17:43:58 <dtantsur> I'm not forcing you, you said you're interested :)
17:44:11 <milan_> yup and I meant it :)
17:44:14 <dtantsur> cool!
17:44:25 <dtantsur> #action milan_ and etingof to continue their bug triaging effort
17:44:27 <dtantsur> thanks guys!
17:44:33 <milan_> np!
17:44:41 <dtantsur> #topic RFE review
17:44:50 <dtantsur> rloo: let's get started :)
17:45:01 <rloo> https://bugs.launchpad.net/ironic/+bug/1669243
17:45:01 <openstack> Launchpad bug 1669243 in Ironic "[RFE] Ironic doesn't support zmq with oslo.messaging" [Wishlist,Triaged]
17:45:08 <dtantsur> #link https://bugs.launchpad.net/ironic/+bug/1669243  Ironic doesn't support zmq with oslo.messaging
17:45:29 <rloo> do we approve, do we need a spec? is this a bug??
17:45:59 <pas-ha> I've mixed feelings about that
17:46:00 <dtantsur> it may be a bug, which I don't really care about..
17:46:11 <dtantsur> how many real world deployments use zmq with openstack?
17:46:27 <rloo> dtantsur: none if it isn't supported...
17:46:38 <dtantsur> I mean, outside of ironic
17:46:40 <rloo> dtantsur: wondering why this person wanted it
17:46:42 <pas-ha> couple of years ago, it seemed that 0mq was the answer to scaling of openstack messaging, but then nova implemented cells
17:47:20 <pas-ha> so currently rabbit scaling issues are not a pressing as they used to
17:47:24 <sambetts> it was a big topic at the forum about using zmq for RPC and rabbit for notifications
17:47:36 <rloo> sambetts: OH. in Sydney?
17:47:47 <dtantsur> well, zmq for RPC will require rethinking our RPC
17:48:04 <dtantsur> I hope people don't meant to use zmq PubSub for it :) /me suspects they do
17:48:09 <rloo> dtantsur: needs spec then...
17:48:12 <sambetts> rloo: not sure in Sydney but in boston it was
17:48:28 <pas-ha> dtantsur: exactly, it is quite different model from rabbit, even when beeing 'abstracted' by oslo-messaging
17:48:40 * dtantsur dreams of the times when people used RPC to implement RPC..
17:49:16 <rloo> so what should we do? ask for a spec and that whatever is designed should be consistent? with how other projects do it if they do?
17:49:20 <jlvillal> The reporter hasn't commented on the bug for 9 months...  Nobody else seems to be asking for it. Should we look at this when there appears to be more interest?
17:49:20 <dtantsur> anyway, this one is either a bug or needs a spec - depending on its impact
17:49:23 <sambetts> dtantsur: they split notifications and RPC in oslo.messaging so you can load to different drivers, because RPC shouldn't reuqired pub sub but notificaitons do
17:49:42 <dtantsur> I suspect the latter
17:50:01 <rloo> i think it is a spec, cuz we don't say that we support zmg, do we?
17:50:12 <dtantsur> sambetts: right, but you need a specific destination then. like IP:port of the conductor, not just a topic
17:50:29 <sambetts> I think by supprting oslo.messaging we implicatly do support it right?
17:50:33 <dtantsur> yeah, let's have a spec. if somebody shows up and convinces us it's an easy fix - let it be
17:50:43 <rloo> ok, spec.
17:50:46 <sambetts> +1
17:50:47 <rloo> let's move on to the next one...
17:51:08 <dtantsur> #link https://bugs.launchpad.net/ironic/+bug/1660351 serial console through shellinabox is not multi-tenant and has no token/password protection
17:51:08 <openstack> Launchpad bug 1660351 in Ironic "[RFE] serial console through shellinabox is not multi-tenant and has no token/password protection" [Wishlist,Confirmed]
17:52:21 <dtantsur> a spec. for sure
17:52:39 <dtantsur> I'm not even sure I agree with the problem statement, let alone the solution
17:52:58 <rloo> dtantsur: ok. yeah, more details would be useful. will comment.
17:53:01 <rloo> next..
17:53:20 <dtantsur> #link https://bugs.launchpad.net/ironic/+bug/1657170 Change VIF list endpoint to output additional information
17:53:20 <openstack> Launchpad bug 1657170 in Ironic "[RFE] Change VIF list endpoint to output additional information" [Wishlist,In progress] - Assigned to Vasyl Saienko (vsaienko)
17:53:36 <vdrok> so I see sambetts ' comment
17:54:03 <vdrok> the idea was just to include a bunch of stuff in response for use in nova virt driver so as not to do additional calls into ironic api
17:55:04 <dtantsur> while the API-SIG hates it, we can add a parameter IIRC called "include" to make node-list include ports, vifs, whatever
17:55:16 <dtantsur> I agree with Sam that it does expose an internal detail
17:55:18 <rloo> were vifs written/designed to have additional info, that info depended on the network interface?
17:55:28 <vdrok> here is the bit of code https://jenkins.mtn5.cci.att.com/job/FUEL-9.0-kilo-generic-gigantic_single/1317/
17:55:28 <dtantsur> we're moving the to the bright future of hardware that allocates NICs on fly
17:55:33 <vdrok> gah
17:55:51 <vdrok> https://github.com/openstack/nova/blob/master/nova/virt/ironic/driver.py#L901-L904
17:56:10 <vdrok> rloo: correct
17:56:30 * sambetts hates that the nova driver needs to have any info from the ironic ports
17:56:39 <sambetts> tbh I don't hink it does really
17:56:41 <dtantsur> oh, this has a lot of the assumptions
17:56:46 <rloo> vdrok: i'd have to look at the code, but then, maybe the network driver can populate that vif info...
17:57:15 <jlvillal> I recommend "?detail=True" :)
17:57:29 <sambetts> jlvillal: ;)
17:57:35 * jlvillal has been reviewing sambetts' code :)
17:57:49 <rloo> i think it needs a spec
17:57:59 <dtantsur> yeah, I feel like there are options to consider here
17:58:02 <rloo> if it can be genearlized or something
17:58:09 <dtantsur> and new API endpoints usually require a spec anywa
17:58:14 <rloo> right
17:58:16 <jlvillal> 2 minutes left...
17:58:19 <rloo> ok, next, we have 2 min...
17:58:24 <dtantsur> but that's a good call vdrok, this nova code has to be refactored
17:58:36 <sambetts> +1 to generalizing and removing assumtions from nova
17:58:40 <dtantsur> #link https://bugs.launchpad.net/ironic/+bug/1719582 complete SSL support for https image references
17:58:40 <openstack> Launchpad bug 1719582 in Ironic "[RFE] complete SSL support for https image references" [Wishlist,Confirmed] - Assigned to Pavlo Shchelokovskyy (pshchelo)
17:59:07 <pas-ha> just want to get opinions on what to do re config options here
17:59:15 <rloo> pas-ha: i think we should just reuse. if that doesn't work for someone, we could always add new options later?
17:59:38 <dtantsur> well, the image URLs are coming through driver_info/instance_info, right?
17:59:40 <vdrok> ok, will try to add somth to the bug
17:59:47 <dtantsur> then I think the SSL options should come from there as well...
18:00:06 <dtantsur> anyway, let's move to the channel
18:00:10 <dtantsur> thanks all
18:00:12 <dtantsur> #endmeeting