17:00:26 <dtantsur> #startmeeting ironic
17:00:27 <openstack> Meeting started Mon Jan  8 17:00:26 2018 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:32 <openstack> The meeting name has been set to 'ironic'
17:00:36 <jroll> \o
17:00:38 <mjturek> o/
17:00:38 <etingof> o/
17:00:39 <baha> o/
17:00:42 <rloo> o/
17:00:48 <hshiina> o/
17:00:53 <mgoddard> o/
17:00:58 <jlvillal> o/
17:01:06 * mordred would like to discuss shed colors with jlvillal
17:01:06 <dtantsur> hi all! happy new year and welcome to the first meeting in 2018 :)
17:01:13 <jlvillal> heh
17:01:15 <sambetts> o/
17:01:21 <bfournie> o/
17:01:30 <dtantsur> mordred: hey, the API-SIG meeting is on Thu :D
17:01:47 <rpioso> o/
17:01:48 <TheJulia> o/
17:01:51 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic our agenda
17:02:05 <TheJulia> mordred: I'm still in support of purple :)
17:02:14 <rajinir> o/
17:02:25 <mrtenio> o/
17:02:37 <dtantsur> #topic Announcements / Reminder
17:02:58 <dtantsur> #info Deadlines approaching: http://lists.openstack.org/pipermail/openstack-dev/2017-December/125637.html
17:03:04 <dtantsur> #info Jan 18 - Non-client library freeze
17:03:14 <dtantsur> this one affects ironic-lib and sushy
17:03:28 <dtantsur> ironic-lib has iirc one bug fix proposed; sushy has a couple of features
17:03:34 <dtantsur> please do pay attention to these projects
17:03:56 <dtantsur> #info Jan 25 - Client release deadline and Feature Freeze
17:04:17 <dtantsur> please try to wrap up anything requiring client changes as early as possible, ideally this week
17:04:40 <dtantsur> also we ARE doing feature freeze this time; modulo potential exceptions, please wrap up the feature work
17:05:06 <dtantsur> #info dtantsur wants to do ironic and ironic-inspector releases this week
17:05:17 <dtantsur> these will be just checkpoint intermediary releases
17:05:21 <dtantsur> any questions?
17:05:46 <rloo> dtantsur: when are you planning on doing the ironic release? are there things to merge before that?
17:05:59 <dtantsur> rloo: after the tempest plugin code goes away
17:06:09 <rloo> dtantsur: ok
17:06:51 <dtantsur> let's see what we can finish in ironic in the coming days when discussing the statuses
17:06:58 <dtantsur> uwsgi is one of the candidates
17:07:22 <dtantsur> anything else to announce, remind?
17:07:25 <rpioso> dtantsur: Reminder that the OpenStack Director election closes on Friday, 1/12
17:07:35 <dtantsur> aha, good call! please vote
17:08:17 <dtantsur> moving on?
17:08:27 <rloo> +1
17:08:36 <TheJulia> +1
17:08:36 <dtantsur> #topic Review action items from previous meeting
17:08:44 <dtantsur> #link http://eavesdrop.openstack.org/meetings/ironic/2017/ironic.2017-12-18-17.00.html
17:09:01 <dtantsur> I promised a bug about version negotiation, here it is:
17:09:04 <dtantsur> #link https://bugs.launchpad.net/nova/+bug/1739440
17:09:04 <openstack> Launchpad bug 1739440 in OpenStack Compute (nova) "Ironic virt driver is hardcoding Ironic API microversion" [Wishlist,Triaged]
17:09:09 <dtantsur> triaged by Matt
17:09:47 <rloo> triaged but undecided as to whether a bug or feature
17:09:56 <dtantsur> right, depending on how it looks in the end
17:10:03 <dtantsur> but unlikely to require a spec in any case
17:10:19 <rloo> dtantsur: just the deadlines are diff
17:10:39 <dtantsur> well, in any case we need an ironicclient release, which has a strict deadline
17:11:00 <TheJulia> I have two patches up for the client that propose possibilities, both work quite nicely, the second patch likely is best for nova's usage because then the logic becomes very simple in the nova driver
17:11:05 <TheJulia> well, nova ironic virt driver
17:11:34 <dtantsur> #action dtantsur to review TheJulia's ironicclient patches around version negotiation
17:11:49 <dtantsur> TheJulia: you also subscribed to do bug triaging back then. how did it go?
17:12:03 <TheJulia> dtantsur: it was extremely quiet, nothing to report
17:12:27 <dtantsur> thanks!
17:12:31 <dtantsur> moving on?
17:12:34 <TheJulia> +1
17:12:43 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:12:54 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard starting with line 149
17:13:17 <dtantsur> we still have A LOT of bugs, even though triaged
17:15:14 <rloo> how many people do we have that are knowledgeable about inspector?
17:15:37 <dtantsur> weeellll...
17:15:41 <TheJulia> We likely need to spend time sifting through the bugs after we do some releases in order to reprioritize/update
17:15:41 <rloo> (was just looking at inspector patches for auth rework, L213)
17:15:50 <dtantsur> I know of sambetts, aarefiev and me
17:16:02 <TheJulia> I kind of know it decently
17:16:12 <rloo> dtantsur: ok, that's better than 1 :)
17:16:17 <rloo> or zero
17:16:38 <dtantsur> TheJulia: nice! I was not aware of it. You've just subscribed to reviewing it more ;)
17:16:58 <TheJulia> dtantsur: Already was, and rebased the auth patches last week :)
17:17:16 <dtantsur> rloo: well, milan's legacy is a big of a gray area even for me. otherwise, I've written a big share of code there :)
17:17:24 <dtantsur> thanks TheJulia
17:17:34 <rloo> dtantsur: yeah, milan's legacy :-(
17:17:43 <TheJulia> do we know when pas-ha will be back?
17:19:14 <dtantsur> TheJulia: their holidays end tomorrow
17:19:26 <dtantsur> but the last time I talked to him he was sick :(
17:19:31 <TheJulia> Asking because he had updated the patches before, and they are in decent shape, One of them is currently -1, but I suspect we could wrap those up fairly quickly with another core reviewer taking a look at this point
17:19:49 <TheJulia> dtantsur: :(
17:20:33 <rloo> I think we're in good shape there, we have enough cores and enough time to get those two patches in
17:20:44 <dtantsur> ++ next release if not this one
17:20:45 <rloo> i'm more worried about almost all the rest of them
17:21:08 <dtantsur> right, and the bug milan left as a new year gift: https://bugs.launchpad.net/ironic-inspector/+bug/1741035
17:21:09 <openstack> Launchpad bug 1741035 in Ironic Inspector "Spurious race conditions detected white-/black-listing MAC addresses in dnsmasq PXE filter" [High,Confirmed]
17:21:21 <jroll> I have some part-time bandwidth to pick things up if needed
17:21:40 <jroll> but I'm not sure what the best thing to pick up would be, so please feel free to tell me :)
17:22:09 * dtantsur hands jroll the reference architecture work :)
17:22:17 <rloo> traits?
17:22:18 <jroll> oh noez, docs
17:22:21 <dtantsur> haha
17:22:28 <dtantsur> c'mon, you wanted to do it back then
17:22:43 <jroll> yeah, I don't mind. traits would be fine too if mgoddard needs help
17:23:00 <rloo> are we ok if classic driver deprecation stuff slips?
17:23:10 <dtantsur> rloo: I'm going to spend more time on it now
17:23:24 <dtantsur> I was buried into making ansible deploy interface working with tripleo, and now it does
17:23:44 <rloo> dtantsur: ok. wrt deadlines, i think traits is the most important thing. if we want to get the client code in before deadline.
17:24:00 <jroll> ++
17:24:08 <dtantsur> right
17:24:09 * TheJulia tries to remember if we're exposing it such that it would show in the node object that is returned to any api client
17:24:14 <jroll> I didn't realize we were trying to get client code in
17:24:23 <dtantsur> well, ideally. it's not a hard requirement
17:24:27 <jroll> nod
17:24:34 <dtantsur> getting API done is very important though IMO
17:24:48 <dtantsur> and I'd not be in favor of an FFE for an API addition
17:24:49 <rloo> jroll: we don't need to get client code in. just mentioned in case someone thinks we do
17:25:21 <rloo> rescue seems like it has the most deadlines, but it is a high priority, not essential.
17:25:48 <dtantsur> oh, ansible deploy CI and docs is something I want finished before the intermediary release
17:25:55 <dtantsur> to avoid shipping it incomplete and/or untested
17:26:01 <jroll> I'll sync up with mgoddard on traits things
17:26:23 <rloo> dtantsur: wrt ansible, might need to wait/discuss with pas-ha, not sure what state that is all in
17:26:38 <dtantsur> rloo: mostly needs review
17:26:48 <dtantsur> see line 303
17:27:12 <rloo> dtantsur: has anyone looked at those patches? 'needs review' can be simple or not :-(
17:27:22 <dtantsur> I did have a pass over them
17:27:26 <dtantsur> the docs patch is HUGE
17:27:37 <dtantsur> on the bright side, the docs are quite detailed ;)
17:27:59 <rloo> personally, i'm fine if those don't land, and if we can get rescue and traits moving instead in the short term.
17:28:04 <rloo> but that's just me
17:28:07 <TheJulia> That they are, I think I looked them over a couple weeks back
17:28:25 <rloo> i mean, if they don't land sooner, vs reviews/work on the other stuff.
17:28:41 <rloo> tick tock
17:28:43 <dtantsur> that will mean we'll release the ansible deploy untested and without docs
17:28:52 <rloo> intermed. release...
17:28:55 <dtantsur> if we take the intermediary releases seriously, we should not do it
17:29:04 <rloo> we also have some rescue code merged :)
17:29:05 <dtantsur> I know TheJulia takes them seriously :)
17:29:09 <TheJulia> So just pointing out, it is the bottom of hte hour.
17:29:15 <TheJulia> s/he/the/
17:29:21 <rloo> oh, i think i forgot what an 'intermed' release means.
17:29:22 <mgoddard> jroll: johnthetubaguy is picking the ironic side of traits up now, I'm taking a look at the nova virt driver side. I'm sure he'd appreciate some help, particularly with that client deadline looming
17:29:53 <jroll> mgoddard: how'd I miss that conversation? :/
17:30:17 <jroll> anyway, we can figure it out post-meeting
17:30:29 <mgoddard> jroll: sure
17:30:32 <dtantsur> yep
17:30:33 <dtantsur> moving on?
17:30:55 <dtantsur> #topic Deciding on priorities for the coming week
17:31:47 <dtantsur> the existing list is looking well, but I'd add the ansible stuff finishing
17:31:51 <dtantsur> wdyt?
17:32:29 <rloo> i think the bios interface spec has been there for a long time. we should do something about getting that done, besides just having it in our list of priorities. or remove it.
17:32:53 <dtantsur> we have no way to force people to review something..
17:33:03 <TheJulia> imho, docs can always land a little later, since most people are going to go to the web and not look inside the package
17:33:22 <rloo> dtantsur: true, but at this point, i wonder if it is a priority for queens
17:34:12 <TheJulia> dtantsur: nor revise or agree
17:34:12 <rloo> dtantsur: i am fine if we leave it as a priority, just that it makes me sad that it is still there
17:34:38 <rpioso> dtantsur, rloo: I would like to see it land. I owe it another review. This week :)
17:35:00 <dtantsur> okay, for ansible work I'm putting only the CI. the docs can come later indeed
17:35:17 <dtantsur> we can take a minute to reflect why we don't review the BIOS spec
17:35:30 <rpioso> There was an issue about its compatibility with in-band cleaning.
17:35:32 <rloo> dtantsur: do you know what the sushy & ironic-lib patches are?
17:35:47 <TheJulia> dtantsur: wdyt about python-ironicclient related stuffs on the priority list?
17:35:48 <rloo> dtantsur: i guess we also want the tempest stuff but i think we need to discuss that first
17:36:07 <dtantsur> rloo: for ironic-lib https://review.openstack.org/#/c/529325/ may be of value
17:36:08 <patchbot> patch 529325 - ironic-lib - Add wait_for_disk to destroy_disk_metadata function
17:36:29 <TheJulia> rpioso: also, where to place the processes in our state machine, and the resulting impact(s)
17:36:32 <dtantsur> for sushy there are a couple of them, all with negative feedback
17:37:18 <rloo> dtantsur: for the ironic-lib patch, if it is just a docstring missing, then it should be a quick review, so worth adding as a priority
17:37:39 <dtantsur> sushy: https://review.openstack.org/#/c/471942/ and https://review.openstack.org/#/c/455114/ and https://review.openstack.org/#/c/463829/ seem important
17:37:40 <patchbot> patch 471942 - sushy - Implement Redfish Sessions
17:37:41 <rloo> dtantsur: wrt sushy, are there any cores that can vouch / suggest which ones are close/worth getting in?
17:37:41 <patchbot> patch 455114 - sushy - Add local_gb discovery to sushy
17:37:42 <patchbot> patch 463829 - sushy - Add foundation for supporting redfish OEMs
17:38:11 <dtantsur> rloo: these 3 were previously reviewed by me, some also by TheJulia; all have commetns to address
17:39:05 <rloo> dtantsur: ok, if you or TheJulia want them to land, then please chase those folks to update, then ping us when you think they are good. does that work?
17:39:28 <dtantsur> I can try, but some of these folks are not trivial to find
17:39:57 <TheJulia> dtantsur: I'm happy to give it a try, there are a couple other things that I need to follow-up on
17:40:08 <dtantsur> cool!
17:40:09 <dtantsur> okay, we have a list. how does it look?
17:40:29 <rloo> +1
17:40:34 <TheJulia> lgtm
17:40:35 <jroll> wfm
17:40:43 <jlvillal> +1
17:40:58 <dtantsur> SOLD!
17:41:01 <dtantsur> #topic Appointing a bug triaging lead for the coming week
17:41:15 <dtantsur> any victim?
17:42:07 <dtantsur> well, me then :)
17:42:12 * TheJulia suspects she will be the victim
17:42:20 <dtantsur> hah, or you :)
17:42:45 <TheJulia> I can do it, It is a good excuse to go look at some of the older bugs
17:42:53 <dtantsur> I guess you are preferred, since you don't have to figure out a visa to freaking Ireland right now :)
17:43:10 <dtantsur> #action TheJulia to lead the bug triage (and checking the old bugs) again this week
17:43:33 <dtantsur> thanks TheJulia
17:43:43 <dtantsur> #topic Can we remove the tempest plugin code from openstack/ironic and openstack/ironic-inspector now?
17:43:50 <dtantsur> jlvillal: your turn :)
17:43:59 <jlvillal> Basically that is the question :)
17:44:07 <TheJulia> FYI: ironic-inspector's removal landed on friday.
17:44:15 <jlvillal> We have given the 3rd Party CIs over three weeks to migrate
17:44:20 <dtantsur> right, the problem is ironic and 3rd party CI
17:44:21 <TheJulia> s/removal/tempest removal/
17:44:29 <jlvillal> Cisco works
17:44:34 <jlvillal> Fujitsu works
17:44:39 <dtantsur> rajinir, rpioso, do you know Dell status?
17:44:43 <jlvillal> Dell is broken with or without the change.
17:44:54 <dtantsur> your CI gives HTTPS errors when I try to see logs, and it seems all red
17:45:00 <rajinir> Dell Ci is turning green as we speak now
17:45:01 <rajinir> http://ci-watch.tintri.com/project?project=ironic&time=7+days
17:45:02 <jlvillal> Test empty patch: https://review.openstack.org/#/c/531167/
17:45:02 <patchbot> patch 531167 - ironic - WIP/DNM: Test to get idea of 3rd Party CI status
17:45:37 <jlvillal> So basically I feel like we have given enough notice and time to move forward.
17:45:40 <jlvillal> What do others think?
17:45:42 <rajinir> I've been out for vacation, just got back. We have made the changes already. The CI was down for other reasons
17:45:47 <dtantsur> rajinir: great! are you ready for the tempest plugin removal from tree?
17:45:59 <rloo> which are not working then, with the new tempest stuff? dell and ??
17:45:59 <rajinir> We are good with the removal
17:46:20 <dtantsur> anyone from HPE here?
17:46:20 <rajinir> of the tempest plugin changes
17:46:40 <dtantsur> the whiteboard says "under maintenance" for the Proliant CI
17:46:42 <rloo> IBM?
17:46:55 <jroll> powerkvm is failing, yeah
17:46:56 <jlvillal> Unsure on UFCG OneView. Some things pass and some fail, with or without the tempest removal.
17:46:57 <TheJulia> mjturek: ^^^
17:46:58 <jroll> https://review.openstack.org/#/c/527733/
17:46:59 <patchbot> patch 527733 - ironic - Remove ironic_tempest_plugin/ directory
17:47:01 <rpioso> rloo: ^^ Tempest plugin has been removed from Dell CI, and it's turning green.
17:47:20 <rloo> rpioso: thx
17:47:41 <rpioso> rloo: np
17:47:41 <mjturek> TheJulia rloo I'm going to need to confirm, but I can do that today
17:47:49 <TheJulia> mjturek: thanks!
17:47:56 <mjturek> we've been green but I'm not positive that ironic_tempest_plugin is being used
17:48:01 <jroll> thanks mjturek, looks like that's the last one
17:48:04 <dtantsur> IBM fails with "The test run didn't actually run any tests"
17:48:11 <dtantsur> mjturek: https://dal05.objectstorage.softlayer.net/v1/AUTH_3d8e6ecb-f597-448c-8ec2-164e9f710dd6/pkvmci/ironic/33/527733/15/check-ironic/tempest-dsvm-ironic-agent_ipmitool/f412d26/console.html
17:48:17 <jroll> yeah, likely not using the plugin then
17:48:18 <dtantsur> it may be caused by the removal
17:48:35 <rloo> so action item, mjturek to report back?
17:48:37 <mjturek> ah probably then. Okay I'll look into it
17:48:46 <rloo> what about oneview?
17:48:55 <rloo> who is our contact(s) there?
17:48:55 <TheJulia> ricardoas: You around?
17:49:07 <dtantsur> #action mjturek to check/fix the IBM CI with the tempest plugin removed from tree
17:49:11 <jroll> oneview seems intermittent with or without the removal, fwiw
17:49:22 <dtantsur> mjturek: how much time do you need?
17:49:24 <jroll> they passed one job on the removal
17:49:37 <dtantsur> yeah, I suspect oneview is fine with it, but worth double-checking
17:49:44 <rloo> i think if they passed one job on the removal, it should be good to remove.
17:49:47 <TheJulia> so, I just realized, we might not hear from oneview folks until next week
17:49:49 <ricardoas> TheJulia: yep... OneView is migrated!
17:49:51 * TheJulia checks
17:49:52 <jlvillal> mjturek: Why does PowerKVM always say it succeeds even when it doesn't?
17:49:54 <TheJulia> oh, yay!
17:49:55 <jroll> ricardoas: awesome
17:50:07 <rloo> yay, thx ricardoas
17:50:15 <jlvillal> ricardoas: Thanks :)
17:50:27 <TheJulia> Warning: 10 minutes
17:50:29 <ricardoas> We´ve been having some hardware hiccups...
17:50:30 <dtantsur> yeah, oneview logs look okay in this regard
17:50:34 <rloo> ok, we can move on
17:50:41 <jlvillal> So what is the plan?
17:50:41 <dtantsur> that's the last topic anyway
17:50:49 <dtantsur> yeah, I was about to ask about the plan
17:50:52 <jlvillal> Move forward with removal now? Or wait?
17:50:52 <mjturek> jlvillal I'm actually not sure lol, I believe our jobs outside of ironic do it as well
17:51:01 <jlvillal> I vote for move forward now :)
17:51:02 <mmedvede> jlvillal: I can answer that, because the PowerKVM CI job is non-voting. So build as a whole succeeded, even though that one non-voting job failed
17:51:08 <rloo> jlvillal: wait for mjturek to look into it and report back. mjturek you'll know today or tomorrow?
17:51:12 <dtantsur> should we plan the removal e.g. on Wed?
17:51:15 <mjturek> thanks mmedvede :)
17:51:22 <TheJulia> dtantsur: +1
17:51:25 <mmedvede> mjturek: can we make it vote?
17:51:28 <jroll> dtantsur: ++
17:51:37 <jlvillal> mmedvede: Well other non-voting jobs say fail, like OneView, Dell CI, etc...  So why I asked.
17:52:05 <rajinir> dtantsur>:+1
17:52:08 <jlvillal> Wednesday works for me. So reviews appreciated on: https://review.openstack.org/#/c/527733/
17:52:08 <patchbot> patch 527733 - ironic - Remove ironic_tempest_plugin/ directory
17:52:25 <jroll> jlvillal: those *jobs* are voting (though the gerrit user isn't allowed to vote on the patch)
17:52:26 <dtantsur> jlvillal: mind blocking it until Wed then?
17:52:27 <jlvillal> dtantsur: I added release notes :)
17:52:28 <mmedvede> jlvillal: note "(non-voting)" - this is the one I am referring to
17:52:30 <dtantsur> thanks!
17:53:06 <jlvillal> dtantsur: I blocked it
17:53:17 <jlvillal> mmedvede: okay
17:53:27 <dtantsur> #agreed The ironic_tempest_plugin code will be removed from Ironic tree on Wed, Jan 10th
17:53:37 <dtantsur> #topic Open discussion
17:53:39 <dtantsur> anything?
17:53:46 <jlvillal> mmedvede: Yeah, I don't think it has to be non-voting, since it won't block a merge or anything. But up to you :)
17:53:59 <rpioso> jlvillal: Thank you for your patience :)
17:54:16 <jlvillal> rpioso: With the holidays it was easy :)
17:54:37 <rpioso> jlvillal: lol
17:54:53 <dtantsur> wrapping up? :)
17:55:06 <dtantsur> thanks all!
17:55:06 <mmedvede> jlvillal: good, I'll update the PowerKVM CI job to make it like other CIs then. Thanks!
17:55:10 <TheJulia> seems so, but are the crickets making noise yet?
17:55:15 <dtantsur> rloo: ^^?
17:55:21 <dtantsur> you're out crickets liaison
17:55:22 <rloo> crickets
17:55:23 <dtantsur> s/out/our/
17:55:27 <TheJulia> lol
17:55:27 <dtantsur> #endmeeting