17:00:13 <dtantsur> #startmeeting ironic
17:00:14 <openstack> Meeting started Mon Jan 15 17:00:13 2018 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:17 <openstack> The meeting name has been set to 'ironic'
17:00:33 <dtantsur> hi all!
17:00:39 <rpioso> o/
17:00:41 <rloo> o/
17:00:45 <mjturek> o/
17:00:45 <crushil> o/
17:00:49 <stendulker> o/
17:00:54 <TheJulia> o/
17:00:57 <hshiina> o/
17:01:17 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic our agenda
17:01:24 <etingof> o/
17:01:48 <dtantsur> #topic Announcements / Reminder
17:02:00 <dtantsur> #info Jan 18 - Non-client library freeze
17:02:03 <dtantsur> this week!
17:02:17 <jlvillal> o/ US Holiday for some of us :)
17:02:32 <dtantsur> #link https://review.openstack.org/#/c/529325/ ironic-lib patch to consider finishing
17:02:32 <patchbot> patch 529325 - ironic-lib - Add wait_for_disk to destroy_disk_metadata function
17:03:06 <dtantsur> #link https://review.openstack.org/#/c/471942/ sushy patch to consider finishing
17:03:07 <patchbot> patch 471942 - sushy - Implement Redfish Sessions
17:03:32 <dtantsur> there are more outstanding sushy patches, all with -1's for quite some time
17:03:52 <dtantsur> #info Jan 25 - Client release deadline and Feature Freeze
17:03:54 <TheJulia> I should have a new version of 529325 up soon.. just fighting the fun of fuser
17:04:00 <dtantsur> thanks TheJulia
17:04:13 <openstackgerrit> Hugo Nicodemos proposed openstack/ironic master: Remove python-oneviewclient from oneview hardware type.  https://review.openstack.org/524729
17:04:13 <dtantsur> so, by next week we need ironicclient done
17:04:27 <rpioso> dtantsur: What's the freeze date for vendor drivers?
17:04:29 <dtantsur> this particularly includes TheJulia's version negotiation work, esp. its first patch
17:04:48 <dtantsur> rpioso: the same - feature freeze. we can talk about exceptions, but the date is the same for everyone.
17:04:59 <dtantsur> Jan 25
17:05:06 <rpioso> dtantsur: ty
17:05:09 <dtantsur> np
17:05:27 <dtantsur> TheJulia: I haven't checked the last version of that ironicclient patch, are we still in disagreement re upper cap on latest?
17:05:41 <TheJulia> dtantsur: no, we are in agreement now.
17:05:49 <dtantsur> cool! :)
17:06:06 <TheJulia> conceptulaly they match the proposed api-sig spec minus no min/max versions
17:06:11 <TheJulia> as arguments
17:06:44 <dtantsur> TheJulia: okay, we can discuss these separately. I'm more worried about absence of an internal upper limit
17:07:15 <dtantsur> #info with feature freeze coming, start thinking about potential exceptions you may submit
17:07:35 <TheJulia> dtantsur: added that as well
17:07:43 <dtantsur> cool
17:07:51 <dtantsur> note that big changes, breaking changes and API additions are unlikely candidates for a FFE
17:08:28 <rpioso> dtantsur: What's the process for submitting FFE?
17:08:30 <dtantsur> FFEs will be accepted and discussed on the ML and will have a very short time to finish
17:09:02 <dtantsur> post a request to the ML, explain pros, cons and expected risks. mention the ETA for landing, if all goes well.
17:09:40 <dtantsur> anything else?
17:09:44 <rloo> dtantsur: wrt FFEs, I seem to recall that nova asks for 2 cores to step up to review them. is that something we should do too?
17:09:58 <dtantsur> rloo: good idea, I like it
17:10:05 <dtantsur> otherwise it's useless anyway
17:10:14 <dtantsur> any objections to ^^^?
17:10:14 <rloo> yup
17:10:35 <TheJulia> none
17:10:48 <stendulker> None
17:10:57 <rloo> wait... err, oh it was my idea. none :)
17:11:21 <dtantsur> #info FFEs are requested on the ML. Make sure to include pros, cons, risks and find at least 2 cores agreeing to review it.
17:11:30 <dtantsur> note the bribery is illegal in most countries ;)
17:11:39 <dtantsur> anything else?
17:12:02 <rloo> dtantsur: you still planning on doing releases?
17:12:07 <rloo> dtantsur: ironic and ??
17:12:17 <dtantsur> ironic for now. maybe something else, not sure
17:12:28 <dtantsur> the final release will come with a stable/queens branch. IIRC around RC1
17:12:32 <rloo> dtantsur: k. this week. maybe today, tomorrow?
17:12:43 <dtantsur> ironic is today or tomorrow, yes
17:13:22 <dtantsur> moving on?
17:13:28 <rloo> +1
17:13:31 <dtantsur> #topic Review action items from previous meeting
17:13:38 <dtantsur> #link http://eavesdrop.openstack.org/meetings/ironic/2018/ironic.2018-01-08-17.00.html
17:13:53 <dtantsur> so.. I did not review TheJulia's patches, but I did submit a guideline to API-SIG on how to expose versions in SDKs
17:14:12 <dtantsur> #link https://review.openstack.org/532814 guideline on how to expose microversions in SDKs
17:14:13 <patchbot> patch 532814 - api-wg - Add guideline on exposing microversions in SDKs
17:14:26 <dtantsur> TheJulia: anything new from the bug triage?
17:14:39 <dtantsur> mjturek: any news re IBM CI with the tempest plugin removed from tree?
17:14:46 <TheJulia> dtantsur: I last looked at things ?thursday?, and don't remember anything new
17:14:55 <dtantsur> k thanks TheJulia
17:15:04 <mjturek> dtantsur yep, it's been restored (thanks mmedvede)
17:15:10 <mjturek> should be green since Friday
17:15:18 <dtantsur> nice! thanks mmedvede and mjturek
17:15:24 <dtantsur> any comments?
17:15:42 <rloo> the tempest code was removed on wed, right?
17:15:52 <dtantsur> it was, or around that
17:15:56 <rloo> someone should send email to that email thread, for closure on it.
17:16:06 <dtantsur> jlvillal: wanna ^^^?
17:16:26 <openstackgerrit> Harald Jensås proposed openstack/networking-baremetal master: Add baremetal neutron agent  https://review.openstack.org/456235
17:16:27 <openstackgerrit> Harald Jensås proposed openstack/networking-baremetal master: start_flag = True, only first time, or conf change  https://review.openstack.org/533707
17:16:27 <openstackgerrit> Harald Jensås proposed openstack/networking-baremetal master: Switch from MechanismDriver to SimpleAgentMechanismDriverBase  https://review.openstack.org/521838
17:16:28 <openstackgerrit> Harald Jensås proposed openstack/networking-baremetal master: Devstack - Add ironic-neutron-agent  https://review.openstack.org/530117
17:16:28 <openstackgerrit> Harald Jensås proposed openstack/networking-baremetal master: Add support to bind type vlan networks  https://review.openstack.org/532349
17:16:29 <openstackgerrit> Harald Jensås proposed openstack/networking-baremetal master: Add dsvm job  https://review.openstack.org/530409
17:16:41 <jlvillal> dtantsur, Sure!
17:16:44 <mjturek> nothing I can think of looking at the diff it was a pretty straight foward change to our pipeline
17:16:56 <dtantsur> #action jlvillal to announce the final removal of tempest plugins from ironic and inspector trees
17:17:12 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:17:25 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard starting with line 147
17:18:32 <rloo> dtantsur: the classic driver deprecation. does that need to get in before FFE?
17:18:32 <dtantsur> was rescue status really last updated on 18th Dec?
17:18:53 <dtantsur> rloo: ideally. it's not great to deprecate after FF :)
17:19:00 <dtantsur> I'll post the patches this week
17:19:17 <dtantsur> #action dtantsur to post classic driver deprecation patches this week
17:19:18 <rloo> dtantsur: ok. lots to review later this week/next week :-(
17:19:25 <dtantsur> yeaaahhh
17:19:30 <dtantsur> time around FF is never fun
17:19:42 <rloo> wrt traits and rescue. they both have nova components. how much of them need to land before the nova part will be reviewed?
17:20:08 <dtantsur> rloo: API and ironicclient
17:20:16 <dtantsur> which is essentially everything
17:20:31 <rloo> is it fair to say that if they don't land this week, then no need to hurry to get them into Queens?
17:20:59 <rloo> unless someone asks for FFE on nova side. sigh.
17:21:06 <dtantsur> API has to land this week, for sure
17:21:25 <dtantsur> well, I think it's fair to say that the nova part is not making it
17:21:35 <dtantsur> traits - maybe, but not rescue, I guess
17:21:55 <rloo> dtantsur: i'm trying to figure out what our/my priorities might be :)
17:21:55 <dtantsur> I don't think they'll appreciate us coming with a bulk of code 3 days before FF or something
17:22:05 <rloo> exactlly
17:22:15 <dtantsur> I'd still prefer to work on rescue and traits this week
17:22:20 <dtantsur> just not to lose the pace
17:22:35 <dtantsur> but if they don't land this week, the nova part probably won't go to queens
17:22:37 <rloo> ok, will see how far we get this week...
17:23:11 <dtantsur> #link https://review.openstack.org/#/c/531398/ easy win for your stats
17:23:11 <patchbot> patch 531398 - ironic - Make the Python 3 job voting
17:23:29 <rloo> i haven't been paying attention to routed network support (L253). Is there stuff there that needs to get in this week and/or before end of next week?
17:24:23 <dtantsur> IIRC it has some blocker on nova side. hjensas?
17:25:04 <rloo> for rescue, do we need CI to land too, before nova accepts it?
17:25:18 <dtantsur> rloo: not sure. but judging from BFV experience, yes
17:25:18 <hjensas> dtantsur: I am not sure if its a blocker. Placement does not work due to the way they do it in neutron. But the patches solve the problem with ipam.
17:25:49 <dtantsur> hjensas: let's ask it this way: do we have something to realistically finish before FF in 2 weeks?
17:25:58 <dtantsur> I mean, something users may benefit from?
17:26:37 <hjensas> yes, if the patches that are there now land, we can use routed networks (neutron segments plug-in) but we wont have smart placement/scheduling.
17:27:12 <hjensas> dtantsur: without it we cannot bind ports on segments when routed networks is enabled in neutron.
17:27:54 <dtantsur> if we cannot bind ports, what exactly can we use?
17:28:28 <hjensas> dtantsur: with the patches there we can bind.
17:28:42 <dtantsur> ah
17:29:22 <dtantsur> I'm inclined to exclude networking-baremetal for feature freeze. wdyt?
17:29:26 <dtantsur> s/for/from/
17:29:43 <rloo> dtantsur: i think we have to ask for a ffe
17:29:48 <TheJulia> Without more cores looking at it, I don't think we have a choice...
17:30:07 <rloo> right. so we ask for a ffe, and two cores step up :)
17:30:22 <dtantsur> okay, let's do it this way
17:30:24 <TheJulia> I've already been reviewing, but we basically need a non-redhat core to step up
17:30:28 <rloo> cuz i don't think we/i have time this week for that. but mybe next week...
17:30:36 <dtantsur> hjensas: I think it's fair to request an FFE for it, if you want to continue
17:30:48 <dtantsur> I'm in favor of granting such, and I guess sambetts may want to back it
17:31:13 <hjensas> dtantsur: I will continue working on it.
17:31:25 <rloo> thx hjensas
17:31:42 <dtantsur> hjensas: please feel free to request an FFE already then
17:32:00 <dtantsur> everyone ready to move on?
17:32:00 <hjensas> and reviews are welcome. :) thanks TheJulia, sambetts, jlvillal for the previous ones. :)
17:32:29 <rloo> +1 (move on)
17:32:42 <dtantsur> #topic Deciding on priorities for the coming week
17:32:51 <mjturek> I'd like to propose https://review.openstack.org/#/c/501799/ as a vendor priority if possible. It's had eyes on it, but I'd like a final push to get it merged
17:32:52 <patchbot> patch 501799 - ironic-python-agent - Use lshw in place of dmidecode for the default har...
17:33:02 <dtantsur> so, I think we should start concentrating on things that are making it
17:33:25 <dtantsur> mjturek: +1 (but please fix the CI)
17:33:30 <dtantsur> or recheck or whatever
17:33:45 <mjturek> it's passing CI but except for the non-voting job
17:34:23 <dtantsur> mjturek: meaning, it's not passing ;)
17:34:38 <dtantsur> I mean, the inspector job is what actually checks your patch
17:34:42 <mjturek> ahhh - okay I'll fix that then
17:34:43 <rloo> dtantsur: ironic-lib patch. i'm not sure about sushy -- someone else will have to vouch for those as priorities. traits and rescue. and julia's client patch(es)?
17:34:56 <dtantsur> rloo: yep
17:35:04 <dtantsur> I'd prefer to remove BIOS for now, as it's clearly not making it
17:35:26 <rloo> dtantsur: we also need your migration-to-hardware-types etc patch; i'm guessing maybe that may have to wait til next week to review
17:35:32 <jlvillal> dtantsur, Should we consider making the inspector job voting for IPA?
17:35:53 <rloo> yes, unfortunately, bios spec can wait
17:37:02 <TheJulia> That looks good to me
17:37:29 <mjturek> jlvillal: +1
17:37:41 <TheJulia> heh, changing more :)
17:37:53 <dtantsur> jlvillal: that's a question. previously we did not want to couple them, right now I'd prefer we do
17:37:59 <dtantsur> let's wait for the open discussion
17:38:07 <dtantsur> okay, the list is there. how does it look?
17:38:46 <rloo> dtantsur: lots of juicy things to review :D
17:38:51 <TheJulia> dtantsur: looks good to me
17:38:55 <dtantsur> :)
17:39:38 <dtantsur> #topic Appointing a bug triaging lead for the coming week
17:39:51 <dtantsur> should not be a lot of work, unless you want to review old bugs
17:39:53 <dtantsur> anyone?
17:39:58 <mjturek> been awhile since I've done it, I'd like to volunteer!
17:40:05 <dtantsur> thanks mjturek :)
17:40:14 <dtantsur> #action mjturek to lead the bug triaging this week
17:40:23 <dtantsur> #topic Open discussion
17:40:34 <dtantsur> should we discuss making the inspector job voting on ironic and IPA?
17:40:58 <rloo> dtantsur: no. you can decide.
17:41:04 <dtantsur> pros: covering inspection in ironic and inventory in IPA. cons: moar voting jobs
17:41:12 <dtantsur> c'mon, aren't we having a voting on voting? :D
17:41:14 <jlvillal> If only certain parts of IPA get tested by inspector, it seems like it should
17:41:35 <rloo> i'm worried about more voting jobs.
17:41:48 <rloo> have we encountered issues in the past, cuz of lack of these jobs?
17:42:05 <rloo> i mean ideally, i'd say yes.
17:42:12 <TheJulia> rloo: I was going to ask jus that.
17:42:20 <dtantsur> according to http://ci-watch.tintri.com/project?project=ironic&time=7+days it's quite stable recently..
17:42:34 <rloo> just want to be a bit pragmatic. due to situation(s) with jobs/gate/...
17:43:06 <dtantsur> rloo: well, mjturek's patch may be breaking inspection. I've seen similar cases before as well.
17:43:26 <dtantsur> I don't recall someone breaking ironic side though
17:44:01 <rloo> dtantsur: it is non-voting now.
17:44:08 <rloo> dtantsur: can we punt this til after queens is released?
17:44:14 <dtantsur> totally
17:44:37 <dtantsur> then just as a reminder:
17:45:03 <dtantsur> #info the inspector job on ironic and IPA is relatively stable. please watch its results, especially when a patch modifies the inventory
17:45:23 <TheJulia> Warning: 15 minutes
17:45:40 <dtantsur> anything else to discuss?
17:46:04 <rloo> crick
17:46:04 * dtantsur curl https://crickets-as-a-service.example.com
17:46:04 <rloo> ets
17:46:19 <dtantsur> thanks all :D
17:46:23 <TheJulia> dtantsur: cats-chasing-crickets-as-a-service?
17:46:27 <dtantsur> OMG
17:46:37 <dtantsur> yes, totally :D
17:46:43 <dtantsur> #endmeeting