17:00:32 <TheJulia> #startmeeting ironic
17:00:33 <openstack> Meeting started Mon Jan 29 17:00:32 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:34 <TheJulia> o/
17:00:36 <openstack> The meeting name has been set to 'ironic'
17:00:38 <jroll> \o/
17:00:45 <hjensas> o/
17:00:54 <jlvillal> O/ reo
17:00:58 <crushil> \o
17:00:59 <rpioso> o/
17:01:07 <rloo> o/
17:01:07 <hshiina> o/
17:01:07 <stendulker> o/
17:01:19 <etingof> o/
17:01:20 <baha> o/
17:01:25 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:01:35 <TheJulia> As always, our agenda can be found on the wiki
17:01:40 <ricardoas> o/
17:02:06 <bfournie> o/
17:02:06 <TheJulia> #topic Announcements / Reminder
17:02:32 * rloo thinks folks haven't updated their subteam status reports... do it now, quick... :)
17:02:38 <TheJulia> #info Feature Freeze started last Thursday
17:02:58 <TheJulia> #info Hard freeze starts this Friday, Feburary 2nd.
17:03:44 <TheJulia> #info Please expect our release to be cut anytime between Friday February 2nd and Feburary 8th.
17:04:10 <rloo> TheJulia: really? given our FFE is until Feb 2...
17:04:39 <Nisha_Agarwal> o/
17:04:45 <TheJulia> #info Only bug fixes should be landed after this Friday. All features with Feature Freeze Exceptions must be landed by Feb 2nd.
17:05:03 <NobodyCam> o/
17:05:22 <TheJulia> Anyone have anything else announcement or reminder wise?
17:05:26 <rloo> TheJulia: hard string freeze is week of Feb 5. what is 'hard freeze' ^^ ?
17:05:49 <rloo> TheJulia: https://releases.openstack.org/queens/schedule.html
17:06:27 <TheJulia> rloo: Hard freeze as in we're done for the cycle and are ready to cut our branch.
17:06:37 <rloo> reminder about ptg? ptl election?
17:06:57 <rloo> TheJulia: rc1 target week is the hard freeze, right? (next week)
17:07:01 <TheJulia> Since we don't cut an RC, we need to be ready to cut our branch early unless we want to have fun cherry picking
17:07:40 <rloo> TheJulia: right, i think that we want ours to be in sync with rc1
17:07:42 <mjturek> o/
17:07:55 <jroll> yeah, I believe we did want to cut at the same time that everyone else does rc1
17:07:56 <TheJulia> #info PTL nominations start later today \o/
17:08:48 <TheJulia> #info The PTG is coming, please submit topics to the etherpad before Feb 15th.
17:08:50 <TheJulia> #link https://etherpad.openstack.org/p/ironic-rocky-ptg
17:08:57 <TheJulia> jroll: correct
17:09:17 <TheJulia> Wow, this was an annoucement/reminder heavy day
17:09:29 <TheJulia> If there is nothing else, we should move on
17:09:41 <jroll> right, so to be clear: feb 2: deadline for landing any feature, FFE or not, to ironic. feb 9: goal to cut stable/queens branch. yes?
17:10:08 <TheJulia> jroll: Correct
17:10:16 <rloo> jroll: yup. although we should try for feb 8 (Thurs).
17:10:17 <jlvillal> Unrelated. I have to say I'm glad we have our own 'gate' queue. Otherwise our patches would still be in the process of landing :)
17:10:24 <jroll> excellent. thanks
17:10:37 <rloo> thx jlvillal :)
17:10:54 <jlvillal> I didn't do it. Someone else did it before me. I was just cleaning up some stragglers.
17:11:07 <TheJulia> #topic Review action items from previous meeting
17:11:16 <jlvillal> But nothing of ours was in the 'integrated' queue. Which is the really big one.
17:11:17 <TheJulia> #link http://eavesdrop.openstack.org/meetings/ironic/2018/ironic.2018-01-22-17.00.html
17:11:42 <TheJulia> Our only action item from last week was that mjturek would take care of bug triaging this week. mjturek, anything to report?
17:12:36 <rloo> TheJulia: should we enable the multinode-grenade job as voting?
17:12:36 <mjturek> TheJulia nothing really, there were a couple of IPv6 bugs that I looked at
17:12:50 <TheJulia> mjturek: Awesome, thanks!
17:13:00 <mjturek> np!
17:13:22 <rloo> (sorry, TheJulia, I'll take that off line about the grenade job)
17:13:23 <TheJulia> rloo: Perhaps discussion, although personally I've not had a chance to dig through logs and really evaluate the failure rate with recent gate issues
17:13:33 <TheJulia> #topic Review subteam status reports
17:13:40 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:14:04 <TheJulia> Starting around line 232 :)
17:15:32 <TheJulia> I think the largest thing of note is that we were able to land quite a bit last week, and we were able to release python-ironicclient with client negotiation changes as well as support for traits. Resuce support did not make it into the client :(
17:15:39 <rloo> TheJulia: could you update version negotiation? i just quickly updated drivers deprecation
17:17:44 <rloo> jroll: wrt traits, did you push up a patch to test in nova?
17:18:07 <rloo> jroll: ah, i see it. thx :)
17:18:17 <jroll> rloo: yeah, we decided just to use functional tests for now
17:18:36 <TheJulia> rloo: done
17:18:40 <rloo> jroll: great. looks like the nova patches have all been approved, just waiting to land!
17:18:46 <jroll> yep :)
17:18:50 <jroll> we dun good
17:19:09 * TheJulia shifts out of the slowly shifting day star beam
17:19:29 <TheJulia> Okay, I can see again
17:20:10 <TheJulia> rloo: I _think_ we are done with the auth rework
17:20:49 <rloo> TheJulia: ok. i can't even see it on the etherpad. too many things...
17:21:05 <TheJulia> Yeah, the etherpad needs a good cleanup
17:21:34 <TheJulia> I think we are good to move on?
17:21:39 <rloo> TheJulia: found it, i updated with DONE
17:21:55 <rloo> ++ to clean up
17:21:58 <rloo> ++ to moving on
17:22:04 <jroll> +1
17:22:24 <TheJulia> #topic Deciding on priorities for the next week
17:22:27 <rloo> TheJulia: darn, i have a question about version negotiation
17:22:32 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:22:37 <TheJulia> rloo: ask ? :)
17:22:38 <rloo> TheJulia: is there anything more that needs to be done for that? in nova?
17:22:49 <TheJulia> rloo: at this point, negotiation/discussion
17:23:05 <rloo> TheJulia: ok, no more patches for queens. thx.
17:23:06 <TheJulia> I think we're not doing anything else with that until after the PTG
17:23:11 <TheJulia> rloo: correct
17:23:17 <rloo> TheJulia: do we need to discuss with nova at ptg?
17:23:32 <jroll> we should be able to discuss it outside of the ptg, but yeah, nothing for queens
17:23:35 <TheJulia> Okay, as for priorities, rloo created a list of Feature Freeze Exceptions and patches starting on line 157
17:23:42 <jroll> I thought we had agreed at some level
17:24:09 <TheJulia> jroll: we kind of had, but at the same time the sands have shifted if that makes sense
17:24:31 <jroll> I guess, I think folks were just opposed to rushing it :)
17:25:44 <rloo> jroll, TheJulia: I think it makes sense to touch base with nova and make sure we're all in agreement. at or outside ptg :)
17:25:57 <jroll> yep
17:25:58 <TheJulia> jroll: that and the original person that drove the ask has stepped out of the community
17:26:02 <rloo> i'll make a note of it in etherpad
17:26:18 <TheJulia> As for priorities, I think we should work from the FFE list this week
17:27:02 <rloo> TheJulia: i didn't prioritize that list. it seems like routed networks is the highest?
17:27:03 <TheJulia> sambetts did propose a vif locking bug fix I submitted as another thing we would likely want to try and land, since it will help improve gate reliability as well
17:27:26 <rloo> TheJulia: bugs. yeah... someone needs to go through bugs, see which ones we might want to try to land.
17:27:45 <TheJulia> rloo: I think routed networks might be good to have as best because traits is basically at docs at this point
17:27:49 <TheJulia> s/best/highest/
17:28:04 <rloo> TheJulia: oh. and classic drivers deprecation.
17:28:07 <TheJulia> rescue, we're going to need to sift through that list, and we're blocked on any osc-commands due to them not landing in the client
17:28:13 <TheJulia> ++
17:28:17 <rloo> TheJulia: that might be #1 if we don't want to delay the deprecation etc.
17:28:39 <TheJulia> rloo: I agree with that
17:29:30 <rloo> TheJulia: do you want to massage that for the priorities or do you want me to do it. nowish i guess...
17:29:44 <TheJulia> rloo: sure
17:30:08 <rloo> and by the way, there are a lot of patches for routed networks. would be good if someone could indicate which 'need' to land.
17:30:50 <TheJulia> Oneview and ilo uefi iscsi boot just need follow-ups it looks like.
17:30:59 <hjensas> for routed networks at least 521838, 536040 and 537353. since we landed the agent, we need the mech driver updated to actually use the agent_db data.
17:31:16 <TheJulia> hjensas: would you tag those as needed in the list?
17:31:35 <hjensas> TheJulia: yes.
17:32:17 <TheJulia> I've updated the rescue item to note that we need to review that and block at devstack changes
17:32:28 <TheJulia> I can do that after the meeting
17:32:34 <rloo> Thx TheJulia!
17:32:59 <rloo> TheJulia: do you have a link to the vif bug?
17:33:08 <TheJulia> #action TheJulia to review rescue patches and block at appropriate place for devstack to hold for the next cycle.
17:33:43 <TheJulia> rloo: https://review.openstack.org/#/c/534441/4
17:33:44 <patchbot> patch 534441 - ironic - Don't try to lock upfront for vif removal
17:34:24 <TheJulia> Is anyone else aware of any bugs that we need to address this week?
17:35:03 * TheJulia guesses not at this time
17:35:06 <rloo> TheJulia: I added that bug to the prioriites. we can add more if there are any.
17:35:12 <rloo> TheJulia: but we don't really have bugs in our code so ...
17:35:35 <jroll> never
17:35:39 <TheJulia> rloo: Thanks! I think the priorities for this week are good, lots of patches, but many of them are smaller changes
17:35:41 <TheJulia> rloo: only features
17:35:48 <rloo> heh
17:36:06 <TheJulia> I think we're good to move on
17:36:15 <TheJulia> Any objections?
17:36:24 <rloo> ++ I'm good with the priorities and to moving on
17:36:58 <TheJulia> #topic Appointing a bug triaging lead for the coming week
17:37:07 <TheJulia> Anyone up for volunteering this week?
17:37:10 <mjturek> I'm good with continuing
17:37:20 <TheJulia> mjturek: Awesome, thanks!
17:37:33 <mjturek> np
17:37:40 <TheJulia> #action mjturek to lead bug triage this next week.
17:38:36 <TheJulia> Since we have no discussion topics, I think we should just skip to Open Discussion, unless someone has RFEs that need review?
17:38:52 * TheJulia will accept the crickets as confirmation that we can move to open discussion :)
17:39:00 <NobodyCam> ++
17:39:15 <rloo> ++
17:39:53 <TheJulia> Okay, moving on!
17:40:04 <TheJulia> #topic Open Discussion
17:40:16 <TheJulia> Does anyone have any topics to bring up for discussion today?
17:40:31 * jroll does not
17:40:40 <rloo> are these meetings useful?
17:40:52 <rloo> wait, let's not discuss that.
17:41:00 <jroll> heh
17:41:17 <rloo> crickets
17:41:17 <jroll> I suspect they're more useful for people like me that are not plugged in 40+ hours/week
17:41:27 <TheJulia> lol
17:41:48 <rloo> good, i thought maybe it was only useful for more 'project management' related folks.
17:41:53 <TheJulia> jroll: Yeah, very much so, and force a checkpoint for those of us who are plugged into it
17:42:21 <jroll> nod
17:42:44 <rloo> are we waiting now for ... crickets...
17:43:03 <TheJulia> Yes, the creation of crickets as a service :)
17:43:18 <TheJulia> Well, thanks everyone! Have a wonderful week!
17:43:35 <TheJulia> #endmeeting