17:00:19 <TheJulia> #startmeeting ironic
17:00:20 <openstack> Meeting started Mon Mar 12 17:00:19 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:21 <TheJulia> o/
17:00:23 <openstack> The meeting name has been set to 'ironic'
17:00:24 <mjturek> o/
17:00:29 <baha_> o/
17:00:35 <TheJulia> Everyone ready for an ironic meeting? :)
17:00:45 <etingof> o/
17:00:45 <dtantsur> o/
17:00:47 <hshiina> o/
17:01:13 <TheJulia> Our agenda can be found on the wiki, as always!
17:01:15 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
17:01:34 <rloo> o/
17:01:48 <TheJulia> We've got a number of items on the agenda today, partially since we cancelled last week with people still traveling or handling jet lag from the PTG.
17:01:56 <rpioso> o/
17:01:59 <TheJulia> #topic Announcements / Reminder
17:02:31 <TheJulia> I started a poll to help give us an idea of a meeting time more friendly to APAC attendees, I'll look at the results some time this week so there is still time to vote!
17:02:40 <TheJulia> #link https://doodle.com/poll/6kuwixpkkhbwsibk
17:03:30 <rloo> thx TheJulia
17:03:42 <TheJulia> #info jroll has rejoined ironic-core
17:03:48 <openstackgerrit> Nguyen Hai proposed openstack/ironic-specs master: Change ironic-specs webpage from oslosphinx to openstackdocstheme  https://review.openstack.org/552007
17:04:01 <TheJulia> #info The Rocky Cycle priorites review has been posted, please review ASAP.
17:04:16 <TheJulia> #link https://review.openstack.org/#/c/550174
17:04:17 <patchbot> patch 550174 - ironic-specs - Add Rocky Priorities
17:04:36 <dtantsur> wb jroll!
17:04:37 <jlvillal> o/
17:04:45 <rpioso> He's back!
17:04:49 <TheJulia> #info TheJulia wrote up a summary of our PTG discussions and sent it to the mailing list.
17:04:51 <TheJulia> #link http://lists.openstack.org/pipermail/openstack-dev/2018-March/128085.html
17:04:56 <rpioso> And he still has it! :)
17:05:12 <jlvillal> +1 on jroll being back! :)
17:05:46 <rpioso> TheJulia: ty ^^^
17:05:58 <rloo> TheJulia: you've been busy. thx for the great summary!
17:06:26 <TheJulia> #info There is no longer a oneview CI. TheJulia following up with a contact at HPE to determine the next step(s).
17:06:46 <rloo> :-(
17:06:50 <dtantsur> sigh
17:07:23 <TheJulia> Does anyone else have anything they would like to announce or remind us of?
17:08:11 <jlvillal> Is anyone here to accept the award on jroll's behalf? ;)
17:08:39 <TheJulia> jlvillal: I thought he said he would have been back today... I guess maybe vacation captured him
17:09:01 <TheJulia> Okay, I guess we can move on
17:09:01 <jlvillal> It is a good way to miss a meeting :)
17:09:05 <TheJulia> jlvillal: ++
17:09:20 <TheJulia> #topic Review action items from previous meeting
17:09:30 <TheJulia> #info No action items from last week's meeting.
17:09:34 <TheJulia> That was easy ;)
17:09:53 <openstackgerrit> Ilya Etingof proposed openstack/virtualbmc master: multiprocess server, ZMQ-based management cli tool  https://review.openstack.org/488874
17:09:57 <TheJulia> Moving on...
17:10:06 <TheJulia> #topic Subteam status reports
17:10:23 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:10:45 <TheJulia> Our whiteboard needs some cleaning.... Lots of cleaning
17:10:57 <TheJulia> That or we could just burn it with fire and migrate to storyboard
17:11:02 <TheJulia> But that is a topic for later.
17:11:37 <rloo> i suspect we'd still want the whiteboard
17:11:52 <TheJulia> Yeah, agreed.
17:12:35 <TheJulia> Without priorities agreed upon, I'm hesitant to update the whiteboard to reflect those new priorities.
17:13:15 <TheJulia> I think we can delete the Ansible deploy interface from the list
17:13:54 <rloo> TheJulia: traits support planning isn't in list of priorities
17:14:07 <TheJulia> good point
17:14:12 * TheJulia updates python3.5
17:14:15 <NobodyCam> Good Morning Ironic'ers
17:14:23 <rloo> nor is routed network support?
17:14:27 <rloo> or rescue mode
17:14:35 <rloo> but the status of those is still useful
17:14:54 <rloo> TheJulia: is it possible to migrate to storyboard this week?
17:14:57 <TheJulia> Looks like there were some rescue patches still oustanding, we should likely get those landed this week.
17:15:23 <TheJulia> rloo: migration might take a couple days, I started a test on friday and it got a few hundred bugs in before my cats knocked the computer over....
17:15:30 <rloo> TheJulia: at least migrate what we have in the etherpad, to storyboard, before deleting from etherpad?
17:16:05 <TheJulia> I think we should get the data into storyboard first, I'll try to get that machine back up and give folks access to it so they can look and see how our data looks in storyboard
17:16:16 <TheJulia> #action TheJulia to get us a taste of storyboard
17:18:39 <TheJulia> We still need to get the updated client out before we can finish rescue, but that should be soon-ish
17:19:39 <TheJulia> bfournie: sambetts: w/r/t routed networks, is there anything that needs to be done that is still pertinent on the whiteboard?
17:19:42 <rloo> and the nova part -- i suspect that's probably the hardest part that is outstanding
17:19:58 <TheJulia> Yeah, and the issue of client calls and api versions... :\
17:20:21 <rloo> TheJulia: OH :-(
17:21:09 <TheJulia> rloo: I'm going to look at the client in nova this week... likely with something tasty, and see how hard or easy it is going to be to switch it all over.
17:21:39 <TheJulia> dtantsur: any update for Reference architecture stuffs?
17:21:52 <dtantsur> TheJulia: nothing yet, making my way to it
17:23:23 * TheJulia updates some notes
17:24:43 <TheJulia> I think we're good to proceed... although someone is adding things somewhere :)
17:25:19 * rloo just updated the sighup stuff
17:25:24 <TheJulia> Thanks rloo
17:25:43 <TheJulia> Everyone ready to move on?
17:25:48 <dtantsur> yep
17:25:54 <rloo> ++
17:26:11 <TheJulia> #topic Deciding on priorities for the coming week
17:27:15 <TheJulia> Around line 146
17:27:22 <TheJulia> Highest priority that I see is... well.. priorities
17:27:23 <rloo> rocky priorities. we should aim to get that done when, friday?
17:28:03 <TheJulia> Friday is a good goal for that
17:28:19 <TheJulia> I can revise it again today since It looks like we've identified points of contact for all of the items
17:28:59 <TheJulia> I'm adding "remaining rescue patches" since we should have a client release today
17:29:04 <TheJulia> hopefully
17:30:34 <TheJulia> pas-ha: were you able to get a list of patches together for graphical console related things?
17:31:57 <TheJulia> #action TheJulia to clean-up the whiteboard further this week
17:32:22 <hshiina> TheJulia, shall i list remaining rescue patches?
17:32:40 <TheJulia> hshiina: I was going to do that after the meeting, but your welcome to do so
17:33:00 <TheJulia> Really, I think that is it for priorities this week unless someone has something else
17:33:54 <dtantsur> I'm working through driver comp follows ups as well
17:33:55 <rpioso> How about an email coordinating a discussion about lifecycle managment?
17:33:57 <hshiina> TheJulia, sure. i'll do.
17:34:00 <dtantsur> but may be not worth calling priorities
17:34:08 <TheJulia> rpioso: Good point, that is on my calendar for thursday :)
17:34:16 <rpioso> Awesome!
17:34:36 <TheJulia> dtantsur: okay
17:35:04 <rpioso> BIOS spec?
17:35:23 <TheJulia> hmmm
17:35:32 <TheJulia> I thought it landed for some reason, looking
17:35:48 <TheJulia> nope
17:35:49 <TheJulia> https://review.openstack.org/#/c/496481/
17:35:50 <patchbot> patch 496481 - ironic-specs - Hardware interface for BIOS configuration
17:36:45 <dtantsur> it's very close
17:36:56 <TheJulia> hshiina: mgoddard_: w/r/t bios spec: do you feel that the changes can be performed as a follow-up at this point?
17:37:47 <rpioso> TheJulia: I need to spend a couple of quiet hours with it.
17:38:10 <TheJulia> rpioso: acknowledged
17:38:15 <sambetts> I need to re-review that one too since many changes have been made since the ptg
17:38:40 <TheJulia> Okay, I think we're good for this week, just everyone keep in mind that I will be inquiring about various things throughout the week as I clean up some of the whiteboard.
17:38:46 <TheJulia> Time to move on?
17:39:20 <dtantsur> ++
17:39:25 <TheJulia> #topic Appointing a bug triaging lead for the coming week
17:39:38 <TheJulia> Anyone up for spending time with launchpad this week?
17:39:53 <mjturek> I'll do it!
17:40:01 <TheJulia> mjturek: Awesome! Thanks!
17:40:26 <TheJulia> #action mjturek to lead bug triaging for the next week.
17:40:35 <TheJulia> Moving on to discussion then!
17:40:40 <TheJulia> #topic Discussion
17:40:43 <jlvillal> FYI: Easy and needed (IMHO) patch up for review. https://review.openstack.org/#/c/552042/  Thanks rloo for catching it :)
17:40:44 <patchbot> patch 552042 - ironic - multinode, multitenant grenade votes in gate
17:41:30 <TheJulia> I have one discussion item today. Storyboard!
17:41:33 <TheJulia> #link  https://docs.openstack.org/infra/storyboard/migration.html
17:42:18 <TheJulia> We've talked about it in person, and I believe the concerns were linking from gerrit, blueprints (which is covered by the link (there is no blueprint migration))
17:43:36 <dtantsur> I think linking from gerrit works via Story: <xxx>
17:43:38 <TheJulia> As I understand it, linking from gerrit to storyboard will be addressed later on, so the easy click that we have now to bugs might be a little bit of a headache.
17:43:40 <dtantsur> (or something like that)
17:43:52 <dtantsur> and we don't have blueprints \o/
17:44:06 <TheJulia> oh yes, it is Story:
17:44:08 <TheJulia> or Task:
17:44:09 <TheJulia> \o/
17:44:14 <TheJulia> #link https://docs.openstack.org/infra/manual/developers.html#development-workflow
17:44:52 <dtantsur> so looks like we're in a good position to migrate?
17:44:53 <TheJulia> Oh, and tags do appear to migrate as I understand it, that is easy to verify on my test instance.
17:45:10 <TheJulia> Indeed, I would just prefer to get my test instance back up and see how long it takes :)
17:45:44 <TheJulia> If there are no objections, we can proceed forth with it????
17:46:02 <TheJulia> other than getting a test instance stood up and generally accessible to see what our data looks like
17:46:22 * TheJulia is taking silence as agreement
17:46:36 <sambetts> the peice thats currently in progress from infra is storyboard to gerrit links
17:46:58 <sambetts> e.g. if you push a patch adding the link to the story to the patch
17:47:16 <sambetts> from the story to the patch *
17:47:39 <dtantsur> ah, hmm, this is a nice feature to have for sure
17:47:41 <TheJulia> I think we can live with that for now, typically we're going from the patch to launchpad, not the other way around
17:48:02 <mgoddard_> hi TheJulia, sorry I missed your call - in another meeting currently. My major concerns with the BIOS spec have now been addressed - the main one outstanding is the requirement for an object layer. That seems like something we ought to get agreement on, but happy with a follow up to document it
17:48:23 <TheJulia> mgoddard_: thanks!
17:48:53 * TheJulia hears crickets
17:49:16 <TheJulia> If there is nothing else, we can move to open discussion or wrap up the meeting
17:50:28 <TheJulia> #topic Open Discussion
17:50:52 <TheJulia> Anyone have anything they would like to discuss?
17:51:01 <baha> I was wondering if I could get some eyes on a patch set I've had sitting around for a bit =) https://review.openstack.org/#/c/429836/
17:51:02 <patchbot> patch 429836 - ironic - Add OpenBMC class for accessing nodes using OpenBMC
17:51:46 <dtantsur> baha: do we have an RFE approved for that?
17:51:57 <mjturek> dtantsur yep it's the OpenBMC driver RFE
17:52:02 <TheJulia> we have an approved spec
17:52:09 <dtantsur> ah, cool, I'll put it on my list
17:52:18 <sambetts> added to my list too
17:52:18 <baha> Thanks!
17:52:29 <mjturek> thanks dtantsur sambetts
17:52:34 <dtantsur> do you plan on a 3rdparty CI?
17:53:04 <mjturek> we haven't started work on one
17:53:11 <dtantsur> mjturek: and it certainly misses a release note :)
17:53:12 <mjturek> but we could extend the powerkvm ci for it
17:53:29 <mjturek> baha: yeah we should add a reno
17:53:33 <TheJulia> mjturek: the spec says that is how it will be tested
17:53:46 <dtantsur> mmm, and this particular patch does not add any hw types, does it?
17:53:56 <TheJulia> dtantsur: it is a follow-up to add the hw types
17:54:00 <TheJulia> otherwise it would be a 1600 line patch
17:54:11 <dtantsur> I have a mixed feelings about that, but okay
17:54:16 <TheJulia> 2x 800 line patches
17:54:17 <TheJulia> :)
17:54:44 <dtantsur> mjturek: then the release note should go to the patch that exposes something, not to this one. sorry for confusion.
17:55:05 <mjturek> cool makes sense
17:55:12 <TheJulia> https://review.openstack.org/#/c/403835/ is the other patch, and does need a reno
17:55:12 <patchbot> patch 403835 - ironic - OpenBMC Hardware Type
17:55:23 <mjturek> TheJulia so 3rd party ci before it merges?
17:55:42 <rpioso> TheJulia: 800 + 20, no?
17:55:54 <TheJulia> mjturek: We have traditionally allowed for up to six months to pass before it needs to be in place
17:56:12 <dtantsur> yep, it can merge first, but please do not delay the 3rdparty CI
17:56:20 * dtantsur wonders how xclarity CI is doing
17:56:31 <TheJulia> crushil: ^^^
17:56:35 <TheJulia> :)
17:56:47 <mjturek> TheJulia dtantsur okay baha and I can start working that
17:56:52 <TheJulia> I think that is it for today folks, if nobody has anything else?
17:56:59 <TheJulia> mjturek: awesome
17:57:02 * dtantsur has nothing
17:57:33 <rloo> crickets
17:58:02 * TheJulia hears crickets
17:58:03 <TheJulia> Thanks everyone!
17:58:07 <dtantsur> thanks TheJulia
17:58:13 <hshiina> thanks
17:58:35 <TheJulia> #endmeeting