15:00:11 <TheJulia> #startmeeting ironic
15:00:12 <openstack> Meeting started Mon Apr  2 15:00:11 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <TheJulia> o/
15:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <openstack> The meeting name has been set to 'ironic'
15:00:26 <jroll> \o
15:00:28 <kaifeng> o/
15:00:28 <rloo> o/
15:00:30 <TheJulia> Who is awake and energized for an ironic meeting!?
15:00:35 <hshiina> o/
15:00:37 <stendulker> o/
15:00:37 <rpioso> o/
15:00:44 <vdrok> o/
15:00:51 * jroll cheers for the light agenda
15:01:09 <TheJulia> Our agenda can be found on the wiki
15:01:11 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic
15:01:18 <TheJulia> #topic Announcements / Reminder
15:01:28 <TheJulia> I have nothing. Anyone have anything they wish to raise?
15:01:30 <jlvillal> o/
15:01:39 * jroll has nothing
15:02:27 <TheJulia> Well, if we have nothing this morning, time to move on!
15:02:33 <rpioso> Future of OpenStack PTGs suvey.
15:02:36 <rloo> TheJulia: isn't there some deadline to propose stuff for forum?
15:02:38 <TheJulia> oh, good point
15:03:12 <TheJulia> #info The foundation emailed out a poll regarding the future of the PTG. Please respond to the poll and give them your thoughts.
15:03:27 <TheJulia> rloo: Yes, every yes, but the submission tool is not even online yet afaik...
15:03:46 <rloo> TheJulia: oh, guess folks can 'start thinking' :)
15:04:14 <TheJulia> #info Forum is coming up, we need topics! What would you like to discuss? Please let TheJulia know.
15:04:43 * TheJulia moves on
15:04:53 <TheJulia> #topic Review Action Items from previous meeting.
15:05:14 <TheJulia> I know mjturek created a poll for this friday. I'll sadly most likely miss it since I'll be in meetings that day.
15:05:43 <TheJulia> I believe Dmitry spoke with the storyboard folks about building new reporting tooling.
15:06:02 <TheJulia> And Dmitry was kind enough to update the drivers wiki page.
15:06:04 <TheJulia> #link http://eavesdrop.openstack.org/meetings/ironic/2018/ironic.2018-03-26-15.00.html
15:06:04 <rloo> TheJulia: based on the poll, i'm not convinced that is a good day to do it
15:06:15 <rloo> TheJulia: max folks at any time is 3
15:06:26 <TheJulia> rloo: ugh, yeah, that is a bad day then
15:06:29 <rloo> TheJulia: https://doodle.com/poll/xa999rx653pb58t6
15:06:33 <jroll> good, I don't like friday meetings anyway :P
15:06:39 <TheJulia> #link https://doodle.com/poll/xa999rx653pb58t6
15:06:58 <TheJulia> I'll ping mjturek, or at least try to while I'm metal tubing tomorrow to see about changing the day.
15:07:21 <TheJulia> Shall we move on?
15:07:49 <rloo> +1
15:07:53 <TheJulia> #topic Review subteam status reports
15:07:55 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:08:00 <TheJulia> Starting at line 155
15:09:15 <Nisha_Agarwal> o/
15:10:02 <TheJulia> Kind of looks like we're just kind of slowly moving along
15:10:30 <jroll> yep, nothing majorly stuck it seems
15:10:58 <TheJulia> Yeah, just we're all working on getting traction or getting things to begin moving
15:11:07 * TheJulia suspects it is going to be a heavy end of cycle review period...
15:11:26 * jroll is optimistically hoping milestone 2 is the heavy part
15:11:28 <TheJulia> Any questions regarding statuses?
15:11:59 <TheJulia> Shall we move on?
15:12:13 <rloo> ++
15:12:13 * jroll is fine to move on, rloo?
15:12:39 <TheJulia> #topic Priorities for this next week
15:13:10 <rloo> I don't think we got any priorities done last week?
15:13:26 <TheJulia> Looks like we just got some testing stuff landed, I already deleted the line.
15:13:39 <rloo> TheJulia: ah, thx
15:13:40 <jroll> and deploy steps spec just got done :)
15:13:49 <TheJulia> One of the bios interface patches has a +A, but the patch it is dependent upon is blocked
15:13:52 <rloo> jroll: :)
15:14:07 * jroll removes it
15:14:37 <jroll> I see some other +2s, so progress, just not 'done'
15:15:06 <rloo> TheJulia: do you have patches for anything related to Storyboard? we should get those in so folks aren't confused
15:15:10 <jroll> TheJulia: think we'll have anything reviewable for the nova driver rework?
15:15:19 <jroll> (this week)
15:15:50 <TheJulia> eh, we're trying to figure out the most agreeable direction to head in
15:16:21 <jroll> k
15:16:43 <TheJulia> This kind of seems like he path we are likely to go down https://review.openstack.org/#/c/557850/
15:16:43 <patchbot> patch 557850 - python-ironicclient - Support per-call version: set_provision_state
15:17:05 <mjturek> o/
15:17:07 <TheJulia> It will require some tweaks to microversion negotiation logic in case there is a 406 detected. https://review.openstack.org/#/c/558027/
15:17:07 <patchbot> patch 558027 - python-ironicclient - Wire in header microversion into negotiation
15:17:10 <jroll> yeah, reviews can be a next week priority then
15:17:20 <TheJulia> That is kind of what I was thinking
15:17:23 <jroll> cool
15:17:51 <TheJulia> Anyway, I updated the priority list. Does that look good for everyone?
15:17:51 <jroll> priorities list seems fine to me then, let's get those out of the way so we can get the big work in
15:17:58 <TheJulia> ++
15:18:19 <rloo> thx TheJulia
15:18:46 <TheJulia> #topic Appointing a bug triaging lead
15:18:54 <TheJulia> I'll take this task this week
15:19:05 <TheJulia> #action TheJulia to triage bugs
15:19:08 <jroll> thanks!
15:19:10 <rloo> thx TheJulia :)
15:19:33 <TheJulia> Since we have no listed RFEs or Discussion topics, I suggest we move directly to Open Discussion
15:19:45 <jroll> +1
15:19:49 * jroll has an open discussion thing
15:20:25 <openstackgerrit> Merged openstack/ironic-specs master: Support StoryBoard URLs  https://review.openstack.org/557509
15:20:40 <rloo> i think jroll and others can go ahead?
15:20:47 <TheJulia> #topic Open Discussion
15:20:58 <jroll> short version, pycrypto is deprecated, people want to move openstack things to pyca's cryptography. jarrod has some concerns about pyghmi and python 2.6 support. openstack doesn't care about python 2.6 support, but pyghmi users outside of openstack do. what should we do?
15:21:00 <jroll> #link http://lists.openstack.org/pipermail/openstack-dev/2018-April/128963.html
15:21:03 <jroll> my thoughts on it ^
15:21:05 <TheJulia> mjturek: one note from earlier discussion, well two. The feeling is Friday might not work well
15:22:10 <rloo> jroll: ugh
15:22:15 <openstackgerrit> Merged openstack/ironic-specs master: Deployment steps framework  https://review.openstack.org/549493
15:22:20 <TheJulia> jroll: your proposal seems... reasonable
15:22:42 <jroll> I can't think of anything else that will make everyone happy
15:22:49 <rloo> jroll: have you talked to jarrod about your idea?
15:22:53 <jroll> I'm not sure if jarrod reads the list anymore
15:23:01 <jroll> rloo: no, it's been a whole two hours :)
15:23:15 <TheJulia> jroll: I think it might be good to email him directly
15:23:18 <mjturek> TheJulia that's fair, any idea what day you'd want? We can also bring up during open discussion
15:23:20 <TheJulia> and go from there.
15:23:23 <rloo> jroll: heh. worth seeing what he thinks. it means his clients will need to know where/which package to get
15:23:36 <rloo> s/clients/users on py26/
15:23:43 <vdrok> so wil pycrypto still remain in requirements? or it will be removed in favor of cryptography?
15:23:45 <jroll> TheJulia: I can do that, if you have his email address
15:23:48 <TheJulia> mjturek: no idea, I'm going to the DMV after this meeting, metal tubing tomorrow, and will be in Boston the rest of the week. :(
15:23:52 <jroll> vdrok: the goal is to remove it, AIUI
15:23:54 <TheJulia> jroll: sure
15:24:00 <openstackgerrit> Merged openstack/sushy master: Add processor ProcessorId field and Status field  https://review.openstack.org/554838
15:24:00 <rloo> otherwise, i'm good with your suggestion.
15:24:08 <rloo> vdrok: removed in favor of cryptography
15:24:13 <vdrok> jroll: so if it is removed, I guess py26 branch will stop working?
15:24:17 <rloo> vdrok: but pycrypto will remain in the branch
15:24:18 <mjturek> well that's awesome! we'll figure it out
15:24:40 <jroll> vdrok: well, we wouldn't sync that branch with g-r
15:24:44 <vdrok> I mean, all this system with upper-constraints
15:24:56 <jroll> I doubt people on py26 are using upper-constraints :)
15:25:07 <jroll> these are people using pyghmi outside of openstack, afaik
15:25:14 <vdrok> if the requirement is not in global reqs at all, will tox complain when creating the venv? this is my question :)
15:25:33 <jroll> yeah, we'd need some adjustments
15:25:37 <vdrok> as upper-constraints will not contain it and they are used when creating venv
15:25:52 <vdrok> if it can be worked around then the proposal seems good to me
15:26:04 <jroll> suspect it can
15:26:49 <TheJulia> Well, the suggestion for a major version bump is reasonable
15:26:56 <TheJulia> that allows us to constrain our stuff cleanly
15:27:09 * jroll forwarded the list post to jarrod
15:27:15 <TheJulia> jroll: thanks!
15:28:03 <jroll> no problem
15:28:12 <TheJulia> Do we have anything else to discuss this morning?
15:28:53 <rloo> i thought mjturek wanted to discuss good days for bug smash day
15:29:11 <jroll> ah yes
15:29:24 <mjturek> rloo we can also do that on ML, but what about postponing it a week?
15:29:45 <mjturek> 13th instead of 6th
15:29:48 <rloo> my first thought was 'who even wants to participate' given that 4? people replied to the poll
15:30:04 <rloo> mjturek: jroll mentioned that he doesn't like fri meetings
15:30:06 <TheJulia> What if we did a new poll for the 12th instead?
15:30:16 <mjturek> ah okay that's understandable
15:30:26 <mjturek> sounds good to me
15:30:26 <jroll> don't avoid fridays just for me (but then again fridays exclude ruby too, so)
15:30:48 <TheJulia> I'm not a fan of scheduling thing on Fridays either
15:30:58 <rloo> jroll: ahem, well, i am working fridays now (unless there is a holiday or i'm on vaca)
15:31:02 * jroll only schedules beer on fridays
15:31:15 <jroll> rloo: oh! yay! we get 25% more rloo \o/
15:31:40 <TheJulia> \o/
15:32:06 <mjturek> well regardless, friday meetings are no fun. I'm +1 on the 12th!
15:32:23 <TheJulia> Well, if there is nothing else to be discussed, we can have the rest of the hour back.
15:32:38 <vdrok> rloo can now change the nick to rlooo
15:32:56 <rloo> vdrok: ?
15:33:13 <TheJulia> lol
15:33:14 <vdrok> +25% of the nick to match
15:33:20 <jroll> heh
15:33:22 <rloo> vdrok: ohhhhhh :D
15:33:38 <TheJulia> I think we're done for the day. Thanks everyone and have a wonderful week!
15:33:46 <vdrok> thanks!
15:34:10 <rloo> thx!
15:34:25 <TheJulia> #endmeeting