15:00:10 <TheJulia> #startmeeting ironic
15:00:11 <openstack> Meeting started Mon Apr 30 15:00:10 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <JayF> so it doesn't surprise me emptystring works on a lot of machines
15:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <openstack> The meeting name has been set to 'ironic'
15:00:26 <TheJulia> JayF: I knew that, but I thought there was some magic code in hdparm for certian cases
15:00:27 <TheJulia> anyway!
15:00:29 <rloo> thx JayF (want to join our meeting?)
15:00:30 <TheJulia> Meeting time!
15:00:36 <rloo> o/
15:00:38 <arxcruz|pto> o/
15:00:40 * dtantsur lurks
15:00:41 * TheJulia hands out cokies
15:00:43 <TheJulia> cokies
15:00:45 <jiapei_> o/
15:00:49 <vdrok> щ.
15:00:55 <vdrok> woops, o/
15:00:59 <jroll> \o
15:00:59 <TheJulia> okay, o key... why you no like cookies :(
15:01:03 * jroll runs to grab water
15:01:11 <TheJulia> A great comedic start to the morning!
15:01:15 <dtantsur> vdrok: щ to you as well :D
15:01:16 <JayF> o/ (the goodbye kind!)
15:01:24 <TheJulia> Our agenda can be found at https://wiki.openstack.org/wiki/Meetings/Ironic
15:01:25 <dtantsur> hey hey JayF :)
15:01:27 <TheJulia> o/ JayF
15:01:31 <vdrok> :)
15:01:41 <jiapei_> Good evening :)
15:01:47 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic
15:01:50 <TheJulia> Anyway, getting started!
15:02:08 <TheJulia> #topic Announcements/Reminders
15:03:17 <TheJulia> We are a few weeks out from the Summit, I think we should cancel the meeting, but we can vote on that next week
15:03:48 <TheJulia> aside from that, I have nothing else to announce or remind us of this week.
15:03:54 <rloo> TheJulia: cancel the meeting the week of the summit, right?
15:04:00 <TheJulia> rloo: yes
15:04:12 <rloo> TheJulia: +1 to cancel :)
15:04:41 <TheJulia> Does anyone else have anything to annouce?
15:05:37 <TheJulia> I guess not, and we can move on
15:06:33 <TheJulia> #topic Reviewing action items from last week
15:07:06 <TheJulia> #link http://eavesdrop.openstack.org/meetings/ironic/2018/ironic.2018-04-23-15.00.log.html
15:07:10 <TheJulia> #link https://storyboard.openstack.org/#!/story/2001884
15:07:51 <TheJulia> It looks like dmitry posted one patch. dtantsur will there be a second patch?
15:08:20 <dtantsur> yep, but it feels less urgent
15:08:51 <TheJulia> Okay, thanks!
15:09:33 <TheJulia> #topic Review Subteam Status Reports
15:09:37 <openstackgerrit> Merged openstack/bifrost master: Add support for NTP servers in dnsmasq configuration  https://review.openstack.org/563894
15:09:51 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:11:56 <TheJulia> Looks like we at least landed one of the bios interface patches last week
15:12:13 <rloo> SIGHUP work is done too :)
15:12:30 <dtantsur> \o/
15:12:53 <jroll> nice!
15:12:54 <TheJulia> dtantsur: any remaining hardware type work on the horizon regarding the patches to delete classic drivers?
15:13:03 <TheJulia> rloo: by chance has that been updated in storyboard yet?
15:13:06 <dtantsur> yep
15:13:20 <dtantsur> https://review.openstack.org/#/q/topic:api-jobs is needed to move forward with s/fake/fake-hardware/ in the CI
15:13:21 <rloo> TheJulia: i don't know; it is on my list to check/do after this meeting :)
15:13:25 <TheJulia> dtantsur: any this week that we need to have the ironic community attention on?
15:13:39 <TheJulia> rloo: ack, let me know if you need me to do anything then
15:13:50 <dtantsur> these patches, then https://review.openstack.org/564519
15:13:50 <patchbot> patch 564519 - ironic - Switch to the fake-hardware hardware type for API ...
15:13:50 <rloo> TheJulia: will do, thx!
15:15:21 <TheJulia> dtantsur: any expectation on unblocking the last patch this week?
15:15:40 <dtantsur> TheJulia: it's blocked by that three patches, essentially
15:15:48 <dtantsur> then I'll double-check that I don't break any CI, and unblock it
15:15:56 <dtantsur> so yes, totally possible
15:16:02 <TheJulia> okay, then I'll just leave the link to the three patches for now
15:16:30 <dtantsur> k
15:17:57 <TheJulia> I made some minor updates to the priorities for this week list. Sadly I didn't have much time last week since I was hunting nova/heat issues
15:18:24 * TheJulia sighs that the cats have realized how to open the window blinds....
15:19:13 <TheJulia> Looking through things on the whiteboard, I think we should go ahead and remove oneview references, thoughts?
15:19:42 <jroll> +1
15:19:50 <rloo> TheJulia: +1 (i was going to ask, thx)
15:20:05 <TheJulia> #action TheJulia to scrub the whiteboard for oneview items this week
15:20:11 <TheJulia> I'll go ahead and put a doc note up as well
15:20:23 <rloo> TheJulia: might be useful to mention here, why we're doing this
15:20:37 <TheJulia> #action TheJulia to put up deprecation doc note in the oneview docs.
15:21:46 <TheJulia> I'm sure as a number of you remember when contributors from UFCG, about two weeks before the PTG, entered the channel and said that HPE had cancelled their further efforts and had requested that the hardware be shipped back to HPE.
15:22:39 <TheJulia> I've repeatedly engaged HPE and haven't gotten any traction, nor has there been any public action indicating that they may be working to re-establish CI for oneview.
15:23:18 <TheJulia> Since there is no third party CI, it is impossible for us to support the driver and ensure it is in working condition, hence why we're deprecating and will eventually remove it from the source code tree if third party CI is never re-established.
15:23:21 <TheJulia> Any questions?
15:24:28 * TheJulia hears crickets as a service
15:24:50 <TheJulia> so with that, lets move to priorites for the week, then discusison.
15:25:06 <TheJulia> Everyone good with that?
15:25:21 <dtantsur> yep
15:25:37 <TheJulia> #topic Priorities for the coming week
15:26:14 <TheJulia> Starting around line 102
15:26:36 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:26:50 <dtantsur> LGTM :)
15:27:08 <TheJulia> not much different from last week. I removed the merged patches, added a link to make dtantsur's life easier
15:27:15 <jroll> ditto
15:27:22 * dtantsur likes making dtantsur's life easier :D
15:27:25 <TheJulia> heh
15:28:10 <TheJulia> Anyway, moving on#
15:28:11 <TheJulia> err
15:28:13 <TheJulia> !
15:28:16 <TheJulia> #topic Discussion
15:28:16 <vdrok> oh btw all the prerequisites for https://review.openstack.org/359061 are merged
15:28:19 <patchbot> patch 359061 - python-ironicclient - Switch to none auth for standalone mode
15:28:44 <dtantsur> vdrok: oh, quite a long read :) I'll try to get to it
15:28:57 <arxcruz|pto> Hi guys, I'm from tripleo-ci team, and we would like to add a tripleo job on ironic project
15:28:57 <vdrok> thx!
15:29:12 <rloo> vdrok: thx! (I need to get a dev env set up to test that...)
15:29:19 <arxcruz|pto> initially the job will take 2 hours to finish, installing tripleo and running tempest on undercloud
15:29:32 <arxcruz|pto> non voting obviously, but hopefully with time, get it in voting
15:29:42 <arxcruz|pto> we are working hard to decrease the time of the job as well
15:29:44 <TheJulia> arxcruz|pto: why is it that this job is required?
15:29:52 <vdrok> rloo: there also is a patch on top running functional tests with it :) https://review.openstack.org/508330
15:29:53 <patchbot> patch 508330 - python-ironicclient - WIP allow to use none auth in functional tests
15:30:14 <arxcruz|pto> TheJulia: not required, but would help us to catch problems in tripleo faster since tripleo uses ironic a lot
15:30:26 <rloo> vdrok: thx. will try to look soon, it has been on my list for awhile...
15:30:27 <dtantsur> TheJulia: one benefit for us is testing local boot
15:30:31 <arxcruz|pto> sometimes you don't see the problem running on devstack
15:30:58 <TheJulia> We already have a few two hour jobs which, I guess I'm worried about about adding another one and slowing down our CI runs even more
15:30:58 <rloo> 2 hours is a long time. what is the longest time for our existing tests?
15:31:08 <rloo> (existing voting tests)
15:31:11 <dtantsur> rloo: I suspect grenade jobs are comparable
15:31:13 <TheJulia> rloo: multinode grenade is like 1 hour 45 minutes on a good day
15:31:16 <jroll> dtantsur: don't we test local boot already?
15:31:22 <dtantsur> jroll: IIRC no :(
15:31:30 <arxcruz|pto> as i said, we are working to reduce to 1.5 hours
15:31:31 <dtantsur> we were blocked by cirros not supporting grub
15:31:32 <TheJulia> rloo: 2hr 20-minute-ish on a moderate day
15:31:33 <jroll> wut
15:31:35 <jroll> :(
15:31:56 <arxcruz|pto> it will install the undercloud and run ironic tempest tests
15:32:15 <TheJulia> arxcruz|pto: is that even really required for a test executing reporting to ironic?
15:32:34 <TheJulia> since all of our other tests run tempest based quites
15:32:36 <TheJulia> squites
15:32:38 <TheJulia> suites
15:32:43 * TheJulia should just give up on typing today
15:32:45 <arxcruz|pto> TheJulia: yeah, but, not in tripleo environment
15:32:51 <dtantsur> TheJulia: typing is overrated
15:32:55 <TheJulia> dtantsur: indeed
15:33:14 <dtantsur> arxcruz|pto: I think the question is how it benefits ironic, not tripleo :)
15:33:20 <arxcruz|pto> we see several problems that pass without nobody see on devstack, when we change the environment to tripleo, things start to pop up everywhere
15:33:27 <arxcruz|pto> dtantsur: less bugs to fix later :D
15:33:28 <dtantsur> I like being tested by something resembling production, to be honest
15:33:32 <jroll> to be clear, is this tripleo job in the infra queue or some third party ci queue?
15:33:37 <TheJulia> arxcruz|pto: Has Ironic had recent changes that have broken TripleO?
15:34:04 <arxcruz|pto> TheJulia: from time to time, I don't recally anything right now, we usually try to fix in our side
15:34:12 <arxcruz|pto> but we want to increase the coverage
15:34:25 <arxcruz|pto> jroll: infra queue
15:34:40 <jroll> ok
15:34:45 <dtantsur> arxcruz|pto: but there are also RDO 3rdparty jobs, right?
15:34:49 <arxcruz|pto> dtantsur: yes
15:34:53 <dtantsur> adding these could be easier, no?
15:35:02 <dtantsur> I mean, they don't block the gate if they take too long
15:35:11 <arxcruz|pto> well, I'm opened to options :)
15:35:27 <jroll> I don't have a problem with this, I see it as helping other openstack projects. third party would be nice to not increase results time, but I'm fine with infra queue too
15:35:28 <TheJulia> I really like the idea of a third party job personally
15:35:33 <arxcruz|pto> if you guys agree, we can add a job, non voting, if it's not working, we can move on with other options
15:35:37 <dtantsur> arxcruz|pto: we can even create a featureset using ironic both in under and over cloud
15:35:44 <dtantsur> double ironic testing \o/ :D
15:35:53 <arxcruz|pto> dtantsur: let's start simple :D lol
15:35:57 <TheJulia> arxcruz|pto: move on with other jobs? sounds like there is more to this plan?
15:36:17 <arxcruz|pto> TheJulia: sorry, what I meant was move on with other options, like move the job to thirdy party
15:36:22 <arxcruz|pto> third*
15:36:27 <rloo> my only concern with it, even as non-voting, is if it delays us getting the CI results, but since it is faster than grenade multi*, it should be OK. what about resources used for this testing?
15:36:56 <dtantsur> arxcruz|pto: it is OVB, right?
15:37:03 <rloo> arxcruz|pto: would it make sense to put it in RDO 3rdparty jobs first?
15:37:08 <arxcruz|pto> dtantsur: nope, multinode
15:37:13 <dtantsur> arxcruz|pto: ehmm, wait please
15:37:20 <arxcruz|pto> rloo: i can check if that's possible
15:37:26 <dtantsur> last time I checked tripleo multinode CI did not deploy ironic instances
15:37:27 <arxcruz|pto> weshay: can it be ovb on rdocloud ?
15:37:39 <arxcruz|pto> dtantsur: we are working on a featureset for that
15:37:40 <dtantsur> how do you run tempest if you don't have virtual ironic nodes?
15:37:43 <dtantsur> ah, okay
15:37:43 <jroll> rloo: infra generally does not worry about resources if the job has value
15:38:12 <dtantsur> my concern is only about the possibility :) if you can use virtualbmc/whatever on a multinode tripleo job - fine
15:38:14 <arxcruz|pto> dtantsur: it will be a whole new featureset
15:38:27 <weshay> arxcruz|pto, we can add jobs to rdocloud especially for ironic
15:38:28 <weshay> ya
15:38:36 <rloo> jroll: oh, ok.
15:38:38 <weshay> that is only 3rd party though
15:38:44 <arxcruz|pto> so, my boss said yes, so up to you guys :D
15:39:53 <arxcruz|pto> dtantsur: we can work on a job that run ironic in a way that benefit both teams :)
15:40:00 <TheJulia> So to summarize, it seems like we're not opposed to the idea. That we would prefer third party style, but that is also not a hard requirement. Does that summarize contributors feelings well enough?
15:40:03 <weshay> I say especially for ironic as ovb lends itself better to ironic testing
15:40:11 <dtantsur> TheJulia: precisely
15:40:15 <jroll> TheJulia: +1
15:40:40 <rloo> +1 (and as long as it doesn't take as long as our grenade jobs, so we aren't waiting for that test to finish)
15:41:00 <arxcruz|pto> so, ovb job, on third party, non voting for now, running ironic and testing ironic tempest plugins sounds good to everyone ?
15:41:29 <rloo> arxcruz|pto: i think that's a good start.
15:41:40 <dtantsur> ++ great plan
15:41:51 <arxcruz|pto> weshay: ^
15:41:55 <TheJulia> Sounds good, voting would need to be another discussion, but we can have that later once we have statistics
15:42:11 <weshay> +1
15:42:20 <weshay> who owns the ai?
15:42:21 <jroll> ++
15:42:28 <TheJulia> ai?
15:42:29 <jroll> ai?
15:42:31 <dtantsur> ai?
15:42:34 <weshay> lolz
15:42:35 <jroll> :P
15:42:36 <weshay> action item
15:42:38 <weshay> sorry
15:42:41 <weshay> pointy head here
15:42:51 <dtantsur> arxcruz|pto of course :D
15:42:51 <rloo> arxcruz|pto i think
15:42:55 <jroll> yep
15:42:55 <arxcruz|pto> TheJulia: sure, just to have it running on ironic, will help us to catch problems earlier
15:42:57 <arxcruz|pto> yes, me
15:43:04 <arxcruz|pto> I'll work this week on it
15:43:13 <dtantsur> cool, thanks arxcruz|pto
15:43:21 <arxcruz|pto> dtantsur: thanks too :)
15:43:24 <dtantsur> (and why aren't you on pto??)
15:43:25 <jroll> for a moment I had hopes we had built artificial intelligence to review changes
15:43:27 <TheJulia> #action arxcruz|pto to begin working on tripleo ci jobs using ironic reporting to ironic.
15:43:35 <dtantsur> jroll: it's me, no?
15:43:42 <arxcruz|pto> dtantsur: I forgot this meeting :)
15:43:50 <vdrok> need to run now, could someone also take a look at the following diff https://review.openstack.org/#/c/517921/3..4, it is about reporting resources as reserved vs deleting inventory during cleaning, maybe I am doing this wrong :)
15:43:50 <patchbot> patch 517921 - nova - ironic: Report resources as reserved when needed
15:43:51 <arxcruz|pto> i am supposed to be on pto
15:43:52 <jroll> dtantsur: lol, true. we need moar AI though!
15:44:07 <rloo> ciao vdrok
15:44:42 <TheJulia> code review AI as long as it +2's even with a hundred nitpicks.
15:45:06 <jroll> vdrok: thanks!
15:45:11 <TheJulia> So our other discussion item was regarding the backport of https://review.openstack.org/#/c/562314/
15:45:12 <patchbot> patch 562314 - ironic (stable/queens) - Remove vifs upon teardown
15:45:36 <dtantsur> arxcruz|pto: go then :) brewdog is calling!
15:45:46 <TheJulia> That was discussed a little earlier this morning between rloo, dtantsur, and myself. I'm presently drafting an email to the ops mailing list to run it past them/provide visibility
15:46:05 <rloo> Thank you TheJulia!
15:46:09 <arxcruz|pto> dtantsur: been there too many times this month already, edeka had a promotion of belgian beers ;)
15:46:19 <TheJulia> Moving to open discussion if there are no objections
15:46:57 <dtantsur> arxcruz|pto: oh :)
15:46:58 <rloo> There isn't anything wrong with that patch, except that it might break users (see upgrade note). Hence, my hesitation to land w/o more discussion/notice.
15:47:20 <jroll> so with that backport - what use case depends on the VIFs remaining attached? non-nova I guess?
15:47:48 <dtantsur> jroll: I cannot imagine, but it's an API behavior change
15:47:53 <TheJulia> jroll: manual ironic + neutron outside of nova
15:47:58 <dtantsur> so, in theory, we're breaking people
15:48:11 <jroll> TheJulia: yeah, okay
15:48:33 <jiapei_> +1
15:48:48 <jroll> this is very much a bug for nova users, used to hit similar all the time at rackspace
15:48:54 <jroll> leads to undeployable nodes
15:49:16 <TheJulia> Yup
15:49:33 <jroll> I'm okay with backporting it, with an email to the ops list
15:49:35 <TheJulia> If anyone wonders wehre my brain has been for the last two weeks, its been hunting bugs along these lines
15:49:45 <dtantsur> jroll: my position as well
15:49:46 <TheJulia> and the intertwined chaos they create
15:50:05 <TheJulia> #topic Open Discussion
15:50:11 <TheJulia> So what else do we have to discuss?
15:50:16 <jroll> I would suggest adding a config flag, but I don't believe people will see that and not see the email/release notes
15:50:16 <jiapei_> TheJulia: I uploaded a new patch https://review.openstack.org/#/c/561405/
15:50:17 <patchbot> patch 561405 - ironic - Fix XClarity parameters discrepancy
15:50:32 <jiapei_> Could you have a review of it? :)
15:50:32 <jroll> so not worth it
15:50:41 <TheJulia> With regards to storyboard, the new RFE's queue is starting to look sane, the untriaged queue is still crazy but I've been working on it.
15:51:15 <rloo> thanks TheJulia, for dealing with storyboard
15:51:22 <rloo> TheJulia: that reminds me, bug bash on Thursday
15:51:55 <TheJulia> jroll: yeah, I think the population using that scenario is extremely small, it is very rare for us to get people who are doing neutron integration with standalone seeking help so we do know they do exist :(  Then again, they might be happy since it might make their lives easier
15:52:27 <dtantsur> yep, detaching VIFs explicitly may be annoying
15:52:28 <jroll> TheJulia: makes sense
15:53:24 <TheJulia> #info Bug Bash Thursday!
15:53:38 <TheJulia> rloo: have call details been identified?
15:54:01 <rloo> TheJulia: i looked earlier today and i think mike wants you to do a hangout. sec...
15:54:02 <jroll> TheJulia: last email was asking if we can use your bluejeans, so no :)
15:54:29 <TheJulia> :(
15:54:35 * dtantsur can also provide bluejeans, if needed
15:54:35 <rloo> yup. is that ok TheJulia?
15:54:51 <rloo> we only need one pair of bluejeans :)
15:54:54 <TheJulia> What was time time?
15:54:59 <jroll> 9am eastern
15:55:08 <jroll> probably best to use dtantsur's
15:55:09 <rloo> 1-3pm UTC
15:55:35 <openstackgerrit> Merged openstack/ironic stable/queens: Collect periodic tasks from all enabled hardware interfaces  https://review.openstack.org/564201
15:55:59 <dtantsur> so, using mine?
15:56:23 <TheJulia> it looks like I have a call right before
15:56:28 <TheJulia> so either of us can do it I think
15:56:44 * dtantsur waits for the PTL's decision :)
15:56:53 <TheJulia> dtantsur: if you want to host it, that would give me the ability to hang on the other call preceeding it a little longer if it runs long
15:57:03 <dtantsur> TheJulia: okay, I'll do it
15:57:11 <TheJulia> thanks!
15:57:39 <TheJulia> Anyway, I think we are out of things to discuss today
15:57:45 <TheJulia> And we have two minutes left!
15:58:42 <TheJulia> Anything else for this meeting?
15:58:47 <rloo> crickets
15:58:58 <TheJulia> Thanks everyone!
15:59:26 <jroll> TheJulia: thanks for hosting :)
15:59:26 <TheJulia> #endmeeting