15:00:01 <dtantsur> #startmeeting ironic
15:00:02 <openstack> Meeting started Mon Jun 11 15:00:01 2018 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <openstack> The meeting name has been set to 'ironic'
15:00:12 <rloo> o/
15:00:13 * dtantsur waves
15:00:14 <etingof> o/
15:00:16 <stendulker> o/
15:00:17 <bdodd> o/
15:00:19 <jroll> \o
15:00:24 <hshiina> o/
15:00:27 <TheJulia> o/
15:00:33 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic our agenda for today
15:00:37 <dtantsur> looks pretty empty :)
15:00:40 <rpioso> o/
15:01:01 <dtantsur> #Announcements / Reminder
15:01:16 <dtantsur> #info Some releases to be requested this week
15:01:24 <dtantsur> I don't have a full list, will check what is needed
15:01:31 <dtantsur> TheJulia: anything else to announce?
15:01:39 <dtantsur> #chair TheJulia
15:01:40 <openstack> Current chairs: TheJulia dtantsur
15:02:13 * dtantsur assumes Julia is fighting the visa monster right as we speak
15:02:17 <TheJulia> Not that I have on my mind at the moment, aside from intent to try and release some things this week
15:02:27 <dtantsur> cool :) anyone anything else?
15:02:50 <TheJulia> S/monster/hydra/
15:02:55 <dtantsur> true
15:02:59 <dtantsur> #topic Review action items from previous meeting
15:03:09 <dtantsur> #link http://eavesdrop.openstack.org/meetings/ironic/2018/ironic.2018-06-04-15.00.html
15:03:16 <dtantsur> no action items apparently?
15:03:23 <jroll> we did good!
15:03:28 <dtantsur> indeed!
15:03:29 <yolanda> can i get reviews on https://review.openstack.org/#/c/568616/ again? i changed one deprecation bug
15:03:30 <patchbot> patch 568616 - ironic-tempest-plugin - Add manual clean step ironic standalone test
15:03:30 <jroll> yeah, was a short meeting
15:03:45 <dtantsur> yolanda: sure, after the meeting
15:03:49 <dtantsur> #topic Review subteam status reports
15:03:52 <yolanda> doh sorry
15:04:03 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard starting with line 164
15:04:50 <dtantsur> TheJulia: when the hydra is defeated, please elaborate on line 206 there
15:04:59 <dtantsur> "Operators are requesting network specific documentation"
15:05:13 * TheJulia sharpens sword
15:05:19 <dtantsur> heh
15:06:59 <dtantsur> TheJulia: can we remove the "Migrate to Storyboard" topic? while it's far from being perfect, the migration is done, we even have some basic bug stats
15:07:00 <rloo> wrt api versioning with nova. L230? Dmitry asked a question in patch 557850. Do we need to discuss?
15:07:00 <openstackgerrit> Derek Higgins proposed openstack/ironic master: WIP: Testing a basic zuulv3 job  https://review.openstack.org/573244
15:07:01 <patchbot> https://review.openstack.org/#/c/557850/ - python-ironicclient - Support per-call version: set_provision_state
15:07:36 <TheJulia> dtantsur: works for me
15:07:37 <dtantsur> rloo: good idea
15:07:51 <rloo> dtantsur: i didn't realize it was done. just update it saying it is done, (vs 'in progress')
15:08:14 <TheJulia> I’ve not seen the the question on the patch
15:08:28 <jroll> > After working with openstacsdk for some time and talking to Monty about all this stuff, I'm no longer sure this is the direction we should take. Can someone remind me why we cannot just deduce the correct microversion from the input?
15:08:53 <dtantsur> let's bring this on the open discussion, which is quite soon?
15:09:00 <jroll> sure
15:09:04 <rloo> dtantsur: wrt bugs then, L167. is that as of today?
15:09:29 <dtantsur> rloo: yep
15:09:36 <dtantsur> I was out for some time, so the diff is with May
15:09:50 <dtantsur> * out last Monday, I guess
15:09:56 <TheJulia> ++ to open discussion
15:10:00 <jroll> 241 untriaged out of 283?
15:10:01 <rloo> dtantsur: ok thx. i was ignoring those cuz i didn't realize they were actually updated!
15:10:11 <dtantsur> jroll: well, we have to mark them as triaged again..
15:10:17 <dtantsur> I guess this was not moved from LP
15:10:23 <jroll> oh.
15:10:26 <jroll> :|
15:10:29 <dtantsur> yep :(
15:10:36 <rloo> that seems... wrong. 241 out of 283 untriaged?
15:10:56 <dtantsur> rloo: it may be a bug in my tool, but it also may be that we don't have the "triaged" tag on things we triaged back in LP
15:10:57 <TheJulia> Also we had consensus that we needed to wave through them. It is a lot better than six underdogs untreated
15:10:58 <rloo> TheJulia triaged a lot of them. i find it hard to believe we only triaged 42 of them.
15:11:22 * jroll tries to figure out what autocorrect did that
15:11:26 <jroll> s/that/there/
15:11:35 <TheJulia> rloo: some were closed/already fixed
15:11:51 <TheJulia> Yeah, autocorrect hates me
15:11:52 * rloo sighs
15:12:10 <openstackgerrit> Merged openstack/python-ironicclient master: Power fault recovery: client support  https://review.openstack.org/556774
15:12:15 <dtantsur> I can double-check the tool next time
15:12:23 <dtantsur> (or anyone can, it's not much code)
15:12:37 <dtantsur> #link https://github.com/dtantsur/ironic-bug-report
15:12:58 <rloo> question about the NOTE at L268... what does it mean? someone needs to migrate the rest of the stuff into storyboard?
15:13:21 <dtantsur> I think the plan was to create a board per large effort
15:13:24 <dtantsur> kind of a trello board
15:13:31 <dtantsur> which is the way storyboard is supposed to be used
15:13:45 <dtantsur> (we use it still the old way, it's one of the sources of our problems with it)
15:14:04 <rloo> ok. not going to ask for an action item on that :)
15:14:09 <TheJulia> rloo: it was just tracking/visibility wise
15:14:49 <rloo> sambetts|afk: when you have a chance, would you please update the Cisco UCS status (L388ish).
15:15:01 <TheJulia> What dtantsur said
15:15:15 * etingof can take a look at dtantsur's ironic-bug-report tool
15:15:27 <dtantsur> etingof++
15:16:25 * rloo done with status
15:16:31 <TheJulia> 15 more people until I reach the hydra...
15:16:45 <dtantsur> can we remove "Queens high priorities"?
15:16:47 * rloo roots for TheJulia
15:16:54 <TheJulia> dtantsur: yes
15:16:55 <dtantsur> or is it there for historical purposes?
15:16:58 <dtantsur> okay
15:17:03 <rloo> dtantsur: nope. not until they get moved to storyboard
15:17:11 * etingof starts to think that TheJulia is trying to get Russian visa
15:17:12 <rloo> dtantsur: that's what that NOTE was about, right?
15:17:21 <dtantsur> rloo: Queens priorities? no, the NOTE is for current things
15:17:26 <TheJulia> I kept it originally to make sure we wrapped the queens stuff up
15:17:31 <dtantsur> it's line 300
15:17:57 <rloo> dtantsur: i thought it was for 'everything after this'. i mean, isn't that what storyboard is for? to track this stuff?
15:18:08 <TheJulia> It was separate
15:18:12 <dtantsur> rloo: I assumed that these things are mostly finished?
15:18:21 <dtantsur> Rescue has a nova part, but nova (IIRC) does not use SB
15:18:25 <TheJulia> I thought they were delineated with another note
15:19:01 <rloo> shall we discuss each of these now? we could.
15:19:40 <dtantsur> okay. Routed networks - done. Rescue - Nova+Tempest left. Zuul V3 is duplicated with line 276.
15:20:10 <jroll> let's delete the routed networks and zuul v3 at least then
15:20:11 <dtantsur> we could probably leave rescue with these two patches, but everything else can be removed, I guess
15:20:12 <rloo> i just looked at rescue patch (last ironic patch for rescue?) https://review.openstack.org/#/c/528699/. it links to launchpad, not storyboard. presumably we have a storyboard link for it, so it is being tracked so we can remove the rescue section?
15:20:13 <patchbot> patch 528699 - ironic-tempest-plugin - Rescue mode tempest tests
15:21:39 <TheJulia> rloo: because nova has not migrated
15:22:06 <TheJulia> Oh, our tempest, yeah the tag should get updated
15:22:24 <TheJulia> We can’t do anything until the nova portion lands
15:22:46 <dtantsur> right
15:23:19 <rloo> give me a sec, i'm adding a comment to storyboard for resuce, to include the stuff in whiteboard. then i'll delete from whiteboard.
15:24:36 <rloo> ok, i'm going to delete the rescue mode stuff. anyone disagree? (you have 3 secs)
15:24:50 <TheJulia> No disagreement
15:24:58 <jroll> +1
15:25:03 <rloo> gone
15:25:14 <rloo> what about the py 3.5 stuff?
15:25:21 <rloo> how are we tracking that in storyboard?
15:25:43 <rloo> or err maybe we should do this after/outside this meeting
15:27:14 <dtantsur> yeah, let's maybe clean up separately..
15:27:20 <dtantsur> I think openstack goals are tracked on SB now
15:27:24 <TheJulia> Py35 should have community wide tracking afaik
15:27:24 <dtantsur> globally
15:27:30 <dtantsur> yep
15:28:05 <TheJulia> 7 humans to the hydra
15:28:14 <rloo> so all that stuff wrt TODO, submit py3 job for IPA. is that in storyboard? or have we done it?
15:28:27 <rloo> do we create a subtask to track that?
15:28:36 <rloo> wow, TheJulia's line is moving fast!
15:28:38 <dtantsur> yes, we need a subtask on the main story
15:28:47 <dtantsur> I can do it, if needed
15:28:52 <rloo> someone want to do it? we can have an action item!
15:28:57 <rloo> thx dtantsur!
15:29:18 <dtantsur> #action dtantsur to make sure a task is present for IPA support of python 3
15:29:24 <dtantsur> anything else on statuses?
15:29:46 <rloo> inspector & wsgi stuff -- dunno what to do with that. can i leave it for you dtantsur to decide to delete or not from whiteboard?
15:30:01 <dtantsur> I will do the same - find the story and leave it there
15:30:18 <rloo> thx dtantsur!
15:30:22 <dtantsur> moving on?
15:30:26 <rloo> ++
15:30:58 <dtantsur> #topic Deciding on priorities for the coming week
15:31:06 <dtantsur> okay, some progress this week
15:31:35 <rloo> are the BIOS links ordered in priority?
15:31:57 * dtantsur puts OSC first
15:33:21 <dtantsur> power fault is done, wanna put the neutron events spec o nthe list?
15:33:51 <dtantsur> oh, so SB is not used for Pike-era goals
15:34:12 <dtantsur> ah, neutron even spec needs updates. vdrok are you on it?
15:34:42 <rloo> I am fine with what we have, i don't think we need to add more
15:34:51 <dtantsur> yeah, I guess it's good
15:34:54 <dtantsur> any opinions?
15:35:47 * dtantsur hears crickets and assumes they agree
15:36:17 <dtantsur> #topic Open Discussion
15:36:41 <dtantsur> so, ironicclient. blame mordred, he quite convinced me that we should stop exposing innocent souls to microversions.
15:37:06 <rloo> so i was thinking maybe we should defer this until TheJulia is 100% focussed on this.
15:37:07 <dtantsur> esp. for set_provision_state where we actually know which state (+ args) corresponds to which version
15:37:20 <dtantsur> fine, just want to raise it to more folks
15:37:38 <dtantsur> #link https://review.openstack.org/570895 is what I'm trying with openstacksdk
15:37:39 <patchbot> patch 570895 - openstacksdk - [WIP] Add set_node_provision_state to baremetal Proxy
15:38:37 <rloo> dtantsur: for now, shoudl we put a -2 or something so that client patch doesn't land? or does it matter whether it lands or not?
15:39:03 <vdrok> dtantsur: yeah, kind of, slowly progressing with local testing
15:39:07 <dtantsur> I have mixed feelings. We should have done this back in Kilo, and blocking it again....
15:39:25 <dtantsur> thanks vdrok. we may make it a priority next week then.
15:39:35 <rloo> dtantsur: is there anything wrong with landing it?
15:40:05 <dtantsur> rloo: wrong... well, I think we will commit to a much lower-level interface that I'd like to.
15:40:10 <rloo> i will come clean and say i actually don't know the details of this stuff.
15:40:12 <dtantsur> on the other hand, I cannot commit to change it all over ironicclient
15:40:33 <dtantsur> maybe let's leave it as it is (and then eventually bury it in favor of openstacksdk)
15:40:36 <rloo> could we use this lower-level interface for now, until we hae something to replace it?
15:40:40 <jroll> do we advertise python-ironicclient's python sdk to be high level?
15:40:40 <dtantsur> * leave it as it is = land the patch
15:40:57 <dtantsur> jroll: we don't either way, I think
15:40:58 <jroll> yeah that's what I'm leaning toward dtantsur, let openstacksdk be the higher level interface
15:41:21 <dtantsur> that's an option. if we agree on that, I'm fine with proceeding with this patch.
15:41:39 * jroll is okay with that, but would like TheJulia input
15:41:41 <dtantsur> we just have to be ready, after some time when openstacksdk reaches 1.0, to start telling people to use it
15:42:13 * dtantsur should probably stop using commas at all, at least until he gets a clue how to do in in English
15:42:18 <rloo> that makes sense to me. wonder what other projects think, cuz i think this is a good rule of thumb, and would like it if other projects did a similar thing.
15:42:32 <jroll> dtantsur: your commas were good there fwiw
15:42:38 <etingof> commas are even worse in Russian
15:42:42 <dtantsur> hah, guessed then! :D
15:42:43 <rloo> dtantsur: the commas there were good
15:42:49 <jroll> :)
15:43:00 <rloo> (one rule, if the stuff in the commas can be removed and the rest is a complete sentence)
15:43:04 * dtantsur tries to summon mordred again
15:43:16 * mordred runs in screaming and waving his arms around
15:43:19 <dtantsur> lol
15:43:24 * rloo runs away
15:43:37 * etingof is scared
15:43:37 <dtantsur> mordred: do you know if there is any kind of a general agreement to switch over to openstacksdk eventually?
15:43:39 <rloo> has the screaming stopped? :)
15:43:50 <dtantsur> hehe
15:43:52 <TheJulia> Ugh
15:44:12 <mordred> dtantsur: no - we haven't _generally_ agreed to that yet - it's just the thing I keep saying over and over hoping it'll gain traction
15:44:12 * dtantsur hopes that Ugh is related to TheJulia defeating the hydra
15:44:15 <TheJulia> If we’re not going to  expose it, I’ll go down back to re-writing our entire usage in nova...
15:44:28 <TheJulia> And we should revert my last patch to python-ironicclient
15:44:34 <mordred> I think we have a little more work to do before we can fully make that push
15:44:43 <dtantsur> TheJulia: not really. if we do what I think we should, we will just have a try..except block.
15:44:52 <TheJulia> But... there is no way that will likely ever land because we did awful things had been one
15:44:56 <dtantsur> mordred: like finishing microversions ;)
15:44:58 <mordred> but I like what you said earlier - don't try to change ironicclient- and at a point in the future we'll just migrate people over
15:45:02 <mordred> dtantsur: pish
15:45:07 <mordred> *details*
15:45:19 * TheJulia sighs
15:45:22 <rloo> (yeah, that's where the devil is, apparently)
15:45:24 <jroll> dtantsur: right, I think we (nova/ironic) agreed to not to the "try / except 406" thing in the last ptg
15:45:36 * TheJulia just wants consensus and to stop trying to reinvent the wheel over... and over... and over again.
15:45:39 <jroll> I think we should just move forward
15:45:43 <dtantsur> jroll: which is... precisely how microversions are supposed to work....
15:45:51 <jroll> we have a clear path to good code
15:45:53 <dtantsur> anyway. I'm fine with the patch. ship it!
15:46:04 <jroll> dtantsur: "how microversions should work" has changed at least a few times since they began :)
15:46:20 <dtantsur> jroll: and one of the changes was "let's not force SDK users to figure them out" ;)
15:46:35 <dtantsur> anyway, I think we have a consensus here?
15:46:42 <jroll> yeah, let's just do the damn thing
15:46:50 <dtantsur> #agreed Do the damn thing
15:46:50 <mordred> can I stop screaming and waving my arms in the air now?
15:46:53 <dtantsur> mordred: YES
15:46:56 <mordred> awesome
15:46:59 * mordred relaxes
15:47:00 <TheJulia> Lol
15:47:04 * dtantsur removes earplugs
15:47:06 <dtantsur> #undo
15:47:06 <openstack> Removing item from minutes: #agreed Do the damn thing
15:47:12 <TheJulia> Lol
15:47:41 <dtantsur> #agreed We will start supporting specifying microversions per call in ironicclient
15:47:46 <dtantsur> something like this?
15:47:54 <jroll> ++
15:48:15 <rloo> wasn't the RFE approved for that? :)
15:48:34 <jroll> how about #agreed don't change the plan yet again :P
15:48:39 <jroll> yeah, we've already agreed to it
15:48:50 <TheJulia> jroll: yes please
15:49:35 <dtantsur> :)
15:49:41 <dtantsur> anything else?
15:50:13 * jroll has nothing
15:50:23 * etingof is wondering how to attract people to his awesome virtualbmc patch....
15:50:36 <etingof> https://review.openstack.org/#/c/488874/
15:50:37 <patchbot> patch 488874 - virtualbmc - multiprocess server, ZMQ-based management cli tool
15:50:38 <jroll> beer and/or cookies usually work
15:50:43 <dtantsur> ++
15:50:52 <rloo> (screaming and waving hands doesn't work for some people)
15:51:13 <etingof> will you guys come to Brno some day?
15:51:15 * jroll just can't be bothered to review a giant patch to help people run a test tool in production :/
15:51:16 * dtantsur hears crickets screaming and waving hands
15:51:29 <dtantsur> etingof: will you man come to Berlin? ;)
15:51:34 <dtantsur> okay, okay, it's offtopic
15:51:40 <rloo> crickets
15:51:48 <dtantsur> jroll: tbh we have problems in the CI as well, and with long-running QE environments
15:52:01 <dtantsur> it's not only people shutting their legs
15:52:08 <dtantsur> ehmm.. shooting?
15:52:12 <jroll> lol
15:52:44 * dtantsur has a decorative plate saying "Today has been canceled. Go back to bed."
15:52:54 <dtantsur> so, thanks all :)
15:53:01 <dtantsur> #endmeeting