15:00:09 <TheJulia> #startmeeting ironic
15:00:10 <openstack> Meeting started Mon Aug 13 15:00:09 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <TheJulia> o/
15:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <openstack> The meeting name has been set to 'ironic'
15:00:19 <etingof> o/
15:00:23 <TheJulia> Good morning everyone!
15:00:25 <bdodd> o/
15:00:39 <baha> o/
15:00:43 <jroll> \o
15:00:45 <stendulker> o/
15:01:05 <w-miller> o/
15:01:08 <TheJulia> Our agenda can be found on the wiki!
15:01:10 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:20 <rloo> o/
15:01:25 <TheJulia> #topic Announcements / Reminder
15:01:35 <TheJulia> #info The Stein PTG is in 29 days!
15:01:59 <rpioso> o/
15:02:09 <TheJulia> #info Please remember to register and book your hotel room. The room block is expected to sell out.
15:03:14 <TheJulia> Our planning etherpad continues to grow with disussion. If there is something you'd like to see or discuss, please feel free to add or comment. I'll work on creating the schedule after the ?23rd?
15:03:20 <TheJulia> #link https://etherpad.openstack.org/p/ironic-stein-ptg
15:03:43 <dtantsur> o/
15:03:47 <kaifeng> o/
15:03:47 <mgoddard> o/
15:04:04 <TheJulia> #info Ironic 11.1 and all of our related projects were released last week. A giant thanks goes to everyone for their effort during the Rocky cycle.
15:04:38 <TheJulia> #info stable/rocky branches have been cut as a result of the rocky release, and we can begin accepting patches for inclusion in Stein to master.
15:04:59 <rloo> awesome, great work everyone!
15:05:24 <TheJulia> #info If there is a patch you feel requires being backported to rocky, please raise awareness.
15:06:21 <TheJulia> #info Next week during our weekly meeting we will have a discussion about ironic-staging-drivers. All cores please make every effort to attend, as I anticipate a vote being called.
15:06:57 <rloo> TheJulia: is the discussion a vote to keep it?
15:07:00 <TheJulia> That is it for Announcements/Reminders from my point of view. Does anyone have anything to raise or that they wish to announce?
15:07:27 <dtantsur> I think before we put up a vote, we should post something to the ML
15:07:51 <rloo> ++ (since I don't even know what the discussion is about, and I don't think we/ironic own that)
15:07:54 <TheJulia> dtantsur: I can post to the ML today
15:08:16 <jroll> dtantsur: +1
15:09:01 <TheJulia> If there are no objections, I'll post to the mailing list after the meeting.
15:09:02 <dtantsur> rloo: that's precise the question: should we own that
15:09:30 <rloo> dtantsur: ah, ok, i'll get out the popcorn :D
15:09:36 <TheJulia> rloo: good plan!
15:09:46 <dtantsur> :D
15:10:14 <TheJulia> #action TheJulia to send an email to the mailing list regarding ironic-staging-drivers.
15:10:33 <TheJulia> Anything else before we move on?
15:11:09 * TheJulia hears crickets in the background again ;)
15:11:09 <rloo> congrats to TheJulia for being our fearless leader again!
15:11:15 <TheJulia> rloo: thanks!
15:11:32 <TheJulia> s/fearless/crazy/? ;)
15:11:35 <rloo> we were all afraid to run against her ;)
15:11:40 <TheJulia> lol
15:11:48 <mjturek> o/
15:11:54 <TheJulia> \o
15:12:00 <TheJulia> Okay, I think we can move on
15:12:39 <TheJulia> Since there were no action items last week, we can skip directly to subteam status updates
15:12:50 <TheJulia> #topic Review subteam status reports
15:13:09 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:13:16 <TheJulia> Starting around line 180
15:14:34 <openstackgerrit> Jim Rollenhagen proposed openstack/bifrost master: Add doc/requirements.txt to releasenotes tox environment  https://review.openstack.org/591416
15:14:34 <openstackgerrit> Jim Rollenhagen proposed openstack/bifrost master: Allow extra packages to be installed with ironic  https://review.openstack.org/591417
15:14:43 <TheJulia> I didn't mention deploy steps because I didn't see a way to use it in the released client for cycle highlights, at least at a fast glance, so it feels like we have some more work to do there
15:15:16 <dtantsur> yeah, we need API to choose steps, more steps to choose from and finally deploy templates
15:15:20 <dtantsur> sounds like 1-2 cycles more
15:15:28 <jroll> yep, we just merged the backbone
15:15:38 <rloo> right, there isn't anything you can do wrt the deploy steps. not yet anyway.
15:16:29 <rloo> so i think deploy steps framework is done
15:16:59 <TheJulia> That was my refreshed recollection. I'm not suggesting we do that right now, I did put deploy templates spec on the list things that could use some eyeballs/braincells this week. :)
15:17:46 <TheJulia> rloo: ack, guess I concur sans api definition of what to do, but I'm sure we can get to that during Stein
15:18:08 <rloo> TheJulia: ah. ok. hmm, we should discuss whether we need another spec to decompose the one big deploy step into smaller steps.
15:19:13 <TheJulia> Yeah, that part is a little difficult, but maybe looking at deploy templates spec might create some bubbling juices in everyone's brains  ;)
15:19:41 <TheJulia> I think we're functionally done with bios interfaces for now. Would be nice to get the redfish one merged once people are happy with it.
15:19:56 <TheJulia> Refarch docs need work :(
15:21:47 <TheJulia> I proposed an admin-only doc, so we can at least hopefully make some more progress on that, it is currently in review.
15:22:14 <rloo> wrt bios interface, i think it is done. the redfish work is a separate RFE.
15:23:25 <rloo> jroll: conductor location awareness is done after the doc merges?
15:23:26 <jroll> ++
15:23:28 <jroll> yes
15:23:47 <rloo> nice, 3 done in a row :)
15:23:57 <TheJulia> Graphical console was basically "done" in terms of what we had for our goal for the cycle
15:24:02 <jroll> until sambetts pushes on his giant affinity craziness thing :D
15:24:21 <sambetts> ;)
15:24:32 <TheJulia> mkrai has started working on patches for graphical console, so we should be good to just let that proceed into stein
15:24:45 <openstackgerrit> Merged openstack/ironic master: Add conductor_group docs  https://review.openstack.org/589277
15:25:17 <openstackgerrit> Markos Chandras (hwoarang) proposed openstack/bifrost master: [DNM] Switch to Ansible 2.6  https://review.openstack.org/591420
15:25:20 <TheJulia> Neutron event processing and cleaning steps never made it out of spec review
15:25:29 <etingof> once we merge bios support in redfish driver, that would make the whole bios thing functional in ironic
15:25:37 <rloo> I'm good with the status reports
15:25:53 <rloo> we focus now on bug fixes, clean up?
15:26:24 <TheJulia> Specs and bug fixes
15:26:44 <TheJulia> etingof: \o/ that is great motivation for us to get that done.
15:27:42 <TheJulia> I expect our meetings until the PTG will mainly focus on spec review/discussion since we've largely wrapped the rocky cycle at this point.
15:28:07 <rloo> but we've branched, so we can start adding stuff into master, for the stein release, right?
15:28:13 <TheJulia> rloo: yes
15:28:53 <TheJulia> I also encourage picking up neat things that look abandoned or that have not had any attention and hacking it out... like splitting ipxe/pxe into separate interfaces, or at least starting that process ;)
15:29:03 <dtantsur> :)
15:29:43 <TheJulia> Anyway, we should look at priorities for the coming week!
15:30:17 <TheJulia> #topic Deciding on priorities for the coming week
15:30:25 <TheJulia> (since we were already heading in that direction of discussion
15:30:31 * TheJulia goes and cleans up merged things
15:31:40 <TheJulia> And so, I have a list of docs and specs, and some minor housekeeping changes aligning to the python3-first goal that I feel would be good to have on the list for the week, any objections?
15:32:18 <jroll> I'm fine with that, I'll be mostly downstream this week anyway, I think
15:33:46 <TheJulia> Anyway, given the time in the cycle, specs are naturally important for us going into this next cycle.
15:33:50 <TheJulia> anyway, list updtaed
15:33:52 <TheJulia> updated
15:33:53 <rloo> I'm fine, although that is a big list of specs :)
15:34:07 <dtantsur> lgtm
15:34:14 <TheJulia> rloo: I swap them around for next weke ;)
15:34:16 <TheJulia> week
15:34:18 <rloo> TheJulia: how do you decide which specs to list?
15:34:39 <TheJulia> rloo: I exclude my own and mostly just go down the list (although slightly randomly
15:34:41 <TheJulia> )
15:34:51 <TheJulia> status:open
15:35:06 <rloo> from newer specs? cuz we have over 100 I think?
15:35:49 <rloo> ok, not 100. maybe 20 or so.
15:36:19 <TheJulia> these are mostly in review ready or conceptually in a good place, I didn't want to list 20-something specs
15:36:47 <rloo> gotcha. and sigh, it is more than 20.
15:37:43 <TheJulia> them being review ready or recently updated means there is at least people and interest behind them. I figure it might be good to go through older orphaned items soonish
15:38:17 <rloo> just skimming; lots seem valid still. but another discussion :)
15:38:38 <rloo> I'm ready to move on
15:38:56 <TheJulia> yeah, they need eyes
15:38:56 <TheJulia> and button clicks, or git magic :)
15:39:04 <TheJulia> Anyway, since we have no discussion topics, I think we're good to move to open discussion
15:39:23 <TheJulia> #topic Open Discussion
15:40:22 <TheJulia> I feel like we need an ironic comic book.... ;)
15:40:26 * TheJulia is just being silly
15:40:30 <jroll> supercricket
15:40:47 * TheJulia wonders if there is a supercricket station on pandora
15:41:03 <jroll> I was thinking along the lines of a superhero :P
15:41:15 <TheJulia> Interesting!
15:41:29 <dtantsur> :D
15:41:35 * TheJulia should look for cricket stickers online....
15:41:49 <jroll> second mascot?
15:41:57 <TheJulia> dunno, but it could just be amusing
15:42:06 <TheJulia> Anyway, Thanks everyone!
15:42:39 <TheJulia> Have a wonderful week!
15:43:38 <TheJulia> o/
15:43:40 <TheJulia> #endmeeting