15:00:42 <TheJulia> #startmeeting ironic
15:00:43 <TheJulia> o/
15:00:43 <openstack> Meeting started Mon Nov  5 15:00:42 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:46 <etingof> o/
15:00:46 <openstack> The meeting name has been set to 'ironic'
15:00:52 <rpioso> o/
15:00:54 <kaifeng> o/
15:00:54 <vabada> o/
15:00:57 <arne_wiebalck_> o/
15:01:00 <iurygregory> o/
15:01:09 <rajinir> o/
15:01:10 <rloo> o/
15:01:20 <TheJulia> Good morning everyone!
15:01:24 <hshiina> o/
15:01:29 <dtantsur> o/
15:01:35 <hjensas> o/
15:01:36 <mjturek> o/
15:01:46 <jroll> \o
15:01:50 <TheJulia> We have a few things on our agenda this morning. As always, lets try to get through what we can and go from there
15:02:06 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:02:17 <TheJulia> #topic Announcements/Reminders
15:02:30 <TheJulia> dtantsur: I believe you have one regarding the team gathering in Berlin.
15:02:44 <dtantsur> #info Team gathering in Berlin: http://lists.openstack.org/pipermail/openstack-dev/2018-November/136255.html
15:02:55 <dtantsur> so, I booked a restaurant for us on Wednesday
15:02:59 <mgoddard> o/
15:03:11 <TheJulia> dtantsur: Awesome!
15:03:21 <TheJulia> dtantsur: calendar invites *ducks*
15:03:22 <TheJulia> ?
15:03:45 <dtantsur> I don't have everyone's email.. and I'm not strong in calendaring
15:03:52 <TheJulia> (This is a slight inside joke, because we're trying to find times that work and it is becoming impossible...)
15:04:05 <TheJulia> dtantsur: Okay
15:04:25 <dtantsur> oh yeah
15:04:39 <TheJulia> dtantsur: I think I saw you put it on the planning/ideas etherpad as well
15:04:48 <TheJulia> Which should be good
15:04:48 <dtantsur> I think I did
15:05:09 <TheJulia> #info Next week: Berlin Summit
15:05:33 <TheJulia> Does anyone else have anything to announce?
15:06:18 <rloo> no meeting next week or the following week?
15:06:30 * jroll supports this
15:06:42 <jroll> ah, there's a discussion topic for that later :)
15:06:47 <TheJulia> Indeed :)
15:07:05 <rloo> (oops, /me looks at agenda now...)
15:07:10 <TheJulia> #info PTL technically on vacation the week after the Summit
15:07:19 <TheJulia> jroll: That might help :)
15:07:28 <dtantsur> I can cover for you if needed
15:07:40 <TheJulia> dtantsur: awesome, I'll buy you a beer that day then :)
15:07:42 * jroll strikes "technically" and takes away the PTL's computer
15:07:47 <TheJulia> lol
15:07:55 <TheJulia> Anyway, I'm laughing, time to move on :)
15:08:02 <TheJulia> #topic Review action items from previous meeting
15:09:02 <TheJulia> Looks like we had no action items, moving on!
15:09:02 <TheJulia> #topic Review subteam status reports
15:09:02 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:09:06 <TheJulia> Starting around line 178
15:09:10 <TheJulia> err, 166
15:10:32 <TheJulia> Looks like we're making some good progress in getting reviews up for changing the CI jobs
15:10:57 <TheJulia> Upgrade checker status command got proposed as well which is awesome.
15:11:18 <dtantsur> the patch is quite straightforward and has 2x +2 (IIRC)
15:11:59 <TheJulia> Oh awesome
15:12:35 <TheJulia> I've not had any progress on the ipv6 stuff, I'm trying to stand up the same configuration locally in order to get packet captures.
15:12:37 * TheJulia adds that
15:13:50 <dtantsur> conductor role splitting - any help needed?
15:14:20 <dtantsur> oh, I should have put this into announcements, but: if you have any question re Berlin, feel free to ping me :)
15:14:29 <TheJulia> I think jroll was saying he was not going to have brain cells to devote to it until the new year.
15:14:36 <jroll> yep
15:14:58 <dtantsur> jroll: wanna throw it my direction?
15:15:13 <jroll> dtantsur: if you feel like it, my first step was going to be starting up an etherpad and thinking through what things the conductor is responsible for
15:15:25 <TheJulia> I suspect that  might be a good discussion topic after the operator feedback
15:15:43 <dtantsur> jroll: will do
15:15:50 <TheJulia> Because that will help guide us in terms of logical operational chunks/operator needs
15:16:28 <TheJulia> Looks like the neutron event processing spec has been revised, thanks vdrok_!
15:18:52 <TheJulia> Looks like everything has a current update
15:20:11 <TheJulia> As a general reminder, If the primary contacts are unavailable, and you have current status context, please feel free to update the status whiteboard.
15:20:22 <TheJulia> Anyway, I'm ready to move on. Everyone else?
15:20:35 <dtantsur> yep
15:20:46 <rloo> ++
15:21:05 <TheJulia> #topic Deciding on priorities for the coming week
15:21:13 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:21:18 <TheJulia> Starting at line 102
15:21:32 <TheJulia> Looks like a little clean-up is needed
15:21:51 <TheJulia> I figure we could add upgrade-checker if anyone doesn't approve that in the next couple minutes
15:21:53 <dtantsur> can we get https://review.openstack.org/#/q/topic:story/2003869 on list this time?
15:22:16 <TheJulia> I think that is reasonable
15:23:05 <TheJulia> I'd _really_ appreciate eyes on the smartnics spec before next week
15:23:13 <TheJulia> Considering we have a summit session on it
15:23:42 * dtantsur will try his best
15:24:31 * kaifeng have read but not clear about the use case
15:25:19 <TheJulia> kaifeng: Happy to try and provide clarity there
15:25:37 <TheJulia> kaifeng: Just need to understand your perspective, but that is likely best left for outside of the meeting time wise
15:26:05 <TheJulia> I guess I'm good with the list for the next week (or so...). Does anyone have anything that needs to be added?
15:26:39 <dtantsur> nope
15:27:19 * kaifeng will do
15:27:29 <TheJulia> Everyone good with the list?
15:28:03 * TheJulia hears crickets
15:28:12 <dtantsur> looks great
15:28:30 <TheJulia> Sadly my google assistant will only play the sound of a single cricket
15:28:42 <dtantsur> not wow
15:28:54 <jroll> you need a farm of google home devices, I guess
15:29:10 <TheJulia> jroll: already have that.... they work on concert....
15:29:25 <TheJulia> Anyway, Time to move on!
15:29:41 <TheJulia> #topic Discussion
15:30:00 <TheJulia> First topic: Do we have a meeting next week with the summit that week. Jroll also asks about the following week.
15:30:20 <dtantsur> RH has an employee party next Monday
15:30:23 <TheJulia> I will be unable to run a meeting next week because our meeting conflicts with the all day leadership meeting at the summit.
15:30:27 <dtantsur> I can chair the one after that
15:30:37 <dtantsur> (i.e. 19th)
15:30:39 <mgoddard> I think I'll be at the airport next week
15:31:07 <TheJulia> I'm guessing we don't want to next week, but there are no objections to the following week?
15:31:30 <jroll> I won't be here for the 19th either
15:31:52 <rloo> lets cancel the next two weeks then.
15:31:55 <TheJulia> As noted earlier, I'll be trying to take the following week off
15:31:59 <iurygregory> ++ to cancel
15:32:16 <TheJulia> Yeah, the following week is typically a holiday week in the states.
15:32:19 <rloo> cancelling will be less incentive for TheJulia to want to attend
15:32:23 <TheJulia> lol
15:32:24 <dtantsur> rloo++
15:32:28 <TheJulia> Okay, Okay!
15:33:01 <rloo> oh. is Nov 26 a holiday too in the US?
15:33:08 <TheJulia> #info Meetings for the next two weeks cancelled. Ironic meetings will resume on November 26th.
15:33:11 <rloo> black friday, something monday.. ?
15:33:37 <TheJulia> The 12th and 22nd are official US holidays
15:33:38 <persia> rloo: Also 11 November.
15:33:42 <TheJulia> Cyber Monday is what it is called
15:33:48 <jroll> rloo: not an official holiday, but many people take it off
15:34:07 <TheJulia> Yeah, and the banks are open. :)
15:34:07 <rloo> ok, well, if you aren't shopping online, then attend the meeting :D
15:34:13 <TheJulia> \o/
15:34:18 <jroll> oh, 26th, I think most people work. 23rd is what I was thinking of
15:34:19 <TheJulia> Okay, Next topic!
15:34:45 <TheJulia> Next topic on the list is clean_steps
15:34:47 <TheJulia> #link https://review.openstack.org/#/c/606199/
15:34:48 <patchbot> patch 606199 - ironic-specs - A fresh way of looking at step retrieval - 4 patch sets
15:35:00 <TheJulia> s/clean steps/step visibility
15:35:19 <TheJulia> I didn't want to schedule a special meeting for this, but given how things are ramping up this cycle, I think we should.
15:35:21 <TheJulia> Any objections?
15:35:59 <TheJulia> (Or we could discuss now, but we have several other items on the agenda
15:36:15 <dtantsur> I'd discuss it separately. a lot of small issues.
15:36:46 <rloo> i'm not prepared to discuss now. can discuss separately. just need time to get prepared.
15:36:59 <jroll> ++
15:38:06 <TheJulia> #action TheJulia to send out a doodle to try and find a time to discuss making clean/deploy steps visible to API users.
15:38:21 <TheJulia> Next topic!
15:38:36 <TheJulia> mgoddard: I believe this one is yours :)
15:38:46 <mgoddard> Yep
15:39:09 <mgoddard> The tenks repo has been created on git.o.o
15:39:59 <mgoddard> There was a change proposing to add the project to ironic governance which was abandoned until we make a decision
15:40:12 <mgoddard> Is that something we want to do?
15:40:14 <TheJulia> I believe we decided to proceed
15:40:22 <TheJulia> based upon discussion and spec reviews
15:40:38 <TheJulia> So I feel like the next action was for the governance change to be un-abandoned
15:40:40 <mgoddard> Ok, I'll restore that change, then add ironic-core to the tenks-core group
15:40:45 <mgoddard> right
15:40:47 <TheJulia> \o/
15:41:17 <TheJulia> Beyond that I guess there will be an attempt to begin integration in CI?
15:41:54 <mgoddard> right. jovial is looking at getting some CI up for the tenks repo itself
15:42:27 <mgoddard> he's almost finished integrating tenks with kayobe's CI, so we can test bare metal booting
15:42:34 <TheJulia> \o/
15:42:35 <TheJulia> Okay
15:42:55 <TheJulia> Sounds like we have a path forward, we'll just need changeset visibility if we need to land anything in ironic directly
15:43:02 <mgoddard> right
15:43:13 <TheJulia> Works for me. Everyone else?
15:43:23 <dtantsur> ++
15:43:42 <jroll> yep, sounds good
15:43:49 <mgoddard> I'd like to propose jovial for tenks-core. If it's too early to tell that's fine, but the plan is for him to be spending some good time on it
15:44:23 <dtantsur> I guess it's fine.. we need to bootstrap the group with some people who care anyway
15:44:23 <jroll> mgoddard: it's not in ironic governance yet, you can do whatever you want with the core team :P
15:44:43 <TheJulia> mgoddard: Also, even once in governance, we tend to give a little more flexibility to subteams :)
15:44:57 <mgoddard> jroll: true, although it's polite to ask :)
15:44:57 <TheJulia> mgoddard: tl;dr sure! :)
15:45:03 <mgoddard> great!
15:45:22 <TheJulia> I guess we're good to proceed
15:45:28 <mgoddard> is there anyone interested in coding or reviewing for tenks?
15:45:41 <TheJulia> I'm interested, but unsure if I can devote any cycles right now
15:46:08 <mgoddard> there are a few post proof of concept features we could start to look at in order to get to feature parity with devstack
15:46:09 <TheJulia> If there are things you guys would like another set of eyes on, please feel free to add me.
15:46:21 <jroll> I'm happy to help with reviews where pointed at, but not a lot of extra time atm
15:46:21 <mgoddard> sure
15:46:28 <dtantsur> ditto as jroll
15:46:29 <mgoddard> thanks
15:46:32 * jroll notes 13 minutes left
15:46:39 <TheJulia> Moving on!
15:46:43 * mgoddard takes the hint :)
15:46:48 <TheJulia> Next topic!
15:47:04 <TheJulia> I guess this is technically arne_wiebalck's
15:47:13 <TheJulia> But I added it...
15:47:14 <arne_wiebalck_> Right.
15:47:38 <TheJulia> arne_wiebalck_: would you like to talk about it?
15:47:42 <arne_wiebalck_> We’ve started to work on s/w RAID support and summarised things in a doc.
15:47:52 <TheJulia> #link https://docs.google.com/document/d/1a8Z-so4UPINCdJRhnxJrk4t7cXEyUAsVASyFBfKoV8M/edit
15:47:52 <arne_wiebalck_> The link is in the agenda.
15:48:01 <arne_wiebalck_> that’s the one
15:48:25 <arne_wiebalck_> The idea is to see if that is interesting for upstream and, if so, how to upstream this.
15:48:47 * dtantsur already expressed his interest
15:48:54 * TheJulia as well
15:48:55 <arne_wiebalck_> The point today is probably mostly to make people aware.
15:49:17 <TheJulia> It is the one topic that I think can be found on every feedback session we've ever run... so I think it would be good. :)
15:49:18 <arne_wiebalck_> Ok, cool :)
15:49:46 <arne_wiebalck_> What we’d like I guess is some guiding how to tackle this.
15:50:04 * chris_j excited about software RAID option
15:50:04 <arne_wiebalck_> We’re happy to spend some time on upstreaming.
15:50:25 <dtantsur> I guess it's a good case for a spec
15:50:31 <arne_wiebalck_> dtantsur: ok
15:50:49 <dtantsur> you can start with taking the google doc and putting it into a spec with reformatting
15:50:53 <dtantsur> then we can iterate
15:51:04 <TheJulia> I feel like we need to prioritize this. I think we are going to need a spec to at least kind of help provide the context, and hopefully help drive answers to any of the unknowns
15:51:18 <TheJulia> so yeah, what dtantsur said :)
15:51:32 <arne_wiebalck_> ok, happy to strart with that
15:52:05 <TheJulia> Everyone good with this topic?
15:52:13 <arne_wiebalck_> I am.
15:52:52 <TheJulia> Wow, there is a pandora station called "crickets"... sadly not crickets.
15:53:03 <jroll> ++
15:53:10 * TheJulia has been asking the google assistant about crickets. :)
15:53:14 <TheJulia> Final topic!
15:53:27 <TheJulia> CI resource consumption! Everyone's most fun topic
15:54:19 <TheJulia> I'm a little sensitive to the amount of time and resources used by our CI, largely because we lack a lot of parallelization and rely upon the same basic format to test some things we could consider changing in the tempest test to allow parallel or back-to-back slightly different feature integration tests.
15:54:55 <dtantsur> this will need some reorganization of our devstack plugin and/or tempest plugin
15:55:09 <dtantsur> currently we assume that all nodes are enrolled the same
15:55:22 <dtantsur> which is probably because we cannot (do not want to) influence the nova's decision to pick one of them
15:55:28 <TheJulia> I'd like to propose that we consider adopting some of our tests where we're doing single shot scenario integration testing and try and begin to leverage changing drivers, like the deploy interface between two tests so we don't have to pay the tax to setup what is essentially the same job multiple times.
15:55:45 <jroll> fwiw, we've tried doing parallel deploys, and if you think nested virt is slow today... oh boy
15:56:02 <dtantsur> even sequential deploys may be a relief
15:56:06 <jroll> indeed
15:56:09 <TheJulia> Well, we kind of already do that in the multinode jobs, I think we could do some of it standalone testing
15:56:12 <dtantsur> after all, the deploy itself takes like 5 mins, devstack takes 30
15:56:18 <TheJulia> since we don't need nova to validate a different deploy interface
15:56:28 <jroll> we could also just do multiple resource classes and multiple flavors to be able to choose a node easily
15:56:45 <dtantsur> right, that's what I mean by small changes to the devstack plugin
15:56:53 <jroll> indeed
15:58:23 <TheJulia> Does anyone have any thoughts to proceed with maybe doing such work? The reason I ask is because it would be good to avoid the end of cycle CI traffic that will occur.
15:58:52 <TheJulia> (Granted, that is a while away, but it would be good to head off so nobody is spending hours tending CI jobs
15:58:53 <TheJulia> )
15:59:56 <dtantsur> this is where the previous efforts on this got stuck :)
15:59:59 * TheJulia takes silence as a current no, but will raise the question again in a few weeks
16:00:03 <TheJulia> heh
16:00:05 <TheJulia> true.
16:00:16 <TheJulia> Okay, that gives me an idea of consensus versus volunteers.
16:00:19 <rloo> time to ask for a volunteer?
16:00:32 <rloo> maybe you'll meet someone at forum that wants to help out... (i can only hope)
16:00:37 <TheJulia> Perhaps!
16:00:49 <TheJulia> Speaking of which, there will be an onboarding session...
16:00:57 * TheJulia needs to get back to that deck
16:01:10 <TheJulia> Anyway, I guess we're nearly done for the day
16:01:13 <TheJulia> #topic Open Discussion
16:01:25 <TheJulia> Anyone have anything that they wish to raise today?
16:02:13 <rajinir> Is anyone hosting a ci-watch?
16:02:23 <rajinir> I see mmedvede did http://ciwatch.mmedvede.net/project?project=ironic&time=7+days
16:02:32 <rajinir> But not sure if it is permanent?
16:03:41 <TheJulia> rajinir: I've not chatted with mmedvede about what their plans are in the long terms, but I know they stood it up to begin collecting the data :)
16:03:41 * dtantsur has no idea
16:03:59 <dtantsur> also we're out of time :)
16:04:09 <rajinir> ok, thanks TheJulia
16:04:11 <TheJulia> For those that might not have caught it last week, the original ci-watch went down due to a change in employment it seems.
16:04:33 <TheJulia> That we are!
16:04:42 <TheJulia> Have a wonderful week everyone!
16:05:13 <TheJulia> Thanks
16:05:16 <iurygregory> \o/ wonderfull week yay
16:05:21 <TheJulia> #endmeeting