15:00:18 <TheJulia> #startmeeting ironic
15:00:18 <openstack> Meeting started Mon Nov 26 15:00:18 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:19 <TheJulia> o/
15:00:21 <openstack> The meeting name has been set to 'ironic'
15:00:22 <etingof> o/
15:00:22 <iurygregory> o/
15:00:23 <jroll> \o
15:00:27 <stendulker> o/
15:00:31 <bdodd> o/
15:00:32 <dnuka> o/
15:00:33 <TheJulia> Good morning everyone!
15:00:41 <TheJulia> Our agenda this week can be found on the wiki.
15:00:43 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic
15:00:47 <cdearborn> o/
15:01:04 <kaiokmo> \o
15:01:06 <TheJulia> #topic Announcements/Reminders
15:01:06 <rpioso> o/
15:01:11 <mgoddard> \o/
15:01:20 <kaifeng> o/
15:01:32 <TheJulia> #info Tenks is now under Ironic's governance!
15:01:38 <TheJulia> \o/
15:02:00 <rloo> o/
15:02:03 * dtantsur|mtg is lurking
15:02:30 <rloo> yah, tenk you for tenks
15:02:49 <TheJulia> #info The OpenStack summit was very positive, and there was lots of discussion about the future being baremetal clouds. As such things might get a bit busier in here. :)
15:03:10 <TheJulia> Does anyone else have an announcement or reminder that they would like to raise this week?
15:03:37 <dnuka> Hey everyone o/ You may have seen me hanging out in the IRC. So, I just wanted to introduce myself to the ironic team :) My name is Dhanuka (he/him), and I'm from Sri Lanka. I'm your Outreachy intern for the December - March round. I'll be working with my mentors dtantsur and etingof, on the sushy project. Thanks for being so welcoming and helpful community! Looking forward to contribute and learn
15:03:43 <dnuka> a lot :)
15:03:57 <TheJulia> dnuka: Welcome!
15:04:03 <iurygregory> welcome =)
15:04:20 <rpioso> dnuka: Welcome to ironic!
15:04:20 <dnuka> TheJulia , iurygregory thank you :)
15:04:24 <TheJulia> Anyone else?
15:05:02 <jroll> awesome, welcome dnuka :)
15:05:16 <TheJulia> Well, I guess we can move on then
15:05:22 <dnuka> thank you jroll :)
15:05:29 <openstackgerrit> Merged openstack/sushy-tools master: Make external dependencies optional  https://review.openstack.org/611859
15:05:31 <openstackgerrit> Merged openstack/sushy-tools master: Fix wrong `set_server_metadata` args  https://review.openstack.org/618110
15:05:31 <TheJulia> #topic Review action items from previous meeting
15:06:12 <TheJulia> Looks like I never got around to sending out a doodle for clean steps
15:06:33 <TheJulia> #action TheJulia to send out a doodle for clean/deploy steps visibility discussion
15:06:45 <TheJulia> Nothing besides that
15:06:47 <TheJulia> Moving on
15:07:03 <TheJulia> #topic Review subteam status reports
15:07:13 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:07:28 <TheJulia> Starting at line 165
15:07:34 <dnuka> thank you rpioso :)
15:09:37 <TheJulia> \o/ looks like we've made a little progress on switching over our jobs to be more python3 and zuul native where possible
15:09:59 <rloo> TheJulia: is the TODO L202&203 now covered by Python3First?
15:10:23 <rloo> TheJulia: actually, L204&205 too
15:10:50 <TheJulia> rloo: Those are more contextual, I guess we can delete the lines. 206 is totally status informational
15:11:12 <rloo> TheJulia: i was referring to the TODO above that :)
15:11:50 <rloo> TheJulia: oh, sorry, theTODO is part of Python3 First.
15:11:51 <TheJulia> We kind of mashed it all together for us to just get it done.
15:11:58 <TheJulia> Yeah
15:12:01 <TheJulia> no worries
15:12:45 <rloo> Great, the enhanced checksum support is done! (L224)
15:12:49 <TheJulia> hshiina: regarding UEFI first, I wonder if we could use/need a few more CI job or a new job that explicitly supports running UEFI
15:13:39 <TheJulia> kaifeng: is there anything else that your aware of that needs to be done regarding the checksum support? Or do you consider it done?
15:13:59 <kaifeng> I think it's done :)
15:14:59 <rloo> TheJulia: wrt smartnic support (L277). was there a discussion at forum, with neutron folks on it?
15:15:35 <TheJulia> rloo: extensive, I think from our standpoint our needs/required changes has largely been dialed back
15:16:03 <rloo> TheJulia: dialed back --> that could be good? :)
15:16:04 <TheJulia> I'll try and follow-up on that this week. Ive seen the patches have been revised in the last few days so there is hope they are already on track.
15:16:12 <TheJulia> rloo: yes, very good.
15:16:22 <rloo> :)
15:16:59 <TheJulia> etingof: How goes the task execution work?
15:17:50 <rloo> hmm, bug stats hasn't been updated since Nov 5. Do we care?
15:17:53 <TheJulia> Looks like graphical consoles is going to need more attention :(
15:18:02 <TheJulia> rloo: we've not had a meeting since nov 5th
15:18:11 <dtantsur|mtg> I'm too busy, sorry
15:18:19 <rloo> wow, how time flies!
15:18:22 <dtantsur|mtg> I'll get back to bug stats after the current week of meetings
15:18:29 <rloo> no worries dtantsur|mtg
15:18:33 <TheJulia> dtantsur|mtg: thanks!
15:18:33 <etingof> TheJulia, I have not worked on the tasks subsystem itself much lately, but I am quite optimistic concerning ipmitool killing patch - which should improve our most immediate problem
15:19:16 <TheJulia> It does look like one idea seems to have more support than the other, at least when I was glancing through reviewes earlier this morning
15:19:57 <rloo> if it is blocked cuz of lack of feedback, should we schedule a time to discuss? eg next Monday's meeting?
15:20:15 <rloo> or today if it is something that we can grok in 1-2 minutes...
15:20:36 <TheJulia> mgoddard: dtantsur|mtg: If there are only minor items on the spec, would there be a possibility of revising/reviewing and getting that moving this week?
15:21:54 <TheJulia> I think federation discussions likely need a resync from the summit as well.
15:22:06 <mgoddard> TheJulia: for which spec?
15:22:23 * dtantsur|mtg the same question
15:22:25 <TheJulia> deploy templates
15:22:26 <TheJulia> sorry
15:22:29 <mgoddard> ah
15:23:02 <dtantsur|mtg> I don't remember for sure, but I think nothing critical there
15:23:05 <mgoddard> yeah, I can try to get an iteration up this week, if not early next week
15:23:54 <TheJulia> if nothing is critical, could we just merge and approve the spec and revise it?
15:23:56 <mgoddard> not sure how well I understand the consensus around the design changes, but I'll bring those up in the spec
15:24:05 <TheJulia> (well, approve if we have consensus)
15:24:24 <TheJulia> mgoddard: that is a good question
15:25:14 <TheJulia> Looks like neutron event processing needs some eyes as well
15:25:35 <TheJulia> But there is no change there from the last meeting.
15:25:39 <dtantsur|mtg> I don't have time to revisit right now, sorry. I'd prefer mgoddard update it and we go from there.
15:26:30 <mgoddard> I'll do that. should have some time on a train tomorrow
15:26:31 <TheJulia> Okay, I'm just worried about the inherent cost of a -1 to reviews
15:26:40 <TheJulia> mgoddard: thanks!
15:27:19 <TheJulia> I'm done going down the list of priorities, is everyone else done and there are no questions seeking further clarification?
15:29:24 <TheJulia> I guess we're good to move on...
15:29:38 <TheJulia> #topic Deciding on priorities for the coming week
15:30:35 <openstackgerrit> Ruby Loo proposed openstack/ironic stable/rocky: Don't fail when node is in CLEANFAIL state  https://review.openstack.org/620086
15:33:17 <TheJulia> In shuffling around some of the items, it doesn't look like we have too many outstanding patches that are in a shape to receive reviews and potentially be merged this week :\
15:34:03 <TheJulia> I've trimmed and cleaned up the list. Is there anything anyone feels should be on the list of items to review this week?
15:35:21 <kaifeng> https://review.openstack.org/#/c/587698/ can use some eyes if nothing else
15:35:22 <patchbot> patch 587698 - ironic-inspector-specs - Configurable introspection data backends - 7 patch sets
15:36:16 <TheJulia> https://review.openstack.org/#/c/619683/ might be a cantidate as well
15:36:16 <patchbot> patch 619683 - ironic - Expose conductors: db and rpc - 2 patch sets
15:37:16 <kaifeng> there is another patch on the way, would be better if proposed
15:37:49 * etingof has quite a few pending patches against sushy-tools
15:37:51 <TheJulia> kaifeng: will you be re-ordering the patches then?
15:38:02 <TheJulia> etingof: priority list of 3 please :)
15:38:10 <bdodd> https://review.openstack.org/#/c/582314/ could use some eyes
15:38:10 <patchbot> patch 582314 - ironic - Add BIOS interface to Redfish hardware type - 7 patch sets
15:38:18 <kaifeng> no, this is the first patch, the second will be around api
15:38:54 <rpioso> bdodd: I'll place mine on it.
15:38:57 <TheJulia> kaifeng: ack, I went ahead and put that one on the list, and you can add the other once it is there
15:39:05 <TheJulia> bdodd:  Added
15:39:20 <bdodd> rpioso TheJulia - thanks!
15:39:58 <kaifeng> TheJulia thanks:)
15:40:39 <TheJulia> Ohh, I'm going to add https://review.openstack.org/#/c/616968/
15:40:39 <patchbot> patch 616968 - ironic - Let neutron regenerate mac on port unbind - 4 patch sets
15:40:44 <TheJulia> Since that is a bug fix
15:41:21 <etingof> TheJulia, my humble list: https://review.openstack.org/#/c/616998/  https://review.openstack.org/#/c/616998/  https://review.openstack.org/#/c/618112/
15:41:22 <patchbot> patch 616998 - sushy-tools - Fix UEFI firmware path and connection attribute in... - 6 patch sets
15:41:23 <patchbot> patch 616998 - sushy-tools - Fix UEFI firmware path and connection attribute in... - 6 patch sets
15:41:25 <patchbot> patch 618112 - sushy-tools - Fix HTTP response code on errors - 2 patch sets
15:41:30 <etingof> ah
15:41:39 <TheJulia> I guess one didn't copy?
15:41:45 <etingof> yep, hold on
15:42:15 <etingof> TheJulia, https://review.openstack.org/#/c/614316/
15:42:16 <patchbot> patch 614316 - sushy-tools - Fix libvirt driver to handle domains by UUID - 6 patch sets
15:42:50 <TheJulia> okay, added
15:42:56 <TheJulia> That looks like a healthy list for this week!
15:44:51 <TheJulia> Everyone good to proceed to discussion?
15:45:18 <rloo> ++
15:45:29 <TheJulia> #topic Discussion
15:45:55 <TheJulia> Looks like we have a single discussion topic from tonyb this week
15:46:16 <TheJulia> In regards to providing a path forward where a bmc does not support raw commands
15:46:37 <TheJulia> Looks like https://review.openstack.org/#/c/616053/ has a +2 and 2x+1
15:46:38 <patchbot> patch 616053 - ironic - Add ipmi_do_timeout_disable to avoid problematic I... - 4 patch sets
15:46:51 <TheJulia> and https://review.openstack.org/#/c/583488/ has a -1
15:46:51 <patchbot> patch 583488 - ironic - Continue to set boot device even if timeout config... - 2 patch sets
15:46:59 <TheJulia> Seems like consensus has already been built around the first one
15:47:07 * TheJulia is unsure there needs to be much  more of a discussion
15:48:03 <TheJulia> I'm going to go with what the consensus is behind for now, and we can go from there
15:48:14 <jroll> seems like kaifeng is even in favor of taking the first
15:48:16 <TheJulia> Anyone else have thoughts on this topic?
15:48:28 <jroll> (last comment in the second, and a +1 on the first)
15:48:33 <TheJulia> Yeah
15:48:42 <jroll> yeah, no discussion needed imo
15:48:43 <kaifeng> Yeah, I plans to base my patch on tonyb's
15:48:52 <kaifeng> er, s/plans/plan/
15:48:55 <TheJulia> kaifeng: I was kind of guessing that would be the next step :)
15:48:57 <TheJulia> sounds good to me
15:49:05 <TheJulia> I guess we can move on to Open Discussion
15:49:36 <TheJulia> #topic Open Discussion
15:49:57 <TheJulia> \o/ conductor group spec in nova merged
15:50:01 * TheJulia dances
15:50:51 <TheJulia> I don't really have anything else to discuss
15:50:52 <dtantsur|mtg> \o/
15:51:04 <TheJulia> Just starting to go through the tons of things from the last two weeks
15:51:14 <TheJulia> Does anyone have anything they wish to discuss?
15:52:11 * TheJulia guesses the answer is no :)
15:54:10 <TheJulia> Well everyone, Thank you!
15:54:25 <rloo> CRICKETS
15:54:43 <TheJulia> #endmeeting