15:00:31 <TheJulia> #startmeeting ironic
15:00:32 <openstack> Meeting started Mon Dec 10 15:00:31 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:36 <openstack> The meeting name has been set to 'ironic'
15:00:36 <jroll> \o
15:00:37 <rloo> kaifeng: the only one that can't be modified easilyis the name of the config option.
15:00:37 <kaifeng> rloo the name of ipmi_disable_timeout took from the other patch
15:00:37 <iurygregory> o/
15:00:41 <kaifeng> o/
15:00:42 <dnuka> o/
15:00:42 <bdodd> o/
15:00:45 <rpittau> o/
15:00:46 <etingof> \o
15:00:54 <dtantsur> o/
15:00:56 <rloo> o/
15:00:58 <rpioso> o/
15:01:02 <TheJulia> Good morning everyone!
15:01:09 <TheJulia> Looks like we have a very light agenda this morning.
15:01:15 <TheJulia> Our agenda, as always can be found on the wiki.
15:01:18 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:21 <stendulker> o/
15:01:31 <TheJulia> #topic Announcements/Reminders
15:01:54 <TheJulia> #info TheJulia is intending to cut a release of ironic 12.0.0 this week
15:02:35 <TheJulia> Anyone have anything they would like to announce this morning?
15:02:56 <cdearborn> \o
15:03:15 <dtantsur> I'll be on PTO starting next week and till January
15:03:29 <openstackgerrit> Merged openstack/bifrost master: Update devel info: mailing list  https://review.openstack.org/623475
15:03:47 <rloo> happy holidaze dtantsur!
15:03:51 * etingof will be on vacation till next year
15:03:52 <dtantsur> thnx :)
15:03:54 <TheJulia> dtantsur: awesome
15:04:03 * TheJulia should do this same vacation thing...
15:04:18 <rpittau> have fun dtantsur and etingof :)
15:04:36 <iurygregory> everybody should lol
15:04:48 <dnuka> :)
15:04:51 <TheJulia> We are winding down nicely for the end of the year :)
15:05:00 <rloo> TheJulia: the release of ironic -- any ohter ironic-related projects also getting a release?
15:05:14 <rajinir> o/
15:05:30 <TheJulia> rloo: likely a minor for sushy, rev for bifrost. I did IPA like two weeks ago
15:05:47 <rloo> great. thx TheJulia
15:05:48 <dtantsur> maybe stable releases?
15:05:48 <TheJulia> kaifeng: any thoughts on inspector?
15:05:57 <iurygregory> maybe python-ironic-inspector-client will need?
15:06:05 <rloo> did we ever do stable release for the upgrade bug?
15:06:22 <TheJulia> rloo: I _think_, I'd have to check
15:06:40 <TheJulia> I'll look at the stable branches and do the appropriate as well
15:06:44 <iurygregory> we add the check-errors flag to the client, not sure if will be necessary a release =)
15:06:48 <dtantsur> iurygregory++
15:06:59 <TheJulia> release all the things \o/
15:07:06 <rloo> release often!
15:07:06 <iurygregory> yay
15:07:15 <TheJulia> Anyway, since we have no action items this week, lets proceed to status updates
15:07:21 <kaifeng> TheJulia no outstanding issue in the inspector
15:07:40 <TheJulia> #topic Review subteam status reports
15:07:58 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:08:02 <TheJulia> Starting at line 233
15:08:24 <TheJulia> dtantsur: re federation, you were thinking of trying to sync after the first of the year right?
15:08:35 <dtantsur> yep
15:10:38 <TheJulia> dtantsur: same for ideas regarding possible further process splitting right?
15:10:54 <TheJulia> or the capability to launch smaller portions of the conductor is the way I should put it
15:10:54 <dtantsur> indeed
15:11:10 <TheJulia> How does everyone feel about doing a virtual midcycle in janurary?
15:11:36 * iurygregory never did, +1 for the idea =)
15:11:39 <dtantsur> ++ (esp. mid-January)
15:11:50 * jroll probably won't be around, so no feelings
15:12:02 * jiapei +1
15:12:07 * etingof +1
15:12:13 <TheJulia> I need to check my schedule because I think mid-January I think I'll have some metal tubing
15:12:36 <TheJulia> I guess that is an action item for me, to setup a doodle poll for us to figure out days
15:13:04 <iurygregory> yeah =)
15:13:05 <TheJulia> #action TheJulia to create virtual midcycle doodle poll
15:13:49 <dtantsur> yeah, end of January is devconf.cz, then FOSDEM
15:13:57 <TheJulia> re getting CI jobs changed over, I've been really struggling with getting the n-g-s and networking baremetal jobs changed over to use zuul based jobs and python3. If anyone wants to lend a hand, it would be appreciated
15:14:46 <iurygregory> i can try to help TheJulia o/
15:15:39 <TheJulia> iurygregory: okay, I'll try and sync up with you after the meeting to chat about them
15:15:46 <TheJulia> Everyone good with status updates for this week?
15:15:48 * rpittau can give a hand as well
15:15:52 <iurygregory> sure =)
15:15:57 <TheJulia> rpittau: much appreciated as well
15:16:48 * TheJulia takes silence as we can proceed to discussing some priorities for the next week
15:17:39 * TheJulia hears crickets
15:17:41 <TheJulia> #topic Deciding on priorities for the coming week
15:17:52 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:18:08 <TheJulia> Starting around line 113
15:18:17 <TheJulia> Looking at the list from last week, we got a lot merged
15:18:19 <TheJulia> \o/
15:18:26 * TheJulia proceeds with removing merged things
15:20:39 <TheJulia> Anyone aware of items that need reviews this week?
15:21:06 * iurygregory still working in push some patchs =)
15:21:16 <kaifeng> https://review.openstack.org/#/c/622862/
15:21:16 <patchbot> patch 622862 - ironic - Expose conductors: api-ref - 2 patch sets
15:21:31 <kaifeng> i guess if we need to cut a release, this one may need to have?
15:21:50 * etingof puts his Christmas wishes on the etherpad
15:21:50 <jiapei> Also this one https://review.openstack.org/#/c/624000/
15:21:50 <patchbot> patch 624000 - ironic - Fix XClarity driver management defect - 4 patch sets
15:22:09 <jiapei> which fix the xclarity driver defect
15:22:13 <TheJulia> kaifeng: it can land after since it is really for the api reference website which publishes master
15:22:14 <kaifeng> but it's rebased on the owner patch atm
15:22:38 <TheJulia> etingof: +++
15:22:52 <kaifeng> oh, that's fine
15:22:53 <dtantsur> looks good
15:24:05 <TheJulia> jiapei: I added that one to the vendor priorites list
15:24:31 <jiapei> TheJulia: Great :)
15:24:32 <TheJulia> jiapei: line 179
15:25:08 <TheJulia> I'm going to remove smartnic support from the review list as the author is still seeking feedback it seems
15:25:57 <TheJulia> How does everyone feel about the list?
15:26:37 <TheJulia> I suspect dtantsur's looks good comment was the list
15:27:21 <etingof> TheJulia, I think we should better replace the last patch for sushy-tools with this one -- https://review.openstack.org/#/c/614456/
15:27:22 <patchbot> patch 614456 - sushy-tools - Redirect to UUID URLs - 9 patch sets
15:27:34 <dtantsur> TheJulia: it was about the list, yes
15:27:44 <etingof> because they are lined up that way
15:27:56 <TheJulia> etingof: Oh, good catch, please update then
15:28:02 * TheJulia thought that one has been approved...
15:28:02 <etingof> axk
15:28:11 <TheJulia> Anyway, Time to proceed onward I guess
15:29:01 <TheJulia> #topic discussion
15:29:48 <TheJulia> One item, regarding CI job links. rajinir do you have an ETA to when links being posted will be valid again?
15:30:12 <rajinir> The website was down
15:30:24 <TheJulia> looks like xclarity's log server is down as well, the status notes indicate it is being worked on
15:30:25 <rajinir> It is up now, the logs are being synched now
15:30:28 <TheJulia> \o/
15:30:32 <TheJulia> rajinir: Awesome thanks!
15:30:43 <TheJulia> I guess with that, we can move to open discussion. \o/
15:30:47 <TheJulia> #topic Open Discussion
15:31:15 <kaifeng> i have one just before the meeting :)
15:31:19 <kaifeng> https://review.openstack.org/#/c/583488
15:31:19 <etingof> rajinir should I recheck my patches to get proper links?
15:31:20 <patchbot> patch 583488 - ironic - Introduce configuration option [ipmi]ipmi_disable_... - 5 patch sets
15:31:40 <rajinir> etingof, give it an hr.
15:31:42 <TheJulia> etingof: please use the dell syntax
15:31:50 <TheJulia> etingof: if rajinir is okay with it
15:32:19 <TheJulia> kaifeng: Yes, you said there was a comment from rloo but rloo seemed confused
15:32:37 <kaifeng> wrt ipmi_disable_timeout, rloo thought disable_ipmi_timeout is more suitable there
15:32:39 <rajinir> etingof,TheJulia, it must be just the logs, recheck may not be needed. I will make sure your patch links works after the sync
15:32:55 <etingof> rajinir++
15:32:55 <rloo> kaifeng: i think i said 'disable_boot_timeout' ?
15:32:56 <TheJulia> How does everyone feel about meetings later this month? Looking at the work we've accomplished recently we seem to be winding down for the year. I guess we'll see bug fixes and some minor feature work. Seems like we're going to be getting into another feature patch period for most of us
15:33:08 <rloo> kaifeng: or maybe i mistyped. let me see.
15:33:55 <TheJulia> I think ipmi_* is more consistent with other field names
15:34:12 <rloo> kaifeng: ah yes. so the node's driver_info has 'ipmi_disable_timeout' which disables the 60-sec timeout for booting. It worries me that/if we add another timeout, it won't be clear what this disable-timeout is for.
15:34:41 <rloo> so i don't know if it makes sense (ie inconsistent) to name the config option 'disable_boot_timeout' so it is clearer.
15:35:03 <rloo> and given that it is in the [ipmi] group, I see no reason to have 'ipmi' in the config option name (that is an aside though)
15:35:15 <rloo> anyway, i was just wondering about it.
15:35:28 <TheJulia> rloo: but the same name is also a driver_info name as well
15:36:01 <rpittau> TheJulia, I believe if we skip next monday we're going directly to january 7
15:36:18 <rloo> TheJulia: right, that's what i mentioned above. or if you mean the 'ipmi' part, i didn't have time to look, but i believe we have another vendor with driver_info stuff and their config options omit the prefix (i forgot which vendor)
15:36:21 <kaifeng> that was the initial thought, yeah, be consistent to some extend
15:37:30 <rloo> i haven't been paying much attention, don't know how long we've had the driver_info name -- is it possible/easy to change both. and/or are folks ok with existing name? This is just my opinion.
15:38:06 <TheJulia> I'm okay with the existing name, I do concur the descriptive text could use a slight little work in follow-up
15:39:01 <stendulker> I think rloo's suggested name looks better. The driver_info name was also recently introduced.
15:39:58 <stendulker> driver_info anme was introduced as part of https://review.openstack.org/#/c/616053
15:39:58 <patchbot> patch 616053 - ironic - Add ipmi_disable_timeout to avoid problematic IPMI... (MERGED) - 7 patch sets
15:42:14 <TheJulia> I feel like we've already committed to that, and the only thing kaifeng's patch really does is add it so it can be conductor default
15:42:18 <TheJulia> via ironic.conf
15:42:32 <rloo> wrt the prefix in the config option name. irmc I think has a bunch of config options that might be used instead of driver_info ones, the config options do not have 'irmc_' prefix.
15:42:35 <TheJulia> stendulker: thanks for finding thta so quickly
15:43:17 <rloo> [I also see that the driver_info descriptions for irmc do not mention the config options :-(]
15:43:31 * TheJulia is confused
15:43:57 <rloo> TheJulia: did i confuse you?
15:44:12 <TheJulia> rloo: I think we're on a tangent
15:44:22 <rloo> ?
15:44:40 <rloo> i mentioned two issues with the naming of that configuration option.
15:44:47 <kaifeng> i prefer to omit the ipmi_ prefix in the configuration options, open for any names (really not good at that :)
15:46:07 <rloo> (did people want me to recap/rephrase?)
15:46:14 <TheJulia> rloo: but your also trying to relate to something that I see in multiple drivers driver_info field options and some configuration options
15:46:34 <TheJulia> rloo: please, start from the top
15:47:09 <rloo> proposal: instead of the configuration option in the [ipmi] group being 'ipmi_disable_timeout', how about 'disable_boot_timeout'. Why?
15:47:10 <TheJulia> kaifeng: we already merged the initial patch, I'm really confused why we're talking about changing the option name again
15:47:30 <TheJulia> oh, just in ironic.conf?
15:48:00 <rloo> 1. for config options that correspond to driver_info['vendor_xxx'], we don't tend to use the vendor prefix in the config option name, so we'd use just x.
15:48:01 <TheJulia> we're not talking about anything else, correct?
15:48:38 <rloo> 2. in this case, i feel that 'disable_timeout' isn't that specific, esp if in the future, we add another timeout for ipmi, so instead of 'disable_timeout' am thinking 'disable_boot_timeout'.
15:48:53 <kaifeng> TheJulia technically, it's not merged yet, since rloo has concerns i think we could discuss if there is a conclusion to decide whether or not update it.
15:48:59 <rloo> so 2 is inconsistent with the driver_info name 'ipmi_disable_timeout'.
15:49:29 <rloo> 1 is reasonable/easy to change. unless folks really think the config option needs 'ipmi_' for some reason.
15:50:54 <TheJulia> Okay, So then I concur can drop ipmi for the setting in ironic.conf
15:51:09 <jroll> I do agree that disable_timeout is a confusing name, especially considering we already have a command_retry_timeout. I'd even be +1 on the driver_info option being ipmi_disable_boot_timeout for the same reason.
15:51:23 <dtantsur> yeah
15:51:24 <TheJulia> rloo: when your saying config option, I just want to make sure your purely talking about ironic.conf configuration options, and not driver_info configuration options
15:51:46 <rloo> TheJulia: yup, 'config option' == ironic.conf options.
15:51:48 <TheJulia> jroll: ditto
15:52:13 <TheJulia> Okay, so that is where I was confused at because that was not crystal clear to me
15:52:15 <rloo> and yes, if we could, i'd prefer changing the driver_info entry name as jroll suggests
15:52:34 <TheJulia> I think that is fine, if someone reaches out to tonyb first
15:52:54 <TheJulia> err, but then I can't cut ironic 12.0 until this is worked out
15:53:56 <jroll> changing something like this within a release is acceptable per stable policy, last I checked
15:53:58 <TheJulia> I can chat with tonyb if he has concerns
15:54:15 <jroll> we can always deprecate and remove later if we're anxious to release 12.0
15:54:40 <TheJulia> jroll: indeed, I think tony just needs a heads up. We've got three of us on the same page to rename the options
15:54:52 <TheJulia> I think we can go ahead and put that patch up asap, and go from there
15:55:09 <TheJulia> 5 minute warning
15:55:34 <jroll> ok.
15:55:47 <rloo> thx everyone and sorry for the confusion.
15:55:53 <TheJulia> rloo: thank you
15:56:22 <TheJulia> kaifeng: I removed my wf+1 on the patch
15:56:51 <kaifeng> so the name in the driver_info would be ipmi_disable_boot_timeout, and the name in the conf would be disable_boot_timeout, right?
15:57:08 <TheJulia> kaifeng: correct
15:57:10 <kaifeng> TheJulia: no worries
15:57:38 <jroll> ++
15:57:53 <kaifeng> i update the patch tomorrow, if that's is not asap, feel free to help :)
15:57:59 <TheJulia> rpittau: you raised an awesome point that if we cancel next week's meeting, we won't reconvene until Janurary 7th.
15:58:15 <TheJulia> kaifeng: I might, if I have time this morning
15:58:21 <TheJulia> kaifeng: have a wonderful night's sleep
15:58:44 <kaifeng> TheJulia: thanks :)
15:59:03 <TheJulia> Re cancelling holiday meetings, I guess I'm okay with cancelling the 17th, 24th, and 1st. As long as we keep the priority list rolling for the purposes of visibility. Kind of like how we did ?last year?
15:59:38 <rloo> ^^ 1st == 31st, right?
15:59:48 <TheJulia> yeah, sorry
15:59:49 <rloo> ++ good otherwise :)
16:00:23 <jroll> +1 from me
16:00:24 <rloo> do we need some place to record who is avail in case we have any emergencies and need eg +2s?
16:00:28 <TheJulia> Well, I expect many new feature-ish patches to review in January :)
16:00:54 * jroll can be pinged on hangouts or email, I'll at least respond even if I can't help immediately
16:01:05 <TheJulia> I can also be as well, I don't think that will really be an issue
16:01:10 <rloo> i know we've gone through other holidays in the past, my memory must be going ;)
16:02:26 <TheJulia> seems we're good with cancelling the meetings and letting priorities roll forward as needed, emergency contacts are available if needed, but people will need to raise that visibility
16:02:36 <TheJulia> I'll send an email after the meeting
16:02:52 <rloo> thx TheJulia! (and time's up!)
16:02:59 <TheJulia> Yup!
16:03:01 <TheJulia> Thanks everyone!
16:03:09 <jroll> thanks :)
16:03:11 <iurygregory> tks o/
16:03:14 <TheJulia> Have a wonderful week, and if we don't chat again, see you all in the new year.
16:03:16 <stendulker> thanks
16:03:17 <rpittau> thanks :)
16:03:22 <TheJulia> #endmeeting