15:00:36 <TheJulia> #startmeeting ironic
15:00:36 <openstack> Meeting started Mon Feb  4 15:00:36 2019 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:40 <TheJulia> o/
15:00:41 <openstack> The meeting name has been set to 'ironic'
15:00:43 <dnuka> o/
15:00:43 <iurygregory> o/
15:00:45 <rpioso> o/
15:00:50 <arne_wiebalck_> o/
15:01:00 <bdodd> o/
15:01:32 <TheJulia> Our agenda can be found on the wiki.
15:01:35 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:38 <rloo> o/
15:01:41 <jroll> \o
15:01:52 <TheJulia> Seems fairly minimal.
15:02:01 * iurygregory omg jroll is back XD
15:02:06 <jroll> omg! :)
15:02:10 <TheJulia> #topic Announcements/Reminders
15:02:30 <mgoddard> o/
15:03:08 <TheJulia> #info We have approximately one month until the client libraries freeze for OpenStack. Please be mindful of this when doing reviews.
15:03:12 <TheJulia> #link https://releases.openstack.org/stein/schedule.html
15:03:23 <tendulke> o/
15:03:45 <rpittau> o/
15:03:56 <TheJulia> Also, I guess, I'm back after being in in-person meetings last week. :)
15:04:14 <TheJulia> Does anyone have anything they would like to announce or remind us of?
15:04:55 <bfournie> o/
15:05:16 <TheJulia> I guesss not!
15:05:39 * TheJulia announces that she cannot spell
15:05:45 <TheJulia> Moving on then!
15:06:01 <TheJulia> #topic Review action items from previous meeting
15:06:39 <TheJulia> It looks like no action items were recorded in last week's meeting notes.
15:06:41 <TheJulia> #link http://eavesdrop.openstack.org/meetings/ironic/2019/ironic.2019-01-28-15.00.log.html
15:07:39 <TheJulia> I do have one action item, I still need to send out notes from our midcycle call the week before. Hopefully in the next couple days once I'm over conference/travel plague.
15:07:52 <TheJulia> #action TheJulia needs to send out summary from mid-cycle call
15:08:18 <TheJulia> Onward to Subteam status reports!
15:08:24 <TheJulia> #topic Review subteam status reports
15:08:33 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:08:47 <TheJulia> Starting around line 245
15:10:00 <TheJulia> rpittau: I think you have another patch linked for tinyipa to use python3.6, if you have that link handy could you update the python3 notes
15:10:24 <rpittau> TheJulia, sure!
15:10:34 <rpittau> it's a little bug in the agent
15:10:50 <TheJulia> rpittau: what do you mean?
15:11:03 <rpittau> I mean that the agent will never stop if running with python3
15:11:15 <rpittau> https://review.openstack.org/#/c/634646/
15:11:16 <patchbot> patch 634646 - ironic-python-agent - Making ironic-python-agent able to stop with pytho... - 1 patch set
15:11:23 <TheJulia> Sweet
15:11:55 <cdearborn> o/
15:11:56 * TheJulia adds to the list of items to review
15:13:12 <TheJulia> Looks like uefi related docs needs some reviews. The contributors working on that are not around right now, but I'll add it to the review list if there are no objections.
15:14:42 <TheJulia> I've not had time to continue on with HTTPClient booting because I see it as largely refactoring some of our dhcp code
15:15:11 <TheJulia> And I want a v6 url based boot CI job. I was close before I had to travel like 3 weeks ago. Hopefully I'll be able to pick this up again soon.
15:15:30 <TheJulia> jroll: Any word on nova conductor awareness stuffs?
15:16:01 <jroll> TheJulia: first day back today, but plan on getting it done in the next two weeks
15:16:14 <TheJulia> jroll: awesome! Welcome back!
15:16:30 <jroll> thanks! :)
15:17:55 <TheJulia> Re DHCP-less/L3 vmedia work. I'm afraid that is essentially stalled right now. If we can get Booting from a URL sorted though and something like UEFI images to test with... then maybe it is viable to develop entirely upstream in our CI infrastructure.
15:19:31 <TheJulia> mgoddard: Are you going to have any cycles to get back to deploy templates relatively soon?
15:20:44 <mgoddard> TheJulia: not this week, hopefully next week. I think I'm confident enough in the first patch to remove the WIP tag
15:21:37 <TheJulia> mgoddard: Okay. I kind of felt the same way when I looked at it, but it is also in merge conflict. arne_wiebalck_ also had a comment which I've not seen yet
15:22:22 <mgoddard> I'll take a quick look later today and clean it up
15:22:31 <TheJulia> Graphical console interface needs reviews it looks like
15:22:36 <TheJulia> mgoddard: <3
15:24:17 <TheJulia> rpittau: Regarding graphical console, the next step seems to be the actual conductor/rpc/api work.  Nisha with HP did jump into IRC and expressed interest a few days ago, so it might be good if we get an email going. Would you be up for sending an email to her?
15:25:30 <rpittau> TheJulia, sure, do you have time afterwards to discuss details ?
15:25:41 <TheJulia> It looks like etingof's task exec improvements merged. I'm suspecting we should consider it done for now.
15:27:06 <TheJulia> rpittau: sure
15:27:23 <TheJulia> I guess I'll contact etingof and inquire how he feels re task execution
15:27:45 <TheJulia> jroll: Where are things standing re ipa/conductor comm work you were looking at?
15:28:17 <jroll> TheJulia: I haven't started on it, would be surprised if it makes stein but will evaluate over the next week
15:28:32 <TheJulia> jroll: Thanks!
15:29:35 <TheJulia> hjensas has picked up the event processing work. Sounds like he is making progress, and the patches are already on the list of things to be reviewed so \o/
15:30:10 <TheJulia> And it looks like smartnic work is proceeding, but also needs reviews.
15:31:26 <TheJulia> Are we good to proceed forth to deciding priorities for the coming week?
15:32:39 <TheJulia> I'm going to take silence as a yes.
15:32:44 <TheJulia> #topic Deciding on priorities for the coming week
15:32:53 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:33:06 <TheJulia> Staring around line 155
15:33:28 <mgoddard> would be nice to add the first deploy templates patch
15:33:50 <TheJulia> I concur
15:34:24 <TheJulia> We've got a lot in flight that touches the internals, so it would be good to make sure we've got good visibility over the next few weeks
15:34:45 <TheJulia> mgoddard: if you have the link handy, please add. I'm double checking patch status
15:34:52 <mgoddard> sure
15:35:25 <arne_wiebalck_> mgoddard: I started to have a look, but the patches are quite substantial :)
15:37:19 <mgoddard> arne_wiebalck_: all comments are welcome
15:37:30 <TheJulia> Indeed with many or the major changes. I kind of wonder if planning a co-ordinated review day or time window would be helpful?
15:39:43 <TheJulia> I think the list of priorities is also becoming a consolidated what is out there to review list as we approach the end of the cycle. That kind of always happens though
15:40:04 <TheJulia> Anyway, I'm good with the list as-is. I'd really like to have a shorter list for next week
15:41:25 <TheJulia> Everyone else good with the list?
15:41:50 * TheJulia gets out the crickets
15:42:08 <mgoddard> +1
15:42:45 <TheJulia> Okay. It looks like the only discussion item was actually raised last week, so we can go ahead and skip to open discussion if there are no objections.
15:43:37 <TheJulia> Moving to Open Discussion
15:43:44 <TheJulia> #topic Open Discussion
15:43:49 * TheJulia makes everyone coffee
15:43:52 <iurygregory> o/
15:43:55 <rpittau> \o/
15:44:01 <TheJulia> heh
15:44:07 <dnuka> \o/
15:44:20 <iurygregory> i have 2 topics for open discussion =)
15:44:28 <TheJulia> iurygregory: you have the floor
15:44:36 <iurygregory> ty
15:45:22 <iurygregory> 1st tl;dr what everyone think about a bot to post about CI failures 2 or 3x per day?
15:46:19 <iurygregory> during some internal meeting we had this idea since we are having some random failures, having a story with the problem and a bot could be a way to get more help to debug the CI
15:46:30 <iurygregory> it was hjensas|afk idea =)
15:46:39 <TheJulia> iurygregory: I'm intrigued. There is the ci-watch page, but it is often hard to parse through it since it requires digging. A bot could be fairly handy since it could take care of some of the logic to dig a little further
15:47:15 <TheJulia> I have no objections, you may want to raise the question with the infra folks
15:47:44 <iurygregory> since we are fine i will see about that with infra now =D
15:48:14 <TheJulia> Okay
15:48:27 <TheJulia> What else?
15:48:30 <iurygregory> 2nd is about the online data migration, did you got any answer TheJulia (you ping someone during the midcycle) so we could have some feedback
15:48:31 <iurygregory> =)
15:48:56 <TheJulia> iurygregory: I kind of got an answer which was seemingly more confusion
15:49:05 <iurygregory> D:
15:49:49 <iurygregory> so maybe we need to discuss how it should be done right?
15:50:00 <TheJulia> tonyb: When your around, lets chat about the work we've done to migrate/delineate ipxe/pxe since your hybrid deployment scenarios are likely the most impacted
15:50:35 <iurygregory> #link https://review.openstack.org/#/c/631178/
15:50:36 <patchbot> patch 631178 - ironic - Online Data Migration for boot_interface - 4 patch sets
15:50:52 <TheJulia> iurygregory: yeah, I just pinged tonyb to try and see if we can collect his thoughts on if we should migrate, or if we should just assume [pxe]ipxe_enabled=true means that s/pxe/ipxe/g in the database
15:51:10 <iurygregory> TheJulia, ack =)
15:51:17 <iurygregory> tks, thats all for me
15:51:20 <TheJulia> My gut feeling is most deployments will be running one or the other way.
15:51:47 <TheJulia> Opt-in has been historically our other route, but we've also seen how that can sometimes go sideways
15:51:55 * TheJulia is unsure
15:52:03 <TheJulia> Anyway, does anyone else have anything to dsicuss?
15:52:59 <TheJulia> I guess the only thing I have to mention is there is discussion of starting a baremetal sig.
15:53:01 <TheJulia> #link https://etherpad.openstack.org/p/bare-metal-sig
15:53:31 <TheJulia> I guess that will likely see more discussion over the next few weeks.
15:53:38 <TheJulia> Anyway, if nobody has anything else, thanks everyone!
15:53:58 <iurygregory> ty o/
15:54:04 <rloo> crickets... thanks TheJulia!
15:54:04 <rpittau> thanks!
15:54:11 <rpioso> TheJulia: Feel better :)
15:54:14 <dnuka> o/
15:54:33 <TheJulia> rpioso: thanks! :)
15:54:50 <TheJulia> #endmeeting