15:00:02 <dtantsur> #startmeeting ironic
15:00:03 <openstack> Meeting started Mon Mar 11 15:00:02 2019 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <openstack> The meeting name has been set to 'ironic'
15:00:16 <bdodd> o/
15:00:17 <iurygregory> o/
15:00:18 <dtantsur> how's up for some ironic talk?
15:00:18 <rpioso> o/
15:00:20 <hjensas> o/
15:00:22 <dnuka> o/
15:00:23 <mgoddard> \o
15:00:23 <arne_wiebalck> o/
15:00:23 <rpittau> o/
15:00:24 <etingof> o/
15:00:26 <kaifeng> o/
15:00:45 <dnuka> good morning etingof :)
15:00:59 <dtantsur> Welcome folks :) Our agenda can be found where always:
15:01:01 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
15:01:13 <stendulker> o/
15:01:22 <cdearborn> o/
15:01:41 <dtantsur> #topic Announcements / Reminder
15:01:54 <dtantsur> #info Soft feature freeze is upon us
15:02:06 <dtantsur> We don't plan on completely blocking everything that looks like a feature
15:02:13 <dtantsur> but please be very considerate when approving things
15:02:23 <dtantsur> especially if these things add API/RPC versions
15:02:44 <dtantsur> please concentrate on finishing Stein work, fixing bugs, updating docs
15:03:06 <dtantsur> #info Jobs are being switched to Bionic, help needed with two jobs on https://review.openstack.org/#/c/642015/
15:03:07 <patchbot> patch 642015 - ironic - Move all testing to Bionic - 2 patch sets
15:03:24 <dtantsur> if I understood jroll correctly, the UEFI and the multinode jobs don't work on Bionic
15:03:36 <dtantsur> we have (again, IIUC) until Wednesday to fix them. Help very welcome!
15:04:09 <dtantsur> Now a reminder:
15:04:11 <dtantsur> #info Train Forum/PTG topic etherpad: https://etherpad.openstack.org/p/DEN-train-ironic-brainstorming
15:04:45 <dtantsur> The Forum is less than 2 months away. please prepare your approvals, reservations, visas ASAP
15:05:08 <dtantsur> anything else worth mentioning?
15:05:29 <iurygregory> "[all][ptl][tc] Missing PTL nominations for 31 more teams"
15:05:41 <dtantsur> indeed. please nominate yourself :)
15:05:48 <iurygregory> Ironic is on the list =)
15:06:24 <mgoddard> do we know if TheJulia plans to run again?
15:06:34 * dtantsur has no idea
15:07:05 <iurygregory> about the problem with uefi and bionic we had a bug with neutron if i do remember
15:07:21 <iurygregory> not sure if we had a workaround for this
15:07:25 <dtantsur> I don't know. I would love somebody to follow-up on that.
15:07:59 <hjensas> I belive on mailing list the thread:  [ironic][neutron] nf_conntrack_helper now disabled by default
15:08:00 <iurygregory> derekh do you remember anything about the UEFI issue with bionic?
15:08:40 <dtantsur> let's probably move it to open discussion
15:08:47 <iurygregory> ++
15:08:54 <dtantsur> I wanted to also remind you that the final Stein release is pretty soon. End of this week or next week.
15:09:01 <dtantsur> please plan accordingly :)
15:09:04 <dtantsur> anything else?
15:09:24 <dtantsur> well, "final". since we don't have RC's, our RC is a release, which is a final feature release.
15:09:43 <iurygregory> the new cores?
15:09:49 <dtantsur> I'm trying to tame the words, but they're stronger, so much stronger.
15:09:56 <dtantsur> iurygregory: is it in effect?
15:10:03 * iurygregory not sure if need announcement lol
15:10:12 <iurygregory> dtantsur, for rpittau it's o.o
15:10:13 <rpittau> dtantsur, it seems so
15:10:17 <iurygregory> XD
15:10:22 <arne_wiebalck> it is :-D
15:10:43 <dtantsur> #link https://review.openstack.org/#/admin/groups/165,members welcome two new cores: arne_wiebalck and rpittau \o/
15:10:51 <rpittau> thank you :)
15:10:55 <arne_wiebalck> thx!
15:10:55 <dnuka> \o/
15:10:57 <hjensas> thanks arne_wiebalck and rpittau ! Great work!
15:10:58 <dtantsur> great job!
15:11:04 <derekh> iurygregory: yup, will talk after meeting
15:11:05 <iurygregory> \o/ congrats
15:11:10 <kaifeng> congrats arne_wiebalck and rpitta \o/
15:11:16 <dtantsur> on this positive note I hope we're done with the announcements :)
15:11:33 <dtantsur> no action items last week, so moving right into
15:11:35 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
15:11:44 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard around line 252
15:15:12 <openstackgerrit> Iury Gregory Melo Ferreira proposed openstack/python-ironicclient master: Run jobs under python2 and python3  https://review.openstack.org/642474
15:15:49 <dtantsur> the list is shrinking, it's good :) but I'm pretty worried about the Bionic thingy
15:16:36 <rpittau> one note on bionic, if there is a dist filter in the packages list, remember to add bionic or the pkg will not be installed :/
15:16:47 <dtantsur> ugh
15:17:06 <iurygregory> so we need to check the requirements?
15:17:11 <dtantsur> we should ensure we don't mention unsupported releases there
15:17:33 <rpittau> no, I just explained it completely wrong, taht is for devstack
15:17:46 <rpittau> we have a list of pkgs to install
15:18:45 <rpittau> devstack will filter by dist if mentioned: https://github.com/openstack/ironic/blob/master/devstack/files/debs/ironic
15:19:41 <iurygregory> gotcha
15:20:15 <dtantsur> rpittau: yeah, that's what I meant: we should start dropping ancient versions from it
15:20:23 <rpittau> dtantsur, ack
15:20:58 <dtantsur> anyway, is everyone done with the statuses?
15:21:36 <rpittau> yup
15:21:43 <mgoddard> yeah
15:21:51 <dtantsur> #topic Deciding on priorities for the coming week
15:22:00 <dtantsur> good progress this time, lemme clean up the list a bit
15:23:20 <openstackgerrit> Iury Gregory Melo Ferreira proposed openstack/python-ironicclient master: Run jobs under python2 and python3  https://review.openstack.org/642474
15:23:45 <Qianbiao> dtantsur Ironic will release a new version next week?
15:23:57 <dtantsur> Qianbiao: later this week or next week, yes
15:24:14 <Qianbiao> wow, may we speed up the merge process of https://review.openstack.org/#/c/639288/10
15:24:15 <patchbot> patch 639288 - ironic - Add Huawei iBMC driver support - 11 patch sets
15:24:33 <dtantsur> Qianbiao: it's on the proposed priority list, if folks are okay with FFE on it
15:24:38 <Qianbiao> we hope it could be release in next stable version
15:25:01 <dtantsur> Qianbiao: what's the condition of your CI?
15:25:12 <Qianbiao> It's almost done.
15:25:19 <Qianbiao> check Huawei Ironic CI
15:25:34 <Qianbiao> but the network of china is really make me sad..
15:25:42 <dtantsur> Qianbiao: please define "almost". does it validate a deployment with your driver?
15:25:42 <Qianbiao> it's hard to connect to openstack git
15:25:50 <dtantsur> I hear you :(
15:25:54 <Qianbiao> dtantsur yes
15:26:08 <dtantsur> some instability is fine, as long as it works in most cases and tests what it should
15:26:21 <dtantsur> great! I'm fine with an FFE for it. Folks, especially cores?
15:27:37 <stendulker> I'm ok to have it
15:27:55 <Qianbiao> The ibmc driver has been test again all HUAWEI rack server, we are waiting for review and merge now.
15:28:17 <arne_wiebalck> Qianbiao:  you disabled the failing test now I see?
15:28:34 <dtantsur> 3200+ LoC, wow
15:28:44 <Qianbiao> yes. the old test has some problem.
15:28:50 <TheJulia> Regarding PTL, I do plan on running again
15:28:52 <rpittau> and also maybe don't remove rfc3986 from reqs as redfish still uses it :P
15:28:54 <dtantsur> TheJulia: \o/
15:28:59 * TheJulia goes back to waiting for the doctor
15:28:59 <dnuka> \o/
15:29:02 <dtantsur> TheJulia: and regarding FFE for Huawai?
15:29:04 <iurygregory> TheJulia ++
15:29:05 <rpittau> TheJulia :)
15:29:08 <mgoddard> I think if we have passing 3rd party CI tests for the driver it's fine
15:29:11 <dtantsur> sorry, Huawei
15:29:16 <mgoddard> TheJulia to the rescue!
15:29:16 <arne_wiebalck> TheJulia:  \o/
15:29:39 <bfournie> TheJulia ++
15:30:00 <TheJulia> dtantsur: if it is passing and there are no disabled unit tests without notes, I'm okay with it in principle.
15:30:10 <arne_wiebalck> dtantsur:  if you remove the image file, the patch becomes digestible in size :)
15:30:46 <rpioso> TheJulia: :-)
15:30:48 <hjensas> TheJulia ++ :)
15:30:54 <rpittau> yeah, it's just 1900 lines :D
15:31:04 <arne_wiebalck> piece of cake
15:31:05 <kaifeng> TheJulia :)
15:31:20 <dtantsur> Qianbiao: okay, let's try to get it in by the end of the week?
15:31:36 <Qianbiao> <arne_wiebalck> power_state_change_timeout not means timeout times, but timeout seconds. The old assert call count has no meaning. so i just remove the asserts.
15:31:45 <Qianbiao> dtantsur thanks
15:32:06 <dtantsur> #agreed The Huawei driver RFE gets an FFE until the end of the week.
15:32:23 <dtantsur> Now, back to the list of priorities, how does it look?
15:33:26 <openstackgerrit> Mark Goddard proposed openstack/ironic master: Deploy Templates: API reference  https://review.openstack.org/642498
15:33:32 <mgoddard> I'd like to add that ^^ :)
15:33:42 <dtantsur> mgoddard: I was actually about to ask you ;)
15:33:47 <mgoddard> and the to-be-written docs for deploy templates
15:33:51 <mgoddard> (working on it)
15:34:02 <dtantsur> added
15:34:23 <dtantsur> okay, let's use your copy :)
15:34:40 <dtantsur> how's the list looking now?
15:34:48 <openstackgerrit> Iury Gregory Melo Ferreira proposed openstack/python-ironicclient master: Run jobs under python2 and python3  https://review.openstack.org/642474
15:35:24 * dtantsur hears crickets telling him the list is good
15:35:26 <bfournie> For the IPv6 fixes https://review.openstack.org/#/c/626552/ and https://review.openstack.org/#/c/642039/ can these be backported to rocky/queens?
15:35:27 <patchbot> patch 626552 - ironic-inspector - Use getaddrinfo instead of gethostbyname while res... (MERGED) - 10 patch sets
15:35:29 <patchbot> patch 642039 - ironic-inspector - Fix lookup when ipmi_address is a hostname (MERGED) - 1 patch set
15:35:54 <dtantsur> bfournie: if it's needed (Rocky goes first though)
15:35:56 <kaifeng> the deploy template has one patch left https://review.openstack.org/#/c/640446/
15:35:57 <patchbot> patch 640446 - ironic - Deploy templates: conductor and API nits - 5 patch sets
15:36:02 <dtantsur> bfournie: and only together
15:36:10 <bfournie> dtantsur: k, thanks
15:36:16 <dtantsur> kaifeng: I think the nits should not be a priority :)
15:36:16 <kaifeng> dtantsur I guess you just accidentally remove it from the list
15:36:45 <kaifeng> Oo, works for me :)
15:37:02 <dtantsur> moving on?
15:37:50 <dtantsur> #topic RFE review
15:37:55 <dtantsur> I have two for today
15:38:05 <dtantsur> #link https://storyboard.openstack.org/#!/story/2004965 Fast track deployment (FFE for Stein?)
15:38:21 <dtantsur> I know some folks already said it's a good idea. But since we're in FF, I'd prefer to confirm it again.
15:38:37 <dtantsur> I'm +1 on it, and IIRC stendulker put a +2 on the patch
15:38:50 <arne_wiebalck> It's a good idea, too.
15:39:09 <arne_wiebalck> I think it's a good idea, too.
15:39:29 <dtantsur> any objections to granting it an FFE?
15:39:43 <dtantsur> if nothing, I'll leave the patch open till tomorrow and will approve it if nobody objects to the code as well.
15:40:07 <rpittau> sounds good
15:40:33 <arne_wiebalck> dtantsur: ++
15:40:39 <dtantsur> #agreed The fast-track RFE is approved and gets FFE till the end of the week
15:40:56 <kaifeng> works for me as it's off by default :D
15:41:02 <Qianbiao> rpittau I update the redfish utils too. It now does not depend on rfc3986 too.
15:41:04 <dtantsur> it's off by default, yeah
15:41:07 <dtantsur> #link https://storyboard.openstack.org/#!/story/2004969 Make power synchronisation with nova configurable
15:41:14 <dtantsur> arne_wiebalck: yours one ^^
15:41:20 <arne_wiebalck> yes
15:41:32 <dtantsur> would you like to introduce it?
15:41:37 <arne_wiebalck> just checked with Surya, she will follow up with nova upstream
15:42:03 <arne_wiebalck> the spec is up and could in principle get reviews from today onwards
15:42:14 <rpittau> Qianbiao, please not on the same patch
15:42:33 <dtantsur> arne_wiebalck: do we depend on Nova before we can land code?
15:42:37 <arne_wiebalck> this will probably take until after the PTG, though
15:42:46 <arne_wiebalck> dtantsur: I think so
15:42:48 <Qianbiao> rpittau ok, will revert code now
15:43:02 <dtantsur> arne_wiebalck: okay, so I guess I can mark it triaged but not approved yet?
15:43:05 <arne_wiebalck> we'll need to wait until they decide how we should talk to nova
15:43:15 <arne_wiebalck> dtantsur: yes
15:43:22 <dtantsur> ack. any comments on this?
15:43:34 <arne_wiebalck> one thing
15:43:53 <arne_wiebalck> one question raised was when ironic should inform nova
15:44:01 <arne_wiebalck> always vs in unexpected situations
15:44:14 <arne_wiebalck> jroll raised this I think
15:44:22 <dtantsur> what do you consider unexpected here?
15:44:31 <arne_wiebalck> the use case
15:44:46 <arne_wiebalck> i.e. when a node comes up b/c someone  powered it on OOB
15:45:17 <arne_wiebalck> initially we thought we should cover this to prevent nova shuts it down again
15:45:24 <dtantsur> arne_wiebalck: I would probably notify Nova every time the power state is changed..
15:45:32 <arne_wiebalck> now there is the suggestion that nova should be informed on every change
15:45:55 <dtantsur> and note: actually changed, as in node.power_state = <something>
15:45:56 <arne_wiebalck> dtantsur: what about when you have 10k nodes?
15:46:07 <dtantsur> and power them on/off at the same time?
15:46:24 <arne_wiebalck> dtantsur: hopefully not :)
15:46:38 <rpittau> probably rabbitmq will explode :P
15:46:38 <arne_wiebalck> but there will be a constant stream of notifications
15:47:05 <dtantsur> if we only notify Nova when 1. a node is 'active', 2. node's power_state field changes value, it should not be crazy, should it?
15:47:29 <rpittau> arne_wiebalck, the same notifications happen when you have 10k instances, no ?
15:47:54 <arne_wiebalck> rpittau: I think so, yes
15:47:54 <dtantsur> rpittau: it's not rabbit, it's HTTP
15:47:58 <dtantsur> or is it?
15:48:16 * dtantsur just imagined an exploding rabbit
15:48:22 <arne_wiebalck> the main question I think is whether we (ironic) have a preference
15:48:31 <arne_wiebalck> if we do, we should make this clear
15:48:47 <arne_wiebalck> and try to push for it
15:49:03 <arne_wiebalck> the idea is on the review
15:49:14 <arne_wiebalck> maybe we wait for first feedback from the nova folks?
15:49:22 <arne_wiebalck> and then we see
15:49:35 <arne_wiebalck> maybe this is out of question for reasons we don't see atm
15:49:44 <dtantsur> #link https://review.openstack.org/#/c/636132/ Ironic-Nova power state notification spec
15:49:45 <patchbot> patch 636132 - nova-specs - Support server power state update through external... - 1 patch set
15:49:57 <dtantsur> yeah, I suggest we all take our time reading that
15:50:06 <dtantsur> maybe I'll even put it as an optional item to priorities
15:50:06 <arne_wiebalck> dtantsur: +1
15:50:47 <kaifeng> does this has something to do with https://github.com/openstack/ironic/blob/master/ironic/conf/conductor.py#L75 ?
15:50:48 <arne_wiebalck> sounds good
15:51:09 <dtantsur> kaifeng: it's a similar situation, but in Nova
15:51:35 <arne_wiebalck> kaifeng: the idea would be to have sth equivalent in nova
15:51:49 <arne_wiebalck> :)
15:52:02 <kaifeng> got it
15:52:08 <dtantsur> #topic Open discussion
15:52:17 <dtantsur> the floor is open
15:52:24 <arne_wiebalck> I have one thing.
15:52:45 <arne_wiebalck> For the sw RAID support, there are a couple of open questions I'd like to get input for.
15:53:16 <arne_wiebalck> For instance, how the RAID config should be exposed.
15:53:28 <arne_wiebalck> It's currently in the generic h/w manager.
15:53:40 <arne_wiebalck> It was suggested to move that to a dedicated one.
15:53:45 <arne_wiebalck> Any thoughts on this?
15:53:56 <dtantsur> well, it's not hardware-specific, is it?
15:54:02 * rpioso needs to review the s/w RAID spec
15:54:04 <dtantsur> what are we going to win by moving it out?
15:54:12 <arne_wiebalck> dtantsur: it's not, correct
15:54:33 <dtantsur> arne_wiebalck: then it will be use by default anyway, right?
15:54:40 <arne_wiebalck> dtantsur: I'm not clear if we would gain anything.
15:54:42 <dtantsur> unless we move it out of IPA, which I personally don't want to
15:54:47 <arne_wiebalck> dtantsur: correct
15:55:10 <dtantsur> arne_wiebalck: is it possible to use something in target_raid_config to mean "yes, I do mean software RAID"
15:55:12 <dtantsur> ?
15:55:18 <arne_wiebalck> dtantsur: the argument was to prevent using it by accident
15:55:26 <arne_wiebalck> dtantsur: yes
15:55:32 <dtantsur> yeah, I get this argument. but a hardware manager won't help.
15:55:44 <arne_wiebalck> I put sth in there to trigger grub on whole disk images anyway.
15:55:59 <arne_wiebalck> and the target_raid_config needs to comply with a certiny layout
15:56:03 <dtantsur> I guess I should actually read your patches :)
15:56:08 <arne_wiebalck> s/certiny/certain/
15:56:12 <arne_wiebalck> dtantsur:
15:56:15 <arne_wiebalck> :)
15:56:21 <dtantsur> arne_wiebalck: my thought is: if something is only valid for software RAID, we can use it as a sign
15:56:32 <arne_wiebalck> dtantsur: yes
15:56:50 <dtantsur> arne_wiebalck: do we have an RFE with the design?
15:56:52 <arne_wiebalck> I can remove the [WIP], this may make the patches more visible
15:57:18 <arne_wiebalck> dtantsur: the design of the raid layout?
15:57:28 <arne_wiebalck> dtantsur: or the s/w RAID as a whole?
15:57:28 <dtantsur> arne_wiebalck: the design of the whole feature?
15:57:38 * arne_wiebalck is looking for the story ...
15:57:46 <arne_wiebalck> https://storyboard.openstack.org/#!/story/2004581
15:58:20 <arne_wiebalck> spec : https://review.openstack.org/#/c/624413/
15:58:21 <patchbot> patch 624413 - ironic-specs - Support for Software RAID (MERGED) - 2 patch sets
15:58:45 <dtantsur> oh, I should have read this, right? :D
15:58:55 <arne_wiebalck> The spec does not have that flag I was just mentioning, only realised later we would need sth like that.
15:59:28 <dtantsur> arne_wiebalck: could you propose a spec update with it?
15:59:29 <arne_wiebalck> ok, I don't want to occupy the whole meeting
15:59:37 <arne_wiebalck> dtantsur: sure
15:59:37 <dtantsur> no problem, thanks for the update!
15:59:51 <dtantsur> thanks all!
15:59:56 <rpittau> thanks!
15:59:57 <arne_wiebalck> I'll remove the WIP, reviews welcome
16:00:00 <dtantsur> #endmeeting