15:00:21 <TheJulia> #startmeeting ironic
15:00:22 <openstack> Meeting started Mon May 27 15:00:21 2019 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:24 <TheJulia> o/
15:00:26 <openstack> The meeting name has been set to 'ironic'
15:00:27 <etingof> \o
15:00:30 <stendulker> o/
15:00:33 <iurygregory> o/
15:00:42 <kaifeng> o/
15:00:50 <TheJulia> Good morning and evening everyone!
15:01:19 <dtantsur> o/
15:01:23 <TheJulia> Our agenda is on the wiki, as always
15:01:27 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:43 <rpittau> o/
15:01:55 <TheJulia> Today is also a holiday in the state, so we have limited attendance today.
15:02:13 <TheJulia> #topic Announcements / Reminder
15:02:28 <TheJulia> I have none, does anyone have anything to announce or remind us of?
15:02:54 <dtantsur> milestone 1 is next week, if it matters
15:03:04 <dtantsur> probably worth doing some master releases
15:03:09 * TheJulia blinks
15:03:37 <TheJulia> Yeah, if we can get the allocation backfill merged that would e good
15:03:42 <TheJulia> I'd love to see us merge raid too :)
15:03:50 <dtantsur> ++
15:04:01 <TheJulia> Anyway, we can discuss that in priorities
15:04:13 <TheJulia> Well, if there is nothing else, we can move onward
15:04:56 <TheJulia> #topic Review action items for the prior week
15:05:08 <TheJulia> One action item, I just didn't get to it :(
15:05:20 <TheJulia> #action Follow-up on baremetal sig communication
15:06:03 <arne_wiebalck> Met Chris today, he said he didn't get round to do anything yet either, but he will :)
15:06:32 <TheJulia> arne_wiebalck: oh, awesome! Thanks!
15:06:42 <TheJulia> #topic Review subteam status reports
15:06:44 <rloo> o/
15:06:49 <TheJulia> \o
15:06:52 <bdodd> o/
15:07:04 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:08:10 <dtantsur> sorry, I had an action item re zuul jobs:
15:08:13 <dtantsur> #link https://opendev.org/openstack/openstack-zuul-jobs/src/commit/c716915911a612ea351ab6b1718c3239e900c469/zuul.d/project-templates.yaml#L417
15:08:30 <dtantsur> openstack-python3-train-jobs is the template we should be using instead of explicit py3* jobs
15:08:47 <dtantsur> openstack-python3-train-jobs-neutron - for networking projects
15:09:16 <openstackgerrit> Ilya Etingof proposed openstack/ironic master: WIP: Add Redfish Virtual Media support  https://review.opendev.org/638453
15:09:43 <TheJulia> Neat! smartnics has a +2 in neutron
15:10:00 <rloo> i think we need to get the train priorities PR approved and update that whiteboard
15:10:13 <TheJulia> rloo: indeed
15:10:37 <TheJulia> I've updated the items that are on the whiteboard already for which I have context at present
15:10:55 <TheJulia> If there are no questions then I think we can move forward to priorities
15:11:02 <TheJulia> dtantsur: I guess our templates need to be updated?
15:11:28 <dtantsur> I guess so
15:12:28 <TheJulia> Everyone good to move on to priorities for the week?
15:12:34 <rpittau> yep
15:12:48 <rloo> ++
15:13:08 <TheJulia> #topic Priorities for the week
15:13:16 <TheJulia> I'll go ahead and remove the merged items from the list
15:14:46 <TheJulia> well, the list is now shorter :)
15:15:44 <TheJulia> Is anyone aware of things that need review activity this week?
15:16:13 <rloo> train priorities. could we have an AI to get the cores to review/approve this week?
15:16:56 <TheJulia> I concur, we need it. Presently only has 3 +2s
15:17:11 <rpittau> I think there's still one comment that need to be sorted out
15:17:35 <TheJulia> It can be followed up on, we don't need to merge perfect or final.
15:17:36 <rpittau> otherwise I'm on also on +2
15:17:41 <rpittau> ok
15:18:10 <TheJulia> #action all_core_reviewers Review the Train priorities https://review.opendev.org/#/c/660145/
15:18:11 <patchbot> patch 660145 - ironic-specs - Add train priorities - 3 patch sets
15:18:21 <TheJulia> Does anyone have anything else?
15:19:12 <kaifeng> just did :) I was feeling the same of rpittau today earlier.
15:19:20 <TheJulia> Ahh1
15:19:21 <TheJulia> okay
15:19:23 <rpittau> :)
15:19:54 <TheJulia> I don't think we'll see a review from hshinna. I'll approve it once all the active cores have reviewed it.
15:20:07 <TheJulia> or approve it Monday, whichever comes first
15:20:49 <TheJulia> If there are no objections, we can move on?
15:20:53 <dtantsur> ++
15:20:59 <TheJulia> #topic Baremetal SIG
15:20:59 <rpittau> let's!
15:20:59 * kaifeng thought hshinna had sent out an email for stepping down..
15:21:13 <dtantsur> kaifeng: yep :(
15:21:14 <TheJulia> kaifeng: I must have missed it or forgotten it
15:21:22 <TheJulia> okay, my brain lost it somewhere along the way :(
15:21:26 <dtantsur> I've just found it in my inbox
15:21:34 <TheJulia> the last month has been insane
15:21:39 * dtantsur has removed him from core
15:21:43 <TheJulia> dtantsur: thanks
15:22:22 <TheJulia> Is there anything to discuss regarding the baremetal sig this week? Seems like arne_wiebalck spoke with Chris, so I suspect next week we might have things to discuss
15:23:09 * TheJulia guesses no
15:23:18 <TheJulia> And if there is nothing else, then I think we can jump to Open Discussion
15:24:23 * TheJulia hears the crickets
15:24:25 <TheJulia> Moving on!
15:24:30 <TheJulia> #topic Open Discussion
15:24:55 <TheJulia> Do we have anything else to discuss today? Taking over the world and all?
15:25:47 <dtantsur> Taking over the world, yes :)
15:26:05 <TheJulia> Perhaps going to the beach maybe....
15:26:15 <kaifeng> It seems jroll is not here, I was thinking about the sync up of no ipa to conductor implementation
15:26:25 <rpittau> TheJulia: as soon as the sun comes back :)
15:26:40 <TheJulia> kaifeng: There is a lot of interest coming from various directions on that....
15:27:06 <rloo> kaifeng: US holiday; he should be back tomorrow.
15:27:41 <kaifeng> rloo, act, thanks! I guess next time works
15:27:42 <TheJulia> kaifeng: Maybe a call needs to be setup at some point in the next few weeks to discuss how to move it forward?
15:27:55 <TheJulia> or specific discussion time
15:29:03 <rloo> we have the spec approved; is it to discuss changing it or getting the work done or ? https://specs.openstack.org/openstack/ironic-specs/specs/not-implemented/no-ipa-to-conductor.html
15:29:19 <TheJulia> rloo: moving it forward I think
15:29:25 <kaifeng> it's not on the train priority though, so I guess we have lower priority for it
15:29:37 <TheJulia> Yeah
15:29:52 <rloo> kaifeng: it isn't a priority because no one spoke up about it at the PTG or online, about wanting it as a priority.
15:29:53 <TheJulia> Anyway, seems like we're done for the day if there is nothing else.
15:30:47 <TheJulia> rloo: also interestingly enough, I've had 3 or 4 unique instances where it has been brought up as a thing that is wanted or needed in the past week, so the larger community may want/need/desire it
15:31:01 * rloo wonders if we ought to make it clearer for those not attending PTG, that they can provide feedback wrt priorities etc.
15:31:34 <rloo> TheJulia: it isn't too late to update the train priorities. or not bother, if people want it and people volunteer to work & review it...
15:31:56 <rloo> just because something isn't a priority, doesn't mean it won't get done.
15:32:00 <TheJulia> rloo: It is never too late to adjust priorities
15:32:04 <TheJulia> ++
15:32:05 <rloo> ++
15:33:05 <kaifeng> this feature doesn't seem to be complex, so I guess it's fine to be not in the list
15:33:35 <TheJulia> kaifeng: I think there is a lot of hidden complexity because of how mechanics work presently
15:33:38 <TheJulia> but... maybe not
15:33:52 <TheJulia> Kind of depends on how we run it, and maybe it actually becomes really simple
15:33:57 <rloo> well, let's find out from jroll about status. and find out who is willing to work on it and review it, if he isn't able to.
15:34:06 <TheJulia> ++
15:34:39 <kaifeng> I need to take a look on the spec again
15:35:41 <TheJulia> Sounds like a plan :)
15:35:44 <TheJulia> I guess we're done, have a wonderful week everyone!
15:35:53 <rloo> thx TheJulia!
15:35:55 <rpittau> thanks!
15:36:00 <kaifeng> thanks!
15:36:37 <TheJulia> #endmeeting