15:00:06 <TheJulia> #startmeeting ironic
15:00:07 <openstack> Meeting started Mon Jun  3 15:00:06 2019 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:10 <openstack> The meeting name has been set to 'ironic'
15:00:14 <TheJulia> Good morning everyone!
15:00:22 <bdodd> o/
15:00:23 <etingof> \o
15:00:26 <bfournie> o/
15:00:27 <rpittau> o/
15:00:28 <TheJulia> It is time for our weekly meeting of irony!
15:00:31 <rloo> o/
15:00:37 <TheJulia> Our agenda can be found on the wiki.
15:00:39 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:00:44 <kaifeng> o/
15:00:50 <TheJulia> #topic Announcements/Reminders
15:01:09 <jungleboyj> o/
15:01:11 <TheJulia> #info Shanghai Open Infra Summit CFP closes on July 2nd
15:01:13 <dnuka> o/
15:01:54 <TheJulia> #info The Ironic train priorities document merged! \o/
15:01:55 <TheJulia> #link https://specs.openstack.org/openstack/ironic-specs/priorities/train-priorities.html
15:02:06 <mgoddard> o/
15:02:13 <TheJulia> Does anyone have anything they would like to announce or remind us of?
15:02:49 <rodneyHugh> Good morning. My name is Rodney Brown from Lenovo DCG.  I will be joining the discussion over the next few weeks to see how I might be able to contribute.
15:02:58 <dtantsur> \o
15:03:00 <TheJulia> rodneyHugh: Welcome!
15:03:08 <jroll> \o
15:03:48 <arne_wiebalck> o/
15:04:07 <TheJulia> Well, sounds like there are no other announcements or reminders this week!
15:04:08 <TheJulia> Onward!
15:04:20 <jungleboyj> TheJulia:  rodneyHugh  is working with my group from Lenovo.  :-)
15:04:20 <cdearborn> o/
15:04:29 <jungleboyj> rodneyHugh:  Thanks for joining.
15:04:39 <TheJulia> jungleboyj: awesome!
15:04:46 <rodneyHugh> Thank you.
15:04:50 <jungleboyj> \o/
15:05:08 <dtantsur> welcome, rodneyHugh
15:05:25 <TheJulia> All action items seem resolved with Chris Hodge following up and core reviewers reviewed the train priorites, so we can skip ahead then.
15:05:42 <TheJulia> #topic Subteam Status Reports
15:05:48 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:06:00 <TheJulia> I re-shuffled the reports based upon the train priorities
15:06:09 <TheJulia> Starting at line 207
15:07:27 <TheJulia> As we discussed, some of our items are more general themes to allow for ideas to evolve. Seems like the faster deployment topic is getting some discussion
15:08:22 <TheJulia> etingof: resolved dupliation
15:08:59 <dtantsur> arne_wiebalck: I suggest removing old notes from the software RAID section
15:09:11 <arne_wiebalck> +1
15:09:24 <arne_wiebalck> thanks for all the reviews, btw
15:09:42 <arne_wiebalck> I'll try to get round to this again during the next days
15:09:43 <TheJulia> So for the record, smartnic stuff is follow-up in neutron. I'm going to put a note for us to add a reno for us to indicate that the functionality should work if properly setup.
15:10:08 <etingof> how about the indicators feature? how much is it of interest?
15:10:44 <dtantsur> nice to have for sure
15:10:58 <TheJulia> I think it is interest, we've had some operators of recent express lots of interest, so I'll definitely review it
15:11:16 <dtantsur> do we have the code up (updated to match the spec)?
15:11:29 <etingof> coming this week I think
15:12:16 <TheJulia> Regarding v6, I've been trying to focus on getting us a v6 native CI job going. The traffic seems to be disappearing somewhere into the router ether. If anyone wants to help me with that, I would love another set of eyes.
15:12:53 <TheJulia> Sadly, MOST devstack seems to be missing lots of "only use v6 knobs too" so it is going to take a litle time before everything is v6
15:13:27 <TheJulia> Anything else for subteam updates?
15:14:06 <rloo> I added Node retirement... @ L269ish.
15:14:17 <rloo> since that was in the train priorities
15:14:22 <TheJulia> rloo: Thanks!
15:14:26 <arne_wiebalck> rloo: thx
15:15:02 <TheJulia> Are we good to proceed to priorities for the week?
15:15:25 <rloo> line 290
15:15:31 <rloo> is that the same as line 336?
15:16:14 <TheJulia> rloo: different
15:16:53 <rloo> TheJulia: thx.
15:16:56 <arne_wiebalck> 290 is power only
15:17:32 <rloo> so 290 is subset of 336? (do we need 336 then?)
15:17:58 <TheJulia> Lets keep 336 on our radar for now
15:18:33 <arne_wiebalck> rloo: seems so, yes. maybe a door opener :)
15:18:52 <rloo> arne_wiebalck: heh. whatever works for you all :)
15:19:44 <TheJulia> So onward to priorities for the week?
15:19:55 <mjturek> o/
15:20:00 <TheJulia> \o mjturek
15:20:05 <dtantsur> onward!
15:20:09 <arne_wiebalck> TheJulia: ++
15:20:22 <TheJulia> #topic Priorities for the coming week
15:20:29 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:20:33 <TheJulia> Line 123
15:20:40 * TheJulia removes the completed items
15:22:13 <TheJulia> Okay, that looks like what is outstanding. Are there any items anyone would like to add to the list this week?
15:25:53 <TheJulia> I'e added a couple things from inspector, two stable changes which shouldn't be a big deal
15:26:01 <TheJulia> Is there anything else or are we happy with the list?
15:26:18 * dtantsur removed duplicates
15:26:30 <dtantsur> I think this is good
15:26:52 <rpittau> I think it's ok
15:27:10 <TheJulia> Shall we proceed onward?
15:27:10 <rloo> TheJulia: qq about https://review.opendev.org/#/c/629060/ since it is in the list. do we want more people to ack or should we merge?
15:27:11 <patchbot> patch 629060 - ironic - Add a high level vision reflection document - 3 patch sets
15:27:43 <TheJulia> Well, considering the window I just looked at was only one core reviewer, I suspect we can just approve it
15:27:48 <TheJulia> to merge that is
15:28:09 <rloo> done
15:28:15 <TheJulia> \o/
15:28:29 <TheJulia> Moving to Discussions
15:28:40 <TheJulia> #topic Discussion
15:29:47 <TheJulia> I have two items, and this first one is largely a raise awareness item to see if anyone is willing to go hunt down depreation noties in our test runs and submit patches for some of the various things that are deprecated. In our current state, we have deprecation notices warning us that we will break on python 3.8.
15:30:31 <rpittau> TheJulia: I would gladly do that
15:31:00 <dtantsur> rpittau: thanks! FYI python 3.8 (alpha) is in Fedora.
15:31:09 <TheJulia> rpittau: thanks!
15:31:10 <rpittau> dtantsur: yep :)
15:31:19 <rpittau> anything for Python 3.x :P
15:31:26 <TheJulia> If anyone else is interested, please feel free to jump in, and we can keep a list of patches on an etherpad.
15:31:33 <TheJulia> Next item!
15:31:42 <TheJulia> Meeting times! :(
15:32:26 <TheJulia> We've had an uptick in people in Aisa/Pacific timezones that would like to attend a meeting and be more involved with the community. Steve Baker and Jacob Andrews have both expressed interest in being more involved.
15:32:42 <TheJulia> Jacob created a doodle for us to hopefully visualize overlaps
15:32:44 <TheJulia> #link https://doodle.com/poll/bv9a4qyqy44wiq92
15:33:12 <TheJulia> I feel like the only truly viable option is to alternate week to week. Are there any thoughts?
15:33:28 * jroll wonders if rloo saw the wednesday options or is busy on wednesdays
15:33:41 <rloo> i found the doodle confusing. was it to find a time on m/t/w only?
15:33:49 <dtantsur> if we have enough people for the other time - we can alternate
15:33:55 <jroll> last time we did alternate meetings, we didn't get very much activity in the US-nighttime meeting, but that was ages ago
15:34:00 <rloo> i thought it was to find a time of the day. not the actual day. what happened to thurs then?
15:34:01 <TheJulia> It was to find a overlaping time window over the course of two days that would generally work
15:34:43 <rloo> i am fine with alternate or whatever. my recollection is that we had alternating but we cancelled because there weren't enough cores to have any quorum in one of the meetings.
15:35:10 <TheJulia> And those meetings were silent most times
15:35:41 <rloo> is there one time that can accommodate most folks? vs 2 alternate times?
15:35:41 <TheJulia> But we've diversified, so I think it would be good. I can propose a time to the folks more focused on the other side of the planet, and we can go from there
15:37:33 <dtantsur> I'd rather find 2 times that are convenient each for many people, rather than one time that is inconvenient for everyone
15:37:55 <jroll> ++
15:38:05 <kaifeng> ++
15:38:08 <TheJulia> agreed
15:38:10 * rloo agrees, why would we want one time that is inconvenient for everyone. best is one time that is convenient for everyone :)
15:38:41 <dtantsur> heh
15:38:42 <rloo> so we're agreeing on a time now. the day of the week is going to be decided later?
15:38:59 <rloo> i mean, we're agreeing to find times that work for people. not the actual days yet?
15:39:01 <TheJulia> I think decide later, we have insufficent information to make that determination ath teh moment
15:39:37 <rpioso> Is the doodle still open?
15:39:41 <arne_wiebalck> yes
15:39:52 <jroll> I would like to see more people respond to the poll, looks like only 2-3 apac people in there now (not sure where harald is)
15:39:55 <rloo> maybe we should change the doodle to only give choices for 24 hours then. or maybe i was the only one that was confused.
15:40:22 <dnuka> I just saw this. I'll vote too :)
15:40:36 <mgoddard> are people planning to attend the inconvenient week?
15:40:59 <mgoddard> presumably PTL would be expected to, is TheJulia ok with that?
15:41:00 <rloo> i see 4 from apac? (where is apac? :D)
15:41:13 <rloo> mgoddard: it depends on the inconvenient time. (for me anyway).
15:41:21 <arne_wiebalck> there is probably inconvenient as in 10pm and inconvenient as in 3am
15:41:26 <rloo> fwiw, i'm totally fine not attending all the meetings.
15:41:28 <hjensas> jroll: I'm in Central Europe timezone. :)
15:41:31 <rpittau> rloo: Asia-Pacific :)
15:41:49 <rloo> rpittau: that includes india, right?
15:42:03 <rpittau> rloo: yes
15:42:04 <mgoddard> nobody should be having meetings in the middle of the night, PTL included
15:42:04 <TheJulia> I will do my best, I'm actually in a decent timezone for it... at least for the next few weeks :)
15:42:13 <arne_wiebalck> mgoddard: ++
15:42:21 <rloo> mgoddard: i agree.
15:43:06 <rloo> i don't expect anyone to attend a meeting if it is outside their normal working hours. if you/we can't communicate in other ways, then shame on us.
15:43:10 <jroll> hjensas: ok, so 2 in apac on the poll so far :)
15:43:16 <mgoddard> how about a biweekly ML-based 'meeting'?
15:43:18 <jroll> rloo: ++
15:43:37 <mgoddard> something async that is timezone neutral
15:43:47 <TheJulia> That is... tempting
15:44:04 <TheJulia> How does everyone feel about doing that?
15:44:15 <TheJulia> Maybe we should try it for one week
15:45:08 <mgoddard> encouraging discussion might take a bit of practice, but it should be quite inclusive
15:45:08 <openstackgerrit> Ilya Etingof proposed openstack/ironic master: Add Redfish Virtual Media support  https://review.opendev.org/638453
15:45:17 <mgoddard> and visible
15:45:23 <jroll> what does that look like? feels like a status update that generates discussion
15:45:35 <mgoddard> something like that
15:45:38 <TheJulia> jroll: I'm kind of thinking the same
15:45:46 <TheJulia> or an agenda with explicit questions to be raised
15:45:51 <TheJulia> or resolved
15:46:24 <jroll> ++
15:46:27 <jroll> I like the sound of it
15:46:56 <rloo> we can try it. i think we aren't very responsive to email discussions.
15:47:00 <TheJulia> #agreed Ironic will try to run a meeting next week entirely on the mailing list. Wish us luck ;)
15:47:04 <rloo> 'we' meaning more than 1-2 people.
15:47:16 <mgoddard> rloo: that is the worry - ML is easy to ignore
15:47:34 <TheJulia> It is worth a try!
15:47:45 <TheJulia> Anyway, are we ready to move on?
15:47:57 * kaifeng wonders how would we define the ML meeting is ended?
15:47:58 <rloo> so what did we decide?
15:48:03 <mgoddard> but then IRC meetings are sufficiently slow to be distracted from, unlike emails
15:48:06 <rloo> async meeting + two different times for sync meetings?
15:48:13 <TheJulia> kaifeng: when people stop replying? :)
15:48:30 <mgoddard> I was thinking keep the current meeting time?
15:48:49 <rloo> mgoddard: no, that isn't fair to the ones that are asking for a diff meeting time.
15:48:54 <kaifeng> I guess emails would have more latency
15:49:11 <dnuka> mgoddard: I agree.
15:49:21 <TheJulia> emails should encourage us to convey more complete thoughts. There would be no rush to fit thoughts into an hour
15:49:26 <rpittau> well let's keep the current time/date plus one different, no ?
15:49:30 <mgoddard> rloo: it's an improvement on the current status though
15:49:43 <rloo> mgoddard: well, put yourself in the other folks' shoes.
15:50:08 <rloo> mgoddard: we might as well just pick some other time (via the poll, what is the most voted time) and use that time, + this async one.
15:50:22 <mgoddard> rloo: sure, I'm just worried we'll end up with two meetings where TheJulia is the only common attendee
15:50:33 <TheJulia> That is a distinct possibility
15:50:39 <mgoddard> and that isn't fair on TheJulia
15:50:53 <rloo> mgoddard: oh, i agree. that goes to the 2-diff time thing. but we need to look at that first, to see if that is what will happen. if so, then no way.
15:50:54 <TheJulia> Hence why I'm thinking we should try fully async and see if that works for a week
15:51:28 <dtantsur> async ML meetings + infrequent video calls?
15:51:38 <rloo> well, the folks that cannot make this meeting have no voice wrt the fully async. so perhaps the first thing, before we go to async? or maybe go to async anyway, is to solicit their feedback.
15:51:53 <mgoddard> that's a fair point
15:52:05 <TheJulia> I was thinking exactly that
15:52:24 <rloo> we have this poll. the very least we can do is use it to pick another time (if there is one) that most people voted for. assuming we stick with one time.
15:52:25 <TheJulia> "We're going to try something, lets see if it helps, let us know what you think!"
15:52:33 <jroll> ++
15:52:38 <arne_wiebalck> rloo: ++
15:52:59 <dnuka> rloo: ++
15:53:20 <rpittau> ++
15:53:21 <rloo> i'm not saying the async thing is a bad idea. i just want to kind of stand up for the ones that asked for alternate meeting time :)
15:53:21 <TheJulia> Looking at the doodle, Apac->India response times don't overlap very well :(
15:53:40 <TheJulia> Well, lets reach out to them and broaden the discussion
15:53:44 <rloo> so india is not in apac?
15:54:10 <TheJulia> I kind of see it as its own zone, tbh
15:54:15 <dnuka> rloo: It is, also Sri Lanka
15:54:22 <rloo> kaifeng: not to pick on you but will you vote? :)
15:55:20 <kaifeng> rloo, sure I will take vote, but I think there is no much difference with current time :(
15:55:21 * rloo thinks we should take this offline now. an async email thread to continue discussion. would be good to see how much discussion occurs there...
15:55:23 <rpittau> technically APAC includes India, but eh....
15:56:05 <rloo> if we want to try the async meeting, then we need to be better at email discussions...?
15:56:08 <TheJulia> I'll send an email to the mailing list
15:56:16 <TheJulia> Indeed
15:56:26 <jroll> thanks TheJulia
15:57:11 <openstackgerrit> Merged openstack/ironic master: Add a high level vision reflection document  https://review.opendev.org/629060
15:57:32 <TheJulia> Is there anything else for us to discuss today?
15:57:37 <TheJulia> #topic Open Discussion
15:58:16 * TheJulia pages for crickets
15:58:29 <kaifeng> 2mins left..
15:59:07 <rpittau> I believe there's something to discuss about the bandit tests, but I guess we can postpone ?
15:59:24 <kaifeng> post-meeting works
15:59:28 <TheJulia> ++
15:59:35 <TheJulia> And with that, thanks everyone!
15:59:43 <rpittau> thanks!
15:59:46 <rpioso> Thank you \o
15:59:48 <arne_wiebalck> thx TheJulia
15:59:52 <dnuka> thank you TheJulia
15:59:55 <TheJulia> #endmeeting