15:00:29 <TheJulia> #startmeeting ironic
15:00:30 <openstack> Meeting started Mon Jun 10 15:00:29 2019 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <TheJulia> o/
15:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:33 <openstack> The meeting name has been set to 'ironic'
15:00:34 <iurygregory> o/
15:00:36 <cdearborn> o/
15:00:39 <bdodd> o/
15:00:42 <rpioso> o/
15:01:10 <kaifeng> o/
15:01:27 <baha> o/
15:01:31 <TheJulia> I suspect, since a number of folks in Europe are on holiday today, our attendance is going to be low.
15:01:32 <mkrai> o/
15:01:36 <stendulker> o/
15:02:14 <mjturek> /
15:02:18 <mjturek> o/*
15:02:48 <iurygregory> you are probably correct TheJulia ^^
15:03:05 <TheJulia> Our agenda is on the wiki, but I think this meeting should be fairly quick.
15:03:15 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:03:29 <TheJulia> #topic Announcements/Reminders
15:04:05 <jungleboyj> o/
15:04:31 <TheJulia> I started a discussion on the mailing list regarding the future of our meetings. Please check it out.
15:04:34 <TheJulia> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-June/007038.html
15:04:46 <TheJulia> Does anyone have any announcements or reminders this week?
15:05:25 <openstackgerrit> Merged openstack/bifrost master: Enable redfish by default  https://review.opendev.org/662961
15:05:44 <TheJulia> I'm taking silence as a no. :)
15:06:22 <TheJulia> I see no action items from last week, besides what was already mentioned regarding the future of the meeting.
15:06:31 <TheJulia> So lets skip to reviewing subteam status reports
15:06:48 <TheJulia> #topic Review subteam status reports
15:07:02 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:07:15 <TheJulia> Starting around line 246
15:07:38 <TheJulia> Software raid merged \o/
15:07:45 * TheJulia updates
15:08:31 <iurygregory> \o/
15:08:55 <TheJulia> Looks like arne_wiebalck still has a few items left on his story
15:09:58 <TheJulia> Looks like I need to update our release notes regarding Smartnics
15:10:21 <TheJulia> #action TheJulia needs to add release note for smartnics as neutron support has merged.
15:10:34 <jroll> \o (sorry I'm late)
15:11:17 <TheJulia> mkrai: any update on replacing wsme?
15:11:22 <rloo> o/ (me late too)
15:12:20 <TheJulia> Looks like redfish virtual media is starting to see reviews
15:12:52 <mkrai> TheJulia: Hi, I created an RFE for it. Starting to work this week.
15:12:59 <kbaegis> Will Supermicro support for virtual-media be included? Do they participate here?
15:13:09 <mkrai> Collected patches from Keystone to get an idea
15:13:18 <TheJulia> mkrai: excellent, can you add a note with the date to the etherpad?
15:13:44 <TheJulia> kbaegis: Lets differ that to open discussion
15:13:56 <TheJulia> mkrai: and today's date please :)
15:14:06 <rloo> arne_wiebalck, rpittau|afk: i updated the node retirement status (around L311). hope it is correct :)
15:14:25 <mkrai> TheJulia: Yes sure. I will do that
15:15:06 <TheJulia> Re ipv6: I've been fighting the good fight, but looks like v6 networking is completely broken when I try to run it on devstack. hjenas is going to try and take a look too. Any additional ideas/people to help would be good so we can hopefully at least get an initial CI job running.
15:15:14 <mkrai> TheJulia: Got it :)
15:15:33 <TheJulia> kaifeng: Any update on single doc generation?
15:16:02 <TheJulia> rloo: thanks!
15:16:04 <kaifeng> nope, is it ongoing?
15:16:26 <TheJulia> kaifeng: I don't think it has been started, but you and rpittau|afk are listed on the item.
15:16:37 <kaifeng> I assume there is a community template for that, it's a simple job as long as it's ready
15:16:48 <kaifeng> so I am waiting for that :)
15:16:51 <TheJulia> I _think_ it is supposed to already be ready
15:17:11 <kaifeng> I will check it out
15:17:19 <TheJulia> kaifeng: thanks!
15:17:31 <TheJulia> I think we're good to move forward then?
15:18:03 <rloo> arne_wiebalck: i also updated with what i know (which isn't much) about 'Power state callbacks to Nova' (around L322)
15:18:19 <rloo> arne_wiebalck: might be outdated (or maybe I am hoping it is!)
15:18:36 <TheJulia> rloo: thanks :)  I think arne_wiebalck has a holiday today
15:18:46 <rloo> TheJulia: yeah, lucky him :D
15:19:02 <iurygregory> riccardo also is on holiday XD
15:19:07 <TheJulia> So lets move on to Priorities for this next week.
15:19:23 <hogepodge> hi, sorry I'm late myself
15:19:31 <TheJulia> o/ hogepodge
15:19:48 <TheJulia> #topic Priorities for the coming week
15:19:57 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:20:00 <TheJulia> Starting aroudn line 124
15:20:21 <TheJulia> We got a LOT merged over the last two weeks, so I'm going to clean up the merged items real quick.
15:20:30 <TheJulia> Proposed items start around line 172 at the moment
15:21:44 <TheJulia> jroll: re your xml change, I'm wondering if we should backport that....
15:22:02 <TheJulia> Thoughts?
15:22:30 <jroll> TheJulia: why? it doesn't really make a difference at runtime
15:22:36 <jroll> was just removing dead code
15:22:50 <TheJulia> Okay, I was just wondering about security aspect, but yeah, it is just dead code
15:23:11 <jroll> nah, it doesn't even reach that code :)
15:23:19 <TheJulia> Okay
15:23:56 <kaifeng> it can be scanned by some software
15:23:59 <TheJulia> Is everyone good with the proposed items to be added? Is there anything that is missing that needs eyes?
15:24:31 * rloo good with proposed
15:25:20 <kaifeng> wrt the opendev stuff, https://review.opendev.org/#/c/656473/1/tox.ini
15:25:20 <patchbot> patch 656473 - molteniron - Update to opendev - 4 patch sets
15:26:09 <kaifeng> it seems the community hasn't decided the final url schema yet
15:26:24 * TheJulia sighs
15:26:31 <TheJulia> for the upper constraints
15:27:21 <jroll> I think we finally did decide
15:27:28 * jroll finds the mail
15:27:48 <jroll> http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006478.html
15:28:34 <kaifeng> jroll thanks!
15:29:41 * kaifeng adds that to the whiteboard
15:30:52 <TheJulia> Awesome
15:31:00 <TheJulia> I guess we're good to proceed?
15:31:15 <rloo> proceed +1
15:31:20 <iurygregory> ++
15:31:27 <kaifeng> ++
15:31:36 <stendulker> +1
15:32:00 <TheJulia> #topic Baremetal SIG
15:32:24 <TheJulia> o/ hogepodge
15:32:55 <TheJulia> Is there anything for the SIG to discuss or that could use assistance?
15:33:22 <hogepodge> so turning my attention back to it after travel
15:33:42 <hogepodge> The next items to work on are the whitepaper.
15:34:32 <hogepodge> Returning to that original document we started and coming up with a longer plan to complete and publish in the next few months.
15:34:55 <TheJulia> Okay, are more use cases still required?
15:35:21 <hogepodge> I've shifted teams within the OSF, from Marketing to Engineering, so I need to keep on top of how Marketing is soliciting and publishing the use cases.
15:35:26 <hogepodge> Definitely still required. :-)
15:35:50 <TheJulia> I think the suggestion when we last discussed this was for people to propose the changes directly?
15:36:06 <TheJulia> to the doc that is. Do you have a link for the whitepaper draft that is being worked on that we can share?
15:36:17 <hogepodge> Only a few that were submitted before the Denver summit had enough narrative structure to use, and we want to use those as examples for new work.
15:36:39 <hogepodge> https://docs.google.com/document/d/1KBhJcmpCTm8hn0BX-jO5MAyBYf2RHM5Jh5ib7GTZogM/edit
15:36:48 <TheJulia> #link https://docs.google.com/document/d/1KBhJcmpCTm8hn0BX-jO5MAyBYf2RHM5Jh5ib7GTZogM/edit
15:36:49 <hogepodge> #link https://docs.google.com/document/d/1KBhJcmpCTm8hn0BX-jO5MAyBYf2RHM5Jh5ib7GTZogM/edit Bare Metal Whitepaper
15:37:29 <TheJulia> heh
15:37:31 <TheJulia> #undo
15:37:32 <openstack> Removing item from minutes: #link https://docs.google.com/document/d/1KBhJcmpCTm8hn0BX-jO5MAyBYf2RHM5Jh5ib7GTZogM/edit
15:37:32 <TheJulia> #undo
15:37:33 <openstack> Removing item from minutes: #link https://docs.google.com/document/d/1KBhJcmpCTm8hn0BX-jO5MAyBYf2RHM5Jh5ib7GTZogM/edit
15:37:47 <TheJulia> #link https://docs.google.com/document/d/1KBhJcmpCTm8hn0BX-jO5MAyBYf2RHM5Jh5ib7GTZogM/edit Bare Metal Whitepaper
15:37:50 <TheJulia> There we go :)
15:37:55 <TheJulia> Anything else hogepodge ?
15:38:28 <hogepodge> That's it for me.
15:38:33 <TheJulia> Awesome!
15:38:57 <TheJulia> Moving on to Open Discussion
15:39:01 <TheJulia> #topic Open Discussion
15:39:03 <iurygregory> o/
15:39:06 <TheJulia> Anyone have anything else to discuss
15:39:09 <iurygregory> me
15:39:15 <TheJulia> goodnight iurygregory
15:39:33 <kbaegis> I was wondering if anyone is testing with supermicro equipment
15:39:36 <TheJulia> kbaegis: So we've not heard from anyone at supermicro but I have a business card from someone....
15:39:54 <iurygregory> On Friday I've sent and email to the openstack-discuss http://lists.openstack.org/pipermail/openstack-discuss/2019-June/006993.html
15:39:58 <TheJulia> kbaegis: A number of us use normal pxe on supermicro gear without issues, the vmedia is going to vary afaik.
15:40:14 <kbaegis> I’ve seen that several of the vendors implement optional portions of the redfish protocol, and the development here is hard coded to assume those features
15:40:15 <iurygregory> to see if we are ok in having the ironic-prometheus-exporter under Ironic umbrella =)
15:40:24 <hogepodge> kbaegis: I'm running supermicro equipment, but use pxe and ipmi
15:40:45 <kbaegis> I might need to fall back to that then
15:40:48 <TheJulia> kbaegis: Looks like they are claiming they support ISO virtual media attachment on their website... for newer hardware I guess
15:41:07 <kbaegis> They do- with a $150 license I don’t actually have. I might investigate that
15:41:22 <TheJulia> we're still working on the code to support vmedia
15:41:43 <TheJulia> #link https://www.supermicro.com/manuals/other/RedfishRefGuide.pdf Supermicro Redfish Ref Guide
15:41:55 <kbaegis> Well it’s awesome that the team is using the same vendor I am in my lab. Just asking. I may need to file a bug
15:42:30 <TheJulia> kbaegis: By all means, there is a huge variety in that hardware though.
15:42:49 <TheJulia> And their reference doesn't seem to actually talk about virtual media
15:43:14 <TheJulia> ohh... I see it... that looks super different
15:43:32 <kbaegis> As a user, I could also use a lot of help around the documentation pertaining to traits and overriding of deploy.deploy “core” steps
15:44:02 <kbaegis> I found it pretty confusing and so just dug straight into the code. I have a better idea now, but I’m not sure that could be consumed by other folks very easily
15:44:29 <TheJulia> kbaegis: There is not much overriding static methods in any of the deploy code :\
15:44:54 <kbaegis> The documentation states that you can set a priority of ‘0’ to disable/override anything you want
15:44:58 <kbaegis> Is that inaccurate?
15:44:59 <TheJulia> kbaegis: Please feel free to create bugs and we'll go from there (or even better patches) :)
15:45:14 <TheJulia> kbaegis: only actual steps
15:45:37 <TheJulia> kbaegis: what you mentioned as one of the method names was not an actual step, it is a method
15:45:44 <kbaegis> And this may be where I’m just dumb. I’m not understanding the difference, but we can discuss after the meeting
15:45:46 <TheJulia> iurygregory: I think we should put it under the ironic umbrella
15:45:54 <TheJulia> iurygregory: the exporter that is
15:46:01 * TheJulia is on two meetings at once, which adds lag.
15:46:08 <iurygregory> TheJulia, ok ^^
15:46:25 <iurygregory> any other people agree or have questions about it?
15:46:59 <openstackgerrit> Merged openstack/ironic-specs master: Replace git.openstack.org URLs with opendev.org URLs  https://review.opendev.org/654885
15:47:15 <jroll> iurygregory: I agree with that, it makes sense
15:47:18 <TheJulia> kbaegis: Nah, your not dumb :) It is complex and we use decorators, I can provide the context as to differences after the meeting
15:47:28 <iurygregory> jroll, tks
15:47:34 <jroll> iurygregory: I would love to keep pursuing the more common framework for openstack as a whole as mentioned in the thread :)
15:47:57 <rloo> kbaegis: don't we just have one core deploy step?
15:48:11 <rloo> kbaegis: has been a while, so i could be wrong.
15:48:17 <iurygregory> jroll, yeah, we would have to discuss how to move in that direction =)
15:48:22 <TheJulia> rloo: he wants to override an internal method
15:48:29 <rloo> TheJulia: OH.
15:48:49 <kbaegis> Because it’s broken for redfish :)
15:49:04 <rloo> kbaegis: then a bug.
15:49:12 <iurygregory> from my side thats it o/ tks TheJulia and jroll I will see how to move the project tomorrow =)
15:49:21 * iurygregory need to drop now o/
15:49:23 <rloo> kbaegis: and we should fix.
15:49:25 <kbaegis> I’m not seeing ironic on bugs.launchpad.net. Just ironic-dashboard
15:50:01 <rloo> kbaegis: this might be useful: https://docs.openstack.org/ironic/latest/contributor/code-contribution-guide.html
15:50:13 <TheJulia> iurygregory: o/
15:50:19 <rloo> kbaegis: 'Storyboard' is the bug tracker
15:50:34 <rloo> (among other things it is used for)
15:50:45 <kbaegis> Tyvm
15:50:50 <TheJulia> https://storyboard.openstack.org
15:51:08 <mkrai> kbaegis: Ironic uses storyboard https://storyboard.openstack.org/#!/project/943
15:53:17 <TheJulia> Is there anything else for us to discuss today during the meeting?
15:53:50 <rloo> crickets
15:55:38 <TheJulia> Well thanks everyone!
15:55:49 <rpioso> Thank you!
15:55:54 <jroll> thanks :)
15:56:10 <kaifeng> thanks :)
15:56:21 <mkrai> Thank you!
15:56:23 <TheJulia> #endmeeting