15:00:24 <TheJulia> #startmeeting ironic
15:00:25 <openstack> Meeting started Mon Oct 14 15:00:24 2019 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:25 <TheJulia> o/
15:00:26 <iurygregory> o/
15:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:28 <openstack> The meeting name has been set to 'ironic'
15:00:29 <openstackgerrit> Ilya Etingof proposed openstack/ironic master: Add `get_node_network_data` to non-Neutron NetworkInterface  https://review.opendev.org/688266
15:00:30 <jroll> \o
15:00:32 <TheJulia> etingof: all the rebases :)
15:00:33 <etingof> o/
15:00:37 <kaifeng_> o/
15:00:38 <bdodd> o/
15:00:45 <openstackgerrit> Ilya Etingof proposed openstack/ironic master: Make redfish boot interface using network interface metadata  https://review.opendev.org/688272
15:00:45 <TheJulia> Good morning everyone
15:00:45 <rajinir> o/
15:00:57 <cdearborn> \o
15:01:09 <arne_wiebalck> o/
15:01:14 <TheJulia> Our agenda for this meeting is on the wiki.
15:01:16 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:28 <TheJulia> #topic Announcements / Reminders
15:02:10 <rpioso> o/
15:02:11 <TheJulia> #info PTL will be in Shanghai for the Summit in early November.
15:02:19 <TheJulia> #info Summit is in 3 weeks! \o/
15:02:22 <mgoddard> \o
15:02:38 <openstackgerrit> Rachit Kapadia proposed openstack/ironic master: DRAC: Drives conversion from JBOD to RAID  https://review.opendev.org/679093
15:02:46 <TheJulia> Does anyone have anything else that they wish to announce or remind us of?
15:03:30 <TheJulia> I guess that is a no...
15:03:38 <TheJulia> Moving on then!
15:03:42 <TheJulia> #topic Review action items from previous meeting
15:04:16 <rpittau> o/
15:04:20 <TheJulia> mkrai let me know she was unable to double check the deprecation docs this past week, that it is on her list for this next week.
15:04:33 <TheJulia> iurygregory: Any update on 3.8 unit testing?
15:04:40 <iurygregory> TheJulia, yes =)
15:04:50 <iurygregory> I've summarized the status in https://etherpad.openstack.org/p/ironic_integration_jobs
15:04:52 <TheJulia> rpittau: and similarlly 37 and 38 compatability issues
15:05:11 <iurygregory> we are in a good shape for all jobs, but ironic-standalone has some problems for the BaremetalIpmiAnsibleWholedisk that is reaching timeout for the ping
15:05:21 <rpittau> TheJulia: I didn't see any other issues on that except what's reported in https://etherpad.openstack.org/p/Python_3.8_Deprecation_Hunt
15:06:00 <TheJulia> iurygregory: interesting, sounds like maybe an ansible compatability issue?
15:06:16 <TheJulia> rpittau: awesome, thanks
15:06:32 <iurygregory> TheJulia, yeah, not much expert in ansible, I'm trying to debug this =)
15:07:44 <TheJulia> iurygregory: okay, well if you see anything that has your wondering, please raise visibility in IRC :)
15:07:58 <iurygregory> TheJulia, ack
15:08:02 <TheJulia> Awesome, well carrying on then!
15:08:21 <TheJulia> #topic Review subteam status reports
15:08:29 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:08:38 <TheJulia> Line 236
15:10:28 * TheJulia removes hodgepodge from the etherpad :(
15:11:02 <TheJulia> regarding faster deployment stuffs, has anyone looked at hacking in support for kexec?
15:11:15 <TheJulia> crazy off the wall question, but it has been on my mind
15:12:20 * iurygregory nope
15:12:26 <TheJulia> It looks like there is nothing really new to cover
15:12:53 <openstackgerrit> Ilya Etingof proposed openstack/python-ironicclient master: Add `network_data` port/portgroup attribute support  https://review.opendev.org/688299
15:18:32 <TheJulia> And I got mentally derailed
15:18:34 <TheJulia> sorry folks
15:18:39 <iurygregory> np
15:18:47 <TheJulia> Priorities for the coming week!
15:18:54 <TheJulia> #topic Priorities for the coming week
15:19:08 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:19:11 <TheJulia> Line 156
15:19:40 <TheJulia> I saw two backports were proposed, which seems to make sense to add the backport list
15:21:13 <TheJulia> Adding an ironic-tempest-plugin change to the list
15:22:02 <TheJulia> etingof: how do you feel about virtual media patches?
15:23:00 <etingof> TheJulia, would be good to review some, e.g. -- https://review.opendev.org/687250
15:23:01 <patchbot> patch 687250 - ironic - Burn configdrive into virtual media boot ISO - 5 patch sets
15:24:35 <etingof> we have a chain of 7 ironic patches implementing dhcpless boot
15:24:45 <etingof> over virtual media
15:24:50 <TheJulia> Okay, I added the patches up to the patch you linked
15:24:54 <rpioso> etingof: \o/
15:24:57 <TheJulia> including pxe_append_params use
15:25:52 <etingof> awesome! pxe_append_params is just a virtual sugar, it's not really required for dhcpless boot as it stand now
15:25:54 <TheJulia> I think the list looks good
15:26:05 <TheJulia> etingof: it is, but it is in your patch series and it makes sense :)
15:26:17 <TheJulia> maybe one day we rename that var
15:26:51 <TheJulia> I've removed the old items from that list, Are we good to proceed?
15:26:54 <rpioso> TheJulia: Is a new sushy release for Train on the list?
15:27:11 <TheJulia> rpioso: do you need one of us to propose a 1.9.1?
15:27:37 <rpioso> TheJulia: Yes, please.
15:27:51 <TheJulia> okay, if you have the link for the patch, please send it over
15:28:02 <TheJulia> #action TheJulia will try to get a sushy 1.9.1 out this week
15:28:12 <TheJulia> So moving on to Discussion!
15:28:16 <TheJulia> #Discussion
15:28:22 <TheJulia> #topic Discussion
15:28:23 <rpioso> TheJulia: If memory serves, last Thursday we agreed to create a new sushy release off of an existing patch.
15:28:36 <TheJulia> rpioso: k
15:28:52 <rpioso> TheJulia: It would greatly benefit from etingof's input.
15:29:21 <TheJulia> One topic for quick discussion: I was looking at the release notes and found things kind of jumbled for vendors and wondering if we should create specific bunched release notes for hardware types?
15:29:51 <TheJulia> maybe create a single file and we keep appending to that during the cycle?
15:30:39 <mgoddard> TheJulia: is there any ordering to the notes?
15:30:46 <mgoddard> could we prefix?
15:30:55 <arne_wiebalck> TheJulia: I think this would be handy.
15:30:57 <TheJulia> mgoddard: none really, and that is kind of what I'm wondering, how to keep it logically together
15:31:19 <mgoddard> I mean in terms of what reno generates based on filenames
15:31:34 <iurygregory> the easy way to keep together would be using one file per hardware type maybe
15:31:35 <mgoddard> i.e. if you add 99_dell_fancy_feature_3543523.yml
15:31:37 <TheJulia> It is worth asking...
15:32:06 <TheJulia> I can try to remember and ask this week and hopefully we can do something to keep it a little more sane this cycle
15:32:32 <mgoddard> for the main benefit of reno IMO is separating the notes to avoid collisions
15:32:32 <rpioso> TheJulia: Perhaps a PVG topic?
15:33:00 <mgoddard> (it's also the main drawback from the perspective of someone tidying notes at the end of the cycle)
15:33:05 <TheJulia> #action TheJulia to ask reno authors for providing ordered clarity in overall notes.
15:33:18 <TheJulia> Good to proceed to RFE Review?
15:34:17 * TheJulia hears crickets
15:34:22 <TheJulia> #topic RFE Review
15:34:23 <rpioso> TheJulia: What about the Baremetal SIG?
15:34:33 <rpioso> TheJulia: Who's now leading it?
15:34:58 <TheJulia> rpioso: arne_wiebalck and I are still trying to sort that out
15:35:13 <rpioso> arne_wiebalck, TheJulia: Thank you!
15:35:18 <TheJulia> #link https://storyboard.openstack.org/#!/story/2003594
15:35:32 <rpioso> That's mine :-)
15:36:21 <rpioso> The idea of that RFE is to support rapid provisioning of baremetal.
15:37:10 <TheJulia> rpioso: is the export intended to be manual?
15:37:24 <rpioso> Port PXE boot enable, BIOS settings, RAID, etc. could be declaratively specified and applied via a clean/deploy step.
15:37:55 <rpioso> TheJulia: Any reason why it couldn't be auto, too?
15:38:18 <rpioso> TheJulia: Couldn't some code in the automatic workflow process it?
15:39:39 <TheJulia> rpioso: well, my concern would be if automated export was a thing, having to tool through the path to retrieve that when your working on another machine that you want deployed
15:39:51 <TheJulia> granted, maybe one day we'll have snapshot capabilities :)
15:40:33 <TheJulia> So fundimentally it is more concerns over lower level interactions, I guess we need more information of the workflow and mechanisms (like flow diagrams)
15:41:18 <rpioso> TheJulia: If the export output were stored in Swift or some other datastore, it could be used by subsequent processing.
15:41:29 <TheJulia> absolutely
15:42:01 <rpioso> TheJulia: That data would provide info on what's possible and what already exists.
15:42:29 <rpioso> TheJulia: In terms of hardware, BIOS settings, RAID volumes, etc.
15:42:34 <TheJulia> Indeed, and that could be saved from a clean step?
15:42:58 <rpioso> TheJulia: Right. Deploy step could save it, too.
15:43:16 <TheJulia> But only for the machine it is working upon
15:43:39 <rpioso> TheJulia: It's specific to the machine being operated on.
15:43:49 <TheJulia> As in the one in task.node, no other machine
15:44:00 <rpioso> TheJulia: Yep
15:44:51 <rpioso> TheJulia: Of course, installed hardware components, BIOS config, RAID volumes, and the like are specific to a node.
15:46:38 <TheJulia> Okay, I really think some more mechanics information is needed since it is really a whole suite of things
15:46:50 <TheJulia> so borderline spec to be honest
15:47:07 <TheJulia> But since it is inside your driver's interfaces, rfe I guess is fine
15:48:26 <rpioso> TheJulia: We'd prefer an RFE. I could add more detail to the story, if that would help.
15:48:34 <TheJulia> That would help
15:49:37 <rpioso> TheJulia: Could it be tagged rfe-approved, as-is, with a comment asking for more details?
15:50:26 <TheJulia> Other cores, what do you think?
15:51:12 <jroll> I wouldn't tag it approved without all of the information
15:51:20 <TheJulia> I'm a little hesitant to mark it approved without some additional details first. I think I understand based on this discussion, but the source of truth for that work is the story without any sort of spec document
15:51:22 <rpittau> I'm all for a detailed RFE
15:51:32 <TheJulia> I concur, thanks jroll, rpioso
15:51:37 <TheJulia> err, rpioso
15:51:38 <TheJulia> gah
15:51:40 <TheJulia> rpittau:
15:51:42 <rpittau> that yeah :D
15:51:46 <TheJulia> tab autocomplete fail
15:51:56 <TheJulia> Anyway! Moving on to Open Discussion
15:51:59 <TheJulia> #topic Open Discussion
15:52:06 <TheJulia> Do we have anything else to discuss this week?
15:52:17 <rpioso> Thank you for your consideration :)
15:53:39 <rpioso> TheJulia: Would there be any way to include https://review.opendev.org/672498 in a Train release?
15:53:39 <patchbot> patch 672498 - ironic - Add Redfish vmedia boot interface to idrac HW type (MERGED) - 24 patch sets
15:53:40 * TheJulia senses the open discussion crickets
15:53:52 <rpittau> TheJulia: team photo
15:53:53 <TheJulia> rpioso: There is not any way
15:54:06 <TheJulia> rpittau: best we can do is do a early U cycle release
15:54:11 <TheJulia> rpittau: oh yes!
15:54:30 * rpioso considers changing his name ;-)
15:54:48 <rpittau> I could use my alt nickname :D
15:55:03 <rpioso> rpittau: lol
15:55:28 <TheJulia> rpittau: set for 11:20-11:30 AM which gives us a quick break before lunch at 12:30
15:55:39 <TheJulia> on Thursday
15:55:48 <rpittau> TheJulia: sounds good to me
15:56:19 <TheJulia> I guess wear something... ironic :)
15:56:53 <rpittau> so for who's coming to Shanghai, there will be a team photo, keep a 10 minutes slot free for Thursday at 11:20 :)
15:57:08 <arne_wiebalck> Do we have baremetal shirts?
15:57:30 * rpittau might consider using a full knight armor
15:57:33 <TheJulia> arne_wiebalck: no, but... hmm
15:57:39 <iurygregory> rpittau, ++
15:58:11 <TheJulia> arne_wiebalck: Let me see if I can get in touch with the original artist and post soemthing that we can order. Doing distributed that way so nobody runs into any issues with trying to import a quantity of t-shirts
15:58:39 <arne_wiebalck> TheJulia: Sounds great!
15:59:22 <TheJulia> jroll: JayF: Do you guys remember if it was a racker that did the "how ironic really works" artwork?
16:00:36 <TheJulia> Also, topics wise, the etherpad is still open for thoughts/ideas: https://etherpad.openstack.org/p/PVG-Ironic-Planning
16:01:00 <TheJulia> I _suspect_ we're going to go through things kind of free form
16:01:02 <jroll> TheJulia: yeah, it was an intern
16:01:51 <TheJulia> dtantsur|brb: do you have the image you had printed on the last round of t-shirts?
16:02:23 <TheJulia> #endmeeting