15:00:30 <TheJulia> #startmeeting ironic
15:00:31 <TheJulia> o/
15:00:31 <openstack> Meeting started Mon Dec  2 15:00:30 2019 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:34 <openstack> The meeting name has been set to 'ironic'
15:00:36 <iurygregory> o/
15:00:38 <TheJulia> Good morning everyone!
15:00:41 <kaifeng> o/
15:00:42 <jerrywang> o/
15:00:46 <arne_wiebalck> o/
15:00:49 <stendulker> o/
15:00:52 <mkrai> o/
15:00:56 <cdearborn> o/
15:01:12 <rloo> o/
15:01:22 * TheJulia makes one last moment change to agenda that likely nobody will notice because she has CDO
15:01:34 <TheJulia> Our agenda can be found on the wiki
15:01:36 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:58 <TheJulia> #topic Announcements / Reminders
15:02:03 <jroll> \o
15:02:05 <rpioso> o/
15:02:17 <rpittau> o/
15:02:27 <TheJulia> #info Cycle priorities have merged.
15:02:39 <TheJulia> #info Whiteboard has been updated to reflect cycle priorities.
15:03:02 <TheJulia> #info Older/still-in-flight items have been moved into the lower section of the etherpad accordingly.
15:04:31 <TheJulia> As a reminder, the Operators mid-cycle is scheduled to take place in London January 6th and 7th. If anyone from ironic is in attendance, it would be good for a community representation and relationship building context. If you have any questions, please feel free to reach out to me as I have attended a few of their mid-cycles over the years.
15:04:43 <TheJulia> Does anyone have any other Announcements or Reminders for us this morning?
15:05:11 <rpittau> I will probably be in London for the ops meetup
15:05:36 <rpittau> btw should be January 7-8, not 6-7
15:05:37 <TheJulia> rpittau: Awesome!
15:05:39 <TheJulia> doh!
15:05:43 <rpittau> :)
15:05:45 <TheJulia> Thanks!
15:05:54 <TheJulia> Anything else or shall we proceed onward?
15:06:51 * TheJulia takes silence as that we can proceed
15:06:56 <iurygregory> HP 3rd Party CI is with POST_FAILURE since past week =)
15:07:24 <iurygregory> I've sent an e-mail to the main contacts from the wiki Page =)
15:07:33 <TheJulia> iurygregory: Awesome!
15:07:50 <TheJulia> #topic Action Items from the prior meeting
15:08:30 <TheJulia> We had only one action item last week which was mine to reach out to the regarding use cases regarding the baremetal whitepaper. I didn't get a chance to do that because I simply ran out of time last week.
15:08:49 <TheJulia> #action TheJulia to reach out to the foundation regarding the baremetal program use cases.
15:09:05 <TheJulia> Moving on!
15:09:08 <TheJulia> #topic Review subteam status reports
15:09:17 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:09:25 <TheJulia> Starting at line 275
15:10:17 <TheJulia> arne_wiebalck: I've not had a chance to circle back to the ml thread from Nova regarding nova-compute performance, but we still had try to make scale/performance improvements/testing, so I've added at least one possible item to the theme on the whiteboard.
15:11:08 <arne_wiebalck> TheJulia: ok, thanks
15:11:18 <arne_wiebalck> TheJulia: will try to have a look at this asap
15:11:35 <arne_wiebalck> TheJulia: with our local nova experts
15:11:35 <TheJulia> arne_wiebalck: thanks
15:12:03 <rloo> TheJulia: just a bookkeeping thing; L277. Are you still updating this based on our priorities, or has it been updated already.
15:12:04 <TheJulia> etingof: It would be good if you could update line 310's section at some point in the next week
15:12:45 <TheJulia> rloo: Deleted line 277, good catch, I already indicated earlier on that I had updated the etherpad from the priority list
15:12:56 <rloo> TheJulia: thanks :)
15:13:00 <TheJulia> struckout items on the etherpad I'll delete after this meeting
15:13:56 <TheJulia> I think the list mostly looks good.
15:14:17 <TheJulia> iurygregory: I saw the client library py27 removals were hitting issues? Is there anythign requiring assistance there?
15:14:40 <iurygregory> TheJulia, according to the community goals we can only drop on Phase 2
15:14:46 <rloo> dtantsur|afk: or jerrywang, for replacing WSME, would you please clean that up, show the current status? (Or did people want history?)
15:14:53 <rloo> L315ish
15:14:55 <iurygregory> thats why I've mark Workflow -1
15:15:00 <TheJulia> iurygregory: ack
15:15:00 <jerrywang> ok.
15:15:48 <TheJulia> A little history is always useful for context, but I concur, I Was looking at that item earlier and thinking that it wasn't clear what the current status really was at a glance.
15:16:26 <jerrywang> I Update latest WSME status
15:16:39 <rloo> TheJulia: similar thing with Python 3 (L368). I'm not sure what the status is...
15:17:17 <rloo> and Python 3 is an 'other'. did we finish up what we wanted to do?
15:17:41 <rpittau> rloo: I think that should be moved under community goals
15:18:01 <TheJulia> rpittau: done
15:18:10 <TheJulia> I'm striking out py3 related stuff that looks out of date
15:18:13 <rpittau> thanks :)
15:18:23 <rpittau> oh ok I removed py3.5 already
15:18:45 <TheJulia> that is fine
15:18:52 <kaifeng> is six not python3-compatible?
15:18:53 <arne_wiebalck> xXraphXx reworked & rebased the UEFI s/w RAID patches if anyone wants to have a look, I'll also try to review test this week
15:19:03 <TheJulia> okay, I think that covers things from my pov
15:19:04 <arne_wiebalck> *review and test
15:19:09 <rloo> i just looked at our priorities. 'drop python 2.7 support' is there. iurygregory and rpittau are the contacts.
15:19:33 <rloo> rpittau, iurygregory: you ok if I put your names next to Python 3? (L366)
15:19:34 <TheJulia> kaifeng: six is just a py2/py3 compatability library
15:19:34 <rpittau> kaifeng: it is, but it's not required anymore since we're dropping py2.7
15:19:42 <iurygregory> rloo, sure
15:19:47 <TheJulia> arne_wiebalck: thanks!
15:19:53 <TheJulia> I'll try to look this week.
15:19:54 <rpittau> rloo: syre
15:19:59 <rpittau> s/syre/sure
15:20:08 <kaifeng> not sure if we want to specific python3 version through it
15:20:13 <rloo> thank YOU rpittau & iurygregory :)
15:20:32 <iurygregory> rloo, yw
15:20:55 <rpittau> kaifeng: can you elaborate please ?
15:21:52 <rloo> wrt zuul v3 migration, it looks like we're blocked on grenade not migrated? is that right? (L390)
15:22:12 <TheJulia> rloo: afaik, yes, that seems to be the issue for everyone afaik
15:22:28 <rloo> any idea when/if grenade will be migrated?
15:23:03 <TheJulia> Looks like gmann is working on it
15:23:19 <TheJulia> and some others it looks like
15:24:42 <TheJulia> I suspect it is just going to be a waiting game
15:25:13 <rloo> TheJulia: ok, i noted that we're blocked on that. we can wait. patience is a virtue etc :)
15:25:15 <kaifeng> rpittau: oh i need a new brain, i mean stuff like sys.version_info
15:25:24 <iurygregory> we can only move after they have the grenade migrated =)
15:26:07 <iurygregory> I'm keeping an eye on ML to see when it's done so we can give a try to move our jobs
15:26:09 <TheJulia> kaifeng: I suspect lots of that can go away, but we only had minimal amounts of such checks/logic paths
15:26:46 <rloo> thx iurygregory! I'll put your name down next to that.
15:27:06 <iurygregory> rloo, ty
15:27:16 <kaifeng> TheJulia: that's true
15:27:56 <TheJulia> Are we good to move on?
15:28:23 <rloo> ++
15:28:36 <rpittau> let's
15:28:59 <TheJulia> Excellent
15:29:21 <TheJulia> #topic Priorities for the coming week
15:29:40 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:29:46 <TheJulia> Starting at line 167
15:30:29 <TheJulia> arne_wiebalck: is the patch on line 224 still needed?
15:30:52 <rpittau> mmm sorry if I go back in time but have you seen the note on L154 about the HP CI ?
15:30:52 <arne_wiebalck> TheJulia: no
15:30:59 <TheJulia> looks like https://review.opendev.org/#/c/686585/ is what is needed in the IPA list
15:30:59 <patchbot> patch 686585 - ironic-python-agent - Software RAID: Use UUID to find root fs - 5 patch sets
15:31:19 <arne_wiebalck> TheJulia: I should clean this up as well (I did at another place on the etherpad)
15:31:30 <TheJulia> rpittau: That is about two months old
15:31:40 <TheJulia> arne_wiebalck: okay
15:31:57 <rpittau> oh ok, thought they had another one!
15:32:35 <arne_wiebalck> TheJulia: it's cleaned up around line 330 (Ussuri priorities, probably the wrong place)
15:32:55 <arne_wiebalck> TheJulia: we have kind of a double bookkeeping for these
15:33:03 <TheJulia> It seems we're going to need to discuss virtual media based L3 deploy, but dtantsur|afk is not here so I guess that item can stay in review fo rnow, otherwise the list lgtm minus raid cleanups :)
15:33:17 <TheJulia> arne_wiebalck: kind of yeah, more so "what is out there, and what to focus on this week"
15:34:18 <TheJulia> arne_wiebalck: are those two patches needed in any particular order?
15:35:05 <arne_wiebalck> TheJulia: the rootfs and the ueif one?
15:35:09 <arne_wiebalck> uefi
15:35:16 <TheJulia> the one for ironic and the one for ipa
15:35:26 <TheJulia> in the list around line 330
15:36:09 <arne_wiebalck> w/o the ironic one, the IPA one will break things (as it would expect a proper UUID)
15:36:26 <arne_wiebalck> so the ironic one should go first
15:36:32 <TheJulia> ok
15:37:11 <TheJulia> okay, I see the dependency. Uhhh... that makes me wonder if newer IPA were to break on a train ironic then?
15:37:40 <arne_wiebalck> yes, it would
15:37:52 <TheJulia> that is a little bit of a problem :\
15:38:31 <arne_wiebalck> how can we solve this? I guess the IPA cannot really check if the passed UUID is valid.
15:38:33 <TheJulia> the intent is for IPA to support ironic n-1
15:38:56 <TheJulia> I'd have to look at the code to really be able to discuss it
15:39:11 <arne_wiebalck> we could try with the UUID and fall back to the current behaviour
15:39:20 <arne_wiebalck> but, yeah, we can take this offline
15:39:39 * TheJulia goes and makes notes
15:40:47 <TheJulia> I'm good with the list, are we good to proceed?
15:41:14 <openstackgerrit> Merged openstack/ironic-python-agent master: Remove the configuration sample file  https://review.opendev.org/696862
15:41:47 * TheJulia hears crickets
15:41:59 <TheJulia> everyone good with the list?
15:42:03 <rpittau> yep
15:42:05 <openstackgerrit> Merged openstack/ironic-python-agent master: Remove the unused dependency on iso8601  https://review.opendev.org/696379
15:42:06 <arne_wiebalck> yes
15:42:11 <rloo> ++
15:42:57 <TheJulia> Okay, onward!
15:43:10 <TheJulia> #topic Discussion
15:43:36 <TheJulia> We still have the discussion item about the midcycle, I guess there is not much to really discuss since some people have indicated they are seeking budget approvals
15:43:50 <TheJulia> arne_wiebalck: you mentioned something about double checking hotels?
15:44:29 <arne_wiebalck> TheJulia: No, the rooms (as we may shift to Feb 26/27)
15:44:42 <TheJulia> Oh, okay
15:44:42 <arne_wiebalck> TheJulia: We can put up a list of hotels, though.
15:44:51 <arne_wiebalck> 26/27 would be more diffcult
15:45:06 <arne_wiebalck> we'll need to decide at some point
15:45:16 <arne_wiebalck> if 25/26 is ok, I suggest we stick with it
15:45:28 <arne_wiebalck> unless there are major objections?
15:46:25 <TheJulia> I don't have any objections,
15:46:27 * arne_wiebalck hears crickets
15:46:33 <rpittau> no objections
15:46:33 * arne_wiebalck is too slow
15:46:57 <arne_wiebalck> then it'd be great if people registered on https://indico.cern.ch/event/863986/
15:47:17 <TheJulia> #link https://indico.cern.ch/event/863986/
15:47:38 <arne_wiebalck> so I get the number of participants, can prepare the site access (and of course tours :)
15:47:49 <TheJulia> okay
15:47:56 <arne_wiebalck> it's really just to get an idea
15:48:07 <rpittau> arne_wiebalck: even if we're not 100% sure ?
15:48:24 <TheJulia> rpittau: that is the impresison I'm getting :)
15:48:25 <arne_wiebalck> rpittau: I thought you are 120% sure?
15:48:39 * TheJulia wonders if we're creating new number systems of counting
15:48:48 <arne_wiebalck> rpittau: yes, you can of course also cancel if things do not work out
15:48:57 <TheJulia> Can we do percentages in hex?
15:49:03 <arne_wiebalck> rpittau: but esp for the tours I need to be early
15:49:18 <arne_wiebalck> TheJulia: :-D
15:49:27 * iurygregory registered even without 100% sure =)
15:49:34 <TheJulia> \o/
15:49:35 <rpittau> arne_wiebalck: I understand, and I'm optimist, so goingto register anyway :D
15:49:40 <TheJulia> Okay, well, I guess we're good to carry on
15:49:44 <arne_wiebalck> iurygregory:  nice
15:50:03 <TheJulia> We have nearly 10 minutes left, I'm not sure there is anything to really discuss with the Baremetal SIG
15:50:13 <TheJulia> at least right now
15:50:26 <arne_wiebalck> I don't think so ... we should ping potential authors now.
15:50:32 <TheJulia> And there are no RFE's for review, so I think the next step is Open Discussion?
15:50:36 <TheJulia> arne_wiebalck: ++
15:50:49 * arne_wiebalck is getting mails about mid-cycle registrations
15:50:53 <openstackgerrit> Merged openstack/ironic master: Add indicator management to redfish hw type  https://review.opendev.org/652740
15:51:03 <TheJulia> arne_wiebalck: \o/
15:51:18 <TheJulia> Moving to Open Discussion
15:51:25 <TheJulia> #topic Open Discussion
15:51:28 <TheJulia> Anyone have anything?
15:52:27 <kaifeng> there is an interesting requirement to add a no-deploy interface, want to know if it has value to the upstream?
15:53:42 <kaifeng> the idea is to do no real deployment, but utilize the network switching for vlan trunk configuration.
15:54:13 <TheJulia> kaifeng: to what end? just like environment management?
15:54:30 <kaifeng> there is a preexisting deploy server to do the rest.
15:54:54 <mkrai> kaifeng, I had a similar use-case in the past
15:55:08 <kaifeng> yeah, something like that, we are about to do so for our bare metals
15:55:20 <TheJulia> kaifeng: I could see that making a lot of sense for some of the mixed lab enironments out there... the idea is really growing on me
15:56:59 <TheJulia> Anything else for discussion today?
15:57:49 * TheJulia hears cricket
15:58:16 <kaifeng> TheJulia: I'll recap this after all this is done, still in verification stage, but things seems working fine.
15:58:33 <TheJulia> kaifeng: awesome
15:58:42 <TheJulia> Well, thanks everyone!
15:58:51 <arne_wiebalck> TheJulia: Thanks!
15:58:55 <rpittau> thanks!
15:58:59 <kaifeng> TheJulia: thanks!
15:59:08 <jerrywang> thejualia, thanks!
15:59:25 <rpioso> TheJulia: Thank you!
15:59:57 <TheJulia> #endmeeting