15:00:27 <TheJulia> #startmeeting ironic
15:00:29 <openstack> Meeting started Mon Mar 16 15:00:27 2020 UTC and is due to finish in 60 minutes. The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:32 <openstack> The meeting name has been set to 'ironic'
15:00:33 <iurygregory> o/
15:00:33 <rpittau> o/
15:00:42 <bdodd> o/
15:00:48 <mgoddard> \o
15:00:48 <rpioso> \o
15:00:53 <ajya> o/
15:00:53 <kaifeng_> o/
15:00:54 <erbarr> o/
15:01:13 <TheJulia> Greetings everyone! I'm kind of hoping for a quick meeting today, for I'm making good progrss on notes from our midcycle!
15:01:13 <dtantsur> o/
15:01:21 <TheJulia> well s/notes/summary/
15:01:30 <arne_wiebalck> o/
15:01:37 <TheJulia> Thanks dtantsur, rpittau, and iurygregory for helping out with $words
15:01:38 <cdearborn> o/
15:01:38 * arne_wiebalck is still in another meeting
15:01:44 * TheJulia goes and deals with her cat for a moment
15:01:45 <rpittau> :D
15:01:47 <jroll> \o
15:01:48 <iurygregory> np o/
15:01:58 <TheJulia> and cat removed from home office
15:02:01 <dtantsur> always welcome
15:02:23 <TheJulia> Our agenda today is on the wiki
15:02:29 <TheJulia> And looks like it is the default agenda.
15:02:31 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:02:48 <TheJulia> #topic Announcements/Reminders
15:03:02 * iurygregory maybe for announcements - grenade in stable/stein is fixed tks gmann for the help!
15:03:42 <etingof> o/
15:03:42 <TheJulia> A gentle reminder to all contributors, we only have a few more weeks where we'll be able to focus on merging feature code. Please be mindful and review/rebase/update patches. It is a community effort together!
15:04:09 <TheJulia> Does anyone have any reminders or announcements for the community this week?
15:04:51 <dtantsur> stay safe and wash your hands!
15:04:52 * iurygregory not sure if what I said before would count but ...=)
15:04:56 <iurygregory> dtantsur, lol
15:05:27 <TheJulia> dtantsur: ++
15:05:35 <iurygregory> same announcements everywhere here
15:05:42 <TheJulia> Indeed!
15:05:49 <TheJulia> Anyway, lets move on!
15:06:14 <rajinir> o/
15:06:14 <TheJulia> #topic Review action items from the prior week
15:06:41 <TheJulia> dtantsur: Looks like you had one action item to document supported branches for ?ironic-tempest-plugin?
15:06:53 <dtantsur> I didn't even remember about that, sorry
15:06:58 <TheJulia> no worries
15:07:06 <TheJulia> Shall we carry it forward?
15:07:08 <dtantsur> yep
15:07:23 <iurygregory> dtantsur, I can take care if you don't have time
15:07:39 <TheJulia> iurygregory: I think that would be awesome
15:07:46 <TheJulia> iurygregory: do you want the action item?
15:07:51 <iurygregory> TheJulia, sure
15:08:00 <TheJulia> #action iurygregory to document supported branches for ?ironic-tempest-plugin?
15:08:20 <dtantsur> it's not only for the plugin
15:08:24 <TheJulia> #undo
15:08:25 <openstack> Removing item from minutes: #action iurygregory to document supported branches for ?ironic-tempest-plugin?
15:08:28 <TheJulia> #action iurygregory to document supported branches
15:08:31 <dtantsur> overall, what our policy on supported branches is
15:08:36 <dtantsur> at least atm
15:08:49 <TheJulia> so contributor guide docs, I think
15:09:01 <dtantsur> yep
15:09:02 <TheJulia> Anyway, we shall see
15:09:05 <TheJulia> Onward!
15:09:12 <TheJulia> #topic Review subteam status reports
15:09:21 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:10:00 <TheJulia> Line 239
15:10:29 <TheJulia> Ugh, we need to spend some time bug triaging :(
15:11:04 <dtantsur> we do
15:11:18 <dtantsur> I've been unable to dedicate time to it for a while (sorry!)
15:11:31 <TheJulia> arne_wiebalck: hopefully my desire to deal with words won't burn out today and I can do the major word shuffling for the whitepaper
15:12:26 * TheJulia updates the multitenancy note
15:12:37 <arne_wiebalck> TheJulia: that would be great
15:12:55 * arne_wiebalck is not sure if wfh will allow to work more or even less on this
15:14:16 <etingof> depends on the kids
15:14:20 <TheJulia> etingof: updated dhcp-less deployment for you
15:14:23 <TheJulia> etingof: indeed
15:14:38 <TheJulia> and cats, and wife, and economy, and chaos, and grocery shopping
15:14:48 * TheJulia digresses until open discussion
15:15:06 * etingof will update spec status
15:15:28 <TheJulia> :)
15:15:38 <TheJulia> look 4 lines down :)
15:16:06 <TheJulia> arne_wiebalck: regarding node retirement, are we completely done? As in I can find docs on it if I go search?
15:16:29 <arne_wiebalck> code wise, I think so
15:16:44 <arne_wiebalck> we may need a description of a workflow
15:16:51 <arne_wiebalck> I can take care of this
15:17:03 <dtantsur> yeah, maybe a short admin guide page
15:17:04 <arne_wiebalck> I don't think we have docs yet
15:17:10 <arne_wiebalck> dtantsur: ++
15:17:11 <rpittau> no, we don't
15:17:25 <arne_wiebalck> otherwise we should be good I think
15:17:49 <TheJulia> Yeah, a short admin guide page would be perfect. I can also send that over to an operator whom I know was impressed that such support has merged :)
15:18:04 <TheJulia> dtantsur: you posted a disk targets wip right?
15:18:23 <dtantsur> yeah
15:18:36 <dtantsur> https://review.opendev.org/713209
15:18:37 <patchbot> patch 713209 - ironic-python-agent - [WIP] Allow specifying target devices for software... - 1 patch set
15:18:44 <dtantsur> I need to rebuild my devstack to try it out
15:18:44 <TheJulia> okay
15:18:50 <TheJulia> k
15:19:00 * TheJulia should have ordered 3 disks for the supermicro...
15:19:28 * dtantsur should have built a small rack in the kitchen
15:20:04 <openstackgerrit> Merged openstack/ironic stable/stein: tell reno to ignore the kilo branch https://review.opendev.org/706785
15:20:15 <dtantsur> stein is releasable now, nice
15:20:25 <TheJulia> yay
15:20:54 <TheJulia> iurygregory: Are the grenade notes on the etherpad yours?
15:21:01 <iurygregory> yes
15:21:12 <TheJulia> and that is latest status?
15:21:45 <iurygregory> yup
15:21:54 <iurygregory> still doing tests with the multinode
15:21:56 <TheJulia> Additional question, any of those need to be reviewed this week?
15:22:20 <iurygregory> no need o/
15:22:48 <TheJulia> awesome
15:22:58 <TheJulia> Well, are we good to proceed to priorites for the week?
15:23:23 <dtantsur> ++
15:23:27 <rpittau> let's
15:24:24 <TheJulia> #topic Priorities for the coming week
15:24:31 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:24:34 <TheJulia> Line 122
15:24:43 * TheJulia removes merged things
15:26:37 <TheJulia> Okay, I think that is good
15:26:48 <TheJulia> Does anyone have anything to add to the list?
15:27:27 <dtantsur> looks like plenty of work
15:27:52 <mgoddard> ooh, bifrost
15:27:53 <rpittau> centos8 job in bifrost is broken -> https://review.opendev.org/712692
15:27:54 <patchbot> patch 712692 - bifrost - Fix for PEP517 issue with Python 3.6.8 - 6 patch sets
15:28:06 <TheJulia> I should likely rebase https://review.opendev.org/#/c/492114/... but it can go on the list again next week
15:28:07 <patchbot> patch 492114 - ironic - Change [deploy]/default_boot_option to local - 25 patch sets
15:28:30 <TheJulia> rpittau: Interesting! I hit that yesterday oddly enough
15:29:03 <TheJulia> rpittau: however, on Ubuntu
15:29:13 <rpittau> that was a true surprise, considering that 3.6.8 is the last version with bugfixes
15:29:17 <rpittau> ubuntu has 3.6.9
15:29:34 <iurygregory> rpittau, I've added your patch to re-add grenade jobs in stable/stein in the backports section
15:30:06 <rpittau> iurygregory: ok, not sure that can be considered a backport though
15:30:10 <TheJulia> rpittau: I might be slightly old on that machine, I ran package upgrades and it went away
15:30:23 <TheJulia> Anywya, the list looks good to me
15:30:25 <iurygregory> rpittau, it helps with a backport to stable/stein XD
15:30:42 * arne_wiebalck joins o/
15:30:47 <rpittau> iurygregory: I'm not following :/
15:30:54 * rpittau might need another espresso
15:31:08 * TheJulia makes coffee
15:31:26 * iurygregory have a backport in stable/stein and it was failling in grenade only.. we removed the jobs, now we are adding again since it's fixed
15:31:27 <TheJulia> Everyone happy witht he list? If so, I propose we move directly to Open Discussion.
15:31:35 * dtantsur is
15:31:41 <rpittau> yeah
15:31:43 <mgoddard> +1
15:31:43 <TheJulia> iurygregory: why are we re-adding the job?
15:31:48 <iurygregory> TheJulia, yes
15:31:53 <iurygregory> it's green again
15:31:59 <rpittau> TheJulia: the jobs were fixed by gmann
15:32:00 <iurygregory> gmann, found the issue and fixed
15:32:15 <TheJulia> Grenade test of EOL to stein is not something we need to support
15:32:35 <iurygregory> hummm
15:33:10 <iurygregory> so we can just move without re-adding the jobs...
15:33:13 <mgoddard> EM, not EOL :)
15:33:19 <rpittau> rocky is EM
15:33:34 <TheJulia> sorry, brain wants more coffee it seems
15:34:38 <TheJulia> I'm not objecting to really adding back, but I'm not sure there is really much risk there if the jobs are no longer there and we're no longer releasing rocky
15:35:05 <dtantsur> I guess the reasoning is that we should still support people who want to jump off the EM release
15:35:11 <dtantsur> (which is not entirely dead, just not well supported)
15:35:23 <dtantsur> it also brings us back to the discussion of supported branches
15:35:30 <TheJulia> indeed
15:35:32 <mgoddard> if it passes, we could keep it until it stops working
15:35:38 <mgoddard> at that point we can make a call
15:35:39 <TheJulia> Okay, I'll +A a patch to put it back then
15:35:48 <openstackgerrit> Iury Gregory Melo Ferreira proposed openstack/ironic-prometheus-exporter master: Add documentation https://review.opendev.org/713274
15:36:01 <TheJulia> mgoddard: exactly
15:36:15 <TheJulia> Okay, sounds like we're good to move on then?
15:36:30 <iurygregory> ++
15:36:45 <dtantsur> ++
15:36:46 <TheJulia> #topic Open Discussion
15:37:10 <TheJulia> Everyone please stay safe during this time. I'm worried about you al!
15:37:16 <TheJulia> s/al/all/
15:37:19 <iurygregory> ++
15:37:20 <dtantsur> ++ thanks TheJulia
15:37:27 <rpittau> thanks :)
15:37:33 <kaifeng_> :)
15:37:34 <iurygregory> things are crazy all over the world =(
15:37:37 <dtantsur> yeah
15:37:52 * dtantsur is worried about Russia particularly nowadays
15:38:01 * iurygregory the president of Brazil doesn't care .-.
15:38:31 <dtantsur> hey, we're in the same bucket then :)
15:38:46 <TheJulia> well, I highly encourage us to be here for one another, even if it is just rant, or share videos to cute cats, or a distraction through a KSP "look at this crazy thing I built" video
15:38:56 <mgoddard> No problem for us plucky Brits, just keep calm and carry on washing those hands...
15:38:57 <iurygregory> ++
15:39:05 <iurygregory> share funny things on twitter
15:39:10 <TheJulia> ++
15:39:12 <iurygregory> action item to everyone
15:39:17 <dtantsur> I see people are organizing spontaneous virtual conferences
15:39:29 <TheJulia> dtantsur: ohhh, ahh!
15:39:29 <dtantsur> I wonder if the OpenStack world should come up with one too
15:39:41 <mgoddard> PTG will go virtual
15:39:51 <TheJulia> Can we have a spontaneous unconference?
15:39:56 <dtantsur> "While you're at home getting crazy with kids, we'll tell you about ironic and how it can make at least some things better"
15:40:00 <iurygregory> we can
15:40:00 <dtantsur> I mean, yeah!
15:40:25 <iurygregory> dtantsur, this sounds like when ironic will support irc...
15:40:35 <dtantsur> sooon
15:40:42 <iurygregory> XD
15:40:47 <dtantsur> fwiw I'm quite serious about this
15:40:55 <TheJulia> but Ironic shall never have an integrated mail reader!
15:41:02 <dtantsur> or a text editor
15:41:06 <TheJulia> ++
15:41:15 <etingof> let it become just an operating system
15:41:25 <TheJulia> we'll just call out to vim for that part :)
15:41:39 <dtantsur> and to emacs for a mail reader!
15:41:45 <TheJulia> doh!
15:41:49 <rpittau> isn't emacs actaully an OS ?
15:41:57 <mgoddard> I have a non-virus-related item for discussion
15:42:00 <dtantsur> I think it has some chat and email apps
15:42:07 <TheJulia> mgoddard: sure!
15:42:41 <mgoddard> For Kayobe we are transitioning from CentOS 7 to CentOS 8 at the train release
15:42:48 <mgoddard> Same as tripleo
15:43:02 <TheJulia> yes
15:43:06 <mgoddard> We use bifrost, which doesn't support CentOS 8 in train
15:43:11 <mgoddard> Should it? Could it?
15:43:13 <dtantsur> I was afraid of this
15:43:16 <mgoddard> :)
15:43:28 <rpittau> mgoddard: yeah, was thinking the same :)
15:43:35 <dtantsur> it should, I'm not sure it could
15:43:43 <mgoddard> Of course the tricky part is that unlike master, it needs to continue to support CentOS 7
15:43:45 <dtantsur> for now we've taken the "full-switch" approach
15:43:54 <TheJulia> I think it makes sense to backport the support for operator sanity/support
15:44:00 * iurygregory think it should support...
15:44:32 <TheJulia> that being said, I'm not sure how crazy that would actually look in reality
15:44:33 <dtantsur> we explicitly used stuff like calling pip3
15:44:34 <mgoddard> I've spent quite a lot of time making ansible things support both versions now, it should be possible
15:44:38 <iurygregory> the backports woulld need some workaround or some sanity check to verify the platform probably
15:44:53 <mgoddard> ansible_distribution_major_version is your friend
15:45:01 <TheJulia> heh
15:45:02 <TheJulia> yeah
15:45:19 <dtantsur> I don't mind reviewing such patches if they get proposed
15:45:22 <mgoddard> I mean we could probably make it work without this
15:45:28 <TheJulia> I say put the patches up, and lets see
15:45:30 <mgoddard> but it would be cleaner
15:45:32 <dtantsur> we probably should, any branching is risky
15:45:40 <dtantsur> but dunno
15:45:44 <dtantsur> whatever works in the end
15:45:54 <TheJulia> and supports our users, I think
15:46:12 * dtantsur just had a brain glitch that made him surprised he writes English instead of Russian
15:46:38 <mgoddard> ok, I'll look into how big this will be and chuck up a patch if not too onerous
15:46:44 <iurygregory> I have one small topic after mgoddard
15:46:48 <dtantsur> mgoddard++
15:46:59 <mgoddard> go ahead iurygregory
15:47:00 <TheJulia> mgoddard: excellent
15:47:06 <iurygregory> mgoddard, ack o/
15:47:09 <rpittau> mgoddard: I'd be glad to help if needed
15:47:19 <mgoddard> thanks rpittau
15:47:27 * dtantsur is sorry we didn't finish the compatibility in the train timeframe..
15:47:37 <iurygregory> so we have some missing bits in our devstack configuration (how can we enable tempest) https://review.opendev.org/#/c/712901/
15:47:37 <patchbot> patch 712901 - ironic - Add info on how to enable ironic-tempest-plugin - 3 patch sets
15:48:14 <dtantsur> oh, I know you responded, I need to look at that again
15:48:26 <iurygregory> I'm a little bit worried to move devstack config into ironic-tempest-plugin docs since we don't have much information there
15:48:38 <TheJulia> I think it would be best in ironic's docs
15:48:43 <iurygregory> we could add in both maybe?
15:48:44 <TheJulia> as a sub-item or something
15:48:54 <TheJulia> The reason being, people do often wonder how to do it
15:49:01 <iurygregory> yeah
15:49:02 <TheJulia> and if they are already there they will see it
15:49:13 <dtantsur> iurygregory: I think I agree with your comments
15:49:18 <TheJulia> and maybe cross reference back and forth
15:49:19 <dtantsur> but I also agree with Shiv re using notes
15:49:32 <dtantsur> we have 5 (!!!) notes in a row in this part
15:49:34 <TheJulia> ++
15:49:39 <TheJulia> yeah, separate section please
15:49:43 <iurygregory> so maybe one section with how we have devstack+plugin? =)
15:49:55 <TheJulia> I think that is fair
15:49:58 <dtantsur> iurygregory: feel free to just split the existing section into more
15:50:04 <dtantsur> whatever feels natural to you
15:50:10 <iurygregory> awesome, I'll update =)
15:50:16 <TheJulia> excellent!
15:50:20 <TheJulia> Does anyone have anything else?
15:50:26 <dtantsur> notes should be safe to skip
15:50:56 <dtantsur> We haven't posted any cat pictures yet
15:51:02 <arne_wiebalck> I can confirm that getting tempest to run with our docs was difficult.
15:51:14 <TheJulia> dtantsur: working on it!
15:51:22 <arne_wiebalck> I needed iurygregory's handholding :)
15:51:33 <dtantsur> iurygregory++
15:51:34 <iurygregory> arne_wiebalck, anytime o/
15:51:49 <arne_wiebalck> iurygregory: will be sooner than you think ;)
15:51:52 <TheJulia> https://www.youtube.com/watch?v=FGJfup-0rhc <-- maybe? #Disclaimer: I've not watched it yet
15:51:56 <iurygregory> glad to help =)
15:52:32 <TheJulia> Anyway, if there is nothing else, thanks everyone!
15:53:41 <TheJulia> eh, that video returns EINSUFFICENTCATS
15:53:54 <iurygregory> space cats omg
15:54:23 <TheJulia> Have a wonderful day everyone!
15:54:30 <TheJulia> #endmeeting