15:00:25 <TheJulia> #startmeeting ironic
15:00:26 <openstack> Meeting started Mon Mar 23 15:00:25 2020 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:30 <openstack> The meeting name has been set to 'ironic'
15:00:31 <arne_wiebalck> dtantsur: to implement what, sorry?
15:00:38 <dtantsur> arne_wiebalck: support for dual-boot images
15:00:39 <kaifeng_> o/
15:00:41 <rajinir> o/
15:00:41 <dtantsur> o/
15:00:42 <rpioso> \o
15:00:42 <etingof> \o
15:00:42 <TheJulia> dtantsur: I _suspect_ if we can't use uefibootmgr, we're dead in the water
15:00:43 <cdearborn> o/
15:00:45 <iurygregory> o/o/
15:00:45 <rpittau> o/
15:00:47 <erbarr> o/
15:00:49 <TheJulia> honestly
15:00:50 <TheJulia> Anyway!
15:00:52 <arne_wiebalck> dtantsur: it seems to work for us :)
15:00:58 <dtantsur> good :)
15:01:00 <TheJulia> Good morning everyone! It is time for another meeting if the ironic minds!
15:01:00 <rloo> o/
15:01:02 <arne_wiebalck> o/
15:01:14 <TheJulia> Our agenda is on the wiki!
15:01:16 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:47 <TheJulia> Seems we have a few topics so we should go ahead and get started!
15:01:59 <TheJulia> #topic Announcements / Reminders
15:02:05 <mgoddard> \o
15:02:31 <ajya> o/
15:02:33 <TheJulia> #info We are engering the end of the Ussuri cycle, and as such deadlines are coming up.
15:03:05 <TheJulia> #info Extra-ATC submissions must take place by March 26th, or R-7
15:03:23 <TheJulia> #info Non-client library freeze is April 2nd. (ironic-lib, sushy)
15:03:52 <openstackgerrit> Merged openstack/virtualbmc master: Fix stop command by using default SIGTERM handler in children  https://review.opendev.org/713038
15:04:13 <TheJulia> #info Client library freeze and the Ussuri-3 milestone for the openstack community is April 9th.
15:04:19 <rloo> does that extra-atc submission mean anything, now that it is going virtual?
15:04:21 <TheJulia> #info Cycle Highlightes are also due on the 9th.
15:04:48 <dtantsur> rloo: ATC also participate in elections, for example
15:04:51 <TheJulia> rloo: extra-atc can be granted for people that aid discussion, or that help others in irc.
15:05:03 <rloo> ah, then yes, it means something. thx!
15:05:06 <TheJulia> Extra-ATC is also valid for ?11? months
15:05:36 <TheJulia> so in theory, 2 election rounds.
15:05:51 <TheJulia> Does anyone have anything to raise or remind us of this week?
15:06:06 * dtantsur reminds to stay safe
15:06:38 <TheJulia> Yes, everyone, please stay safe!
15:07:06 <TheJulia> Also, everyone! Reviews!
15:07:32 <TheJulia> Shall we carry on?
15:07:35 <iurygregory> ++
15:07:52 <rpittau> let's
15:08:02 <TheJulia> #topic Review action items from previous meeting
15:08:20 <TheJulia> iurygregory: you had an action item to document supported branch policy, I believe you posted it?
15:08:26 <iurygregory> TheJulia, https://review.opendev.org/713660
15:08:27 <patchbot> patch 713660 - ironic - Document our policies for stable branches - 2 patch sets
15:08:42 <TheJulia> most excellent
15:09:45 <iurygregory> we just need to reach a consensus on the text
15:09:47 <iurygregory> =)
15:09:48 * TheJulia adds to the list of patches for the week
15:10:02 <TheJulia> Moving on!
15:10:06 <TheJulia> #topic Review subteam status reports
15:10:14 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:11:13 <TheJulia> Starting at line 251
15:11:19 <TheJulia> arne_wiebalck: thanks for the scale testing notes!
15:11:33 <iurygregory> rpittau, are we tracking the CI work in the status report?
15:11:47 <arne_wiebalck> TheJulia: will add more data as it comes in :)
15:11:56 <arne_wiebalck> TheJulia: looks good so far
15:11:56 <TheJulia> Regarding the Bare Metal SIG whitepaper, would it help if we did some scheduled "editing the doc times"?
15:12:26 <arne_wiebalck> I think so ... this is dangling since so long now.
15:12:30 <rpittau> iurygregory: no, I'm adding a section now as I have the story as well
15:12:35 <TheJulia> arne_wiebalck: yeah :(
15:12:54 <arne_wiebalck> TheJulia: let's just schedule sth and finish it
15:13:03 <TheJulia> k
15:13:04 * arne_wiebalck is naive maybe
15:13:12 <TheJulia> Anyone have any ideal time windows?
15:13:14 <TheJulia> or days?
15:13:37 <TheJulia> Looks like multitenancy patches are still in review
15:13:48 <dtantsur> TheJulia: start a doodle?
15:14:10 <TheJulia> #action TheJulia to send out a doodle for whitepaper
15:14:23 <arne_wiebalck> thanks
15:14:47 <TheJulia> I saw network_data discussion in irc earlier, so that is a good sign
15:15:23 <TheJulia> dtantsur: can you add your disk device selection patch to priorites to review if they are not already there
15:15:23 * etingof is working on dhcpless full-throttle now days
15:15:30 <TheJulia> etingof: <3
15:15:35 <dtantsur> TheJulia: added earlier today
15:15:38 <TheJulia> <3
15:16:17 <TheJulia> Looks like iurygregory has made good progress on retooling some tempest jobs for simplification of CI load :)
15:16:31 <iurygregory> it's working with redfish
15:16:43 <TheJulia> \o/
15:16:49 <iurygregory> I would appreciate feedback to see if this is the way we want to move or not
15:17:12 <TheJulia> iurygregory: maybe put the patch(s) on the list to review?
15:17:23 <iurygregory> TheJulia, sure
15:17:50 <TheJulia> Updates look good to me, shall we carry on to priorities for the week?
15:18:16 <iurygregory> ++
15:18:22 <rpittau> yup
15:18:42 <TheJulia> #topic Deciding on priorities for the coming week
15:19:03 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:19:08 <TheJulia> Line 122
15:20:37 <etingof> should we review pending sushy patches?
15:20:52 <TheJulia> etingof: yes, very much so given the short time we'll ahve on them
15:20:57 * TheJulia is marking out merged patches
15:21:39 * TheJulia is amused by the "race lottery"
15:21:47 * etingof can gather sushy patches pending reviews on the whiteboard
15:23:37 <TheJulia> sounds good
15:23:47 <TheJulia> there are a lot of things on the board today. I'm going to delete the merged items now
15:24:14 <TheJulia> Anyone interested in making the pxe module smarter about what format messages to return for neutron integrated stacks?
15:24:42 <iurygregory> TheJulia, I can
15:24:59 <TheJulia> https://review.opendev.org/#/c/714212/
15:25:00 <patchbot> patch 714212 - ironic - "dual stack" support for PXE/iPXE - 7 patch sets
15:25:02 <TheJulia> Already did it :)
15:25:03 <rpittau> I'm too slow :(
15:25:20 <iurygregory> oh =)
15:25:46 <iurygregory> rpittau, no you are not slow
15:25:49 <TheJulia> I can add it to the list if people are interested
15:27:14 <dtantsur> let's try
15:28:26 <TheJulia> done!
15:28:40 * TheJulia moves the 3 sushy items up
15:29:39 <TheJulia> The list looks good to me, hopefully this many of us will be able to focus on reviews and trying to get some code merged as we're starting to run out of time in the cycle.
15:29:48 <TheJulia> Shall we move on to Discussion topics?
15:29:53 <iurygregory> ++
15:30:21 <TheJulia> #topic Discussion
15:30:51 <TheJulia> The first item I believe was added by iurygregory noticing that HP's 3rd party CI logs were inaccessible and they were now attempting to run python2 jobs
15:31:00 <TheJulia> unfortunately, I don't see anyone from HP here this morning.
15:31:06 <iurygregory> yeah =(
15:31:22 <TheJulia> iurygregory: Would you be able to draft an email to stendulker and copy me?
15:31:30 <iurygregory> I can't access any job logs from HPE CI
15:31:36 <iurygregory> TheJulia, sure!
15:31:45 <iurygregory> you can put as action item
15:31:48 <TheJulia> iurygregory: if you don't have his email address, just let me know
15:32:03 <TheJulia> #action iurygregory to reach out to HPE regarding CI status
15:32:04 <iurygregory> I'm also wondering if other 3rd party CI have py2 jobs running
15:32:09 <iurygregory> I hope not =)
15:32:23 <TheJulia> I am 98% sure I already talked to Dell folks about changing all of their jobs to python3
15:32:36 <rajinir> All Dell CI jobs are Python3 now
15:32:43 <iurygregory> rajinir, tks!
15:32:50 <TheJulia> rajinir: Thanks!
15:32:58 <TheJulia> Okay, next topic then!
15:33:13 <TheJulia> Migrate from oslo.rootwrap to oslo.privsep. I don't know who added this, but it seems like a thing
15:33:18 <rpittau> TheJulia: I did
15:33:31 <iurygregory> I saw the thread on openstack-discuss
15:33:37 <rpittau> there was a topic in the ML about that, it's a proposed goal for V release
15:33:39 <iurygregory> rpittau, ++
15:33:42 * TheJulia hands the microphone over
15:34:03 <rpittau> maybe we can start having a look at it since other projects (nove) moved there already
15:34:06 <TheJulia> I guess that is reasonable, although I've been hoping cycle goals get re-thought
15:34:23 <TheJulia> Oh, that is good and does help a lot
15:34:26 <iurygregory> rpittau, I've started looking at it =)
15:34:28 <rpittau> I believe it's a good idea in general, not a super high priority
15:34:49 <rpittau> iurygregory: heh ok, nvm then :)
15:34:54 <TheJulia> rpittau: My impression from this discussion is the same
15:34:56 <TheJulia> iurygregory: awesome!
15:35:25 <iurygregory> I will work on a etherpad with the projects we need to update
15:36:13 <TheJulia> Well we have nothing listed for Baremetal SIG and I already have an action tiem for that. And no listed RFE's for review. One worth noting, I did start updating the old kexec RFE with some thoughts and comments becuase I'm trying to sort through how to make it all work in the machenery
15:36:39 <TheJulia> I'm also hacking it out and will hopefully have it working during one of the quarentine days ahead.
15:36:50 <TheJulia> iurygregory: awesome
15:36:58 <TheJulia> So I guess we're good to proceed to Open Discussion?
15:37:11 <iurygregory> ++
15:37:27 <dtantsur> yeah
15:37:41 <TheJulia> #topic Open Discussion
15:37:48 <TheJulia> so is everyone doing okay?
15:37:55 <dtantsur> Do we need a virtual ironic (un)conference? :)
15:38:17 <TheJulia> I think it could be a good idea. Maybe have a rule for everyone to wear crazy hats?
15:38:37 <dtantsur> We could even have a post-conference beer-n-chat
15:38:45 * iurygregory will use a pikachu hat
15:38:46 <TheJulia> ++
15:38:55 <dtantsur> iurygregory: I need to see that!
15:39:08 <iurygregory> dtantsur, hahahaha you can check on instagram =)
15:39:14 * dtantsur will
15:39:16 <rpittau> I still have my goofy hat from disneyland, can that work ?
15:39:18 <TheJulia> Shall I put together a "un-conference video call, and bring your best crazy hat, and then enjoy a pint?"
15:39:28 <TheJulia> err, a doodle
15:39:31 <iurygregory> TheJulia, ++
15:39:59 <TheJulia> Excellent!
15:40:16 <openstackgerrit> Merged openstack/sushy-cli master: Update commands to generate docs, renos and pdf  https://review.opendev.org/706826
15:40:22 <TheJulia> I like the idea of just trying to do it Wednesday or Thursday, personally
15:40:52 <dtantsur> I'd take Friday, fewer meetings for me
15:41:03 <dtantsur> but we can doodle it
15:41:09 <TheJulia> k
15:41:16 <TheJulia> Wheee I have a jury summons coming in the mail :(
15:41:59 <dtantsur> great time for that
15:42:01 <TheJulia> iurygregory: by the way, if you logout and log back into gerrit, you'll have some more rights on a few repos.
15:42:06 <etingof> btw, we have quite a lot of pending sushy-cli patches
15:42:20 <dtantsur> TheJulia: I think refreshing a page is enough for iurygregory :)
15:42:29 <iurygregory> TheJulia, \o/
15:42:37 <iurygregory> etingof, I'll take a look
15:42:42 <TheJulia> dtantsur: not for group memberships if memory serves
15:42:50 <dtantsur> mmm, maybe
15:42:53 <dtantsur> it's easy to check
15:42:56 <TheJulia> yeah
15:43:46 <iurygregory> I can see after a f5
15:44:20 <TheJulia> Anyway, is there anything else to dsicuss today?
15:44:37 <iurygregory> thanks for the opportunity, I will do my best o/
15:45:02 <TheJulia> iurygregory: Thank you for being an active reviewer!
15:45:50 <rloo> ++++
15:46:42 <iurygregory> =)
15:46:49 <TheJulia> for our unconference, shall I just send out a bluejeans link or something?
15:47:24 <dtantsur> works for me
15:48:08 <TheJulia> "The SPUC - Sanity Preservation Un-Conference" ?
15:48:22 <iurygregory> ++
15:48:31 * TheJulia feels that is an ironic title if there ever was one
15:48:33 <dtantsur> lol, like it
15:48:51 <dtantsur> shall we announce it on the ML/twitter/etc or keep it more private?
15:48:58 <TheJulia> I was going to post it to the ML
15:50:05 <dtantsur> ++
15:50:18 <TheJulia> Anyway, I think we're done for the day! Thanks everyone and happy reviewing changes!
15:51:50 <TheJulia> #endmeeting