15:01:13 <TheJulia> #startmeeting ironic
15:01:14 <openstack> Meeting started Mon Nov 16 15:01:13 2020 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:17 <openstack> The meeting name has been set to 'ironic'
15:01:22 <dtantsur> o/
15:01:23 <rpioso> \o
15:01:24 <TheJulia> dtantsur: I mean, I could revise the docs and note it in tuning docs
15:01:27 <ajya> o/
15:01:36 <iurygregory> o/
15:01:40 <TheJulia> maybe just -1 my tuning doc update and I can put it in place.
15:01:45 <TheJulia> anyway! Good morning everyone!
15:02:00 <TheJulia> Time for our  meeting of ironic irony!
15:02:02 <dtantsur> TheJulia: let's figure it out in a follow-up then?
15:02:08 <TheJulia> dtantsur: wfm
15:02:09 <tzumainn> o/
15:02:16 <TheJulia> Our agenda can be found on the wiki
15:02:27 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:02:47 <TheJulia> #topic Announcements / Reminders
15:02:56 <erbarr> o/
15:02:59 <rpittau> o/
15:03:06 <TheJulia> I have two, well, ultimately three items this morning to bring up
15:03:10 <TheJulia> The first!
15:03:21 <rloo> o/
15:03:22 <TheJulia> #info The Wallaby priorities have merged.
15:03:41 <TheJulia> #info The Wallaby priorities have been added to the Ironic Whiteboard.
15:03:53 <TheJulia> well, that was two
15:04:03 <TheJulia> The final item that I have to remind everyone is that the first sprint ends soon
15:04:21 <TheJulia> #info Sprint 1 is targetted to end around December 14th.
15:05:20 <TheJulia> I suspect many contributors will be taking time off to recharge and de-stress during the month of December, so if there are any changes required or reviews needed please remember to raise them sooner rather than later
15:05:25 <openstackgerrit> Dmitry Tantsur proposed openstack/ironic-python-agent-builder master: [WIP] Clean up installed packages  https://review.opendev.org/762816
15:05:59 <TheJulia> Also, people in the states tend to take part if not most of next week off as well. Just something to keep in mind.
15:06:10 <fmuyassarov> Hello everyone! I have a patch https://review.opendev.org/#/c/762343/ and it fails to pass ironic-tempest-ipxe-ipv6 & ironic-inspector-tempest-partition-bios-redfish-vmedia jobs. In the first one I get “RTNETLINK answers: No route to host” and the second seems to be related to rabbitmq-server.service. Can someone please point out how I can debug ipv6 routing and rabbitnq with my local changes to identify the ex
15:06:10 <fmuyassarov> act issue?
15:06:10 <patchbot> patch 762343 - ironic - Allow disabling automated_clean per node - 9 patch sets
15:06:22 <TheJulia> And with that, does anyone have any announcements they would like to make or remind us of things?
15:06:39 <rpittau> fmuyassarov: that is a known issue with focal
15:06:41 <TheJulia> fmuyassarov: we're in the middle of our weekly meeting, Could we save this discussion for a little later?
15:06:58 <fmuyassarov> Definitely TheJulia
15:07:03 <fmuyassarov> thanks
15:07:38 <TheJulia> Looks like we had no action items raised last week
15:08:09 <TheJulia> So I guess if nobody has anything to announce we can proceed to a fairly quick update of subteam status
15:08:43 * TheJulia hears crickets
15:09:08 * TheJulia hears lots of crickets
15:09:12 <rloo> crrrrricket
15:09:12 <iurygregory> ++
15:09:12 <TheJulia> Carrying on I guess!
15:09:35 <TheJulia> #topic Review subteam status reports
15:09:42 <TheJulia> #link https://etherpad.opendev.org/p/IronicWhiteBoard
15:09:59 <TheJulia> Starting around line 285
15:10:11 <TheJulia> If anyone has more ideas for Not getting more insane, add them!
15:10:32 <TheJulia> dtantsur: Thank you for bringing back the SPUCs
15:10:39 <dtantsur> SPUC \o/
15:11:19 <openstackgerrit> Merged openstack/ironic master: Make driver documentation more prominent on the landing page  https://review.opendev.org/762179
15:11:55 <TheJulia> I've added the links to the etherpad
15:12:21 <TheJulia> Anyhow there should be space for all of the listed items, and if there is nothign else we can move on to priorites for the week?
15:13:14 <TheJulia> I can also carry things like oslo.privsep up from below or well, anyone can do that
15:13:26 * TheJulia wonders if she forgot to hand out coffee this morning
15:13:37 <TheJulia> or.... I've I've had too much.
15:15:03 <TheJulia> So onward to priorities for the coming week?
15:15:09 <iurygregory> ++
15:15:16 <rpittau> let's
15:15:57 <TheJulia> #topic Deciding on priorities for the coming week
15:16:05 <TheJulia> #link https://etherpad.opendev.org/p/IronicWhiteBoard
15:16:22 <TheJulia> The list starts at line 129, but in essence a LOT of things merged last week
15:16:31 <TheJulia> so first, I'm going to remove the merged items as always.
15:16:40 <TheJulia> I've been adding new items for consideration below stable
15:17:16 <openstackgerrit> Leo McGann proposed openstack/ironic-specs master: Add security interface spec  https://review.opendev.org/576718
15:18:03 <TheJulia> Is everyone good with the items proposed around lien 176?
15:18:09 <TheJulia> And does anyone have have more items to add?
15:18:15 <dtantsur> seems good to me
15:18:31 <rpittau> looks good
15:19:24 <TheJulia> That can be cleaned up later
15:19:40 <TheJulia> Well then, onward!
15:19:55 <TheJulia> #topic Discussion
15:20:08 <TheJulia> We have one item listed on the agenda for discussion today.
15:20:10 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:20:30 <TheJulia> The item is in essence do we want to schedule a review jab so we can effectively begin to work through stevebaker's API patches
15:20:52 <TheJulia> I think we do, but wanted to raise it as a discussion item since I think we should schedule a time and get moving forward on that.
15:21:55 <arne_wiebalck> o/
15:21:59 * arne_wiebalck is late
15:22:04 <TheJulia> o/ arne_wiebalck
15:22:22 <rpittau> I guess we need to schedule a time where stevebaker can be present, or do we just want to do a general review session ?
15:22:24 <dtantsur> oh, good point. I completely forgot about that
15:22:37 <dtantsur> I think the idea was to schedule 2 slots: during his morning and his evening
15:22:43 <TheJulia> ++
15:22:50 <rpittau> ok
15:23:15 <TheJulia> and not really be presentation, more work through the patches, try to understand, raise changes at once if needed or just approve if they are good
15:23:32 <TheJulia> I know some of us have done some sporatic reviews of patches, but I'd love to see that work begin to merge
15:23:46 <dtantsur> yep
15:23:46 <rpittau> right, sounds good
15:23:59 <TheJulia> Maybe, we ask steve to schedule the windows that way he can indicate the times he is comfortable with
15:24:00 <dtantsur> TheJulia: do you have overlap with him? maybe discuss later today?
15:24:12 <TheJulia> Yeah, I overlap with him in his morning
15:24:27 <TheJulia> so I guess that is an action item to bestow an action item upon stevebaker
15:24:44 <TheJulia> #action TheJulia to talk with steve about getting some review jabs scheduled
15:25:05 <TheJulia> Next stop, BareMetal SIG
15:25:08 <TheJulia> #topic Baremetal SIG
15:25:21 <TheJulia> arne_wiebalck: anything here? I guess the best question is when is the next meeting
15:25:28 <arne_wiebalck> I think Dec 8
15:25:44 <arne_wiebalck> interop profiles if rpioso is still up for it
15:26:00 <TheJulia> Awesome, sounds good
15:26:00 <arne_wiebalck> otherwise NTR
15:26:12 <TheJulia> Sounds good, then I guess that means we're at open discussion
15:26:15 <TheJulia> #topic Open Discussion
15:26:20 <rpioso> arne_wiebalck: I am :-)
15:26:30 <arne_wiebalck> excellent, thanks!
15:26:31 <TheJulia> Anyone have anything they would like to discuss?
15:26:38 <tzumainn> hi!
15:26:57 <TheJulia> hi tzumainn
15:26:59 <tzumainn> I've been trying to understand the networking required to boot-from-volume
15:27:12 <tzumainn> and I've been failing miserably :) is there anyone with the expertise to help me out post-meeting?
15:27:27 <TheJulia> tzumainn: I can chat with you a little later today after I have breakfast
15:27:36 <tzumainn> TheJulia, that sounds great, thanks!
15:28:24 <TheJulia> anything else this morning?
15:28:32 <ajya> a general question - have there been ideas about not launching IPA if it is not needed? E.g., there are OOB cleaning steps that don't really need IPA.
15:29:15 <TheJulia> ajya: there have and there were notes on the path forward in the Shanghai and Berlin PTG notes if memory serves
15:29:46 <dtantsur> and Geneva midcycle
15:30:03 <ajya> does anyone have those links at hand?
15:30:34 <TheJulia> ajya: They are linked from the whiteboard
15:30:40 <dtantsur> well, the idea is quite simple: update decorator with a new flag that defines if the step requires a ramdisk
15:30:41 <arne_wiebalck> the erase_pstore clean step: there are concerns with having it enabled by default ... should we disable to start with, and gather some experience (and then revisit at some point)?
15:30:42 <TheJulia> Towards the very top
15:30:52 <dtantsur> the implementation is going to be really challenging
15:31:01 <TheJulia> arne_wiebalck: I think that seems reasonable
15:31:01 <dtantsur> saying that as the person who has last touched that area of code :)
15:31:19 <ajya> :) ok, I'll take a look
15:31:37 <ajya> that means that idea is not discarded but just need some resources?
15:31:38 <arne_wiebalck> TheJulia: the only thing is that noone will run it and we probably won't collect any experience
15:31:49 <TheJulia> arne_wiebalck: this is true :\
15:32:02 <TheJulia> maybe enable by default but have conductor flag?
15:32:06 <arne_wiebalck> TheJulia: still fine with me ... I think it is good if we offer this at least
15:32:25 <TheJulia> technically it is a device, just stored/accessed totally differently, more like a MTD
15:32:38 <TheJulia> Any objections or concerns?
15:32:56 <arne_wiebalck> yeah, I don't think one can break stuff by deleting files ... but you never know
15:33:21 <TheJulia> Indeed
15:33:27 <TheJulia> Well if there is nothing else, thanks everyone!
15:34:28 <dtantsur> thank you!
15:34:33 <TheJulia> \o
15:34:35 <rpittau> thank you :)
15:34:48 <TheJulia> #endmeeting