15:00:10 <TheJulia> #startmeeting ironic
15:00:12 <openstack> Meeting started Mon Nov 30 15:00:10 2020 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <TheJulia> o/
15:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:15 <openstack> The meeting name has been set to 'ironic'
15:00:20 <rpioso> \o
15:00:20 <dtantsur> o/
15:00:23 <kaifeng> o/
15:00:31 <TheJulia> Welcome to our weekly meeting of Irony for Ironic. I'll be your host!
15:00:35 <rloo> o/
15:00:37 <ajya> o/
15:00:55 <bfournie> o/
15:01:01 <TheJulia> Our agenda an be found on the wiki.
15:01:03 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:12 <TheJulia> Our agenda also looks very bare, so maybe this will be a super quick meeting
15:01:27 <TheJulia> #topic Announcements / Reminders
15:02:31 <TheJulia> I only have one item to announce/remind us of this week which is for contributors to be mindful of reviews. With holidays coming up and a number of people taking time off, it is going to become increasingly difficult to move things forward so earlier feedback will always help.
15:02:51 <TheJulia> Does anyone else have anything to remind us of or announce this week?
15:04:03 <stendulker> o/
15:04:11 * TheJulia gets out the crickets and lets them make announcements indicating we should likely move on
15:04:14 <TheJulia> \o stendulker
15:04:40 <rpittau> o/
15:05:00 <TheJulia> We had no action items from our last meeting, so we can proceed to reviewing subteam status reports
15:05:19 <TheJulia> #topic Review subteam status reports
15:05:29 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:05:40 <TheJulia> Starting at line 257
15:05:50 * TheJulia also makes coffee in hopes that it wakes people up
15:07:21 <TheJulia> hmm, I must not have uploaded the community goal update to the specs repo :\
15:07:21 <TheJulia> doh!
15:09:51 <TheJulia> bdodd: ajya: Regarding redfish raid, what is the next step for that patch?
15:09:58 <arne_wiebalck> o/
15:10:27 <ajya> TheJulia: I have left some comments around async operations and Tasks - need to decide if taking that approach
15:10:46 <TheJulia> ajya: okay, would it help for others to review that patch this week?
15:11:12 <ajya> TheJulia: yeah, can do that for additional input
15:11:28 <TheJulia> ajya: please add that patch to the list of changes to review this week
15:11:36 <ajya> TheJulia: ok
15:12:08 <ajya> TheJulia: there is related sushy patch also to be reviewed, will add that too
15:12:15 <TheJulia> ok
15:13:38 <TheJulia> Well, I guess Iury can't comment on oslo.privsep stuff :(
15:14:24 <TheJulia> ajya: Is there any updates with regards to configuration molds? Even no-update works on the etherpad :)
15:15:05 <TheJulia> zer0c00l: Looks like your anaconda spec is getting closer.   :)
15:15:06 <ajya> TheJulia: will add update in the pad, checking Swift&tokens, might have questions later
15:15:14 <TheJulia> ajya: okay
15:15:51 <TheJulia> Looks like the interop profile is still under review
15:15:57 <arne_wiebalck> Would be great to have someone else try them.
15:16:21 <arne_wiebalck> The profiles look ok, but we may need a discussion on how to use them.
15:16:37 <arne_wiebalck> Maybe during the SIG meeting next week.
15:16:44 <TheJulia> Is everyone good to proceed to priorities for the week?
15:16:45 <TheJulia> arne_wiebalck: ++
15:16:48 <arne_wiebalck> When rpioso is presenting them.
15:18:25 <TheJulia> I guess we're good to proceed onward
15:19:07 <TheJulia> #topic Deciding on priorities for the coming week
15:19:16 <TheJulia> #link https://etherpad.opendev.org/p/IronicWhiteBoard
15:19:35 <TheJulia> Starting at line 120
15:20:18 * TheJulia removes merged/not applicable items
15:21:31 <TheJulia> Looks like all of the proposed for addition items seem logical to add to me
15:22:00 <TheJulia> Anything else to add this week?
15:24:10 <rpittau> mmm nothing super pressing, but if there's time I'd like to add the tenacity conversion patch https://review.opendev.org/c/openstack/ironic/+/376574
15:25:16 <TheJulia> Seems reasonable
15:25:34 <rpittau> thanks!
15:25:35 <TheJulia> Added
15:25:40 <kaifeng> i'd like to add this https://review.opendev.org/c/openstack/ironic/+/764563 but I think we need to discuss in the rfe review
15:25:42 <TheJulia> Is there anything else? or does htis list look good?
15:26:08 <TheJulia> kaifeng: yes, lets discuss that in rfe review
15:26:21 <TheJulia> Well, since we have no discussion items
15:26:43 <TheJulia> arne_wiebalck: Anything beyond the redfish profiles for the next SIG meeting
15:26:43 <TheJulia> ?
15:26:49 <TheJulia> w/r/t the baremetal sig?
15:27:01 <arne_wiebalck> TheJulia: no
15:27:18 <TheJulia> #topic Baremetal SIG
15:27:28 <arne_wiebalck> Meeting #3 Tue Dec 8, 2020 at 2pm UTC
15:27:40 <arne_wiebalck> https://etherpad.opendev.org/p/bare-metal-sig
15:27:42 <TheJulia> #info Next scheduled session is Tue Dec 8, 2020 at 2pm
15:27:49 <TheJulia> #link https://etherpad.opendev.org/p/bare-metal-sig
15:27:55 <TheJulia> #topic RFE Review
15:28:23 <TheJulia> kaifeng: since you wanted to discuss that item, you as they say, have the floor :)
15:28:39 <kaifeng> thanks
15:28:56 <kaifeng> it was an old proposal https://storyboard.openstack.org/#!/story/2003091
15:29:03 <kaifeng> that to have a name field for ports
15:29:26 <TheJulia> wow, yeah, 2019
15:29:30 <TheJulia> err, 2018
15:29:41 <kaifeng> yeah, i was thinking differently at that time
15:30:36 <TheJulia> so just an idea of a human relatable name storage?
15:30:45 <kaifeng> things turned out that a name field helps us managing ports like other resources, nodes, portgroups
15:31:04 <TheJulia> It does
15:31:07 <TheJulia> or, would
15:31:24 <TheJulia> and it keeps the same style of unique constraint
15:31:27 <kaifeng> the new proposal is to have a unique name fields, so that some operations can be automated
15:31:40 <TheJulia> Seems reasonable to me, anyone else?
15:32:08 <dtantsur> do we need names for everything then?
15:32:26 <dtantsur> at least all physical entities?
15:32:44 <kaifeng> probaly not, but ports are quite important one :)
15:33:05 <dtantsur> oh, we have port group names? then we should probably have port names
15:33:18 <dtantsur> I remember having some objection, but I don't remember its essence now, soo..
15:33:33 <kaifeng> portgroup comes later and have a name field
15:34:11 * kaifeng there was a patch to address this proposal but it's quite long ago
15:34:38 <TheJulia> I think the objections/concerns were that someone would always try to store the inspection ramdisk identified interface name
15:35:08 <TheJulia> and as we've all learned over time, that not be consistent across OSes or upgrades
15:35:37 <kaifeng> yes, that's different
15:35:43 <TheJulia> I sense this is RFE-approved if there are no objections.
15:36:47 <TheJulia> I don't think it needs a spec at this point, it is a fairly simple change
15:38:05 <rloo> i'd suggest that the story itself have the highlevel info
15:38:24 <rloo> eg, API changes. will need data migration thing.
15:38:29 <TheJulia> kaifeng: yeah, it would kind of help for a slight revamp for historical context
15:39:19 <kaifeng> ok, will update the story in a moment
15:39:25 <TheJulia> Anyway, with that I think we're good to move to Open Discussion
15:39:29 <TheJulia> #topic Open Discussion
15:39:40 <TheJulia> Everyone have a good weekend?
15:40:20 <dtantsur> a cold one :)
15:40:30 <rpittau> cold indeed...
15:40:44 <TheJulia> good cold? or just very cold weather moved in?
15:40:59 <rloo> TheJulia: i can't remember where we discussed this, maybe at the ptg. wrt backports and 'skipping' some older releases. were we going to discuss with the community? (Not sure this is open discussion, i was just reminded of it.)
15:41:55 <TheJulia> rloo: I thought we had settled given one of the additional jump points stein went EM ?last? week.
15:42:37 <rloo> i honestly don't recall the details of that discussion but saw that stein went em and was going to update the whiteboard with that info :)
15:43:07 <rloo> it was something like backport but to eg only queens but not rocky
15:43:10 <Qianbiao> I have a question: is port group created manually by admin? or has an automatic method to generate it?
15:43:51 <TheJulia> Qianbiao: manual, you have to know the configuration available to you and what may be represented in the switch config already
15:44:09 <Qianbiao> yeah, i guess so.
15:44:19 <Qianbiao> I am courious that: port name is not volatile
15:44:28 <TheJulia> rloo: yeah, unless there is a real reason to, we were going to skip and focus on the branches taht are cared about
15:45:00 <Qianbiao> so, if we use a fixed port name, we need to use stable interface name
15:45:01 <stendulker> During inspection we do create ports for the MACs discovered https://github.com/openstack/ironic/blob/master/ironic/drivers/modules/redfish/inspect.py#L162-L182
15:45:04 <TheJulia> Qianbiao: OS precieved port name can be depending on settings and mismatches that can occur between ramdisk, persistant port naming schemes, etc
15:45:35 <rloo> TheJulia: ah, right. there was something about testing/ci too i think. guess i can look back at the notes. what i recall? is that it seemed like a good idea to get community thoughts about it. to be somewhat consistent or whatever? or maybe needed to discuss with the release team?
15:45:38 <TheJulia> Names are really for humans, not the software
15:45:45 <Qianbiao> yes, TheJulia kaifang, this is what I was worry about
15:46:05 <TheJulia> rloo: there are already other projects skipping em branches unless people really want a thing on them
15:46:52 <TheJulia> Anything else for us to discuss today?
15:46:54 <rloo> TheJulia: right. I haven't seen anything though, where this 'awareness' is mentioned in the community as a whole, vs individual projects.
15:48:11 <TheJulia> rloo: yeah, I don't think there was anything actionable from that. I really don't remember though
15:48:17 <rloo> TheJulia: for ironic, perhaps you might update our whiteboard (around line 207) about what we decided if it is still appropriate.
15:49:30 <rloo> ah, https://etherpad.opendev.org/p/ironic-wallaby-ptg. around L326
15:52:03 <TheJulia> ahh, yeah
15:52:07 <TheJulia> Okay, I'll try to do that this week
15:52:32 <TheJulia> #action Julia to sync with stable team w/r/t backport strategy
15:52:41 <rloo> thx TheJulia!
15:52:50 <TheJulia> Well everyone, have a wonderful day! And a wonderful week!
15:52:53 <rloo> and then we ought to doc so I don't forget :D
15:53:14 <rloo> same to you too TheJulia!
15:53:26 <TheJulia> o/
15:53:38 <TheJulia> Thanks everyone!
15:53:41 <TheJulia> #endmeeting