15:00:34 <TheJulia> #startmeeting ironic
15:00:35 <openstack> Meeting started Mon Apr 26 15:00:34 2021 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:36 <TheJulia> o/
15:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:37 <iurygregory> o/
15:00:40 <openstack> The meeting name has been set to 'ironic'
15:00:42 <rpittau> o/
15:00:42 <dtantsur> o/
15:00:46 <rpioso> \o
15:00:50 <ajya> o/
15:00:50 <JayF> o/
15:00:57 <arne_wiebalck> o/
15:00:57 <erbarr> o/
15:01:20 <TheJulia> Our growing agenda today can be found on the wiki.
15:01:21 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic
15:01:27 <TheJulia> To get started!
15:01:42 <TheJulia> #topic Announcements / Reminders
15:01:57 <rloo> o/
15:02:00 <TheJulia> #info JayF reminds us that the new ironic whiteboard is updated and in place.
15:02:09 <TheJulia> #link https://etherpad.opendev.org/p/IronicWhiteBoard
15:02:35 <TheJulia> JayF encourages people to continue to improve it and in particular check the review dashboard links.
15:03:15 <TheJulia> #info The Foundation is attemptin got schedule an OpenInfra Life webcast on the 29th for a PTG recap. If anyone is interested in joining that and representing Ironic, please ping TheJulia.
15:03:16 <stendulker> o/
15:03:42 <TheJulia> #info Additionally, anyone interested in contributing content to ironicbaremetal.org should see TheJulia
15:03:45 <TheJulia> Finally
15:04:11 <iurygregory> yay
15:04:42 <TheJulia> It has been pointed out to me that referring to vaccination as 5G may make some people feel uncomfortable. We *do* have people who work for several telecoms in this IRC channel, so moving forward please avoid the nanite enabled microchip vaccination jokes.
15:05:15 <TheJulia> Does anyone have anything else to announce or remind us of?
15:05:57 <TheJulia> I don't think we need to review action items, but I'm just checking in case
15:06:28 <openstackgerrit> Merged openstack/bifrost stable/wallaby: [CI] Make Kolla job running again  https://review.opendev.org/c/openstack/bifrost/+/787605
15:06:39 <TheJulia> No action items so I *think* we can skip ahead
15:06:45 <iurygregory> ++
15:06:47 <rpittau> yup
15:07:05 <TheJulia> Do we feel the need to review subteam status reports, given this is the week after the PTG?
15:07:36 <rpittau> not sure, probably need to define the new priorities first ?
15:07:49 <TheJulia> Yeah, and I think that is all rooted in the change which needs attention on the repository
15:07:56 <rpittau> yep
15:07:59 <TheJulia> so I think we can skip both and move forward to discussion for today?
15:08:05 <TheJulia> Any objections?
15:08:08 <iurygregory> makes sense to me
15:08:09 <iurygregory> +1
15:08:12 <dtantsur> yep
15:08:46 <TheJulia> #link https://review.opendev.org/c/openstack/ironic-specs/+/784143
15:08:57 <TheJulia> #topic Discussion
15:09:36 <TheJulia> JayF brings us a discussion today of extreme old patches and asks if we should mass-abandon anything 6 months or older?
15:09:53 <TheJulia> I have mixed feelings on this subject, but I wonder how others feel.
15:09:59 <JayF> Yeah, it just became obvious how many old patches we have when I brought up the dashboards.
15:10:06 <rpittau> mmm 6 months feels still too close
15:10:09 <dtantsur> probably? I have some patches that I intend to eventually continue
15:10:16 <JayF> I think there are some patches that 100% should be mass abaandoned. I'm not sure about where we should set the line.
15:10:22 <TheJulia> likewise though
15:10:26 <JayF> 12 months? 18?
15:10:36 <dtantsur> 18 month is what I'd use
15:10:41 <rpittau> 18 probably
15:10:43 <TheJulia> Maybe 1-ish year, but I still think we should skim the backlog to see if there is anything we want to keep
15:10:43 <dtantsur> after all, abandoned patches can be resurrected
15:10:43 <JayF> abandon, IMO, is more about removing from review queue. You can always unabandon a patch
15:10:45 <dtantsur> actually
15:11:09 <JayF> if you haven't updated your patch in, say, 12 months -- what's the value in it *not* being abandoned?
15:11:11 <dtantsur> we can abandon everything 6 months old and ask the author to revive if they think it's useful
15:11:25 <iurygregory> 18 ++
15:11:29 <JayF> that's pretty much what I was thinking dtantsur
15:11:31 <dtantsur> the value is that I won't lose it in hundreds of my patches
15:11:36 <TheJulia> or a core spots it, I still think should skim through the items out there
15:11:41 <dtantsur> but I can instant-resurrect patches that I find useful
15:11:52 <rloo> if someone submits a spec and they are waiting for comments, isn't it somewhat mean to just abandon and ask them to resubmit?
15:11:57 <TheJulia> I have no objection to 6 months really if that is the approach we take
15:12:07 <dtantsur> mmm, I assumed we're talking about patches with negative feedback or merge conflict
15:12:07 <rpittau> what about abandon automatically what's 12 months old or older and discussing 6 months to 12 months ?
15:12:19 <TheJulia> rpittau: that is a good compromise
15:12:26 <TheJulia> dtantsur: good point
15:12:34 <JayF> Bluntly, if I do this, I'm not going to discuss items beyond the line. I'm going to abandon stuff that needs it with a copy+paste message.
15:12:44 <dtantsur> I don't think we should abandon patches that are all green (still)
15:12:49 <JayF> but I don't want to dedicate the time to IRC and get consensus on a small set of patches
15:12:50 <rpittau> I agree
15:13:00 <dtantsur> yeah, I don't think it's realistic to review all patches
15:13:03 <JayF> so if we have 12 months as the line, then 12 months is the line
15:13:15 <dtantsur> it's easier to resurrect those few we still find valuable
15:13:17 <JayF> and if I see something that's all green along the way... maybe I'll just approve it (or review it properly) and see if it can get in
15:13:26 <TheJulia> I think 12 months is a reasonable line
15:13:34 <rloo> i think we've had discussions in the past about how to encourage folks to contribute upstream, etc, etc, so... lets make sure we do this in a human-friendly way...
15:13:52 <JayF> rloo: I'll make a kind message to put in there :) You can trust me to be human friendly ;)
15:13:59 <rloo> ++
15:14:03 <TheJulia> :)
15:14:14 <TheJulia> sounds like 12 months with a friendly message is consensus?
15:14:19 <rpittau> alright
15:14:56 <TheJulia> #agreed We will abandon patches not updated in the past 12 months to remove them from the review queue with a kind message to authors to resurrect them.
15:15:10 <TheJulia> Next item I added a little before the meeting.
15:15:17 <TheJulia> Is anyone interested in writing a PTG recap
15:15:17 <TheJulia> ?
15:15:20 <TheJulia> for Ironic itself
15:15:29 <JayF> As a note, I don't expect to include specs in these abandons :)
15:15:42 <TheJulia> JayF: sounds good to me
15:16:37 * TheJulia hears crickets
15:17:46 <TheJulia> Okay, I guess I can string words together
15:17:55 <TheJulia> Onward to the Baremetal SIG!
15:17:58 <TheJulia> #topic Baremetal SIG
15:18:15 <TheJulia> arne_wiebalck brings us an interesting question today. arne_wiebalck would you like to elaborate?
15:18:22 <arne_wiebalck> Sure.
15:18:40 <arne_wiebalck> We have no topics yet for  the next meetings, so I put some proposals up.
15:18:56 <arne_wiebalck> And this is ofc a call for suggestions :)
15:19:02 <arne_wiebalck> And volunteers :-))
15:19:24 <dtantsur> I can talk about IPA-builder
15:19:29 <TheJulia> The first two topics, "Getting started with Ironic: Bifrost" and "Building images for Ironic: The IPAB (not automatic brewer)" sound interesting
15:19:37 <arne_wiebalck> nice, thanks dtantsur !
15:19:38 <TheJulia> and sound like they could potentially be very short
15:19:57 <TheJulia> Scaling and deploying topics are a bit... more complex
15:20:00 <arne_wiebalck> Yeah, and we could maybe reuse some of this for the website :)
15:20:13 <TheJulia> exactly, so more thought is definitely required for htose
15:20:26 <TheJulia> "Realities of scaling ironic, what to know!"
15:20:50 <arne_wiebalck> Any volunteer for a bifrost intro/demo?
15:20:58 <TheJulia> I'm personally okay with fairly short clips too, even something just two to three minutes long could be awesome
15:21:09 <arne_wiebalck> agree
15:21:31 <TheJulia> I guess I could or if someone wants to partner up I can talk about the history of it while the example is running or whatever
15:21:33 <arne_wiebalck> Ok, that is mostly it for the SIG, I think :)
15:21:50 <arne_wiebalck> thanks, TheJulia !
15:22:18 <TheJulia> Speaking of SIG, I would love to see if there are thoughts on "appropriate metrics" to be collected, but maybe the scaling topic might weigh in on that
15:22:34 <TheJulia> I'll ponder scaling since that is such an abstract topic
15:22:46 <arne_wiebalck> appropriate metrics for monitoring a deployment?
15:23:32 <TheJulia> Would it make sense to maybe have one talking about metal3<->ironic
15:23:45 <arne_wiebalck> oh, that would be nice!
15:23:46 * TheJulia wonders if dhellmann could be convinced to talk about it
15:23:49 <dtantsur> I was going to write a blog post on ^^^
15:23:57 <dtantsur> or we can ask dhellmann to talk, works for me as well :)
15:24:20 <TheJulia> maybe an underlying theme is "spread the load"
15:24:38 <TheJulia> arne_wiebalck: metrics as in reporting back to the community, but in-deployment metrics could be a thing
15:24:40 * dhellmann tries to catch up with the scrollback
15:25:13 <arne_wiebalck> TheJulia: ah, ok, basically what we discussed at the PTG
15:25:17 <TheJulia> and maybe a larger operator discussion is needed to gauge relative pain from the bottleneck points and comfort levels or needs to try and develop a semi-consistent/nice way
15:25:21 <TheJulia> arne_wiebalck: yes
15:25:27 <arne_wiebalck> TheJulia: what to look at for a deployment may also be interesting
15:25:28 <TheJulia> Anyway, that is just an idea.
15:25:36 <TheJulia> arne_wiebalck: indeed
15:25:48 <TheJulia> Anyway, all ideas. We should revisit this next week.
15:25:58 <arne_wiebalck> TheJulia: ++
15:26:09 <TheJulia> We have no listed RFE's today, so I'm going to go ahead and move us forward to RFE review
15:26:10 <TheJulia> err
15:26:13 <TheJulia> not RFE review
15:26:15 <TheJulia> Open Discussion
15:26:19 <rpittau> when is the the next SIG meeting ?
15:26:55 <arne_wiebalck> usually 2nd Tue of each month
15:27:07 <dhellmann> TheJulia : I imagine we can come up with better people to talk about that than me, these days. dtantsur, zaneb, someone from upstream metal3 perhaps
15:27:09 <arne_wiebalck> May 11th
15:27:14 <rpittau> ok, thanks
15:27:33 <iurygregory> May 4th would be better :D
15:27:39 <iurygregory> hehehe
15:27:48 <dtantsur> heh
15:27:52 <arne_wiebalck> :-D
15:27:54 <rpittau> iurygregory: that's a sacred day, not sure :)
15:28:01 <arne_wiebalck> may the ironic force be with you
15:28:09 <erbarr> cinco de cuatro?
15:28:31 <TheJulia> dhellmann: thanks
15:28:42 <TheJulia> ironic force, oh my :)
15:28:45 <TheJulia> #topic Open Discussion
15:29:02 <TheJulia> There was something I wanted to bring up, but it has escaped me. Possibly it saw something, screamed and ran away
15:29:10 <rpioso> A simple question ... During in-band introspection/out-of-band inspection, for which hardware ports should ironic baremetal ports be created?
15:29:30 <rpioso> Ports without link?
15:29:49 <rpioso> What about ports which have been disabled via BIOS settings?
15:29:50 <TheJulia> Inspector and ilo oob inspection offers knobs if memory serves
15:30:41 <TheJulia> I think it boils down to ports with links, but it has been a very long time since I had last thought of this or looked at it.
15:30:57 <rpioso> And, should in-band and out-of-band behave consistently?
15:31:07 <TheJulia> well, there are knobs
15:31:14 <TheJulia> so... *shrug*
15:31:33 <TheJulia> It is a choose your own adventure path, I'd return the list and have similar decision point capability
15:32:10 <TheJulia> "all", "all link active", or "what we boot from" seems reasonable and to be essentially what there is already
15:32:22 <TheJulia> of course, the last being a bit harder to determine
15:33:11 * rpioso looks for knobs ...
15:35:24 <TheJulia> Well, I guess we can move to the final step of the meeting since no other topics are coming forth
15:35:32 <TheJulia> #topic Who is going to run the next meeting?
15:35:59 <rpioso> TheJulia: Thank you :-)
15:36:01 <TheJulia> This is something we discussed during the PTG and I'd like to get a volunteer each week to run the next week's meeting.
15:36:22 <TheJulia> If there are fears/worries, it is fairly straight forward and the irc bot commands are easy :)
15:36:53 <TheJulia> And also, the week of May ?10th? I may be completely MIA due to family stuff, so it will be unlikely for me to be able to run the meeting that week.
15:37:02 <rpittau> TheJulia: I can run next meeting
15:37:12 <TheJulia> rpittau: Thanks!
15:37:25 <TheJulia> Well, if there is nothing else, Thanks everyone!
15:37:29 <dtantsur> o/
15:37:45 <arne_wiebalck> Thanks TheJulia !
15:37:49 <rpittau> thanks all
15:37:55 <TheJulia> #endmeeting