15:00:12 <rpittau> #startmeeting ironic
15:00:12 <opendevmeet> Meeting started Mon Jul 12 15:00:12 2021 UTC and is due to finish in 60 minutes.  The chair is rpittau. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:12 <opendevmeet> The meeting name has been set to 'ironic'
15:00:16 <iurygregory> o/
15:00:23 <erbarr> o/
15:00:25 <tkot> o/
15:00:32 <TheJulia> o/
15:00:44 <stendulker> o/
15:00:49 <ajya> o/
15:00:54 <rpioso> \o
15:01:04 <rpittau> Hello everyone and welcome to our weekly meeting!
15:01:19 <rpittau> Our agenda can be found in the wiki
15:01:19 <rpittau> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:02:00 <rpittau> mmm I wonder if we have quorum today
15:02:19 <iurygregory> I think we do
15:02:28 <iurygregory> 8 people..
15:02:36 <iurygregory> time to summon arne_wiebalck :D
15:02:58 <arne_wiebalck> oops ... o/
15:03:09 <rpittau> yep, we should be fine
15:03:19 * arne_wiebalck was lost in grub
15:03:28 <rpittau> #topic Announcements / Reminders
15:03:59 <TheJulia> arne_wiebalck: oh noes
15:04:05 <iurygregory> We have a new contributor, tkot ! He's an intern at Red Hat and will collaborate to ironic upstream =)
15:04:12 <TheJulia> Welcome tkot!
15:04:12 <tkot> Hi everyone :)
15:04:16 <rpittau> welcome tkot :)
15:04:22 <arne_wiebalck> Hey tkot !
15:04:47 <opendevreview> Aija Jauntēva proposed x/sushy-oem-idrac master: Fix missing Target@Redfish.AllowableValues  https://review.opendev.org/c/x/sushy-oem-idrac/+/800495
15:04:49 <opendevreview> Aija Jauntēva proposed x/sushy-oem-idrac master: Fix IncludeInExport allowed value validation  https://review.opendev.org/c/x/sushy-oem-idrac/+/800496
15:04:52 <opendevreview> Aija Jauntēva proposed x/sushy-oem-idrac master: Update default IncludeInExport value  https://review.opendev.org/c/x/sushy-oem-idrac/+/800497
15:05:20 <rpittau> I have only a reminder that we're close to a new bugfix branch
15:05:44 <TheJulia> ++
15:05:46 <rpittau> that should happen late this week or early next week
15:05:54 <TheJulia> I was thinking about that last week when posting updates for ironicbaremetal.org
15:06:53 <rpittau> oh yeah, we need to remember to update that after the release
15:07:12 <iurygregory> I would say to do next week
15:07:31 <iurygregory> if possible ofc (we won't die because of 1 week :D)
15:07:32 <TheJulia> ++, it presently lists 17.0.1, I posted an update to 18.0, but was thinking we may also want to discuss noted versions later on in the meeting
15:07:48 <rpittau> yeah, most likely early next week, depends on how things go with the patches this week
15:08:03 <rpittau> TheJulia: sure!
15:09:09 <rpittau> does anyone have anything else to announce/remind us ?
15:09:41 <rpittau> alright, moving on
15:09:46 <rpittau> #topic Review action items from previous meeting
15:10:03 <rpittau> I didn't see any action items from 2 weeks ago
15:10:12 <rpittau> we can skip forward
15:10:16 <iurygregory> yeah we can move on =)
15:10:18 <rpittau> #topic Review subteam status reports
15:10:18 <rpittau> #link https://etherpad.opendev.org/p/IronicWhiteBoard
15:11:52 <TheJulia> Are we done with anaconda short of CI at this point?
15:12:42 <rpittau> mmm last update was from JayF 3 days ago
15:12:57 <iurygregory> we probably need to ping zer0c00l or JayF to see if they are working on something
15:13:24 <rpittau> we'll see during the week as JayF update is from Friday
15:13:50 <TheJulia> I chatted with JayF regarding CI, turns out nobody publishes an anaconda stage2 ramdisk. There *is* an upstream ramdisk that has *everything* but it feels inappropriate to pull like 700MB into a CI run for Ironic on every single change revision.
15:14:07 <TheJulia> ahh, he likely noted that
15:14:09 <iurygregory> wow :O
15:14:26 <iurygregory> maybe we can have a job in the experimental pipeline?
15:14:40 <iurygregory> so we can run from time to time to see if things are ok?
15:14:41 <TheJulia> maybe
15:15:06 <iurygregory> it will only run on check-experimental so maybe "it's fine"
15:15:22 <rpittau> arne_wiebalck: any update about the node error history ?
15:15:31 <arne_wiebalck> no, sorry
15:15:58 * arne_wiebalck will try to get to it now that burn-in is coming to an end
15:16:02 <TheJulia> arne_wiebalck: could you list the latest known patch. I might pick it up as my next free time thing...
15:16:17 <TheJulia> arne_wiebalck: or we could collaborate :)
15:16:32 <arne_wiebalck> TheJulia: yes, sounds good
15:16:40 <rpittau> I think there's an open patch since a while
15:16:46 <TheJulia> for db model changes
15:16:59 <arne_wiebalck> yes, that one did not see many reviews yet
15:17:03 * MahnoorAsghar Hey guys! I'm sorry I wont be able to attend the meeting today. Had an RFE for review on the agenda (https://storyboard.openstack.org/#!/story/2008866). Can we kindly drop comments on the storyboard?
15:17:40 <rpittau> MahnoorAsghar: sure thing, no problem
15:17:45 * MahnoorAsghar (Sorry for the interruption, please go on)
15:17:53 * MahnoorAsghar Thanks ^-^
15:18:28 <rpittau> I think we can move on
15:19:04 <TheJulia> iurygregory: w/r/t virtual media visibility. You note verify steps work. I'm largely unaware of this, is there someplace I can read about it?
15:19:30 <iurygregory> TheJulia, it was a conversation with janders downstream only
15:19:50 <iurygregory> If I recall correctly dtantsur pointed to him that could be useful for the vmedia also
15:19:53 <rpittau> do we maybe need a story for that ?
15:19:59 <TheJulia> Okay, lets try and upstream that discussion
15:20:10 <iurygregory> I think we do have for verify steps upstream
15:20:15 <TheJulia> rpittau: apparently
15:20:16 <iurygregory> let me see if I can find
15:20:24 <iurygregory> but I don't think it mentions the vmedia part =)
15:20:28 <ajya> https://storyboard.openstack.org/#!/story/2009025 is the one janders working on
15:20:41 <ajya> btw, should that be RFE?
15:21:01 <rpittau> ajya: thanks, and yes that looks like an RFE
15:21:19 <rpittau> it's mentioned by janders in the story
15:22:28 <ajya> yup, could add usual tags
15:22:33 <rpittau> yeah
15:23:02 <iurygregory> I've updated the title
15:23:07 <TheJulia> Okay
15:23:09 <TheJulia> thanks!
15:23:51 <rpittau> cool, let's move forward ?
15:24:12 <iurygregory> ++
15:24:18 <rpittau> #topic Deciding on priorities for the coming week
15:24:18 <rpittau> #link https://tinyurl.com/ironic-weekly-prio-dash
15:24:33 <rpittau> we have few patches left
15:24:38 <rpittau> I'm going to add a couple for bifrost
15:24:55 <ajya> can these be added for sushy https://review.opendev.org/c/openstack/sushy/+/800267 https://review.opendev.org/c/openstack/sushy/+/799504 ?
15:25:04 <rpittau> we also have the one for the node history db there
15:25:22 <TheJulia> Has anyone scrubbed through the randomly submitted patches recently to see if some should be reviewed?
15:25:53 <rpittau> ajya: feel free to add the tag there :)
15:25:55 <iurygregory> I would like people to re-review the event subscription spec =)
15:26:21 <arne_wiebalck> The last burn-in step (network) could be added maybe: https://review.opendev.org/c/openstack/ironic-python-agent/+/799687
15:26:34 <iurygregory> arne_wiebalck, ++
15:26:44 <arne_wiebalck> (the static part, we work on the dynamic version)
15:27:02 <ajya> rpittau: thanks
15:27:16 <TheJulia> hmm, the ismount catch should be as well
15:27:24 <TheJulia> https://review.opendev.org/c/openstack/ironic-python-agent/+/798394 <-- any objections?
15:27:58 <iurygregory> sounds good to me
15:28:10 * arne_wiebalck is all for more bootloader things
15:29:40 <rpittau> iurygregory: I'll find the time this week to review the spec
15:29:40 <TheJulia> arne_wiebalck: I found out the vfs layer would lie. was awesome troubleshooting it :(
15:30:05 <arne_wiebalck> TheJulia: lying about what is mounted?
15:30:37 <iurygregory> rpittau, tks! I did a lot of changes after some discussion last week with dtantsur and TheJulia  =)
15:30:40 <TheJulia> Yeah, or to be more specific, the ismount call was returning False and then the handling code would blow up
15:30:56 <TheJulia> because it was actually already mounted
15:30:59 <arne_wiebalck> erm ...
15:31:02 <TheJulia> yeah
15:31:23 <arne_wiebalck> I have a patch submitted recently where I do check for sth being mounted, since it sometimes was mounted
15:31:30 <arne_wiebalck> Unclear to me why.
15:31:38 <arne_wiebalck> Maybe I was lied to!
15:32:03 <rpittau> looks like we have a good list for the weekly priorities
15:32:08 <rpittau> anything else to add ?
15:32:19 <TheJulia> the filesystems that get loaded with ramdisks have really funky vfs calls/interactions. We found a similar issue with pre-made device files from the cpio file when compared to devfs behavior
15:32:26 <TheJulia> rpittau: not from me
15:32:58 <rpittau> ok, we don't have any topic for Discussion so we'll skip that
15:33:13 <rpittau> #topic Baremetal SIG
15:33:13 <rpittau> #link https://etherpad.opendev.org/p/bare-metal-sig
15:33:26 <arne_wiebalck> Next meeting is tomorrow 10 July 2021 featuring TheJulia on "Getting started with Ironic: Bifrost".
15:33:36 <arne_wiebalck> Don't miss out! :)
15:33:56 <arne_wiebalck> We do not have a topic for August yet.
15:34:09 <arne_wiebalck> I was wondering if we skip it due to holiday season?
15:34:17 <TheJulia> could we do an ironic operator's round table?
15:34:34 <arne_wiebalck> Sure ... how do get operators to join, though?
15:34:51 <TheJulia> Lots of outreach I guess?
15:34:54 <arne_wiebalck> I could ask some Ironic operators I know directly.
15:35:02 <TheJulia> I could do the same
15:35:17 <TheJulia> I could also tweet some to see if any that follow me may be interested
15:35:22 <arne_wiebalck> So, we keep the one next month or this is for Sep?
15:35:23 <iurygregory> post on twitter for RT :D
15:35:29 <rpittau> I could too, but in August basically everyone is on vacation :D
15:35:46 <TheJulia> oh, yes, the great august vacation window :)
15:35:49 * TheJulia needs a vacation
15:35:50 <rpittau> we may have more luck for September
15:35:53 <TheJulia> Yeah
15:35:55 <TheJulia> agreed
15:36:02 <arne_wiebalck> I wold vote for Sep, too.
15:36:04 <arne_wiebalck> would
15:36:08 <arne_wiebalck> ok, Sep it is then
15:36:23 <arne_wiebalck> I think that is it for the SIG for today.
15:36:48 <rpittau> #agreed no baremetal-sig meeting in August
15:36:55 <rpittau> thanks arne_wiebalck :)
15:37:05 <TheJulia> iurygregory: tweet posted, retweet away
15:37:54 <rpittau> ok, onward!
15:38:20 <rpittau> we had only one request for RFE review but MahnoorAsghar can't participate to the meeting today
15:38:36 <rpittau> #topic RFE review
15:38:51 <rpittau> [RFE] RAID config by Operator using generic disk numbers, and vendor-specific RAID controller names https://storyboard.openstack.org/#!/story/2008866
15:39:02 <rpittau> he asked to leave comments directly in the story
15:40:38 <rpittau> alright I guess we can move on
15:40:40 <TheJulia> okay
15:40:50 <rpittau> #topic Open Discussion
15:41:07 <rpittau> anything to discuss today?
15:42:31 <TheJulia> So one thing I wanted to raise is ironicbaremetal.org
15:42:39 <TheJulia> We presently list only one latest release
15:43:02 <TheJulia> I'm wondering if we should consider noting something like "latest release" and "latest stable branch"
15:43:17 <rpittau> I think it makes sense to mention both
15:43:18 <TheJulia> s/branch/release
15:43:56 <TheJulia> We need a goodbye iscsi blog post as well :)
15:44:02 <rpittau> do we need to make it clear that the latest-latest is in development ?
15:44:47 <TheJulia> rpittau: well, in development can be viewed a different ways. We've released the thing, we'll stand by and support the thing, just not for a super long time like we will with a stable branch version
15:45:10 <rpittau> ok
15:45:20 <TheJulia> and there will be times where the releases will be the same around stable release cycle times
15:46:42 <rpittau> yes, of course
15:46:42 <rpittau> anyway, I'm in favor of that
15:48:40 <TheJulia> There was something else I was thinking of, but my brain can't recall at the moment
15:49:16 <rpittau> :)
15:49:57 <rpittau> if we don't have anything else to discuss, I'll pass to the weekly question of....
15:49:58 <TheJulia> surely it was something to facilitate taking over the world
15:50:07 <rpittau> lol
15:50:15 <lmcgann> Ill just throw out, sdanni and I are working on a demo for a complete attestation workflow - we've identified a few keylime bugs but we're super close!
15:50:51 <TheJulia> lmcgann: awesome
15:50:59 <rpittau> that sounds great lmcgann
15:51:26 <TheJulia> lmcgann: I was working on the bifrost presentation and started recalling all the bugs we found then... so I know that feeling :)
15:51:55 <TheJulia> lmcgann: When would be good? or do you guys just want to record a video or???
15:53:18 <lmcgann> I think a video might be easiest
15:53:27 <TheJulia> cool
15:53:29 <lmcgann> And more easily shareable
15:55:03 <rpittau> alright then, let's move to the last topic
15:55:06 <rpittau> #topic Who is going to run the next meeting?
15:55:37 <iurygregory> I can
15:55:44 <rpittau> thanks iurygregory :)
15:55:52 <iurygregory> np!
15:56:01 <rpittau> and that's all folks!
15:56:07 <rpittau> #endmeeting