14:59:59 <iurygregory> #startmeeting ironic
15:00:00 <opendevmeet> Meeting started Mon Jul 19 14:59:59 2021 UTC and is due to finish in 60 minutes.  The chair is iurygregory. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:00 <opendevmeet> The meeting name has been set to 'ironic'
15:00:05 <iurygregory> o/
15:00:09 <rpioso> \o
15:00:09 <JayF> o/
15:00:11 <TheJulia> arne_wiebalck: any last_error
15:00:12 <erbarr> o/
15:00:12 <TheJulia> o/
15:00:13 <rloo> o/
15:00:19 <iurygregory> Hello everyone! Welcome to our weekly meeting!
15:00:19 <stendulker> o/
15:00:27 <cenne> o/
15:00:35 <iurygregory> You can find our agenda in the wiki
15:00:40 <iurygregory> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:13 <iurygregory> #topic Announcements / Reminders
15:01:14 <arne_wiebalck> TheJulia: last_error is Non
15:01:15 <opendevreview> cenne proposed openstack/ironic master: [WIP] Add api endpoint for setting boot_mode on managed node  https://review.opendev.org/c/openstack/ironic/+/800084
15:01:16 <arne_wiebalck> None
15:01:27 <arne_wiebalck> o/
15:01:28 <iurygregory> #info we will cut the new bugfix branches this week
15:01:35 <rpittau> o/
15:01:51 <iurygregory> rpittau, do you want to add some info about when we will cut the release?
15:02:10 <rpittau> ideally tomorrow :)
15:02:11 <iurygregory> and also, do we have any more announcements or remminders? =)
15:02:19 <TheJulia> also, release notes should be scrubbed
15:02:36 <rpittau> yep, let's see how that goes
15:02:56 <iurygregory> #topic Review action items from previous meeting
15:03:07 <dtantsur> o/
15:03:10 <iurygregory> No action items from last meeting, skipping =)
15:03:45 <iurygregory> I'm going a bit fast because we have quite a few topics in discussion =)
15:03:56 <opendevreview> Merged openstack/ironic stable/wallaby: Redfish: Get only RAID controller's physical disks  https://review.opendev.org/c/openstack/ironic/+/800930
15:03:59 <opendevreview> Merged openstack/ironic stable/wallaby: Update Redfish RAID disk_type unit test  https://review.opendev.org/c/openstack/ironic/+/800931
15:04:02 <opendevreview> Merged openstack/ironic master: Burn-in: Add documentation  https://review.opendev.org/c/openstack/ironic/+/800806
15:04:02 <iurygregory> #topic Review subteam status reports
15:04:04 <opendevreview> Merged openstack/ironic-inspector master: Update requirements  https://review.opendev.org/c/openstack/ironic-inspector/+/800680
15:04:09 <iurygregory> #link https://etherpad.opendev.org/p/IronicWhiteBoard
15:04:13 <iurygregory> starting on L65
15:05:05 <JayF> I'll note I do not expect further updates for Anaconda; AFAIK there is nobody planning to tackle the CI work right now.
15:05:51 <iurygregory> JayF, can you add the info in the etherpad?
15:06:20 <JayF> The last update is accurate; it's got a link to the story documenting the CI hurdles.
15:06:45 <iurygregory> oh you added in 2021-07-09 :D
15:06:59 <iurygregory> to me the last update was the one I added hehe
15:08:38 <TheJulia> I guess I might try to enhance the metadata scrub for happiness of ceph
15:08:41 <iurygregory> arne_wiebalck, no updates in Node error history right?
15:08:49 <TheJulia> iurygregory: I've not seen anything
15:09:03 <iurygregory> yeah, I saw the patch is in merge conflict
15:09:12 <arne_wiebalck> no sorry: TheJulia rebased the DB patch, but it needs another rebase now I see
15:09:12 <TheJulia> ugh
15:09:31 <TheJulia> I need to find a good code problem to sink my brain into, I'll try to again this week
15:10:05 <iurygregory> we have updates in everything, moving on
15:10:16 <iurygregory> #topic Deciding on priorities for the coming week
15:10:22 <iurygregory> #link https://tinyurl.com/ironic-weekly-prio-dash
15:10:31 <TheJulia> dtantsur: w/r/t driver info, how do you feel about some of the username insanity?
15:10:45 <dtantsur> TheJulia: I'm totally for it, just not sure if I have time
15:11:00 <iurygregory> Let us know if you have any patches that we should add =) (we will cut the bugfix branch by tomorrow so if there is something urgent that you would like let us know)
15:11:00 <dtantsur> depends on how openshift staff works out (I'll know next week, I hope)
15:11:11 <dtantsur> re patch, I only have https://review.opendev.org/c/openstack/bifrost/+/799837
15:11:26 <TheJulia> dtantsur: I can try and make time, its been on my mind recently
15:11:35 <dtantsur> would be great
15:11:37 <iurygregory> I've added https://review.opendev.org/c/openstack/ironic/+/801064 vendor passthru for subscriptions =)
15:11:45 <dtantsur> ++ to ^^^
15:12:05 <iurygregory> tested in real HW Dell R640 and HPE e910 =)
15:12:15 <TheJulia> how do we feel about https://review.opendev.org/c/openstack/ironic-python-agent/+/801260 ?
15:12:15 <iurygregory> bifrost ++ when testing new things :D
15:12:24 <TheJulia> I tagged the bifrost change
15:12:57 <iurygregory> CI seems a bit unhappy not sure if is because of the change
15:13:11 <iurygregory> but we can add the tag and I can take a look at it later
15:13:16 <TheJulia> yeah, true
15:13:18 <rpittau> it's the metalsmith job
15:13:32 <TheJulia> I was asking more from a point of "do we have any thoughts/feelings
15:13:33 <TheJulia> "
15:13:33 <iurygregory> oh ok I saw ipa-tempest-ironic-inspector-src
15:13:35 <TheJulia> point of view
15:13:42 <iurygregory> but is non-voting already =)
15:14:10 <iurygregory> probably need a release note and a story I would say
15:14:11 <TheJulia> Has anyone reviewed backport candidates to make sure we've actually done the backports?
15:14:28 <rpittau> I did on some, probably not all
15:14:47 <TheJulia> k
15:15:08 <iurygregory> I will take a look at the backports later today
15:15:34 <iurygregory> I've added the tag in https://review.opendev.org/c/openstack/ironic-python-agent/+/801260
15:15:47 <TheJulia> k
15:15:52 <TheJulia> iurygregory: thanks
15:16:13 <iurygregory> jssfr, can you please add a releasenote on your patch? https://review.opendev.org/c/openstack/ironic-python-agent/+/801260 let us know if you have any questions on how to do that =)
15:16:16 <TheJulia> iurygregory: if there is anything that you feel should go to train, lmk
15:16:23 <iurygregory> TheJulia, ack
15:17:09 <iurygregory> are we done with priorities?
15:17:22 <TheJulia> I think so
15:17:45 <iurygregory> ok, moving on
15:17:49 <iurygregory> #topic Discussion
15:18:03 <iurygregory> we have a few topics from TheJulia and rpittau =)
15:18:10 <iurygregory> TheJulia, the mic is yours =)
15:18:14 <TheJulia> So first up is the PTG
15:18:22 <iurygregory> PTG \o/
15:18:32 <TheJulia> It is coming up in... ?12-13? weeks or something like that.
15:18:39 * TheJulia hopes she didn't just book vacation for the same week
15:18:53 <TheJulia> Anyway, We as a project need to figure a few things out.
15:19:02 <rpittau> October 18-22, 2021
15:19:03 * iurygregory will look to not book vacation during the PTG week also
15:19:19 <TheJulia> 1) timing, how much time we need, 2) topics to be discussed, Who is going to represent Ironic with the TC and who is planning it
15:19:28 <TheJulia> rpittau: ugh, yup, that is the week :(
15:19:40 * TheJulia un-does vacation booking
15:19:45 <rpittau> :/
15:19:47 <iurygregory> I can help planning
15:20:08 <iurygregory> organize the etherpad and schedule
15:20:15 <iurygregory> #link https://etherpad.opendev.org/p/ironic-yoga-ptg
15:20:20 <dtantsur> same. I'll be available in October.
15:20:28 <TheJulia> Sounds good!
15:20:34 <rpittau> I should be there too
15:20:39 <iurygregory> we can start adding topics we would like to discuss
15:20:43 <TheJulia> ++
15:20:43 * rpittau disapproves "yoga" btw
15:20:52 <iurygregory> yoda would be better :D
15:21:01 <TheJulia> heh
15:21:04 <dtantsur> probably trademarked :)
15:21:08 <iurygregory> yeah =)
15:21:37 <iurygregory> regarding time this will depend on how much topics we will have, we can't make a decision now
15:21:44 <TheJulia> Any volunteer for representing the team with the TC ?
15:21:51 <iurygregory> depends
15:21:53 <dtantsur> I can do it
15:21:57 <iurygregory> what the person needs to do hehe
15:22:02 <dtantsur> ranting a lot
15:22:05 <iurygregory> ok we have dtantsur \o/
15:22:06 <TheJulia> dtantsur: that would be much appreciated
15:22:07 <dtantsur> leave that me, my friend :D
15:22:13 <cenne> Yeren?
15:22:13 <iurygregory> :D
15:22:20 * TheJulia can change that week to half pto now
15:22:37 <dtantsur> TheJulia: just remind me closer to $subj in case I forget
15:22:43 <TheJulia> dtantsur: ack
15:22:58 <TheJulia> so next topic, is a question of if we feel we need a virtual midcycle?
15:23:26 <rpittau> IHMO it's been proved useful in the past, I vote for having one
15:23:29 <dtantsur> possibly? we're in vacation season, but we can try
15:23:42 <TheJulia> It *feels* like we've all been absurdly busy the last couple months, so I'm not sure if it would help right now
15:23:45 <TheJulia> dtantsur: that is my concern too
15:23:49 <TheJulia> rpittau: true
15:23:59 <iurygregory> yeah we can try, at least having it would help to collect topics for the PTG probably
15:24:00 <rpittau> mmm yeah, vacations
15:24:04 <TheJulia> So maybe one for in a few weeks?
15:24:07 <iurygregory> and maybe start discussions..
15:24:11 <TheJulia> iurygregory: that sounds like a good idea
15:24:26 <dtantsur> let's have a doodle for a few slots? I'll be out on week in August and one in September
15:24:26 <TheJulia> even if those calls are just to kind of "lets tease out some of the topics for the ptg"
15:24:31 <iurygregory> maybe a doodle to figure out when we should do?
15:24:34 <TheJulia> any volunteers for a doodle?
15:24:38 <rpittau> doodle sounds good
15:24:39 <iurygregory> I will
15:24:48 <iurygregory> I will send to the ML
15:24:55 * TheJulia feels like we need #action :)
15:25:07 <TheJulia> Okay! So next up on topics!
15:25:08 <iurygregory> #action iurygregory to create a doodle for the midcycle
15:25:20 <TheJulia> I've been chatting with the Open Infra Live folks.
15:25:25 * iurygregory hopes this is correct ^
15:25:33 <TheJulia> iurygregory: it is correct
15:26:11 <TheJulia> Is anyone interested in particpating in an ironic overview and operator usage of ironic discusison call for OpenInfra live?
15:26:32 <TheJulia> We've got a couple windows which *are* open we can book into, but we need to move quickly if we want to do so
15:27:16 <TheJulia> August 5th or August 12th are presently open
15:27:17 <dtantsur> I may be, depending on what exactly is required
15:27:25 <dtantsur> not on the 12th though
15:27:27 <iurygregory> I can probably help but I would be afraid to do alone the ironic overview =D
15:27:43 <TheJulia> dtantsur: that would be ideal because I'm trying to organize an operator feedback session as well
15:27:43 <arne_wiebalck> I am happy to join (unless  it is felt there is too much CERN presence already from the last sessions :)
15:27:51 <dtantsur> we can do it together, I have experience organizing such things (so does arne_wiebalck)
15:28:18 <dtantsur> are these two different things?
15:28:28 <dtantsur> operator usage and operator feedback?
15:28:35 <TheJulia> how about this? I'll create a basic presentation slide deck, tag you guys on it, and maybe we can figure out what we want to spend 10-20 minutes kind of walking through, and then kind of try to get operators talking?
15:28:38 <dtantsur> I suspect you won't get enough presence for 2 similar calls
15:28:44 <dtantsur> yep
15:28:56 <TheJulia> arne_wiebalck: I am kind of hoping for other operators at present, there has been some outreach already just waiting to hear back
15:29:11 <TheJulia> well, the operator feeedback sesison is more openstack-wide
15:29:12 <arne_wiebalck> TheJulia: ++
15:29:26 <TheJulia> not *just* ironic, and it may completely fizzle. We'll see.
15:29:30 <dtantsur> ah
15:29:56 <dtantsur> we had a very successful Russian ironic meetup a few months ago, but I did receive a lot of help wrt outreach
15:31:27 <arne_wiebalck> TheJulia: the ops feedback session would also be on OpenInfra live?
15:31:33 <TheJulia> arne_wiebalck: it would be
15:31:44 <TheJulia> and community wide is the hope
15:32:00 <arne_wiebalck> TheJulia: in addition or to replace the one we are trying to put together for the next SIG meeting?
15:32:03 <TheJulia> Anyway, I wasn't planning on discussing the community wide feedback session one this morning
15:32:19 <TheJulia> Oh, yeah, we did talk about that didn't we
15:32:30 <TheJulia> maybe replace... maybe
15:32:46 <TheJulia> not entirely sure right now
15:33:17 <arne_wiebalck> we need to make we do not confuse the few operators willing to show up on either of these occasions :)
15:33:18 <iurygregory> we can decide after the presentation and the operator feedback hehe
15:33:22 <opendevreview> Derek Higgins proposed openstack/ironic stable/wallaby: Allow reboot to hard disk following iso ramdisk deploy.  https://review.opendev.org/c/openstack/ironic/+/801343
15:33:30 <TheJulia> arne_wiebalck: ++
15:33:32 <arne_wiebalck> *make sure
15:34:11 <TheJulia> okay, I'll create a slide deck and we'll go from there I think
15:34:21 <TheJulia> well, the beginnings of a slide deck
15:34:46 <iurygregory> rpittau, your topic now =)
15:35:06 <rpittau> thanks iurygregory :)
15:35:27 * rpittau having some network issues
15:35:43 <rpittau> anyway
15:36:10 <rpittau> maybe a crazy proposal but I'm seriosuly considering that having the lower-constraints tests back could be a good thing
15:36:19 <rpittau> only for the current development branch
15:36:27 <iurygregory> hummm
15:36:39 <rpittau> this is because we usually don't update the lowest requirements
15:36:40 <TheJulia> Why, and how will we ensure we don't leak them into stable branches forevermore?
15:36:53 <TheJulia> This is a good point.
15:36:56 <rpittau> well
15:37:16 <rpittau> I came up with some interesting issues when installing packetized ironic code recently
15:37:18 <dtantsur> I think the problem with lower-constraints where that they don't work as we expect
15:37:26 <rpittau> depends
15:37:31 <rpittau> if properly configured they do
15:37:50 <TheJulia> I thought he dependency resolver changes made it impossible
15:38:10 <iurygregory> *if properly configured they do* - this is what I'm afraid hehe
15:38:15 <dtantsur> well, we don't have an operation "install minimum necessary packages in pip"
15:38:20 <rpittau> I gave that a try locally and it worked ok
15:38:34 <dtantsur> so we'll end up with lower bounds for stuff we depend on directly and with random packages that are indirect dependencies
15:39:14 <rpittau> the alternative to automatically have such test is to have someone do an update manually from time to time
15:39:14 <rpittau> I did that last week for example
15:39:55 <dtantsur> We can do it 1) only for master, 2) providing some automation to update them
15:40:04 <rpittau> the main reason is that what we have in requirements is not correct
15:40:31 <dtantsur> well... it kind of is
15:40:41 <rpittau> eheh now it is :)
15:40:49 <dtantsur> that transient dependencies bring in a newer version is less of a concern
15:41:03 <dtantsur> what we care about is the minimum version that our code is written against
15:41:15 <dtantsur> if a dependency bump it further up - great
15:41:35 * TheJulia transforms to a fly on the wall with minimal opinion
15:41:50 <dtantsur> TheJulia: a fly next to a cat and a corgi? you're brave.
15:42:01 <TheJulia> dtantsur: iknowrite!
15:42:15 <iurygregory> lol
15:43:19 <dtantsur> rpittau: I don't necessarily disagree with bringing the job back, just trying to set the expectations right
15:43:20 <TheJulia> I'm trying to recall what the resolver breakage issue was that triggered it all to get ripped out
15:43:34 <dtantsur> well, the resolver started taking requirements and constraints seriously
15:43:38 <rpittau> TheJulia: basically an infinite loop cause it could not resolve proper dependencies
15:43:46 <iurygregory> yeah ^
15:43:46 <TheJulia> ahh, right
15:43:49 <dtantsur> rather than just coming up with some combination of packages that may or may not satisfy them
15:43:55 <rpittau> yep
15:44:26 <dtantsur> since that broke stable branches, we had no real choice other than drop the job
15:44:33 <TheJulia> so instead of constraints, it should be treated as the lowest possible version, but then it seems like it is duplicating requirements.txt
15:44:39 <rpittau> I think we can ignore stable branches
15:44:46 <dtantsur> I think we have to
15:45:25 <dtantsur> anyway, I'm curious to see how the process of updating a requirement will look like. other than that, no real objections.
15:45:55 <TheJulia> no objections from myself as long as we don't shoot ourselves in the foot
15:46:07 <dtantsur> wait, isn't that what software is about??
15:46:11 <iurygregory> same from me =)
15:46:15 <TheJulia> dtantsur: oh my
15:46:17 <dtantsur> :D
15:46:18 <iurygregory> dtantsur, omg XD
15:46:24 <TheJulia> dtantsur: no footguns as a service, right now
15:46:25 <rpittau> I'll do a test to see if the behavior of the job has actually improved as I expect
15:46:54 <rpittau> that's all :)
15:46:59 <iurygregory> tks rpittau !
15:47:21 <iurygregory> moving to the next topic \o/
15:47:27 <iurygregory> #topic Baremetal SIG
15:47:43 <iurygregory> #info Next Baremetal SIG meeting in September, skipping August due to vacations.
15:47:46 <arne_wiebalck> The session from last week on Bifrost by TheJulia is already online. Thanks stevebaker.
15:48:02 <TheJulia> stevebaker rocks
15:48:06 <iurygregory> ++, great job everyone!
15:48:11 <arne_wiebalck> I will add an entry to the website as well.
15:48:19 <iurygregory> the presentation was amazing =)
15:48:40 <TheJulia> I guess it flowed nicely?
15:48:47 <iurygregory> totally =)
15:48:58 * TheJulia can't actually watch recordings of herself
15:49:21 <arne_wiebalck> So, no session in August. We need to decide on the topic for Sep (which tentatively is/was ops feedback).
15:49:33 <iurygregory> arne_wiebalck, you will send an email to the ML saying that the next meeting will be in Sep?
15:49:39 <arne_wiebalck> But this may move to Infralive.
15:50:03 <iurygregory> I don't think we need to say the topic but we should probably let people know in the ML I would say =)
15:50:09 <arne_wiebalck> iurygregory: not until we know what the topic will be, I think.
15:50:18 <iurygregory> gotcha!
15:50:40 <arne_wiebalck> let's see how the openinfra thing comes along
15:50:46 <iurygregory> ack
15:51:02 <TheJulia> arne_wiebalck: I should have that pinned down this week
15:51:06 <arne_wiebalck> I still have some topics we could do for a 10 min presentation/discussion
15:51:22 <TheJulia> we *should* enumerate a list of 10 minute topics
15:51:24 <arne_wiebalck> TheJulia: great
15:51:30 <iurygregory> I can probably do a demo with the event subscription using vendor passthru also
15:51:33 <arne_wiebalck> TheJulia: there is no rush I thnk
15:51:36 <arne_wiebalck> *think
15:51:39 <TheJulia> arne_wiebalck: agreed
15:52:00 <iurygregory> but only to create delete get subscriptions (not showing how they work sending information :D)
15:52:03 <arne_wiebalck> iurygregory: will note this down
15:52:19 <arne_wiebalck> in general, I think we should have some more basic topics
15:52:36 <arne_wiebalck> to attract more people
15:52:41 <iurygregory> it would help new comers to understand how they would implement things I would say
15:52:42 <dtantsur> have we ever talked about metal3? is it something people want someone to talk about?
15:52:53 <iurygregory> I can probably mention how we can update code to test etc
15:52:53 <arne_wiebalck> dtantsur: definitely!
15:53:08 <dtantsur> I can do that unless someone else from our team wants to?
15:53:19 <iurygregory> I'm not metal3 expert =)
15:53:23 <arne_wiebalck> iurygregory: yeah, a how to contribute session would be sensible as well I think
15:53:44 <iurygregory> arne_wiebalck, ++
15:53:54 <arne_wiebalck> I also have a "how to debug" session in mind
15:53:54 <TheJulia> dtantsur: I think it would be good to talk about as something integrating, helping collaborate
15:54:17 <dtantsur> okay, sign me up
15:54:18 <TheJulia> iurygregory: I think a newcomers episode would be awesome
15:54:26 <dtantsur> I can do both a short version and a long one, up to you
15:54:44 <iurygregory> seems like we will have topics for 2022 :D
15:54:49 <TheJulia> ++
15:54:54 <dtantsur> not bad :)
15:55:00 <iurygregory> yeah!
15:55:00 <TheJulia> can we get some of these added to the baremetal sig etherpad?
15:55:03 <arne_wiebalck> please put your ideas on the bare metal etherpad so they do not get lost!
15:55:09 <arne_wiebalck> :-D
15:55:34 * arne_wiebalck types (or thinks) slower than TheJulia
15:55:38 <iurygregory> #link https://etherpad.opendev.org/p/bare-metal-sig
15:55:41 * arne_wiebalck or both
15:56:05 <TheJulia> iurygregory: line 160-177
15:56:13 <arne_wiebalck> thx everyone, that is it for the SIG, I believe
15:56:26 <iurygregory> awesome tks arne_wiebalck !
15:56:47 <iurygregory> #topic RFE review
15:56:56 <iurygregory> we don't have any items, skipping
15:57:02 <iurygregory> #topic Open Discussion
15:57:23 <iurygregory> I don't think we will have time to discuss something...
15:57:34 <iurygregory> but I will give 1minute =D
15:57:49 <TheJulia> My brain is out of spoons
15:57:57 <TheJulia> it needs ice cream, and a chiropractor
15:58:04 <iurygregory> ice cream ++
15:58:10 <iurygregory> #topic Who is going to run the next meeting?
15:58:16 <iurygregory> Do we have any volunteers?
15:58:34 <dtantsur> I can do it
15:58:39 <iurygregory> tks dtantsur!
15:58:47 <iurygregory> #endmeeting