15:00:06 <iurygregory> #startmeeting ironic
15:00:06 <opendevmeet> Meeting started Mon Sep 13 15:00:06 2021 UTC and is due to finish in 60 minutes.  The chair is iurygregory. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <opendevmeet> The meeting name has been set to 'ironic'
15:00:11 <iurygregory> o/
15:00:11 <TheJulia> o/
15:00:17 <arne_wiebalck> o/
15:00:33 <sam_z> o/
15:00:36 <ajya> o/
15:01:00 <iurygregory> Hello everyone, welcome to our weekly meeting
15:01:00 <rloo> o/
15:01:02 <rpioso> o/
15:01:11 <stendulker> o/
15:01:21 <iurygregory> seems like we have enough people so let's get started :D
15:01:29 <iurygregory> #topic Announcements/Reminders
15:01:59 <iurygregory> #info This week is the R-3 week - we have RC1 for all projects with release-model cycle-with-rc under the ironic
15:02:11 <erbarr> o/
15:02:34 <iurygregory> #info Yoga PTG is in 5 weeks! Don't forget to register and add topics in our etherpad!
15:02:42 <iurygregory> #link https://www.eventbrite.com/e/project-teams-gathering-october-2021-tickets-161235669227
15:02:57 <iurygregory> #link https://etherpad.opendev.org/p/ironic-yoga-ptg
15:03:49 <iurygregory> Does anyone have something to add to our  Announcements/Reminders? =)
15:04:42 <TheJulia> iurygregory: I guess we need to try and release end of this week or at the latest sometime next week.
15:05:14 <TheJulia> Since we typically trail a little after RC1 release as often we devstack changes which can break us at times.
15:05:56 <iurygregory> TheJulia, agree, I would say that depending on the project we can wait till next week
15:06:12 <TheJulia> sooner obviously better, of course
15:06:45 <iurygregory> yeah for most of the projects I think we are in a good shape, ipa-builder we will be able to release this week, we need to take a look at ironic and inspector
15:07:48 <iurygregory> moving on
15:08:00 <iurygregory> #topic Review action items from previous meeting
15:08:15 <iurygregory> skipping since we don't have any Action Item
15:08:26 <iurygregory> #topic Review subteam status reports
15:08:33 <iurygregory> starting on L60
15:08:55 <TheJulia> url? :)
15:09:02 <iurygregory> #link https://etherpad.opendev.org/p/IronicWhiteBoard
15:09:12 <iurygregory> sorry =)
15:09:17 <TheJulia> no worries
15:09:36 <TheJulia> I'm going to note db performance done
15:10:00 <iurygregory> makes sense to me
15:10:01 <TheJulia> I've noticed our periodics are becoming less... efficent, and Dmitry and I chatted about this some last week but it will be a longer term better solution
15:11:35 <iurygregory> do we have some data that confirms that is becoming less efficient? (just wondering) =)
15:11:48 <TheJulia> knowledge of hundreds of needless extra db queries
15:11:52 <TheJulia> based upon the pattern
15:11:57 <iurygregory> got it
15:12:32 <TheJulia> For example, if we request driver_internal_info from nodes_iter, and then pull a task before making a decision based on d_i_info, then we've triggered more db queries needlessly
15:12:42 <TheJulia> when d_i_i had the answer all along
15:12:53 <TheJulia> I may look around and try to fix those this week
15:13:02 * TheJulia notes node history
15:13:27 <iurygregory> got it, yeah if we have the information handy we don't need to go to the db...
15:15:06 <TheJulia> Updated the node event history stuffs
15:15:09 <TheJulia> with links!
15:15:15 <iurygregory> links++\
15:15:54 <arne_wiebalck> TheJulia: I will replace my name with yours for this item :)
15:16:13 <TheJulia> arne_wiebalck: okay :)
15:16:23 <iurygregory> or just add TheJulia =)
15:16:46 <TheJulia> arne_wiebalck: please feel free to review. I got nobodycam to skim the periodic logic and he +1'ed it based upon his use case and also incorporated his feedback
15:17:03 <arne_wiebalck> TheJulia: ok, I will!
15:17:41 <iurygregory> are we good to proceed?
15:17:48 <TheJulia> yes
15:18:14 <iurygregory> #topic Deciding on priorities for the coming week
15:18:19 <iurygregory> #link https://review.opendev.org/q/status:open+hashtag:ironic-week-prio
15:18:53 <TheJulia> I'd like to get reviews on the events patches this week, it would be a good item to get out there and people can at least use it as soon as the client is out early next cycle
15:18:56 <ajya> Can these be added to priorities - https://review.opendev.org/c/openstack/ironic/+/808098 https://review.opendev.org/c/openstack/ironic/+/805431 https://review.opendev.org/c/openstack/ironic/+/805428
15:19:06 <ajya> given that release is close and 2 of them have been open for a while
15:19:40 <iurygregory> ajya, ++ make sense to add them I would say
15:20:04 <iurygregory> TheJulia, I didn't see any patches for events (maybe I missed)
15:20:21 <iurygregory> but I does sound like something we should try to include
15:20:50 <TheJulia> iurygregory: node history
15:21:04 <iurygregory> oh ok, related to node history!
15:21:15 <TheJulia> adding
15:21:28 <TheJulia> added
15:22:03 <iurygregory> ajya, I think we probably want to backport https://review.opendev.org/c/openstack/ironic/+/805428 right?
15:22:16 <iurygregory> can you add a releasenote?
15:22:46 <TheJulia> https://review.opendev.org/c/openstack/ironic-python-agent-builder/+/808198 would also be good to land this week
15:23:16 <ajya> iurygregory: yes to backport and releasenote
15:23:24 <iurygregory> TheJulia, ++ I will take a look
15:25:12 <TheJulia> hmmm https://review.opendev.org/c/openstack/networking-generic-switch/+/763794 is tagged as a wip
15:25:22 * TheJulia wonders if it is not really
15:25:28 <TheJulia> of course, it has also missed the release
15:25:53 <iurygregory> TheJulia, well we can hold a bit the ngs release (but we need to do this week)
15:26:24 * iurygregory wondering why the patch is marked as WIP...
15:26:25 <TheJulia> oh yeah
15:26:30 <TheJulia> it hasn't released yet
15:26:37 <TheJulia> that we need to go ahead and get sorted this week
15:26:50 <iurygregory> yup, we can still hold ngs, networking-baremetal
15:27:05 <TheJulia> yup
15:27:18 <TheJulia> it has only had very minor changes since the last release
15:27:25 <TheJulia> being networking-baremetal
15:28:31 <iurygregory> exactly
15:29:37 <iurygregory> later today I will take a look at the non-tagged in patches in our projects and see if there is something we want to include
15:29:48 <TheJulia> ++
15:29:53 <iurygregory> should we move on?
15:29:55 <TheJulia> yes
15:30:06 <iurygregory> #topic Discussion
15:30:25 <iurygregory> I have a topic, but I forgot to add to our agenda
15:30:42 <TheJulia> Okay
15:31:08 <iurygregory> I was talking with the release team since we need the RC for some of our deliverables
15:31:22 <TheJulia> should be the neutron tied ones
15:31:54 <iurygregory> we have projects like IPE and ironic-ui (that doesn't get a lot of changes) and we are using cycle-with-rc
15:32:14 <TheJulia> Because the release team wants to cut a new release regardless of if it changes.
15:32:25 <TheJulia> which... artificially increases the version
15:32:27 <TheJulia> sadly
15:32:41 <TheJulia> What are they proposing?
15:32:46 <iurygregory> yes, but they will cut with the major bump, I don't think it makes sense...
15:33:38 <TheJulia> Yeah... That has been a point of contention in the past.
15:34:00 <iurygregory> yup, I noticed that they asked for the change to RC
15:34:07 <iurygregory> https://opendev.org/openstack/releases/commit/7ac3b50659a225846831fec978ecc89041ee459e
15:34:51 <iurygregory> for the end user perspective if they check the version they will think we added a bunch of new things that required a Major bump..
15:34:53 <TheJulia> OpenStack's All or Nothing model is *largely* driven to help drive market forces and new versions are part of that, but at the same time they are supposed to also pull in the last release or the next appropriate release.
15:35:15 <TheJulia> however, that has changed such where they require a release to be pulled in during a cycle
15:35:26 <TheJulia> iurygregory: exactly
15:35:46 <TheJulia> iurygregory: and even if we had a release note to the contrary, the perception has been set.
15:35:54 <iurygregory> yup!
15:36:19 <iurygregory> oh we added this small feature, there is no breaking change in our API (major bump \o/)
15:37:16 <TheJulia> yup
15:37:32 <TheJulia> As I said, it is really driven to try and play the market with "new version"
15:37:37 <iurygregory> so I think we probably need to try to evaluate our projects to cycle-with-intermediary, or maybe see with the release team if we can have a new model (not sure)
15:37:42 <opendevreview> Verification of a change to openstack/ironic-inspector master failed: Update parameters for authtoken middleware  https://review.opendev.org/c/openstack/ironic-inspector/+/805443
15:37:55 <TheJulia> iurygregory: It could be good to discuss
15:38:33 <TheJulia> iurygregory: perhaps a ptg session with the release team. I'm sure largely they are driven by the "this is the way it has been documented", and that can be changed if they are willing
15:38:50 <iurygregory> TheJulia, yeah I was thinking about that
15:39:05 <iurygregory> I will talk with Herve about this
15:39:19 <TheJulia> Okay, let me know if there is any way I can help
15:40:00 <iurygregory> #action iurygregory to talk with Herve about changing the release of some ironic projects
15:40:05 <iurygregory> TheJulia, sure! tks
15:40:19 <iurygregory> that's it from my side
15:40:33 <TheJulia> onward?
15:40:46 <iurygregory> #topic Baremetal SIG
15:40:52 <iurygregory> #link https://etherpad.opendev.org/p/bare-metal-sig
15:41:05 <iurygregory> arne_wiebalck, do you have something for the Baremetal SIG ?
15:41:07 <arne_wiebalck> Lively ops/feedback discussion last week.
15:41:30 <arne_wiebalck> There were suggestions to have a 2nd one as we did not really finish.
15:41:51 <TheJulia> second one would be good
15:41:51 <arne_wiebalck> Maybe it is a good idea to have another one right before the PTG?
15:42:04 <TheJulia> I know two firms that just had stuff come up and couldn't make it
15:42:08 <TheJulia> arne_wiebalck: ++
15:42:13 <iurygregory> ++
15:42:13 <arne_wiebalck> oh, ok!
15:42:19 <arne_wiebalck> How do we find a slot?
15:42:30 <arne_wiebalck> Also for TheJulia to join :)
15:42:44 <arne_wiebalck> TheJulia: you have a permanent clash with the slot?
15:42:55 <TheJulia> arne_wiebalck: yes, OSF board meetings
15:43:05 <TheJulia> err
15:43:06 <TheJulia> OIF
15:43:13 <arne_wiebalck> TheJulia: they picked our slot? :-D
15:43:23 <iurygregory> I also know I friend that couldn't join because it was holiday in Brazil
15:43:37 <TheJulia> arne_wiebalck: it has always been their slot, just... not every month and sometimes shifted time zone wise. This year threw a wrench into things as we were not able to do in-person
15:44:09 <TheJulia> I think maybe a little later would help, at least from some of the feedback from west-coast US operators was that it was just really early for most of them
15:44:32 <arne_wiebalck> later, but same day of the week?
15:44:49 <TheJulia> could be good
15:45:00 <arne_wiebalck> would 2 hrs later be good enough?
15:45:09 <TheJulia> yes
15:45:14 <arne_wiebalck> that is still acceptable in Europe, I think
15:45:28 <arne_wiebalck> well, some of Europe at least
15:45:43 <TheJulia> time zones are hard :(
15:45:58 <arne_wiebalck> ok, let's try, I will schedule one and we pick up the usual short tutorials after, soounds ok?
15:46:15 <iurygregory> ++
15:46:20 <iurygregory> arne_wiebalck, thanks!
15:46:33 <arne_wiebalck> cool, that's it from the SIG I believe
15:47:02 <iurygregory> #topic RFE review
15:47:08 <iurygregory> no topics so skipping
15:47:15 <iurygregory> #topic Open discussion
15:48:07 <iurygregory> Anyone have anything for our open discussion?
15:49:26 <TheJulia> I've got nothing
15:49:34 <TheJulia> arne_wiebalck: that sounds good to me
15:49:46 <sam_z> i will be submitting a spec for review soon (once i can figure out how to do so)
15:49:58 <TheJulia> I expect we should review jam attestation tomorrow
15:50:15 <sam_z> it's for the redfish power control intermediary
15:50:15 <iurygregory> sam_z, feel free to ask here and we can try to help you =)
15:50:24 <TheJulia> sam_z: awesome
15:50:29 <sam_z> will do!
15:50:36 <iurygregory> TheJulia, ++ for review jam tomorrow
15:50:51 <TheJulia> I can drive the jams
15:51:18 <iurygregory> I can join without problems I think
15:51:36 <iurygregory> so lets go for our last topic
15:51:43 <iurygregory> #topic Who is going to run the next meeting?
15:51:57 <iurygregory> Do we have any volunteers?
15:53:13 <iurygregory> ok, I will run the meeting next week =)
15:53:23 <iurygregory> Thanks everyone!
15:53:27 <iurygregory> #endmeeting