15:00:00 <iurygregory> #startmeeting ironic
15:00:00 <opendevmeet> Meeting started Mon Sep 20 15:00:00 2021 UTC and is due to finish in 60 minutes.  The chair is iurygregory. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:00 <opendevmeet> The meeting name has been set to 'ironic'
15:00:04 <TheJulia> o/
15:00:04 <iurygregory> o/
15:00:05 <rpittau> o/
15:00:05 <opendevreview> Dmitry Tantsur proposed openstack/ironic bugfix/18.1: Always update cache for HTTP images if Last Modified is unknown  https://review.opendev.org/c/openstack/ironic/+/809667
15:00:07 <erbarr> o/
15:00:08 <dtantsur> o/
15:00:16 <rpioso> o/
15:00:22 <ajya> o/
15:00:26 <iurygregory> Hello everyone, welcome to our weekly meeting!
15:00:44 <iurygregory> You can find our agenda in the wiki
15:00:46 <iurygregory> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:06 <iurygregory> #topic Announcements/Reminders
15:01:24 <iurygregory> #info CI is in a bad shape and we hope that https://review.opendev.org/c/openstack/ironic/+/809895 will fix so we release the other ironic projects this week.
15:01:35 <opendevreview> Dmitry Tantsur proposed openstack/ironic bugfix/18.1: Fix in-band cleaning for ramdisk and anaconda deploy  https://review.opendev.org/c/openstack/ironic/+/810033
15:01:37 <iurygregory> tks TheJulia for the patch =)
15:01:51 <opendevreview> Dmitry Tantsur proposed openstack/ironic stable/wallaby: Remove images from the OS profiler docs  https://review.opendev.org/c/openstack/ironic/+/809668
15:01:54 <iurygregory> #info Yoga PTG is in 4 weeks! Don't forget to register and add topics in our etherpad!
15:02:00 <iurygregory> #link Registration (https://www.eventbrite.com/e/project-teams-gathering-october-2021-tickets-161235669227)
15:02:07 <iurygregory> #link Etherpad (https://etherpad.opendev.org/p/ironic-yoga-ptg)
15:02:50 <iurygregory> This week I will start to organize the topics we have in the etherpad in the slots we have, I will update the etherpad during the week
15:03:15 <iurygregory> Does anyone have something to add to our  Announcements/Reminders? =)
15:03:55 <TheJulia> I may not be around the week of October 4th
15:04:05 <TheJulia> I received a Jury summons :(
15:04:18 <iurygregory> oh =( good luck TheJulia
15:04:31 <TheJulia> c'est la vie
15:04:33 <dtantsur> fun fact: they still try to summon me for jury back in Russia
15:04:41 <TheJulia> dtantsur: fun!
15:04:47 <dtantsur> even though I no longer *officially* live there
15:04:52 <iurygregory> dtantsur, wow O.o
15:05:00 <dtantsur> anyway, good luck TheJulia!
15:05:24 <dtantsur> iurygregory: you need to urgent get a corgi for background (dis)approval noises!
15:05:41 * dtantsur is still unable to switch to a serious mood
15:05:51 <TheJulia> dtantsur: silly moods are encouraged
15:05:51 <iurygregory> dtantsur, ++ :D I would love to get a corgi
15:06:03 <TheJulia> iurygregory: For the record, most corgi nosies are disapproval noises
15:06:09 <iurygregory> the close one I have is a cocker spaniel :D
15:06:20 <iurygregory> well my mother has...
15:06:21 <dtantsur> yeah, but if it's a disapproval for a disapproval, is it an approval in the end?
15:06:34 <TheJulia> Including the "cat is someplace which is not explicitly permitted, humans! Humans! Where are you!?! Fix this!" noises
15:06:48 <iurygregory> maybe TheJulia can record the disapproval noises and share with us <3
15:07:12 <TheJulia> Would it make sense to remind the mailing list w/r/t ptg?
15:07:15 <dtantsur> we need a meetpad plugin
15:07:20 <dtantsur> TheJulia++
15:07:30 <iurygregory> TheJulia, ++ I will add an action for this
15:07:54 <iurygregory> #action iurygregory to send an email to remind about the upcoming PTG
15:08:40 <iurygregory> #topic Review action items
15:09:26 <iurygregory> last week we talked a bit about the release model of some projects and  I had the action item to talk with Herve (or maybe even a PTG session so we can discuss with the release team)
15:10:06 <iurygregory> I did some progress, I've created a list with the model - project we have atm, and I'm finishing to read the documentation about each model this week
15:10:18 <TheJulia> iurygregory: ahh, fun reading
15:10:24 <iurygregory> TheJulia, yes =)
15:10:50 <iurygregory> I will check with him during this week and I will update the status of the action item next week
15:11:25 <iurygregory> #action iurygregory - sync with Herve after reading the details about each release model this week
15:11:46 <iurygregory> #topic Review subteam status reports
15:11:51 <iurygregory> #link https://etherpad.opendev.org/p/IronicWhiteBoard
15:11:58 <iurygregory> starting on L62
15:15:09 <iurygregory> I think we have updates on the topics so moving on
15:15:30 <iurygregory> #topic Deciding on priorities for the coming week
15:16:16 <TheJulia> I didn't see anything to really add this week
15:16:34 <TheJulia> at least that was a "we must get this in asap"
15:17:03 <iurygregory> we need CI to get a few patches we approved merged so we can cut the release
15:17:11 <iurygregory> ironic/inspector/ipa I would say
15:17:31 <dtantsur> I guess bifrost can go already?
15:17:33 <iurygregory> I will also talk with the release team since our CI is in a bad shape..
15:17:40 <iurygregory> dtantsur, agree =)
15:18:22 <TheJulia> Looks like the ironic fix for the neutron startup failures is going to need a recheck
15:18:32 <TheJulia> like 50% of the jobs failed
15:18:37 <iurygregory> O.o
15:18:38 <iurygregory> wow
15:18:39 <TheJulia> but it looks like connectivity issues took them out
15:18:43 <iurygregory> =(
15:18:57 <iurygregory> zuul, we will give you cookies, please help us =)
15:21:53 <iurygregory> we don't have any topics for Discussion/ RFE review or updates for the SIG so moving to Open Discussion
15:21:56 <TheJulia> onward?
15:22:06 <iurygregory> #topic Open discussion
15:22:20 <TheJulia> no bare metal sig update?
15:22:28 <iurygregory> no
15:22:31 <TheJulia> :(
15:22:35 <TheJulia> okay
15:22:36 <iurygregory> I've talked with arne_wiebalck already
15:22:43 <arne_wiebalck> I don't think there is anything to report this time.
15:23:01 <TheJulia> ?2? weeks until the next meeting
15:23:28 <arne_wiebalck> 3, I think
15:23:37 <TheJulia> ok
15:23:38 <arne_wiebalck> usually it is the 2nd Tue
15:23:39 <iurygregory> is on the second week of each month right?
15:23:43 <iurygregory> yeah ^
15:23:50 <TheJulia> yeah, then it would be 3
15:23:51 <arne_wiebalck> not sure why we had on the first last time :)
15:24:08 <arne_wiebalck> plan is the 2nd ops feedback session
15:24:19 <arne_wiebalck> I will update the etherpad ...
15:24:25 <sam_z> i've updated my spec proposal at https://review.opendev.org/c/openstack/ironic-specs/+/808804
15:25:14 <TheJulia> sam_z: unfortunately I didn't get a chance to look again last week
15:25:24 * iurygregory adds the hashtag
15:25:24 <sam_z> yea no rush!
15:26:47 <iurygregory> looking at specs I think I should probably start the Yoga themes...
15:26:56 <NobodyCam> o/ good morning ironic’ers
15:27:32 <iurygregory> good morning NobodyCam =) welcome to our meeting \o/ (I think is the first time I see you in the meeting XD)
15:28:00 <iurygregory> anything else we should discuss?
15:28:03 <NobodyCam> :)
15:28:15 <dtantsur> NobodyCam: these new kids, right? :D
15:28:29 <NobodyCam> Hehehe
15:28:33 <TheJulia> NobodyCam did raise a patch he would like feedback on last week
15:28:46 <dtantsur> okay, I have a question. How seriously do we take backward compatibility in stuff like image_utils?
15:29:00 <dtantsur> I'm looking at it again this week and I want: 1) to scream, 2) to rewrite half of it.
15:29:09 <TheJulia> If I groked what he told me while I was welding steel this past weekend, he has SNMP pdus which have a 30+ second request -> action lag
15:29:25 <TheJulia> dtantsur: not strongly, I don't think
15:29:45 <rloo> dtantsur: so you want to fix it starting from master?
15:29:53 <TheJulia> I'd double check codesearch, of course :)
15:30:02 <dtantsur> rloo: s/fix/refactor/ mostly, so yeah. master (yoga?).
15:30:08 <iurygregory> https://opendev.org/openstack/ironic/src/branch/master/ironic/drivers/modules/image_utils.py this image utils?
15:30:25 <dtantsur> well, there is also common/images.py which contains a part of this logic, I'm not sure why
15:30:35 <rloo> i think it probably depends on what 'backwards compatibility' the refactored code isn't compatible with?
15:30:41 <iurygregory> dtantsur, well yoga will be the master after we merge a few things - when CI is happy again ofc =)
15:30:48 <opendevreview> Merged openstack/ironic-lib stable/xena: Avoid using blkid in favour of lsblk and parted  https://review.opendev.org/c/openstack/ironic-lib/+/808166
15:30:53 <dtantsur> rloo: I want to redo most of public interfaces, maybe even move it around
15:30:57 <TheJulia> I'd prefer yoga personally since last minute has bitten us before
15:31:07 <iurygregory> ^ agree
15:31:15 <dtantsur> yeah, I don't think I'll wrap my head around it until the middle of this week anyway
15:31:22 <TheJulia> fair enough
15:31:37 <dtantsur> background: I've been working on this code a lot, and every time I'm struggling to understand the data flow
15:31:48 <rloo> if yoga -- could bring it up in ptg if there are any 'serious' backward compatibility issues?
15:31:50 <dtantsur> even though I'm literally the one who knows this code the best right now
15:32:07 <dtantsur> rloo: who do you expect to be the target audience?
15:32:17 <rloo> (I don't recall what the public interfaces buy us and/or who uses/cares)
15:32:20 <NobodyCam> Yea the patch is There for criticism :) and direction.
15:32:42 <TheJulia> a lot of that code in image_utils is to get "the needful done" for drivers
15:32:51 <rloo> dtantsur: ^^. I don't know. I think sufficient to bring it up and us ack'ing that we're ok with whatever backwards incompatibilities there might be.
15:33:07 <dtantsur> rloo: that's my question pretty much. I think we talked about it a few years ago, wanted to define some sort of a stable API.. and it never happened
15:33:24 <TheJulia> NobodyCam: remind me mid-week if I haven't looked by then
15:33:34 <rloo> if we never said they were 'public' APIs, then we can do what we want!
15:33:40 <NobodyCam> :) will do
15:33:44 * dtantsur does what he wants \o/
15:34:21 * rloo glad that dtantsur is happy ;)
15:34:29 <dtantsur> thank you <3
15:34:59 <iurygregory> Dobby is free!
15:35:09 <TheJulia> huh?
15:35:17 <iurygregory> this type of happiness =)
15:35:18 <rloo> ha ha. all cuz of one sock
15:35:25 * TheJulia reaches peak confusion
15:35:32 <rloo> (harry potter...)
15:35:33 <iurygregory> TheJulia, Harry Potter reference? :D
15:35:41 <TheJulia> oh, no clue about that
15:35:45 <iurygregory> =O
15:35:50 * iurygregory shocked!
15:35:59 * dtantsur is curious if corgis are interested in socks
15:37:01 <TheJulia> dtantsur: not really
15:37:01 <iurygregory> maybe they are
15:37:04 <rpittau> as clothing probably not, as toys I bet they are
15:37:07 <TheJulia> more intereted in the kittens
15:37:13 <TheJulia> and things which squeek
15:37:14 <iurygregory> wow =O
15:37:20 <TheJulia> but if there is more than one squeeker, it breaks his brain
15:37:23 <dtantsur> I've seen a lot of pomeranians obsessed with socks, hence the question
15:38:05 <TheJulia> the longest surviving squeeky toy has 30 squeekers in it
15:38:10 <TheJulia> it is mostly just a pillow now
15:38:19 <TheJulia> ... used by the kittens
15:38:25 <iurygregory> my mother's cocker spaniel is very interested in any type of clothes
15:38:58 <iurygregory> she destroyed 3 pair of socks and 1 t-shirt
15:40:22 <TheJulia> fun :(
15:40:38 <TheJulia> Do we have anything else to discuss on our critical path to world domination?
15:41:06 <iurygregory> not from me =)
15:41:29 <iurygregory> so let's go to the last topic
15:41:31 <iurygregory> #topic Who is going to run the next meeting?
15:41:47 <iurygregory> Do we have any volunteers?
15:42:54 <TheJulia> I guess I can
15:43:18 <iurygregory> TheJulia, tks, if doesn't work for you let me know =)
15:43:30 <TheJulia> k
15:43:31 <iurygregory> #endmeeting