15:00:00 <iurygregory> #startmeeting ironic
15:00:00 <opendevmeet> Meeting started Mon Oct 11 15:00:00 2021 UTC and is due to finish in 60 minutes.  The chair is iurygregory. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:00 <opendevmeet> The meeting name has been set to 'ironic'
15:00:04 <dtantsur> o/
15:00:05 <TheJulia> o/
15:00:08 <erbarr> o/
15:00:12 <iurygregory> Welcome to our weekly meeting! o/
15:00:26 <iurygregory> Our agenda can be found on the wiki.
15:00:28 <stendulker> o/
15:00:30 <ajya> o/
15:00:30 <iurygregory> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:00:35 <rpittau> o/
15:01:07 <rpioso> \o
15:01:13 * iurygregory wondering if we should try to summon arne_wiebalck (because of the SIG updates =P)
15:01:22 <arne_wiebalck> o/
15:01:29 <iurygregory> #topic Announcements / Reminders
15:01:47 <iurygregory> #info Yoga PTG is inext week! Our schedule is in the ML and in the etherpad
15:01:54 <iurygregory> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-October/025249.html
15:02:00 <iurygregory> #link https://etherpad.opendev.org/p/ironic-yoga-ptg
15:02:19 <TheJulia> I see we have powerful arne_wiebalck summoning spells in place in IRC :)
15:02:29 <iurygregory> :D
15:02:32 * arne_wiebalck was summoned again
15:02:39 <iurygregory> #info No upstream meeting on Oct 18 because of the PTG
15:02:51 <iurygregory> #action iurygregory to send email to the ML
15:03:35 <iurygregory> just and fyi, I probably won't be able to join the first day of the PTG Oct18, I will be on PTO =)
15:04:00 <iurygregory> but Tue-Fri I will be around =)
15:04:39 <iurygregory> Anyone has something to add for announcements/reminders?
15:05:13 <TheJulia> Official Xena release was last week
15:05:23 <iurygregory> oh right! :D
15:05:24 <TheJulia> As well as press releases on the growth of openstack
15:06:09 <TheJulia> Use of bare metal as a back-end to nova grew 9% year over year.
15:06:16 <iurygregory> #info Xena was officially released last week
15:06:19 <TheJulia> Well, actually...
15:06:23 <TheJulia> it is now 20% of all respondants
15:06:50 <iurygregory> the Open Infra Live showed some interesting data from the survey
15:06:58 <dtantsur> sweet!
15:07:14 <TheJulia> it is like 82% growth overall
15:07:18 <rpittau> nice
15:07:22 <iurygregory> \o/
15:07:30 <TheJulia> which is kind of epic!
15:07:36 <TheJulia> Anyway, I'll be quiet now :)
15:08:05 <iurygregory> well, congrats to everyone who contributed during the Xena cycle :D
15:08:13 <dtantsur> ironic++
15:08:33 <iurygregory> #topic Review action items from previous meeting
15:08:45 <iurygregory> we don't have any actions items, moving on
15:09:02 <iurygregory> #topic Review subteam status reports
15:09:03 <iurygregory> #link https://etherpad.opendev.org/p/IronicWhiteBoard
15:09:14 <iurygregory> starting on L62
15:10:56 <dtantsur> we've done some good job cleaning up obsolete RFEs.. but bugs are piling up :(
15:11:22 <dtantsur> I don't find 300+ bugs and 200+ RFEs comfortable numbers
15:12:12 <Charlotte> Hello, my name is Charlotte. A software engineer and python lover. I am glad to be here
15:12:18 <arne_wiebalck> maybe we need a bug jam session to do the triaging
15:12:23 <iurygregory> dtantsur, agree
15:12:32 <rpittau> arne_wiebalck: was thinking the same
15:12:54 <iurygregory> ++ I think it makes sense
15:12:57 <TheJulia> dtantsur:  We need to scrub the bugs just like RFEs I think
15:13:01 <arne_wiebalck> to see which are valid, how to reproduce, how difficult to fix, who can have a look, ...
15:13:06 <TheJulia> I went through some and found them to be out dated or already fixed
15:13:13 <TheJulia> it just takes time :(
15:13:13 <arne_wiebalck> TheJulia: exactly
15:13:22 <arne_wiebalck> TheJulia: exactly again
15:13:36 <dtantsur> Hi Charlotte! We're in a meeting right now, so may delay saying welcome to you a bit :)
15:13:36 <TheJulia> Anyway, I'm all for the week after the PTG
15:13:48 <TheJulia> Welcome Charlotte
15:13:54 <iurygregory> welcome Charlotte =)
15:14:11 <TheJulia> lets just not cause that time window to collide with a board or committee meeting
15:14:51 <iurygregory> if we know the at what time is the board/committee meeting we can avoid this :D
15:15:01 <TheJulia> iurygregory: tuesdays. Avoid tuesdays :)
15:15:24 <iurygregory> TheJulia, awesome! so we should probably try to change the review jam day?
15:15:59 <TheJulia> so luckilly enough, the 26th is clear as the board meeting is 2pm-4pm my time
15:16:01 <rpittau> what about wednesdays?
15:16:14 <TheJulia> wednesdays are actually a really good day for me
15:16:27 <JayF> Time to ruin it with more meetings? ;)
15:16:31 <dtantsur> \o/
15:16:40 <iurygregory> JayF, lol!
15:16:43 <arne_wiebalck> JayF: heh
15:16:44 <rpittau> d'oh! yeah
15:16:47 <TheJulia> JayF: presently meeting free, but don't tell anyone ;)
15:16:58 <TheJulia> and of course I look at it this week and I do have one
15:17:01 <TheJulia> d'oh
15:17:05 <dtantsur> my Wednesday slots are 12pm and 2pm (UTC)
15:17:29 <iurygregory> metal3 meeting is on wed we can try to avoid the same slot and we should be good I think...
15:18:26 <rpittau> 2pm utc looks good
15:18:53 <TheJulia> Looks like I can do 2pm-3pm utc
15:20:10 <iurygregory> works for me also
15:20:37 <iurygregory> who will be the good soul that will update the wiki? :D
15:21:17 <iurygregory> shall we go to the next topic?
15:21:25 <arne_wiebalck> this will be new review/bug jam slot or is this a one-off?
15:21:56 <TheJulia> https://c.tenor.com/odyVsZbC-OYAAAAM/why-not-both-why-not.gif
15:22:18 <iurygregory> lol ^
15:22:22 <iurygregory> I love it
15:22:35 <TheJulia> doing it weekly will be a much better habit for us
15:22:54 * TheJulia signs in to change the wiki
15:23:05 <iurygregory> thank you TheJulia ++
15:23:32 <iurygregory> ok, next topic :D
15:23:43 <iurygregory> #topic Deciding on priorities for the coming week
15:23:49 <iurygregory> #link https://review.opendev.org/q/status:open+hashtag:ironic-week-prio
15:24:00 <iurygregory> we don't have a lot of topics in the list
15:24:27 <iurygregory> anyone with patches that needs reviews?
15:24:57 <TheJulia> https://wiki.openstack.org/wiki/Meetings/Ironic#Related_meetings updated
15:25:19 <rpittau> this one https://review.opendev.org/c/openstack/metalsmith/+/813400
15:25:51 <iurygregory> ++
15:26:22 <dtantsur> I have a couple as well
15:26:28 <opendevreview> Dmitry Tantsur proposed openstack/ironic master: Add and document high-level helpers for async steps  https://review.opendev.org/c/openstack/ironic/+/807295
15:26:28 <opendevreview> Dmitry Tantsur proposed openstack/ironic master: Add a helper for node-based periodics  https://review.opendev.org/c/openstack/ironic/+/812495
15:26:29 <dtantsur> here they are ^^
15:26:36 <iurygregory> dtantsur, awesome tks!
15:27:12 <iurygregory> hashtags added
15:27:15 <TheJulia> I'm good with what is there, largely CI fixes. I did post and tag a nova fix for the long grumbled about vif attach on nova-compute restart
15:27:44 <iurygregory> yeah, I think we won't have much patches till the PTG probably
15:27:53 <TheJulia> Yeah, unlikely
15:28:03 <TheJulia> We also have the initial round for outreachy starting up
15:28:15 <iurygregory> oh \o/ nice
15:29:16 <iurygregory> shall we move to the next topic?
15:29:21 <TheJulia> ++
15:29:33 <iurygregory> #topic Discussion
15:29:54 <iurygregory> I have one topic for discussion, but I'm not sure if we will be able to get much information :D
15:30:01 <iurygregory> #topic PTG schedule
15:30:30 <iurygregory> I would like the community thoughts about the proposed schedule for the PTG, if we should change something etc
15:31:09 <iurygregory> we have 18 topics and 11 slots (1hr each)
15:31:53 <TheJulia> so I'm wondering if we should drop "Posting to placement ourselves" since it is bypassing the resource tracker and there is a double interaction there that seems problematic. At least, that is the impression I got from NobodyCam who experimented with doing so
15:32:15 <dtantsur> "Stopping use of wiki.openstack.org" is something we should likely decide in a small circle
15:32:31 <dtantsur> (I'm all for it btw)
15:32:50 <rpittau> fine by me too
15:32:56 <iurygregory> ^ we can probably handle in our upstream meetings I think
15:33:03 <iurygregory> or review jam
15:33:07 <dtantsur> or just sit down one evening and Just Do It
15:33:12 <iurygregory> yeah :D
15:33:13 <dtantsur> I don't think it needs a voice call
15:33:31 <TheJulia> but where do we move interactive stuff like meeting agendas?
15:33:38 <iurygregory> ^ this
15:33:41 <dtantsur> etherpad?
15:33:46 <TheJulia> could work!
15:33:58 <TheJulia> worth a try I think
15:33:58 <dtantsur> i.e. the whiteboard, which is actively used for the meeting anyway
15:34:06 <TheJulia> ++
15:34:39 <rpittau> faster and easier to add content o nthe fly
15:34:46 <dtantsur> yep
15:34:56 <iurygregory> sounds like a plan =)
15:35:13 <dtantsur> TheJulia: it looks like you're half-way through it. are there specific areas where you need help?
15:35:20 <dtantsur> migrate something specific to the docs or anything?
15:35:20 <iurygregory> if we think we have a lot of info in the WhiteBoard we can have a specific etherpad for the meeting agenda also
15:35:33 <TheJulia> dtantsur: w/r/t wiki.o.o ?
15:35:36 <dtantsur> yep
15:35:47 <TheJulia> stendulker: you around?
15:35:49 <dtantsur> (I also agree re placement btw)
15:36:01 <TheJulia> I need clarity w/r/t all of the ilo docs on the wiki
15:36:11 <stendulker> TheJulia: yes
15:36:14 <TheJulia> the *rest* of it including the release notes being moved is easy
15:36:31 <stendulker> wiki is not updated off late
15:36:58 <TheJulia> stendulker: I noticed a lot of it duplicated the existing docs, is it safe to just abandon those wiki pages on the iLODrivers ?
15:37:05 <dtantsur> https://wiki.openstack.org/wiki/ThirdPartySystems/* is an openstack-wide thing, I assume, maybe we shouldn't touch it
15:37:21 <stendulker> i think so, its error prone and mostly duplicate
15:37:28 <TheJulia> dtantsur: yeah
15:37:45 <TheJulia> stendulker: Okay, I'll go back grhough it after moving the release notes
15:37:51 <TheJulia> soon()
15:38:15 <dtantsur> "Certificate Management (dtantsur)" - I think we can delay this item, unless anybody has anything for it
15:38:16 <TheJulia> iurygregory: don't delete the text, I spent a ton of time digging up all the pages
15:38:27 <iurygregory> TheJulia, ack =)
15:38:31 <stendulker> TheJulia: Thanks
15:38:54 <dtantsur> VirtualMedia 1.4.0 is still not widely used, and after it is, this may be a Just Do It item
15:39:12 <TheJulia> ++
15:39:59 <dtantsur> "Self-configuring Ironic service" and "Eliminate manual commands" should probably go back-to-back
15:40:02 <dtantsur> (if not merged together)
15:40:14 <TheJulia> they are rather tied together
15:40:26 <TheJulia> same general theme, improving ease of use and operability
15:40:43 <TheJulia> Maybe that is a theme for the community's during the Yoga cycle
15:40:49 <dtantsur> then we should probably do it on one day
15:40:51 <TheJulia> In addition to everyone learning yoga.
15:40:55 <dtantsur> (and they may occupy most of it)
15:40:57 <dtantsur> ++
15:41:20 <iurygregory> ack I will move them to the same day
15:41:31 <Charlotte> ".. so bring that into base.py is appropriate." Hello TheJulia do you mind elaborating further what this means? I found this in this story https://storyboard.openstack.org/#!/story/2009257
15:41:57 <iurygregory> Eliminate manual-commands as sub-topic for Self-configuring Ironic service?
15:42:04 <TheJulia> Charlotte: We're still meeting, although approaching the end, I can switch to your question once the meeting is over
15:42:23 <Charlotte> Thank you so much TheJulia
15:42:52 <TheJulia> iurygregory: yes, I think the idea is more "can we we have times we determine we should just do the needful instead of requiring a human to populate db schema or run the db upgrade
15:43:07 <iurygregory> TheJulia, got it =)
15:43:16 <TheJulia> some of that is totally navigatable too, we have most of the substrate needed already there, just not wired for ease of use
15:43:24 <TheJulia> its all wired for "human run command"
15:44:15 * dtantsur would love to reduce the amount of bash in metal3-io/ironic-image
15:44:23 <iurygregory> I will be updating the agenda locally and will past a link tomorrow to see what everyone think, I plan to send a new email on Thursday/Friday with the new proposal (after we get a consensus :D )
15:44:29 <TheJulia> dtantsur: ++
15:44:47 <TheJulia> dtantsur: if you propose env variable loading/checking, I won't object ;)
15:46:24 <TheJulia> so onward?
15:46:32 <iurygregory> I think we can move to the next topic, since  I got enough feedback to update the schedule, tks everyone
15:46:37 <iurygregory> #topic Baremetal SIG
15:46:44 <iurygregory> #link https://etherpad.opendev.org/p/bare-metal-sig
15:46:53 * iurygregory summons arne_wiebalck
15:47:01 * arne_wiebalck is summoned :)
15:47:16 <arne_wiebalck> Two meetings tomorrow, again on ops feedback.
15:47:23 <arne_wiebalck> All details on the etherpad.
15:47:30 <iurygregory> awesome \o/
15:47:31 <arne_wiebalck> #link https://etherpad.opendev.org/p/bare-metal-sig
15:47:48 <arne_wiebalck> 2 PM UTC (EMEA friendly) and 6 PM UTC (AMER friendly)
15:47:57 <iurygregory> tks arne_wiebalck =)
15:48:20 <iurygregory> #topic RFE review
15:48:21 <arne_wiebalck> timeu: jcosmao_ if you're interested ^^
15:48:37 <iurygregory> skipping since we don't have any RFE's =)
15:48:39 <TheJulia> NobodyCam: you may also be interseted ^
15:48:53 <TheJulia> zer0c00l: And you as well ^
15:49:09 <iurygregory> guilhermesp, please try to join the meeting tomorrow =P you or maybe mnaser_ =)
15:49:21 <TheJulia> ++
15:49:32 <NobodyCam> me? ... Good Morning Ironic'ers
15:49:42 <TheJulia> Yassss, you.
15:49:47 <NobodyCam> :)
15:49:50 <TheJulia> :)
15:50:08 <iurygregory> onward =D
15:50:09 <iurygregory> #topic Open discussion
15:50:28 <iurygregory> do we have more things to discuss?
15:50:30 <TheJulia> Coffee(), lets discuss it ;)
15:50:43 <TheJulia> Joking, mostly. :)
15:50:55 <iurygregory> =D
15:51:27 <dtantsur> we picked up a habit of ordering a completely new coffee flavor each time
15:51:33 <dtantsur> works very well so far :)
15:51:47 <iurygregory> wow =O
15:52:03 <rpittau> mmm I do that with tea :)
15:52:15 <dtantsur> with tea we're quite conservative :)
15:52:29 <rpittau> opposite with coffee here :D
15:52:30 <NobodyCam> mmmm Coffee
15:52:48 <TheJulia> I do need a fresh cup of coffee
15:53:08 <TheJulia> Today is one of those days that if I actually touch code I'll be surprised
15:53:36 <TheJulia> I've done nothing but reply to emails really
15:53:39 <iurygregory> well, it's monday :D
15:53:43 <TheJulia> True
15:53:45 * dtantsur gets surprised when touching code as well.. quite often
15:54:31 <iurygregory> let's go to the last topic and we can enjoy coffee :D
15:54:37 <iurygregory> #topic Who is going to run the next meeting?
15:54:43 <TheJulia> https://twitter.com/ashinclouds/status/1447590940718235651 <-- of course has appropriate gif for 82% growth.
15:54:48 <iurygregory> this would be for the meeting in Oct 25th
15:55:02 <iurygregory> TheJulia, ++
15:55:09 <rpittau> I can run that
15:55:12 <TheJulia> I'll just be back from traveling so I don't think it would be a good idea
15:55:18 <iurygregory> thanks rpittau =D
15:55:21 <rpittau> :)
15:55:26 <TheJulia> I'm only working half time next week, fwiw
15:55:27 <iurygregory> TheJulia, the ++ was for the link :D
15:55:39 <TheJulia> ack
15:55:50 <iurygregory> Thanks everyone!
15:55:53 <iurygregory> #endmeeting