15:00:00 <iurygregory> #startmeeting ironic
15:00:00 <opendevmeet> Meeting started Mon Nov 22 15:00:00 2021 UTC and is due to finish in 60 minutes.  The chair is iurygregory. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:00 <opendevmeet> The meeting name has been set to 'ironic'
15:00:07 <dtantsur> o/
15:00:07 <iurygregory> Hello everyone o/
15:00:24 <ajya> o/
15:00:27 <iurygregory> Welcome to our weekly meeting \o/
15:00:35 <TheJulia> o/
15:00:58 <rpioso> \o
15:01:56 <rloo> o/
15:02:07 <rpittau> o/
15:02:18 <iurygregory> you can find our agenda in the wiki
15:02:20 <iurygregory> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:02:38 <iurygregory> #topic Announcements / Reminder
15:02:47 <erbarr> o/
15:02:52 <iurygregory> #info Tested Runtimes for Yoga - Python 3.8 and 3.9
15:03:01 <iurygregory> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-November/025881.html
15:03:03 <stendulker> o/
15:03:04 <arne_wiebalck_> o/
15:03:21 <iurygregory> #link https://governance.openstack.org/tc/reference/runtimes/yoga.html
15:03:42 <iurygregory> #info First bugfix branch should be created by the end of next week
15:04:40 <iurygregory> #info PTL on PTO during whole December basically
15:04:49 <dtantsur> PTO++
15:05:11 <dtantsur> You can't even imagine how much work we'll assign to you in the meantime :)
15:05:18 <iurygregory> Next week 29,30 and 03Dec I'm on PTO and the whole month...
15:05:24 <iurygregory> dtantsur, omg :D
15:05:40 <iurygregory> well my PTO starts this thursday afternoon :D
15:05:49 <dtantsur> heh, nice
15:05:56 <iurygregory> but I will be on irc/twitter
15:06:01 <dtantsur> I'm available till at least mid-December, back in early January
15:06:07 <iurygregory> if you need something let me know =)
15:06:32 <iurygregory> we should evaluate how we will do the upstream meetings in December
15:06:45 <TheJulia> I'll likely be around the first three weeks of december
15:06:55 <rpittau> well if we move the meeting 1 hour later I can take ownership of some of them
15:07:00 <dtantsur> definitely not on the 27th and unlike on 3rd :)
15:07:02 <TheJulia> I don't expect anything other than banging my head against nova/rbac/etc
15:07:39 <iurygregory> dtantsur, yeah I agree with this dates (we can skip for sure)
15:07:57 <dtantsur> rpittau: I have nothing against moving the meeting, except that it's probably going to be a pain to notify everyone, change eavesdrop.o.o, etc
15:08:24 <dtantsur> iurygregory: so I assume you won't be here to handle what we just discussed re dropping rootwrap?
15:08:39 <iurygregory> 29 I should be able to run the meeting (if the jetlag doesn't hit me very hard)
15:09:07 <dtantsur> I can do it just as well, if needed
15:09:27 <TheJulia> I suspect we will just handle it like we have past decembers
15:09:28 <iurygregory> let's see, I think I will be able to online next monday
15:09:32 <TheJulia> if we have critical mass, awesome, if not skip()
15:09:37 <dtantsur> fair
15:09:39 <iurygregory> ++
15:09:52 <TheJulia> it may mean stuff piles on to the agenda for January
15:10:43 <iurygregory> does anyone have anything to announce/remind us of?
15:10:46 <rpittau> my only problem is that I have double meetings every time (until next time change) and I can't really run the ironic one :/
15:11:13 <iurygregory> rpittau, 0% of chance to change the downstream one? (just wondering)
15:11:20 <TheJulia> I don't think we can realistically change in december, but maybe starting in January?
15:12:56 <iurygregory> maybe we can start a thread and open a doodle to see what people think about moving the time of the meeting for next year?
15:13:10 <TheJulia> ++
15:14:03 <opendevreview> Merged openstack/ironic-python-agent stable/xena: Re-read the partition table with partx -a, part 2  https://review.opendev.org/c/openstack/ironic-python-agent/+/817419
15:14:14 <opendevreview> Verification of a change to openstack/ironic-python-agent bugfix/8.1 failed: Re-read the partition table with partx -a, part 2  https://review.opendev.org/c/openstack/ironic-python-agent/+/817420
15:14:48 <iurygregory> #action iurygregory to create a doodle for the new time so people can vote + email to openstack-discuss
15:15:28 <iurygregory> we don't have any action items from previous meeting or the subteam status (skipping)
15:15:37 <iurygregory> #topic Deciding on priorities for the coming week
15:15:59 <iurygregory> #link https://review.opendev.org/q/status:open+hashtag:ironic-week-prio
15:16:03 <rpittau> iurygregory: not really :/
15:16:37 <dtantsur> I have a few patches to make bifrost a happier place
15:16:55 <iurygregory> \o/
15:17:08 <dtantsur> https://review.opendev.org/c/openstack/bifrost/+/818592 https://review.opendev.org/c/openstack/bifrost/+/818549 https://review.opendev.org/c/openstack/bifrost/+/817978 https://review.opendev.org/c/openstack/bifrost/+/818780
15:18:04 <iurygregory> I'm ok with it ( I can review them after dinner today :D)
15:19:11 <TheJulia> https://review.opendev.org/c/openstack/ironic/+/818735 likely needs to be on that list
15:19:26 <TheJulia> backport to train
15:19:28 <iurygregory> ++
15:19:44 <iurygregory> I see that we have some backports in train that have -1 this will probably help =)
15:20:40 <TheJulia> yup
15:21:29 <iurygregory> anything else?
15:22:51 <iurygregory> moving on =)
15:23:12 <iurygregory> #topic Discussion
15:23:54 <iurygregory> Let's talk about privsep \o/
15:24:19 <TheJulia> so, do we do it given memory footprints... I guess is my question
15:24:20 <dtantsur> yep. has it occurred to you that ISO 9660 is a cursed technology?
15:24:36 * dtantsur reads about file name mangling and goes wtf
15:24:39 <dtantsur> anyway
15:24:46 <dtantsur> we don't need root in ironic now that we don't have the iscsi deploy
15:25:03 <TheJulia> dtantsur: an ancient and cursed technology, possibly developed by the grays to drive us crazy
15:25:03 <dtantsur> there is only this awkward place in images.py that mounts an ISO, I think that's it
15:25:39 <TheJulia> so as a service, does that really warrant privsep?
15:25:58 <TheJulia> on the agent, we need root privs regardless
15:26:00 <dtantsur> that's the question
15:26:16 <dtantsur> okay, we also mount a vfat image, which I guess is not needed either (we could use mtools or anything else)
15:26:30 <TheJulia> yeah
15:26:38 <dtantsur> so my suggestion is: let's stop doing privileged operations in Ironic
15:26:47 <dtantsur> and drop both rootwrap and privsep completely
15:26:47 <TheJulia> dtantsur: I was about to suggest the same
15:26:49 <iurygregory> kill with fire *-*
15:27:06 <dtantsur> yah
15:27:22 <dtantsur> we can start collecting a list of privileged operations to rewrite and assign people to them
15:27:36 <iurygregory> this way we don't need to add privsep and we can also kill rootwrap
15:27:43 <rloo> remind me, is/was privsep a community goal?
15:28:00 <iurygregory> rloo, yup it was/is
15:28:23 <rloo> thx. and i agree, if possible, don't use both. if not possible, i guess we'll need to use privsep...
15:29:03 <iurygregory> we can avoid using, this is the point dtantsur is raising (if I understood correct =) )
15:29:12 <dtantsur> yep
15:29:22 <rloo> right, we 'can'. we will see :D
15:29:44 <dtantsur> I'll create a story and do some research. But I can use volunteers for actual coding.
15:29:57 <iurygregory> dtantsur, you can count on me
15:30:04 <rpittau> dtantsur: I can rpobably spend some time on that
15:30:16 <iurygregory> since I was working on the privsep stuff I will work on this =)
15:31:00 <iurygregory> so I think we are ok with this approach and let's see how it goes =)
15:31:16 * iurygregory will change the themes track this instead of privsep
15:31:27 <iurygregory> to track*
15:31:39 <dtantsur> https://storyboard.openstack.org/#!/story/2009704
15:31:52 <dtantsur> I'll add subtasks as I find them (help welcome)
15:32:17 <iurygregory> awesome
15:33:12 <iurygregory> any questions about this?
15:35:02 <iurygregory> ok, moving on
15:35:19 <iurygregory> #topic Baremetal SIG
15:35:27 <iurygregory> #link https://etherpad.opendev.org/p/bare-metal-sig
15:35:45 <arne_wiebalck_> The latest video is up, thanks again to stevebaker[m] for editing !
15:36:07 <arne_wiebalck_> And I think that is mostly it for today :)
15:36:31 <iurygregory> next meeting will be on Dec 14, with Overview of Metal3 by dtantsur =)
15:37:51 <iurygregory> I don't think we have any RFE for review or topics for Open Discussion
15:38:02 <iurygregory> skipping =)
15:38:22 <iurygregory> #topic Who is going to run the next meeting?
15:38:48 <dtantsur> I can do it to avoid jetlag problems :)
15:39:04 <iurygregory> tks dtantsur =)
15:39:16 <iurygregory> Thanks everyone!
15:39:21 <dtantsur> thank you iurygregory!
15:39:28 <TheJulia> Thanks!
15:39:31 <iurygregory> #endmeeting