15:00:08 <dtantsur> #startmeeting ironic
15:00:08 <opendevmeet> Meeting started Mon Nov 29 15:00:08 2021 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:08 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:08 <opendevmeet> The meeting name has been set to 'ironic'
15:00:12 <rpittau> o/
15:00:16 <dtantsur> hi folks
15:00:30 <TheJulia> o/
15:00:39 <rpioso> \o
15:00:44 <ajya> o/
15:00:57 <stendulker> o/
15:01:17 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic our agenda for today
15:01:24 * TheJulia wonders how light our december meetings may be
15:01:30 <dtantsur> very light, I suspect :)
15:01:35 <dtantsur> #topic Announcements / Reminder
15:02:10 <dtantsur> #info Tested Runtimes for Yoga - Python 3.8 and 3.9 (https://governance.openstack.org/tc/reference/runtimes/yoga.html)
15:02:27 <dtantsur> This did cause a heated discussion on the ML since 3.6 is what CentOS/RHEL 8 has
15:02:36 <dtantsur> I have a discussion topic to return to this issue
15:02:48 <dtantsur> #info First bugfix branch should be created by the end of next week
15:02:56 <dtantsur> Who doesn't like a fresh warm release? :)
15:03:08 <dtantsur> let's make sure to finish whatever can be finished by EOW (this week)
15:03:25 <rloo> o/
15:04:05 <dtantsur> #info PTL on PTO during whole December
15:04:13 <dtantsur> let's wish iurygregory great time :)
15:04:38 <TheJulia> ++ I'm glad he made it home
15:04:44 <dtantsur> yep!
15:04:47 <dtantsur> That's all we had, does anyone have any other announcements?
15:05:44 <TheJulia> I've got nothing annoucement wise
15:06:02 <TheJulia> we *should* try and see when we want to stop holding meetings for the rest of the year, during open discussion
15:06:14 <dtantsur> yep
15:06:22 <dtantsur> #topic Review action items from previous meeting
15:06:27 <dtantsur> iurygregory to create a doodle for the new time so people can vote + email to openstack-discuss
15:06:32 <dtantsur> I don't think this has actually happened?
15:06:38 <TheJulia> I did not see it
15:06:54 <TheJulia> He seemed excepptionally busy last week
15:06:58 <dtantsur> I can imagine
15:07:20 <dtantsur> was it about moving the meeting time? maybe rpittau could drive it since you're the most affected?
15:07:39 <TheJulia> Yeah
15:09:36 * dtantsur pokes rpittau
15:09:48 <rpittau> sounds good, I will take care of it (sorry, double meeting)
15:09:48 <dtantsur> ah, well, conflicting meetings. we'll get back to it.
15:10:02 <dtantsur> no worries, I obviously forgot *why* you were affected :D
15:10:10 <dtantsur> #topic Review subteam status reports
15:10:15 <dtantsur> hmm, first
15:10:27 <dtantsur> #action rpittau to create a doodle for the new meeting time so people can vote + email to openstack-discuss
15:10:32 <dtantsur> now, whiteboard
15:10:36 <dtantsur> #link https://etherpad.opendev.org/p/IronicWhiteBoard white board
15:10:47 <dtantsur> I don't think we've merged the Yoga topics
15:11:01 <TheJulia> We have not
15:11:03 <dtantsur> #link https://review.opendev.org/c/openstack/ironic-specs/+/815308/ Yoga themes
15:11:15 <dtantsur> still, I'd suggest we start reshaping the whiteboard according to it
15:11:21 <dtantsur> any volunteers?
15:11:29 <dtantsur> (I can do it, but I'm happy to delegate :)
15:12:06 <TheJulia> I might be able to this week. I've got a few past-due things to take care of today
15:12:21 <dtantsur> I can do it as well, just checking if anyone is really eager
15:12:26 <TheJulia> ++
15:12:44 <dtantsur> #action dtantsur to update the whiteboard with the (draft) yoga themes
15:13:03 <dtantsur> #topic Deciding on priorities for the coming week
15:13:10 <dtantsur> first and foremost, please review the yoga themes
15:13:31 <dtantsur> I'd love to see https://review.opendev.org/c/openstack/sushy/+/817792 merged, but it's on the list already
15:13:35 <dtantsur> anything else?
15:13:58 <TheJulia> If I can crank out the client patch for node history events tomorrow, any objection for me to add it tomorrow?
15:14:05 <dtantsur> none from me
15:15:27 <dtantsur> okay, let's move on to discussions, we have a couple of things
15:15:34 <dtantsur> #topic Situation around Python 3.6 support
15:15:41 <rpittau> I Added a couple of patche sfor tempest
15:15:45 <rpittau> too late :(
15:15:46 <dtantsur> thanks rpittau
15:15:59 <TheJulia> rpittau: ack, I'll try to review them soon()
15:16:04 <rpittau> ack
15:16:10 <dtantsur> So, as I mentioned earlier, the tested runtimes no longer include python 3.6
15:16:28 <dtantsur> which causes issues for Bifrost which supports Stream 8, which has 3.6
15:16:47 <dtantsur> (it also supports Bionic, openSUSE Leap and Debian 10, all of which have <3.8 and will need to be deprecated)
15:17:07 <dtantsur> but Ubuntu and Debian have new versions which support 3.8+
15:17:25 <dtantsur> CentOS has Stream 9, but I don't know how many folks will feel easy to use it for their production deployments
15:17:36 <dtantsur> any opinions or suggestions?
15:18:15 <TheJulia> I have this bad feeling it doesn't end up with anyone happy
15:18:39 <rpittau> about centos stream 9, I definitely do not suggest it in the current status
15:18:39 <rpittau> for the rest, if we want to keep testing on py3.6 we can, we "just" to add a py3.6 test
15:18:57 <dtantsur> rpittau: do you have any practical experience that makes you say so? re 9?
15:19:15 <dtantsur> we have a discussion on the ML where some people are basically going "9 is just as good as 8, what's the problem?"
15:20:56 <TheJulia> I feel like those saying it didn't get to feel pain during centos stream 8
15:21:56 <dtantsur> I'd like us to keep 3.6 support for at least Yoga; similar voices are coming from Kolla and RDO teams
15:22:07 <dtantsur> but it's seems like the matter is already decided on the TC side
15:22:09 <TheJulia> I'm on board with that for now
15:22:28 <rloo> ++ keep 3.6 support
15:22:35 <rpittau> my experience so far is restricted to bifrost and metal3
15:22:35 <rpittau> if it was an overlap phase where we had to temporarily support both centos8 and centos9 I would say no problem, but abruptly going from one to another is a bit tough
15:23:02 <dtantsur> at the very least we can add add 3.6 unit tests on Ironic and other our projects to make sure *we* don't break and serve as canary for broken dependencies
15:23:09 <TheJulia> This does feel like the community is trying to make a very hard cut
15:23:26 <TheJulia> but I think upfront we knew we would only be on 3.6 for 3-4 years tops.
15:23:57 <TheJulia> but it is hard for us to really comprehend or remember that in active memory from day to day when distros do long lived packaging
15:24:01 <rpittau> I'm ok to add unit tests for py3.6 for yoga, and work on centos9 at the same time
15:24:05 <dtantsur> yep
15:24:07 <dtantsur> and yep
15:24:33 <dtantsur> voting or non-voting?
15:24:49 <TheJulia> voting... at least for the time being
15:24:53 <rpittau> voting
15:25:36 <dtantsur> okay, sounds good, will do (help welcome)
15:25:51 <dtantsur> moving on? or any other opinions?
15:26:07 <TheJulia> I suspect we're safe to move on
15:26:22 <rpittau> I will help
15:26:22 <rpittau> one concern I have is for dependencies removing py3.6 support (oslo libraries for example), need to keep an eye on those
15:26:30 <TheJulia> yeah
15:26:40 <dtantsur> yeah, that's why I'm saying that the job will work as a canary
15:26:52 <TheJulia> if they start slipping in a minimum requirement of 3.8, that is pretty much shooting eveyrone in the foot
15:26:52 <dtantsur> at least we'll know when it's over :)
15:26:56 <rpittau> :)
15:26:57 <TheJulia> ++
15:27:03 <dtantsur> #topic Baremetal SIG
15:27:07 <dtantsur> arne_wiebalck: anything from you?
15:27:40 * TheJulia wonders if the sig is on holiday until January
15:28:13 <dtantsur> well, I have a talk on the 14th :)
15:28:18 * dtantsur is curious if anyone shows up
15:30:18 <dtantsur> okay, I assume nothing new from the SIG at this point
15:30:30 <dtantsur> #topic RFE review
15:30:39 <TheJulia> dtantsur: what is the talk on? I've been under a rock
15:30:40 <dtantsur> #link https://storyboard.openstack.org/#!/story/2008723 Enhance Redfish firmware update user experience
15:30:53 <dtantsur> TheJulia: I'm going to talk about Metal3, maybe even show it
15:31:20 <dtantsur> meanwhile, ajya, you around?
15:31:21 <ajya> about RFE - it is updated after previous review - zip support removed and added download_source similar to images. Any feedback?
15:32:08 <TheJulia> Was zip support added by the ilo folks?
15:33:13 <dtantsur> I think we tried to figure that out and decided that rather no?
15:33:15 <TheJulia> Unfortunately, removing support would cause me to be worried about compatibility and messaging.
15:33:29 <dtantsur> I think ajya means it was removed from the RFE, not from the code
15:33:32 <ajya> as far as I recall, no it was not aded by ilo, they had different packages handled server side
15:33:34 <TheJulia> oh!
15:33:35 <TheJulia> okay
15:33:41 <ajya> yes, removed from RFE
15:33:46 <ajya> for redfish
15:33:48 <TheJulia> nevermind me!
15:34:07 <dtantsur> the RFE seems good to me
15:34:51 <ajya> thanks
15:34:54 <ajya> anyone else?
15:35:29 * TheJulia looks
15:36:59 <TheJulia> lgtm
15:37:13 <dtantsur> any objections?
15:37:23 <TheJulia> none at this time
15:38:03 <dtantsur> okay, marked approved
15:38:10 <dtantsur> #topic Open discussion
15:38:17 <dtantsur> the floor is open
15:38:52 <TheJulia> So, Typically we've taken a moment in these meetings in past years to identify when people were generally going to go *poof* for the year
15:39:24 <dtantsur> I'll be more or less present until ~ 22nd
15:39:42 <TheJulia> I personally can disappear after the 15th, but  I can hang out until say the 22nd or just keep an eye on things
15:39:55 <rpittau> I will be present until the 24th
15:40:23 <TheJulia> so the next question, is how many more times do we want to meet this year?
15:40:28 <TheJulia> Typically we stop mid-month
15:40:54 <dtantsur> definitely not 27th :) unlikely Jan, 3rd
15:41:06 <rpittau> we could skip the 21st ?
15:41:09 <dtantsur> I'll probably be here on the 20th still
15:41:20 <rpittau> sorry, the 20th, yeah
15:41:35 <arne_wiebalck> o/
15:41:44 * arne_wiebalck was in another meeting
15:41:57 <dtantsur> arne_wiebalck: anything from the SIG standpoint?
15:42:13 <dtantsur> arne_wiebalck: I wonder how many people will still be here on the 14th for the meeting..
15:42:13 <arne_wiebalck> nothing for the SIG, except dtantsur's presentation on the 14th!
15:42:18 <arne_wiebalck> hmm
15:42:31 <TheJulia> I don't really have any strong opinions either way, If we want to skip the 27th and the 3rd, I think that works but I suspect the 20th will lack critical mass. Just speaking from experience
15:42:41 <arne_wiebalck> we can postpone to Jan if you prefer, but mid december should be ok, I guess
15:42:46 <arne_wiebalck> as you prefer
15:43:13 <dtantsur> I'll be here anyway
15:43:17 <arne_wiebalck> me, too
15:43:25 <dtantsur> maybe a pre-holiday presentation is actually nice :)
15:43:33 <TheJulia> :)
15:43:37 <dtantsur> TheJulia: I'm cool with skipping 20th
15:43:41 <arne_wiebalck> need some x-mas filter!
15:44:00 <dtantsur> yeah
15:44:13 <arne_wiebalck> rudolph circling the screen or sth
15:44:28 <TheJulia> then lets skip the 20th, 27th
15:44:33 <TheJulia> what about the third?
15:45:02 <dtantsur> I'll probably be still out
15:45:04 <arne_wiebalck> still holiday here
15:45:25 <TheJulia> Then lets resume January 10th
15:45:30 <arne_wiebalck> ++
15:45:34 <rpittau> yep
15:45:37 <TheJulia> and hope all Ironic contributors are ready for plenty of code reviews :)
15:45:40 <dtantsur> who wants to send the announcement?
15:45:42 <dtantsur> yeah
15:45:43 <TheJulia> I'll send the email
15:45:46 <dtantsur> thanks!
15:45:59 <TheJulia> I guess I have a couple other minor items
15:46:45 <TheJulia> It is board nominations right now. You should have an email from the Open Infrastructure Foundation if you'd like to nominate anyone for board of directors. As a reminder, individuals need 10 nominees to appear on the ballot. Please use firefox since it is known to work.
15:47:32 <dtantsur> ++
15:47:36 <dtantsur> anything else?
15:47:44 <TheJulia> Additionally, the nova patche to try and fix the lack of actual rebalance needs eyes
15:47:45 <TheJulia> https://review.opendev.org/c/openstack/nova/+/813897
15:47:49 <sam_z> i've been workin on the implementation of the feature described here and would super appreciate some eyes on my work: https://review.opendev.org/c/openstack/ironic-specs/+/808804/
15:47:57 <TheJulia> it changes the behavior, I'd <3 for operators to review it
15:48:15 * TheJulia looks at rloo, zer0c00l, mnaser, arne_wiebalck ;)
15:48:42 <dtantsur> sam_z: ah, redfish proxy. yeah, it fell off my radar, sorry
15:48:44 <arne_wiebalck> TheJulia: ++
15:49:04 <dtantsur> I wonder how it plays together with the allinone (sorry TheJulia) ironic process.. will need to think
15:49:23 <TheJulia> dtantsur: sam_z ?
15:49:26 <TheJulia> or the nova stuffs?
15:49:33 <dtantsur> the redfish stuffs
15:49:40 <TheJulia> k, good question
15:49:53 <sam_z> also i remember TheJulia saying she had interest in migrating the ironic api to flask and since i'm workin' with flask here i just wanted to put my name in for that lol
15:49:54 <dtantsur> it's probably not a concern, unless sam_z wants to have a new executable
15:50:04 <TheJulia> yeah
15:50:09 <sam_z> allinone process?
15:50:18 <TheJulia> I think the consensus kind of lead to a new process for the proxy anyhow, at least for now
15:50:23 <dtantsur> sam_z: easier to show than to explain: https://review.opendev.org/c/openstack/ironic/+/819620
15:50:34 <dtantsur> basically API and conductor in a single executable
15:50:37 <TheJulia> sam_z: the idea has been kicking around for the last two years
15:51:25 <dtantsur> I'd definitely want to see a possibility to use an all-in-one process
15:51:39 <dtantsur> even if the default is to use a new ironic-redfish-api executable
15:51:43 <TheJulia> one last item from me. It seems I'm doomed to do a lot more in tempest this cycle than I expected. I've been informed more comprehensive testing is expected, basically to ultimately remodel the plugin to be rbac aware at the level of tests above and beyond what client to use
15:51:48 <sam_z> would this feature working with allinone ironic imply it being integrated into the allinone executable?
15:52:08 <sam_z> cuz i *think* that actually might not be too bad actually
15:52:11 <dtantsur> sam_z: likely so. it's probably going to be trivial, just making sure you're aware that it's happening
15:52:12 <TheJulia> I've got a basic wip up https://review.opendev.org/c/openstack/ironic-tempest-plugin/+/819165, since the desire is a mix of positive and negative testing, I'd appreciate any thoughts/feedback since it is going to be a large pile of work
15:52:22 <dtantsur> TheJulia: my condolences (re tempest)
15:52:27 <TheJulia> dtantsur: thanks
15:52:57 <TheJulia> not what I expected to spend december on
15:53:23 <dtantsur> I guess tempest is not the future we wanted, but the future we deserved
15:53:34 <TheJulia> maybe
15:54:12 <TheJulia> Our plugin has somewhat languished as well since it is often an after thought
15:54:15 <sam_z> i have already been brainstorming ways to launch the ironic api and this redfish proxy in the same service anyway and i think because my thingy is a separate wsgi app, in theory we could just use something like the werkzeug dispatcher to serve both
15:54:29 <TheJulia> or a minor thing creeps into being a more major thing
15:55:10 <TheJulia> sam_z: might work, although I think rpittau had an issue with werkzeug directly
15:55:16 <TheJulia> or I may be remembering something else
15:55:23 <dtantsur> sam_z: there are numerous possibilities, depending on whether you want to reuse the same port or not
15:55:47 * TheJulia wonders if we should just let sam_z do what he wants and see what the outcome is
15:55:49 <rpittau> mmmm not me or it was not recently
15:55:57 <TheJulia> rpittau: this felt recent to me
15:56:02 <dtantsur> I have some experience with werkzeug, but it mostly positive
15:56:15 <dtantsur> I think we use it in IPA directly?
15:56:19 <sam_z> yea, i've been meaning to look into trying to implement it and just seeing what happens lol
15:56:29 <TheJulia> hjensas: was there something w/r/t werkzeug recently?
15:56:43 <TheJulia> dtantsur: we do
15:57:17 * TheJulia wonders if we're in the multiverse of python madness
15:57:26 <TheJulia> (w/r/t my thinking of recent werkzeug issues
15:57:28 <TheJulia> )
15:57:56 <dtantsur> werkzeug is the thing behind flask, it's not the worst piece of the puzzle
15:58:03 <TheJulia> true
16:00:18 <TheJulia> Anyway, I guess we're done for today?
16:00:44 <dtantsur> yep
16:00:47 <dtantsur> thanks folks!
16:00:48 <opendevreview> Dmitry Tantsur proposed openstack/bifrost master: Stop exposing JSON RPC to the whole network  https://review.opendev.org/c/openstack/bifrost/+/819649
16:00:53 <dtantsur> #endmeeting