16:01:40 <TheJulia> #startmeeting ironic
16:01:40 <opendevmeet> Meeting started Mon Jan 10 16:01:40 2022 UTC and is due to finish in 60 minutes. The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:40 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:40 <opendevmeet> The meeting name has been set to 'ironic'
16:01:42 <TheJulia> #chair iurygregory
16:01:42 <opendevmeet> Current chairs: TheJulia iurygregory
16:01:47 <dtantsur> o/
16:01:48 <rpittau> o/
16:01:48 <erbarr> o/
16:01:49 * TheJulia hands the microphone to iurygregory :)
16:01:49 <rpioso> o/
16:01:50 <iurygregory> o/
16:01:56 <ajya> o/
16:02:06 <iurygregory> Welcome back everyone! Happy New Year!
16:02:10 <stendulker> o/
16:02:33 <rloo> o/
16:03:27 <iurygregory> #topic Announcements / Reminder
16:03:43 <iurygregory> anyone has something to announce /remind us?
16:03:46 <arne_wiebalck> o/
16:04:12 * iurygregory does a quick check on openstack ML to see if there is something
16:04:58 <TheJulia> I think we've got 11 weeks until Yoga release
16:05:02 <TheJulia> or maybe 12
16:06:01 <iurygregory> it's on Marc 11 so around 11 weeks
16:06:04 <dtantsur> yeah, the first release freezes will be around mid-February
16:06:27 <iurygregory> the second bugfix we will release on begin of Feb
16:07:22 <iurygregory> #info check your emails for "2022 Individual Director Election and Bylaws Amendments"
16:07:36 <iurygregory> if you are a contributor you probably received an email to vote =)
16:09:22 <iurygregory> anything else? =)
16:09:37 <TheJulia> I think that is it
16:09:44 <iurygregory> ok, let's move on
16:10:06 <iurygregory> #topic Review Action items from prior meeting
16:10:27 <iurygregory> I've checked and we don't have any past action items
16:10:42 <iurygregory> #topic Review subteam status reports
16:10:45 <dtantsur> who cares about last year's action items? :)
16:11:12 <iurygregory> only if we had something important XD
16:11:27 <iurygregory> #link https://etherpad.opendev.org/p/IronicWhiteBoard
16:11:33 <iurygregory> starting around L63
16:13:49 <TheJulia> we should really just dogpile on a troubleshooting/set of work one day
16:15:39 <dtantsur> iurygregory: we haven't really talked about rootwrap/privsep for inspector
16:15:57 <dtantsur> the iptables driver at least requires sudo
16:16:02 <TheJulia> yeah
16:16:19 <dtantsur> maybe we can make privsep optional when the dnsmasq driver is used?
16:16:24 <TheJulia> I think steve baker may have looked at that recently...
16:16:37 <TheJulia> I think that would be good but may also be fairly complex at the same time
16:16:38 <dtantsur> yeah, this is what caused me to remember about inspector :)
16:16:56 <TheJulia> oh good, at least my memory slightly works :)
16:16:58 <dtantsur> not really, the dnsmasq driver does not use sudo by default, only when you provide restart/shutdown commands
16:16:58 <iurygregory> dtantsur, good catch
16:17:09 <dtantsur> I *think*
16:17:10 <iurygregory> make it optional would be a good thing
16:17:26 <TheJulia> dtantsur: I was more thinking from the entire process model standpoint but I don't have my head wrapped around it heavily
16:19:17 <iurygregory> maybe I can sync with stevebaker[m] to see what he thinks (my timezone now permits this :D)
16:19:17 <dtantsur> yeah...
16:19:22 <dtantsur> ++
16:20:21 * iurygregory iurygregory to talk with stevebaker[m] about privsep on inspector
16:20:33 <iurygregory> #action iurygregory to talk with stevebaker[m] about privsep on inspector
16:20:48 * iurygregory was using / instead of # <facepalm>
16:21:27 <iurygregory> we have updates on the topics, moving on
16:21:42 <iurygregory> #topic Priorities for the coming week
16:21:51 <iurygregory> #link https://review.opendev.org/q/hashtag:ironic-week-prio+status:open
16:22:15 <dtantsur> I have some stuff to suggest!
16:22:17 <iurygregory> any patches to add to our list? \o/
16:22:23 <iurygregory> dtantsur, go ahead :D
16:22:27 <dtantsur> https://review.opendev.org/c/openstack/ironic/+/821219 enabled foreign keys for sqlite
16:22:38 <dtantsur> https://review.opendev.org/c/openstack/ironic/+/820909 somewhat simplifies enabled_***_interfaces
16:22:42 <rpittau> I added https://review.opendev.org/c/openstack/bifrost/+/819058
16:23:04 <ajya> can these be added - https://review.opendev.org/c/openstack/ironic/+/822781 https://review.opendev.org/c/openstack/ironic/+/823701/ ?
16:23:13 <dtantsur> then we have bifrost combined ironic chain: https://review.opendev.org/c/openstack/bifrost/+/819649 https://review.opendev.org/c/openstack/bifrost/+/819640 https://review.opendev.org/c/openstack/bifrost/+/820390 https://review.opendev.org/c/openstack/bifrost/+/820479
16:23:29 <dtantsur> finally https://review.opendev.org/c/openstack/ironic/+/822329 allows web servers to disable our caching
16:24:23 <dtantsur> any ideas/objections?
16:24:35 <TheJulia> no objections here
16:24:43 <TheJulia> I'm surprised we've not hit caching issues before
16:24:57 <TheJulia> then again I bet folks tend to just use new file names or ID's
16:25:09 <dtantsur> I don't think it's common for people to have images generated on fly
16:25:14 <dtantsur> we may be the only ones :)
16:25:25 <iurygregory> no objections from me also, ajya dtantsur feel free to add the hashtag =)
16:26:08 <iurygregory> dtantsur, probably because we like to dangerous things :D
16:26:13 <dtantsur> exactly :)
16:26:44 <dtantsur> TheJulia: we also respect Last-Modified already
16:26:46 <TheJulia> heh
16:26:56 <TheJulia> dtantsur: true,, and that does address a huge chunk of it
16:27:00 <dtantsur> but not Cache-Control: no-store
16:27:01 <TheJulia> as long as it gets updated
16:27:02 <ajya> iurygregory: thanks, done
16:27:11 <TheJulia> although, I do remember we had someone who had a bogus last-modified from a server once
16:27:16 <TheJulia> 4-ish years ago
16:27:40 <dtantsur> sweeet
16:28:44 <TheJulia> Anyway, onward?
16:28:55 <dtantsur> yep
16:29:04 <iurygregory> cool \o/
16:29:32 <iurygregory> #topic Baremetal SIG
16:29:54 <iurygregory> #link https://etherpad.opendev.org/p/bare-metal-sig
16:30:10 <iurygregory> arne_wiebalck, anything you would like to say?
16:30:22 <arne_wiebalck> TheJulia: summarised the SIG's activities for the foundation's annual report.
16:30:37 <arne_wiebalck> thanks TheJulia
16:30:44 <TheJulia> Happy to help!
16:30:58 <TheJulia> I'd love for us to somehow get some operators talking about size and scope
16:31:02 <arne_wiebalck> For meetings, we have a tentative show-and-tell of an Ironic deployment scheduled for March.
16:31:06 <TheJulia> granted, difficult
16:31:07 <TheJulia> well
16:31:10 <TheJulia> that could work too :)
16:31:37 <arne_wiebalck> We have a free slot in February if someone feels like it :)
16:31:57 <arne_wiebalck> There are some potential topics on the ethepad.
16:32:04 <arne_wiebalck> *etherpad
16:32:42 <arne_wiebalck> Unless someone comes forward, I will try to find a volunteer :-D
16:33:10 <arne_wiebalck> Oh, and no meeting in January we said.
16:33:13 <TheJulia> we should do a thing on scaling ironic
16:33:15 <arne_wiebalck> That is it, I think.
16:33:19 <TheJulia> NobodyCam: hint hint
16:34:10 <NobodyCam> yawn, stretch Good Morning Ironic'ers
16:34:33 <iurygregory> good morning NobodyCam :D
16:34:41 <arne_wiebalck> hey NobodyCam o/
16:34:44 <NobodyCam> ++ on Scaling great topic
16:35:10 <NobodyCam> Morning arne_wiebalck iurygregory, TheJulia :) o/
16:35:39 <TheJulia> It would be a good opportunity to talk about common pain points, ways to kind of route around them, and then kind of what does an ideal layout look like
16:35:57 <TheJulia> And I think we could do a deck, if folks want to collaborate I can start it I guess and shoot for febuary ?
16:36:03 <NobodyCam> yea
16:36:07 <arne_wiebalck> sure
16:36:13 <iurygregory> \o/
16:36:17 <iurygregory> great news :D
16:36:27 <arne_wiebalck> we also have https://techblog.web.cern.ch/techblog/post/conductor-groups/
16:36:42 <arne_wiebalck> (scaling Ironic) which may give some ideas
16:36:53 <NobodyCam> +++
16:37:03 <arne_wiebalck> deal then :), thanks!
16:37:09 <arne_wiebalck> iurygregory: back to you I guess
16:37:20 <iurygregory> arne_wiebalck, thank you!
16:37:45 <iurygregory> #topic RFE review
16:37:58 <iurygregory> anyone has an RFE that would like to discuss?
16:39:08 <TheJulia> I haven't looked at RFE's or even bugs in storyboard recently due to everything going on
16:39:22 <iurygregory> no worries, moving on :D
16:39:28 <TheJulia> mainly bugs
16:39:36 <iurygregory> #topic Open discussion
16:39:45 <dtantsur> yeah, me neither
16:40:08 <TheJulia> dtantsur: my most favorite one is what happens when the bmc disappears mid-authentication refresh
16:40:30 <iurygregory> anything we should discuss?
16:40:40 <dtantsur> TheJulia: sounds like a horror story
16:41:15 <TheJulia> dtantsur: 4 bugs and counting wrapped into one patch :(
16:41:57 * TheJulia looks at the cats trying to remove her window blinds
16:42:45 <TheJulia> I've got nothing, besides we shoudl do a midcycle soon
16:43:03 <rpittau> ++
16:43:07 <iurygregory> maybe we can start with a doodle? :D
16:43:40 <iurygregory> who is interested in participating in the midcycle?
16:43:42 <iurygregory> o/
16:43:45 <NobodyCam> I'd like to put an official happy new year in the record
16:43:55 <TheJulia> iurygregory: o/
16:43:56 * arne_wiebalck realises the mid cycle at CERN is almost 2 years ago already
16:44:06 <rpittau> arne_wiebalck: :/
16:44:11 <dtantsur> :(
16:44:16 <iurygregory> ='(
16:44:21 <dtantsur> c'mon, I'm not paying for the internet to get upset
16:44:23 <TheJulia> arne_wiebalck: I was thinking of that this morning
16:44:30 <arne_wiebalck> dtantsur: heh
16:44:37 <iurygregory> dtantsur, you can blame arne_wiebalck this time
16:44:56 <arne_wiebalck> once things are calm again, I guess we are happy to welcome you again :)
16:45:02 <iurygregory> \o/
16:45:05 <rpittau> \o/
16:45:17 * arne_wiebalck is trying to get dtantsur value for internet money
16:45:54 <dtantsur> I usually extract some suffering out of it
16:46:38 <rpittau> I'm not sure we want to go down the internet-suffering path now!
16:46:50 <iurygregory> rpittau++
16:46:50 <dtantsur> that's literally our profession :)
16:46:53 <rpittau> :D
16:47:17 <TheJulia> oh my
16:47:24 <TheJulia> I suspect this meeting is Fin
16:47:27 <iurygregory> and it's monday... so this make things worse
16:48:08 * iurygregory is trying to understand Fin...
16:48:18 <TheJulia> iurygregory: done
16:48:27 <TheJulia> iurygregory: end, etc
16:48:40 <dtantsur> I hope everyone who celebrates new year has enjoyed the holidays!
16:49:07 <iurygregory> TheJulia, oh :D I was trying to find the word in english
16:49:57 <iurygregory> so, who is going to send the email about the midcycle?
16:50:00 <TheJulia> dtantsur: I need like another week off, can we somehow make the break longer?
16:50:14 <dtantsur> +++
16:50:21 <dtantsur> I haven't had enough snow
16:50:48 <TheJulia> snow++
16:51:09 <TheJulia> I might be able to go up the tramway, put some in a box, but I don't think it would make it to germany as snow :)
16:51:16 <dtantsur> nope :)
16:51:29 <dtantsur> at least so far no snow has made it to Düsseldorf without turning into a heavy rain
16:52:07 <iurygregory> snow++
16:52:30 <TheJulia> I just had a depressing throught
16:52:47 <TheJulia> about snow in general, and climate change
16:53:07 <iurygregory> =(
16:53:09 <dtantsur> there can be depressing thoughts there indeed
16:54:41 <iurygregory> yeah =(
16:54:54 <TheJulia> anyway, shall we end today's meeting so we can proceed with taking over the world
16:54:55 <iurygregory> so, I think we are good with our meeting \o/
16:55:01 <iurygregory> yeah :D
16:55:09 <iurygregory> I will run the next meeting
16:55:19 <iurygregory> Thanks everyone!
16:55:23 <rpittau> thanks iurygregory
16:55:23 <TheJulia> cool, thanks everyone!
16:55:26 <TheJulia> #endmeeting