16:00:05 <iurygregory> #startmeeting ironic
16:00:05 <opendevmeet> Meeting started Mon Jan 17 16:00:05 2022 UTC and is due to finish in 60 minutes.  The chair is iurygregory. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:05 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <opendevmeet> The meeting name has been set to 'ironic'
16:00:08 <TheJulia> o/
16:00:10 <rpittau> o/
16:00:10 <iurygregory> o/
16:00:30 <iurygregory> Hello everyone! Welcome to our weekly meeting o/
16:00:40 <dtantsur> o/
16:01:25 <arne_wiebalck> o/
16:01:35 * iurygregory is wondering if we have quorum..
16:01:39 <stendulker> o/
16:02:06 * TheJulia wonders if everyone slept in from over the weekend
16:02:47 <iurygregory> TheJulia, today is holiday in the US?
16:03:10 <TheJulia> Today IS a federal holiday but only half of business actually honor it
16:03:21 <iurygregory> gotcha =)
16:03:26 <ajya> o/
16:03:37 <iurygregory> let's get started with our meeting \o/
16:03:45 <iurygregory> you can find our agenda in the wiki
16:03:53 <iurygregory> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
16:04:00 <iurygregory> #topic Announcements / Reminder
16:04:10 <iurygregory> #info CFP for the OpenInfra Summit Berlin 2022 is now open!
16:04:19 <iurygregory> #link https://cfp.openinfra.dev/app/berlin-2022
16:04:28 <iurygregory> #info Nomination open for OpenStack "Z" Release Naming
16:04:34 <iurygregory> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-January/026620.html
16:04:48 * TheJulia is wondering if a walk through digging through API performance stuffs would be interesting to folks
16:05:11 <arne_wiebalck> since I asked and others may wonder: there won't be a PTG in Berlin
16:05:33 <rpittau> oh
16:05:34 <dtantsur> I think the PTG will be virtual
16:05:44 <iurygregory> probably...
16:05:46 <arne_wiebalck> there will be the one in April (virtual) and then one in-person is planned for the second half the yeay
16:05:52 <TheJulia> yes, first PTG will be virtual, the second PTG of the year is likely to return to in-person, at least that is what is hoped
16:05:55 <arne_wiebalck> *year
16:06:04 <iurygregory> *fingers crossed*
16:06:20 <TheJulia> yes, I think we're all hoping things calm down very quickly
16:07:15 <iurygregory> anything else to add to our Announcements/Reminder?
16:07:28 <arne_wiebalck> TheJulia: API performance stuff is related to the drop I saw during the W upgrade or sth else?
16:07:47 <TheJulia> arne_wiebalck: related, directly
16:08:30 <arne_wiebalck> TheJulia: a talk for the summit?
16:08:36 <TheJulia> yes
16:08:44 <arne_wiebalck> TheJulia: I would come :-D
16:08:57 <iurygregory> me too
16:09:08 <rpittau> that sounds very interesting
16:09:37 <TheJulia> onward!
16:09:59 <iurygregory> ok \o/
16:10:03 <iurygregory> #topic Review action items from previous meeting
16:10:38 <iurygregory> I had an action item to talk with Steve
16:11:07 <iurygregory> I did, so marking as solved =)
16:11:20 <iurygregory> #topic Review subteam status reports
16:11:30 <iurygregory> #link https://etherpad.openstack.org/p/IronicWhiteBoard
16:11:42 <iurygregory> starting around L63
16:17:06 <iurygregory> I think we can move on, we have the updates on the topics in the etherpad
16:17:18 <TheJulia> so, I guess worth noting, I did chat with nova folks regarding some of the stuff last week, and there was some recognition that maybe what I started is good enough and perfect in this case would be the enemy of good
16:17:40 <TheJulia> They *may* see if they can pickup the patches if I don't get to them before they can, but that won't be during this cycle
16:17:53 <TheJulia> Not really update worthy, but background context worthy
16:18:37 <iurygregory> personally I consider update worthy =), thanks for sharing this info TheJulia!
16:19:34 <iurygregory> #topic Deciding on priorities for the coming week
16:19:44 <iurygregory> #link https://review.opendev.org/q/status:open+hashtag:ironic-week-prio
16:20:03 <iurygregory> Patches are welcome \o/
16:21:15 <dtantsur> you'll be surprised to know that I have a few bifrost changes :)
16:21:34 <TheJulia> I went ahead and finally pulled the wiki change logs for the docs, but I don't think that is a review priority :)
16:21:38 <dtantsur> some security-related https://review.opendev.org/c/openstack/bifrost/+/824702 https://review.opendev.org/c/openstack/bifrost/+/824700 https://review.opendev.org/c/openstack/bifrost/+/824144
16:21:52 <dtantsur> a substantial improvement for the bifrost docs: https://review.opendev.org/c/openstack/bifrost/+/824719
16:22:03 <dtantsur> another small change: https://review.opendev.org/c/openstack/bifrost/+/823552
16:22:19 <dtantsur> any thoughts/objections?
16:22:42 <arne_wiebalck> After adding (some basic) testing, I tagged the resources_url patches as well earlier today, they are basically one-line patches.
16:23:27 <iurygregory> dtantsur, none on my side
16:23:35 <iurygregory> arne_wiebalck, tks!
16:24:16 <TheJulia> we'll want to backport those resource_url fixes to wallaby once they merge, I'm happy to click buttons
16:24:48 <TheJulia> dtantsur: no objections I guess :)
16:25:02 <iurygregory> and we hope we can do the backports by only clicking in the buttons in the gerrit UI :D
16:25:15 <TheJulia> hehe
16:26:28 <iurygregory> rpittau, maybe you want to try things again in https://review.opendev.org/c/openstack/bifrost/+/824193/3 ? (if you don't have time I'm happy to pick up and fix the merge conflict)
16:27:37 <rpittau> iurygregory: there's an issue with SELinux, I'm going to add a temporary fix while I see if we need to open another BZ
16:28:51 <iurygregory> rpittau, ack
16:29:12 <iurygregory> more patches or are we good to go?
16:29:43 <TheJulia> I suspect we're good to go
16:30:35 <iurygregory> skipping "Discussion", we will use Open Discussion if we have topics =)
16:30:38 <iurygregory> #topic Baremetal SIG
16:30:48 <iurygregory> arne_wiebalck, anything you would like to add?
16:31:14 <TheJulia> I need to go see what I volunteered for next month
16:31:17 <TheJulia> I forgot :(
16:31:18 <arne_wiebalck> only that I noted that TheJulia NobodyCam and I will do the next presentation :)
16:31:24 <arne_wiebalck> heh
16:31:37 <TheJulia> last week was exhausting
16:31:37 <arne_wiebalck> happy to remind you :-D
16:31:47 <TheJulia> by all means, or at least make sure it is in the etherpad :)
16:31:58 <arne_wiebalck> it is already
16:32:05 <arne_wiebalck> erm ... I think
16:32:06 <TheJulia> \o/
16:32:23 <iurygregory> nice \o/
16:32:23 <arne_wiebalck> I think that is it for this time iurygregory
16:32:33 <iurygregory> arne_wiebalck, thank you!
16:32:45 <iurygregory> #topic RFE review
16:32:45 <arne_wiebalck> oh, the SIG should also do sth at the summit I suppose:
16:32:48 <arne_wiebalck> ?
16:32:59 <iurygregory> arne_wiebalck, ++ =)
16:33:01 <dtantsur> operators feedback?
16:33:09 <arne_wiebalck> dtantsur: ++
16:33:14 * dtantsur still has no clue how travel will look like
16:33:15 <TheJulia> an operator feedback session is exceptionally powerful tool wise for us
16:33:22 <arne_wiebalck> I was also thinking to summarise what we did last year
16:33:25 <TheJulia> I suspect many of us don't know yet
16:33:32 <iurygregory> arne_wiebalck, ++
16:33:33 <dtantsur> I suspect none of us DO know :)
16:33:39 <TheJulia> yeah
16:33:40 <iurygregory> yeah
16:33:45 <TheJulia> which reminds me
16:33:52 <TheJulia> I'm supposed to be at a conference in March...
16:33:52 <arne_wiebalck> dtantsur can almost go by bike :-D
16:33:52 <dtantsur> I'm actually the closest permanent community member to the venue, right?
16:34:01 <dtantsur> weeelll.. no :)
16:34:08 <TheJulia> dtantsur: yes
16:34:11 <TheJulia> dtantsur: huh, no?
16:34:19 <iurygregory> he is not in Berlin
16:34:22 <dtantsur> no to biking to Berlin :D
16:34:23 <rpittau> if it's like last year should travel not be too much trouble inside EU
16:34:53 <dtantsur> at least for those who's got all the vaccinations and boosters with something EU-approved
16:34:59 <rpittau> yep
16:35:03 * iurygregory is outside EU now =(
16:35:15 <rpittau> yeah, I was going to say, rest of the world is to see :/
16:35:26 <dtantsur> right now it's less about EU-vs-non-EU, more about which vaccination you've got
16:35:37 <iurygregory> yeah ++
16:35:45 <dtantsur> so most Russians will have issues, for example
16:35:51 <opendevreview> Rafael Castillo proposed openstack/ironic-python-agent-builder stable/wallaby: Replace genisoimage with xorriso  https://review.opendev.org/c/openstack/ironic-python-agent-builder/+/823367
16:36:01 <dtantsur> while you, iurygregory, will likely be fine
16:36:08 <dtantsur> (modulo the looooong flight)
16:36:23 <rpittau> depends, they're reducing the time validity of the pass/vaccination
16:36:29 <arne_wiebalck> (modulo the looooong flight under an FFP2 mask)
16:36:38 <iurygregory> well, there is direct flights to Germany :D
16:36:50 <opendevreview> Merged openstack/ironic stable/xena: Do not fail inspection on invalid MAC  https://review.opendev.org/c/openstack/ironic/+/824910
16:36:53 <iurygregory> to Frankfurt
16:37:06 <arne_wiebalck> iurygregory: dtantsur can pick you up with his bike
16:37:11 <TheJulia> lol
16:37:11 <dtantsur> LOL
16:37:13 <iurygregory> arne_wiebalck, lol
16:37:20 <dtantsur> that will be hell of a ride :D
16:37:22 <TheJulia> dtantsur: clearly your getting a bike!
16:37:34 <TheJulia> The community has spoken it seems :)
16:37:37 <dtantsur> :D
16:37:56 <iurygregory> =D
16:38:07 <iurygregory> ok, let's go back to the rfe topic
16:38:12 <iurygregory> we do have one
16:38:16 <TheJulia> https://tenor.com/view/kuiil-have-spoken-mandalorian-star-wars-gif-15566834
16:38:25 <iurygregory> [RFE] Docstrings for API documentation
16:38:32 <iurygregory> #link https://storyboard.openstack.org/#!/story/2009785
16:38:36 <TheJulia> yes, MahnoorAsghar brings us an RFE from her Outreachy work this cycle
16:38:55 <iurygregory> oh nice!
16:39:01 <TheJulia> To kind of set up a high level context, the goal is to find a way to bring our API documentation closer to our actual code
16:39:19 <TheJulia> so we don't get stuck in cases where something gets missed or forgotten, as it is so easy now
16:39:40 <dtantsur> It's a nice idea, as long as we can make it work with the way api-ref is built
16:39:41 <MahnoorAsghar> For that I am suggesting the use of docstrings in code
16:40:14 <dtantsur> MahnoorAsghar: it's important to understand that API reference is built separately from the rest of the documentation and is published differently
16:40:17 <MahnoorAsghar> dtantsur: do you mean the os-api-ref extension?
16:40:28 <MahnoorAsghar> Oh I see
16:40:33 <dtantsur> yeah, all the processes around it
16:40:40 <dtantsur> it's not the same as our normal documentation on docs.o.o
16:40:52 <MahnoorAsghar> Oh I didnt know that
16:40:53 <dtantsur> not saying it's not doable, just making sure you're aware of that
16:41:02 <MahnoorAsghar> Okay
16:41:18 <MahnoorAsghar> Any resources I should be looking at in particular?
16:41:28 <dtantsur> a good question
16:41:42 <dtantsur> you may need to take a careful look how api-ref building works now
16:41:44 <MahnoorAsghar> I have tried to build the api documentation myself using the current framework
16:42:02 <MahnoorAsghar> Ah, i see
16:42:19 <dtantsur> and yes, os-api-ref seems to be the main sphinx extension
16:42:38 <MahnoorAsghar> Yep, as fas as I could tell
16:43:05 <MahnoorAsghar> Would it be helpful to look at its code?
16:43:13 <MahnoorAsghar> If thats what youre suggesting?
16:43:39 <TheJulia> I suspect that is what he is suggesting
16:43:45 <TheJulia> also perhaps the build pipeline if we can find it
16:43:52 <MahnoorAsghar> Okay ^_^
16:43:54 <dtantsur> yep
16:43:55 <TheJulia> There is no if, on ly when
16:44:04 <MahnoorAsghar> Okayy
16:44:04 <TheJulia> s/on\ ly/only/
16:44:29 <MahnoorAsghar> Right now I am trying to build my own extension using docutils as a helper
16:45:16 <dtantsur> may it be useful to talk to the wider openstack community?
16:45:29 <dtantsur> we may not necessarily be the only ones with these plans
16:45:53 <MahnoorAsghar> It couldn't hurt I think
16:45:56 <iurygregory> dtantsur, ++
16:46:31 <TheJulia> one thought I had, is if somehow we could eventually  publish a non-openstack themed/focused reference... somehow
16:46:35 * TheJulia whistles innocently
16:46:56 * iurygregory likes TheJulia's idea
16:47:23 <dtantsur> it's a good thought, but probably a separate one
16:47:30 <iurygregory> yup
16:47:31 <TheJulia> yeah
16:48:00 <MahnoorAsghar> Yhe t
16:48:06 <opendevreview> Merged openstack/bifrost master: Do not run ironic-prometheus-exporter as root  https://review.opendev.org/c/openstack/bifrost/+/824735
16:48:09 <MahnoorAsghar> The theme is a problem?
16:48:46 <iurygregory> since we are ok with the RFE I think we can add the labels rfe-approved and ironic-triaged
16:48:51 <TheJulia> MahnoorAsghar: eh, it is a bit more nuanced then that, I can explain it later :)
16:49:29 <MahnoorAsghar> TheJulia: okay ^_^
16:49:30 <TheJulia> iurygregory: sounds good
16:49:40 <TheJulia> MahnoorAsghar: it is big picture openstack/ironic stuff
16:49:43 <iurygregory> cool, I will add =)
16:49:56 <TheJulia> and how perceptions play into it
16:51:02 <MahnoorAsghar> TheJulia: i see
16:51:08 <MahnoorAsghar> iurygregory: thank you!
16:51:16 <iurygregory> MahnoorAsghar, yw =)
16:51:31 <iurygregory> moving on =D
16:51:34 <iurygregory> #topic Open discussion
16:52:08 <iurygregory> I was looking my gerrit today and I've found the patch from releases to move Ussuri to EM
16:52:20 <iurygregory> #link https://review.opendev.org/c/openstack/releases/+/817593
16:52:52 <iurygregory> It was in Dec and I was on PTO, so I missed
16:53:13 <TheJulia> are there any releases to cut before it is marked?
16:53:35 <iurygregory> I can double check this in our projects
16:53:53 <TheJulia> I guess usage of ussuri might not be that strong given most folks seem to be focused on Wallaby for long term usage
16:55:16 <iurygregory> #action iurygregory to check ussuri release for our projects before moving to EM
16:55:59 <iurygregory> after having the releases (if we have something) we would be good to go to EM, do we agree on this? =)
16:56:00 <TheJulia> Any crazy summit ideas?
16:56:13 <TheJulia> anyone interested in anything in particular or find things particularlly interesting?
16:56:38 <iurygregory> I will try to think about a topic
16:56:41 <TheJulia> I ask becasue we have lots of knowledge, but we've been kind of quiet the last two years with the pandemic so we don't really know the feedback loop and what people might find interesting
16:56:49 <iurygregory> no crazy ideas yet D:
16:57:18 <iurygregory> ++
16:57:21 <MahnoorAsghar> I can try to think of something
16:57:24 <TheJulia> Only galactic domination using either the forces of good or darkness is a crazy idea ;)
16:57:54 <TheJulia> mainly because we would need to wait on Elon and Starship to at least get started. :)
16:57:59 <iurygregory> now we are moving to galactic domination? \o/
16:58:16 <MahnoorAsghar> Sky isn't the limit
16:58:19 <TheJulia> Well, I thought we were already planned for taking over the solar system?
16:58:31 <rpittau> solar system sounds reasonable
16:58:36 <rpittau> with current tech I mean
16:58:36 <TheJulia> ... Or do we need an MCRN light corvette class ship first?
16:58:41 <iurygregory> I think my PTO was too long and I forgot :D
16:59:05 <TheJulia> heh
16:59:14 <TheJulia> MahnoorAsghar: ++, the sky is never the limit :)
16:59:23 <iurygregory> #topic Who is going to run the next meeting?
16:59:43 <iurygregory> anyone?
16:59:51 <TheJulia> I can
16:59:56 <iurygregory> I won't be able to run next meeting (I will be on PTO) =D
17:00:01 <iurygregory> TheJulia, thank you!
17:00:04 <TheJulia> PTO, ohhhh ahhhh
17:00:15 <iurygregory> Friday and Monday only =)
17:00:20 <iurygregory> #endmeeting