15:59:59 <iurygregory> #startmeeting ironic
15:59:59 <opendevmeet> Meeting started Mon Feb  7 15:59:59 2022 UTC and is due to finish in 60 minutes.  The chair is iurygregory. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:59 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:59 <opendevmeet> The meeting name has been set to 'ironic'
16:00:06 <iurygregory> o/
16:00:17 <ajya> o/
16:00:18 <iurygregory> Hello everyone, welcome to our weekly meeting!
16:00:30 <rpioso> o/
16:00:37 <rpittau> o/
16:00:53 <rloo> o/
16:00:57 <arne_wiebalck> o/
16:00:59 <ameya49> o/
16:01:27 <iurygregory> seems like we have quorum =)
16:01:57 <iurygregory> you can find the agenda for our meeting in the wiki
16:01:58 <iurygregory> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
16:02:03 <TheJulia> o/
16:02:11 <iurygregory> #topic Announcements / Reminders
16:02:30 <iurygregory> #info CFP for OIS Berlin 2022 closes in 2 days (Feb 09)!
16:02:41 <iurygregory> #link https://cfp.openinfra.dev/app/berlin-2022/
16:02:43 <erbarr> o/
16:02:55 <iurygregory> Submit all the talks \o/
16:03:15 <TheJulia> Including the crazy idea talks!
16:03:21 <TheJulia> Just no pet rocks. :)
16:03:31 <iurygregory> crazy ideas ++ :D
16:03:43 <iurygregory> #info Baremetal SIG - Scaling Ironic by TheJulia Feb 8, 2022, at 2pm UTC on zoom.
16:03:55 <iurygregory> #link https://etherpad.opendev.org/p/bare-metal-sig
16:04:23 <iurygregory> Tomorrow is our monthly presentation from the Baremetal SIG =D
16:05:01 <iurygregory> #info PTG April 4th-8th
16:05:10 <iurygregory> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-February/027051.html
16:06:04 <iurygregory> I've started looking at the slots for the PTG, I will share the idea for the slots in the ML during this week
16:06:43 <iurygregory> #info Combined PTL/TC Election Feb-Mar 2022 Season (Z Cycle)
16:06:49 <iurygregory> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-February/027070.html
16:07:18 <iurygregory> Seems like is already this time of the year ... elections :D
16:08:05 <TheJulia> Where did the last three months go?!?
16:08:36 <iurygregory> time flies :D
16:09:58 <iurygregory> #info Second release for the projects this week (Yoga)
16:10:11 <iurygregory> we had some problems last week =)
16:10:38 <iurygregory> I'm going to check the releasenotes and see if need any urgent fix to get merged before pushing the release
16:11:11 <iurygregory> #action iurygregory check releasenotes and push release patches
16:11:25 <iurygregory> Does anyone have anything to announce or remind us of this week?
16:11:25 <TheJulia> iurygregory: feel free to /msg me with reno patches to review
16:11:44 <iurygregory> TheJulia, ack
16:11:44 <rpittau> iurygregory: I can help with the releases if needed
16:12:02 <iurygregory> rpittau, ack (I hope I will be able to fix my gerrit problem today...)
16:12:13 <iurygregory> tks :D
16:12:37 <iurygregory> #topic Review Action Items for last week
16:12:55 <iurygregory> no action items from last week
16:13:13 <iurygregory> #topic Review subteam status reports
16:13:25 <iurygregory> #link https://etherpad.opendev.org/p/IronicWhiteBoard
16:13:38 <iurygregory> starting around L62
16:19:53 <iurygregory> I think we can move on
16:20:45 <iurygregory> #topic Deciding on priorities for the coming week
16:20:55 <iurygregory> #link https://review.opendev.org/q/status:open+hashtag:ironic-week-prio
16:21:31 <ameya49> Can I please have feedback on : https://review.opendev.org/c/openstack/ironic-tempest-plugin/+/826646
16:21:49 <ameya49> Zuul is passing and have added priority tag as well
16:22:31 <ajya> can these 2 be added https://review.opendev.org/c/openstack/ironic/+/825489 https://review.opendev.org/c/openstack/ironic/+/825753  ?
16:22:52 <iurygregory> ameya49, sure since you added the tag it will show in the list and we will review =)
16:23:10 <ameya49> iurygregory: Thanks :)
16:24:43 <iurygregory> ajya, I'm ok with adding them, quick question since they are features, you don't need newer version for dracclient ?
16:24:49 <rpittau> I will add the tinycore 13.x upgrade, seems to work quite well
16:24:59 <iurygregory> rpittau, nice!
16:25:19 <ajya> iurygregory: no, the feature does not rely on dracclient
16:25:32 <iurygregory> ajya, ack I just wanted to double check :D
16:25:43 <iurygregory> feel free to add the hashtag
16:25:51 <ajya> ok, thank you
16:28:04 <iurygregory> anything else? =)
16:28:20 <TheJulia> nothing from me at this moment
16:28:34 <rpittau> one more in sushy-tools, I will add the hash
16:28:54 <dtantsur> my CI rework is not ready, I think
16:29:00 <iurygregory> rpittau, ack np
16:29:06 <dtantsur> and we probably don't want to start merging it before the release :)
16:29:06 <iurygregory> woot dtantsur is around
16:29:13 <dtantsur> yeah, I'm lurking :)
16:29:16 <rpittau> done, thanks
16:29:20 <iurygregory> dtantsur, yeah I agree
16:29:43 <iurygregory> ok, moving on
16:29:48 <iurygregory> #topic Discussion
16:30:00 <iurygregory> we have one topic to discuss \o/
16:30:19 <iurygregory> #info Running InspectorBasicTest in a 3rd Party CI
16:30:43 <iurygregory> rpioso or ajya do you want to go and give context?
16:31:19 <rpioso> Dell is working on improving the test coverage in its third-party CI.
16:31:53 <rpioso> We are developing Tempest tests to automate much of the testing we have performed manually.
16:32:54 <rpioso> Those will benefit our third-party CI, regression testing of new server firmware versions, qualification of new server models, and early regression of pre-release firmware.
16:33:13 <TheJulia> Awesome!
16:33:24 <rpioso> We are aiming to leverage as much of the existing tests as possible.
16:33:39 <rpioso> The team is new to Tempest :-)
16:33:39 <TheJulia> Is the plan to contribute this back to ironic-tempest-plugin?
16:34:04 <TheJulia> tempest is.. unique. :)
16:34:13 <rpioso> iurygregory: Thank you so much for giving me the opportunity to provide context.
16:34:22 <iurygregory> rpioso, np
16:34:29 <rpioso> TheJulia: Yes, we plan to contribute it upstream :-)
16:35:21 <TheJulia> awesome! You *might* want to have a specific class for these, fwiw.
16:35:52 <iurygregory> at the moment they are having issues running the inspector tests because we try to assert the amount of ram the server has
16:36:04 <rpioso> TheJulia: ameya49 's contribution is the first of several changes we plan to contribute: https://review.opendev.org/c/openstack/ironic-tempest-plugin/+/826646.
16:36:18 <iurygregory> https://github.com/openstack/ironic-tempest-plugin/blob/master/ironic_tempest_plugin/tests/scenario/test_introspection_basic.py#L27-L29
16:37:37 <iurygregory> would it make sense to have a specific class for the introspection test also? I think we only run on CI and we have some infor that is *hardcoded* like the flavor we use in the tests
16:39:05 <TheJulia> So, anyone know of a page covering copyright stamping off-hand in OpenStack, because stampign for a couple line change has generaly been frowned upon in the past... also since it is pointless and redundant given all rights get assigned and are not actually retained AIUI
16:40:33 <iurygregory> I've talked with Dell folks last week, they will have X machines and they want tempest to run the tests on all the machines, the introspection will fail because it won't match the amount of memory , how we can help them do be able to run this tests (I don't think that for Introspection we would need to create a new class)
16:41:55 <iurygregory> I see a few options on how we can help them
16:42:39 <TheJulia> a specific test would likely need to understand it's role in consuming all of the nodes. Ultimately working all the way through nova and scheduling may not be ideal given that is a number of layers of abstraction when the goal sounds like it is regression and qualification of new hardware models.
16:42:44 <rpioso> Do those assertions against the flavor ^^^ apply, since, AFAIU, they are not used by nova? See the 2d paragraph on https://docs.openstack.org/ironic/latest/install/configure-nova-flavors.html. Perhaps they could be relaxed to check that they are simply greater than zero (0).
16:42:55 <TheJulia> at which point, memory flavor matching is pointless
16:44:04 <TheJulia> They really arn't used for scheduling anymore
16:44:18 <TheJulia> so relaxed could work
16:45:33 <iurygregory> I like the idea
16:46:05 <rpioso> TheJulia: That would be cool! The existing test otherwise seems to fit our needs. We may derive classes from it to ensure iDRAC-specific interfaces are configured on the baremetal node.
16:46:20 <rpioso> *nodes :-)
16:46:52 <TheJulia> derived class would be highly preferred, fwiw
16:47:29 <rpioso> Speaking of which, why are the inspector tests the only ones that deal with all of the available baremetal nodes?
16:48:36 <ameya49> TheJulia : Ack (noted)
16:49:48 <TheJulia> rpioso: because it is about api contract testing for the most part, integration scenario tests get piggy backed on that
16:49:49 <rpioso> With real physical servers, a benefit of that approach is that the test can be completed against a fleet of different server models, along with their different firmware, in 1/N the time, where N represents the number of servers. Running it serially could take most of a day with reboots, etc.
16:49:57 <TheJulia> so nothing is really designed to test every server the same exact way
16:50:11 <TheJulia> it is all about running x scenario to determine the expected result
16:50:56 <TheJulia> so to do so, it requires a separate class as it is less an integration/contract test, but a driver/hardware behavior/capability validation test.
16:51:50 <rpioso> Would standing up N DevStacks, each with one (1) available baremetal node, be the preferred approach for introspection and our other Tempest tests?
16:52:27 <iurygregory> that would ensure that you run the scenario in all tests
16:52:35 <TheJulia> That would be really quite inefficent, tbh
16:52:41 <TheJulia> one test could drive multiple
16:53:10 <TheJulia> but the other thing to keep in mind is tempest is designed to also be able to be run by operators in the field or customers to validate clouds. So these sorts of thigns typically end up needing to be opt-in as well.
16:53:51 <rpioso> TheJulia: Is there an example of one test driving multiple tests you could point us at?
16:54:23 <TheJulia> rpioso: several, but not offhand'
16:54:30 <iurygregory> I think standalone is one
16:54:56 <TheJulia> Yeah, most of them are instandalone
16:55:16 <rpioso> iurygregory: Doesn't that run against just one node?
16:55:19 <TheJulia> aside from basic ops, but that is contract behavior validation + integration testing between multiple services
16:55:32 <TheJulia> rpioso:  there is a networking test which uses two nodes
16:55:42 <TheJulia> and optionally a VM or a barmetal node in addition to it
16:55:50 <iurygregory> rpioso, standalone is just because is ironic without nova =)
16:56:05 <iurygregory> it's in the basic_ops
16:56:06 <rpioso> iurygregory: Yep :-)
16:56:55 <rpioso> For us, each node is associated with a specific physical server.
16:57:53 <iurygregory> rpioso, I think we can end the meeting and continue the discussion in the irc (we only have 3min left)
16:58:06 <iurygregory> can be?
16:58:06 <rpioso> iurygregory: +1
16:58:10 <iurygregory> ty =)
16:58:19 <iurygregory> #topic Baremetal SIG
16:58:34 <iurygregory> #link https://etherpad.opendev.org/p/bare-metal-sig
16:58:53 <arne_wiebalck> you said it all already during the announcements, tell all your friends :)
16:59:01 <iurygregory> yeah :D
16:59:10 <iurygregory> tweet!
16:59:12 <arne_wiebalck> ML and twitter sent out
16:59:21 <iurygregory> tks arne_wiebalck !
16:59:31 <iurygregory> #topic RFE review
16:59:33 <iurygregory> skipping =)
16:59:47 <iurygregory> #topic Open discussion
16:59:49 <iurygregory> skipping
16:59:55 <iurygregory> #topic Who is going to run the next meeting?
16:59:58 <iurygregory> me o/
17:00:02 <iurygregory> Tks everyone!
17:00:08 <iurygregory> #endmeeting