15:01:05 <JayF> #startmeeting ironic
15:01:05 <opendevmeet> Meeting started Mon Oct 10 15:01:05 2022 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:05 <opendevmeet> The meeting name has been set to 'ironic'
15:01:14 <iurygregory> o/
15:01:17 <matfechner> o/
15:01:18 <JayF> Good morning, who all is here today
15:01:19 <TheJulia> o/
15:01:21 <rpittau> o/
15:01:50 <kubajj> o/
15:02:09 <JayF> #topic Announcements/Reminder
15:02:27 <JayF> #note Meeting next week pre-emptied by PTG; please participate in PTG and our next meeting is 10/24
15:03:23 <JayF> #note PTG sessions are scheduled. Check schedule at https://ptg.opendev.org/ptg.html for Ironic and Baremetal SIG Hour meetings. Additionally we are participating in a Nova session, Monday at 1400 UTC, to discuss our Nova driver.
15:03:24 <opendevreview> Julia Kreger proposed openstack/ironic-inspector master: SQLAlchemy 2.0 prep  https://review.opendev.org/c/openstack/ironic-inspector/+/860731
15:03:43 <JayF> Does anyone else have an announcement that wasn't already on the agenda?
15:03:45 <arne_wiebalck> o/
15:03:51 <erbarr> o/
15:04:15 <JayF> Moving on.
15:04:33 <JayF> We had no action items last meeting to review; so skipping that agenda item
15:04:56 <JayF> Subteam status report review usually goes here; but I'm not sure we have too many subteams running right now? We should likely re-evaluate what gets reported here at PTG
15:05:15 <JayF> #link https://wiki.openstack.org/wiki/Meetings/Ironic is the meeting agenda, if anyone needs the link
15:05:53 <JayF> I'm going to give a couple of minutes for folks to look at the status reports in the whiteboard, and say something here if there is a discussion item
15:06:04 <JayF> #link https://etherpad.opendev.org/p/IronicWhiteBoard subteam status reports
15:07:02 <TheJulia> I've updated the items I've been working on
15:07:29 <JayF> Thank you :) It'll be exciting to see the DB stuff land
15:07:42 <JayF> #topic Stable branch status & decisionmaking
15:08:00 <JayF> I put an item on the agenda to talk about branch status for our EM branches; and discuss plans for moving forward
15:08:19 <JayF> Currently wallaby, xena, yoga, and zed are all maintained branches
15:08:38 <JayF> we also maintain queens, rocky, stein, train, ussuri, and victoria to some degree for extended maintenance
15:08:58 <JayF> We had agreed last cycle to retire queens, rocky, and stein but they were never actually retired -- are folks still on board for these to go away?
15:09:14 <TheJulia> I generally care about all the way down to Train, but if nobody else cares about Train, I'm happy to leave it be
15:09:30 <JayF> #link https://releases.openstack.org/ official branch support status and terminology
15:09:46 <rpittau> I stop caring at wallaby :P
15:09:55 <JayF> I have no problem with maintaining back to Train downstream; I just suspect we need to get a little more direct in ensuring that stable branches still work with CI
15:10:12 <JayF> e.g. a periodic run we can check and report on at the meeting, or something else to track CI status
15:10:30 <JayF> Less busy projects have had a problem with the older brnaches bit-rotting because they get so few things backported
15:10:32 <TheJulia> we are though
15:10:44 <JayF> Runinng a periodic job?
15:10:46 <TheJulia> it is just we have a finite amount of resources and CI can break at anytime
15:10:54 <TheJulia> nope, we have no periodics afaik
15:11:16 <TheJulia> nor would we actually be able to pay attention to it short of directly triggering and watching it
15:11:27 <TheJulia> well, I should be specific
15:11:29 <TheJulia> I wouldn't be able to
15:11:57 <TheJulia> if I'm the only one that cares, then we can kill the t, u, v branches.
15:12:34 <JayF> Lets talk specifics instead; With the recent need to migrate out "Queue" directives from zuul, nobody else was stepping up to get it done and we had dozens of branches broken and showing up in the broken zuul report
15:12:46 <JayF> reducing that matrix is one of the only strategies I can think of to reduce that load
15:12:59 <JayF> and/or ensuring we fix things as they break instead of having a periodic painful CI migration
15:13:12 <TheJulia> I agree, the queue fixes I previously put up took months to make any review progress
15:13:21 <TheJulia> unfortunately, I thought we had them all, and we didn't
15:13:54 <JayF> Yeah; there's a real cost to keeping these up and we don't seem to be doing a good job of making sure that work happens ad-hoc
15:14:07 <JayF> Either in not reviewing changes, not pushing them up, etc
15:14:07 <TheJulia> yup
15:14:32 <TheJulia> or they fall of change dashboards because there are too many open changes
15:14:41 <TheJulia> well, individual's dashboards
15:14:45 <JayF> So maybe we can change the approach; should we reduce the testing load for TUV?
15:14:55 <TheJulia> I think we should
15:15:00 <JayF> e.g. if we retired q,r,s and set t,u,v to unit testing and linting only
15:15:09 <JayF> that would reduce our testing matrix by probably hundreds of tests
15:15:12 <JayF> across all Ironic projects
15:15:26 <iurygregory> humm unit testing would be enough?
15:15:34 <TheJulia> I'd keep the more reliable integration jobs there, I can propose a change to cut down the integration jobs
15:15:35 <iurygregory> I'm ok with the approach to reduce
15:15:42 <iurygregory> but some integration jobs would be good
15:15:47 <iurygregory> probably not all of them
15:15:49 <JayF> As far as OpenStack/TC policy is concerned; we have to run unit tests and linting on stable branches
15:15:51 <TheJulia> we've done it before, just haven't done it for victoria and older, recently
15:15:54 <JayF> everything  else is up to us
15:16:50 <JayF> TheJulia: so you said you have interest in back to T, do you expect that to be heavy backports or just security items or what?
15:17:01 <JayF> that might be informational to iurygregory's comment about if we should keep some integration jobs
15:17:16 <TheJulia> mainly security or super awful bug
15:17:32 <TheJulia> Basically where we were with queens two years ago
15:18:17 <JayF> That reinforces my thought that unit tests, linting, and trusting folks who backport past W to manually test or validate the changes
15:18:24 <JayF> is enough
15:18:42 <TheJulia> I'd still wants some integration testing on train, fwiw
15:18:54 <TheJulia> but we can dial a lot of it back I think
15:19:00 <JayF> Do you mind taking the action to do that dialing back in V,U,T
15:19:09 <JayF> and I'll take the action to retire q,r,s?
15:19:14 <JayF> or at least, let me know what we want to keep around
15:19:19 <TheJulia> I can do so
15:19:25 <TheJulia> well, dialing htings back that is
15:19:37 <JayF> #action JayF to officially announce and retire Queens, Rocky, Stein EM branches from Ironic projects
15:19:49 <JayF> #action TheJulia to reduce CI jobs for Train, Ussuri, and Victoria
15:20:09 <JayF> Thank you :-) I'll update the thread I started on the mailing list with this outcome.
15:20:28 <JayF> I will also note; I'm still working to get releases cut from all maintained ironic branches
15:20:51 <JayF> #topic Priorities for the coming week
15:21:11 <JayF> As always, please tag any patches that need priority review with #ironic-week-prio
15:21:28 <rpittau> I still have some patches from last week so I'm not adding more
15:21:34 <JayF> I'd like to ask that my series of stable-only patches to remove the packaging requirement and update releaase notes get some attention; I'll be tagging those in there
15:21:44 <JayF> rpittau: after the meeting i'll take a look thru the list :)
15:21:53 <rpittau> thanks JayF :)
15:22:00 <JayF> rpittau: I'll note I have a comment on one of those (the bugfix branch job pin) if you wanna take a look at it
15:22:09 <rpittau> sure
15:22:31 <JayF> Giving folks a couple more minutes to talk about priority patches they might have before moving on
15:26:34 <JayF> #topic Baremetal SIG
15:26:49 <JayF> #note Next Baremetal SIG will be at the PTG, serving as Ironic's operator hour
15:27:05 <JayF> There's nothing else to mention about BM SIG, afaik.
15:27:16 <arne_wiebalck> no ... any more feedback?
15:27:19 <arne_wiebalck> on the mail I mean?
15:27:22 <arne_wiebalck> I have not seen any
15:27:28 <JayF> I haven't seen any :(
15:27:39 <JayF> I presume the best place to get input might be at the operator hour
15:27:44 <JayF> especially if we have operator participation there
15:27:48 <arne_wiebalck> the question is if we continue to chase community members to give presentations
15:28:16 <JayF> I think the answer to that has to be no? At least not at the current monthly cadence
15:28:19 <TheJulia> It is a good question to ask, and I would tweet that out with an note indicating that we've secheduled an operator hour
15:28:19 <arne_wiebalck> the etherpad still has a couple of potential topics
15:28:41 <TheJulia> fwiw, Operators have often indicated the best means of engagement is Twitter, not any mailing list
15:29:01 <JayF> TheJulia: I've heard; I'm working with spotz and fungi to try and open that line of comms up for Ironic.
15:29:10 <JayF> TheJulia: for instance, I'll get them to mention our EM branch retirement
15:29:45 <JayF> arne_wiebalck: I'll volunteer to do a talk for next BM SIG outside of PTG; that'll at least take us a step further down the road
15:29:50 * JayF can talk about IPA and hardware managers
15:30:02 <arne_wiebalck> JayF: awesome, thanks!
15:30:33 <JayF> #action JayF to connect with ops meetup twitter to plug (and Call-for-talks) for BM SIG after PTG
15:30:51 <JayF> arne_wiebalck: anything else we wanted to hit on this topic before moving on?
15:30:51 <fungi> yeah, the suggestion is for someone like JayF to tweet something, and then we can retweet or whatever with more widely followed twitter handles like openstack or osops
15:31:01 <TheJulia> JayF: when I was ptl, I would just tweet at the twitter accounts with whatever my ask happened to be to retweet :)
15:31:16 <arne_wiebalck> JayF: nothing else for the SIG
15:31:21 * TheJulia still does this actually...
15:31:46 <JayF> Chairwoman, former PTL, social media professional ;)
15:31:50 <JayF> lol
15:31:57 <JayF> Alright, moving on, we're almost done
15:31:59 * TheJulia begins building a trebuchet
15:32:23 <JayF> There are no RFEs for review. As a reminder, add RFEs to review to the meeting agenda if you have any.
15:32:28 <JayF> #topic Open Discussion
15:32:32 <JayF> any topics for open discussion today?
15:33:15 <TheJulia> nothing from me
15:33:46 <JayF> gonna give folks until :35
15:34:04 * TheJulia awaits patiently to get the link for the commit message she has typed out...
15:35:01 <JayF> I'll run next meeting, I should be here.
15:35:05 <JayF> #endmeeting