15:01:44 <JayF> #startmeeting ironic
15:01:45 <opendevmeet> Meeting started Mon Oct 24 15:01:44 2022 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:45 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:45 <opendevmeet> The meeting name has been set to 'ironic'
15:01:47 <TheJulia> o/
15:01:51 <matfechner> o/
15:01:52 <ebbex> o/
15:01:54 <JayF> Good morning everyone. Welcome to our meeting.
15:02:01 <ajya> o/
15:02:03 <hjensas> o/
15:02:10 <JayF> Gonna be honest and say I probably dropped the ball and should've cancelled this; I'm doubtful we have much to talk about so I'm going to move fast.
15:02:14 <iurygregory> o/
15:02:15 <dtantsur> o/
15:02:19 <rpittau> o/
15:02:26 <JayF> #note We had a productive PTG last week. Thank you to everyone who particiapted!
15:02:30 <dtantsur> live fast, endmeeting early
15:02:51 <JayF> There are no action items from last meeting that were not handled in a PTG session.
15:03:08 <JayF> Normally we'd also say at this point to check the whiteboard for workstream status; but we haven't updated any of that for the PTG.
15:03:23 <TheJulia> dtantsur: ++
15:03:36 <JayF> So I am going to just keep going as any information there is more out of date than scrolling up 10 lines in IRC :)
15:03:44 <TheJulia> I would suggest updating the whiteboard
15:03:56 <rloo> o/
15:03:58 <TheJulia> some stuff naturally rolls, some stuff is done and can be struck-trough and removed soon
15:04:00 <JayF> It's my intention to do that very soon as part of the documenation of workstreams
15:04:24 <JayF> #action JayF to ensure whiteboard gets updated when he makes 2023.1 Ironic workstreams spec
15:04:34 <JayF> Moving on
15:04:54 <JayF> Just a reminder if anyone needs code reviewed, please add hashtag ironic-week-prio and/or mention it here
15:05:15 <JayF> I don't believe there's anything outstanding, but if there is, please do tag it. I'll be reviewing all tagged, up to date PRs this afternoon.
15:05:16 <dtantsur> https://review.opendev.org/c/openstack/ironic/+/862476 is the mosti mportant one
15:05:53 <JayF> ack
15:06:04 <ebbex> I've got a bunch for bifrost here. https://review.opendev.org/q/topic:deps , but there's a big question as to what to do with suse.
15:06:23 <dtantsur> ebbex: already deprecated => remove support for good?
15:06:56 <ebbex> Fine by me, all in favor of removing suse support?
15:07:17 <JayF> If it's already been deprecated, removal is the next step
15:07:24 <dtantsur> https://docs.openstack.org/bifrost/latest/install/index.html#supported-operating-systems does not even list suse any more
15:07:31 <rpittau> let's remove it
15:07:32 <dtantsur> I think I just was too lazy to remove the code later on :)
15:07:42 <rpittau> heh me too :P
15:07:42 <JayF> That sounds like the clear consensus.
15:08:07 <ebbex> Cool. I'll have it cleaned out instead.
15:08:11 <JayF> #action ebbex To remove suse-supporting code from bifrost, it's already deprecated and scheduled to be removed.
15:08:42 <JayF> thanks for bringing that up and volunteering to clean it up
15:08:50 <JayF> if there are no other patches to discuss; moving on
15:08:56 <ebbex> np :)
15:09:09 <JayF> Baremetal SIG: it was decided at PTG the BM SIG would move to quarterly, and be booked well in advance with calendar invites sent out.
15:09:21 <JayF> Does someone want to own the action to schedule that? I'd suggest booking one for Q1 2023 as our next one
15:09:56 <dtantsur> arne_wiebalck is the natural candidate, but I can do it if he doesn't have time
15:10:19 <dtantsur> there an internal something that we need to clear up first before I know my schedule for Q1
15:10:30 <JayF> that sounds good; we should follow up next week if nobody has taken action yet
15:10:33 <JayF> thanks :)
15:10:40 <JayF> There are no RFEs for review.
15:10:42 <dtantsur> you can put the action on me for now, keeping in mind that it probably won't happen before next week
15:10:48 <dtantsur> * by next week
15:11:11 <JayF> #action dtantsur or arne_wiebalck to book Baremetal SIG meeting for Q1 2023 sometime in the next couple of weeks.
15:11:22 <dtantsur> yep
15:11:23 <JayF> There are no pre-agenda'd open discussion items
15:11:40 <JayF> Are there any topics for open discussion? I'll give a couple minutes for anyone to speak up before ending the meeting.
15:13:20 <TheJulia> I did talk to a larger operator w/r/t the ironic/nova-compute stuffs
15:13:57 <JayF> Anything interesting come outta the chat?
15:14:24 <TheJulia> basically, I could tell there was an undertone that they were *really* not pleased by the availability and the locked interaction behavior and the fact they will now need to self-implement HA, but that the overall tradeoff from the amount of work/effort they face *today* would offset that as the lost hypervisor records today are *far* more painful than what they view that work to be
15:14:52 <JayF> I think that's generally reflective of how most of us feel about it, yeah?
15:15:06 <JayF> Not ideal, but the best we can do inside the nova model and orders of magnitude better than things today
15:15:22 <TheJulia> They believe that based on what I wrote in the spec that I tossed up for ironic, that it should generally "just work" moving forward
15:15:26 <TheJulia> JayF: yeah, I think so as well
15:15:56 <JayF> That's a good report, thank you.
15:16:06 <JayF> Everyone being slightly unhappy is the usual sign of true compromise :)
15:16:16 <JayF> I'm going to close the meeting out if there's nothing else.
15:16:17 <TheJulia> #link https://review.opendev.org/c/openstack/ironic-specs/+/861803
15:16:34 <TheJulia> JayF: johnthetubaguy: sorry, but I had to get the interaction out of my head
15:16:40 <JayF> Reading that is on my list today :). It's going to be a spec writing/reading day :).
15:16:43 <TheJulia> but nova-side is going to be important/needed as well
15:17:44 <TheJulia> johnthetubaguy: I'd also appreciate a review of that spec if you have the time, since I took a shot at how I percieve the nova-compute service upgrade to execute
15:20:05 <JayF> Thanks for taking the first swing at that spec; we'll review and enhance it
15:20:08 <JayF> #endmeeting